[Boblight SupportThread] Update: 11-02-2014, Boblight 0.8R6

  • Hey Tode, ja , sehr schade das ganze.


    Aber auch schon komisch, dass sowohl Boblight als auch Karatelight das Problem haben und das doch von unterschiedlichen Programmieren kommt. Weiss natürlich, ob die da auch Code ausgetauscht haben...


    Ansonsten hat mamba0815 sehtr intensiv unterstütz bei seinem Karatelight, dem Fehler auf die Spur zu kommen, aber leider bei sich auch nix entdeckt (und wie gesagt, bei Boblight ists ja ähnlich...)


    Und da liegt es schon nahe, dass es was mit den Box-spezifischen Dingen zu tun hat. Ob das dann bei DMM liegt oder aber bei Treibern, die die auch nur einbinden , kann ich nicht sagen, aber nur weil Reichi sagt, "ich bins nicht" muss das ja nicht stimmen, oder ? Und hat er nicht selber in nen DMM Tread mal die USB Treiber als Sündenbock vermutet ? Wo ist sein "Beweis" ? Das würde vielleicht Mamba0815 helfen, den Fehler weiter einzukreisen ?
    Noch besser, wenn alle zusammenarbeiten würden an dem Problem.


    Naja, solange muss die DM8000 halt auf OE1.6 bei mir bleiben und ich kanns auch nicht mehr hören, dass man auf OE2.0 umstellen soll und OE1.6 ein "altes" Release ist. Für die DM8000 ists leider das letzte was richtig funktioniert (mit den "lights").


    Aber vielleicht habe ich persönlich bald ne DREAMBOX- lose Lösung :winking_face: (wenn auch teuer), dann kann die DM8000 auch umgestellt werden.


    Kopf hoch und
    vielleicht mal ne Umfrage starten, wer / wieviele betroffen sind (kllappt bei mir irgendwuie nicht, so wie in den FAQs beschrieben kann ich keine Umfrage starten)


    Charly2mal2

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • Also ich bin betroffen mit meiner 8000nder Box einem Atmolight. Aussetzer bei Atmolight-Plugin und Boblight. Hoffentlich geht da irgendwann was.

  • Hallo,


    ich will nicht lästern, aber bei mir läuft Atmolight/Karatelight 16 auf ner 500HD OE2.0 und Boblight/Arduino 50 auf ner "Billig-Box" Gigablue Solo
    OHNE jegliche Probleme !


    Nur mal so als Kommentar, damit Neulinge, die hier evtl. mitlesen, nicht meinen, es gibt damit nur Probleme...


    Digital

  • Hallo digital.arts,
    Hast wohl völlig recht, das Problem scheint in der Form nur bei der DM 8000 aufzutauchen.
    Bei der DM 7020HD laeufts bei mir mit OE2.0 auch.


    Wenn`s aber einen gibt, der mit seiner DM8000 und OE2.0 keine Probleme hat, bitte melden !!!

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

    Edited once, last by Charly2mal2 ().

  • digital.arts: Die EINZIGE Box, die dieses Problem hat, ist die 8000er... Keine andere DMM- Box hat das Problem, nicht mal die alten Kleinen... Aber helfen tut mir das nix.


    Wegen der Entwickler (korrigiert mich, wenn ich falsch liege): Die "Pionierarbeit" hat (wenn ich das richtig weiss) damals Mamba gemacht, und ein Grossteil des Erkennungs- Codes ist dann in boblight gewandert... Am Anfang sahen sogar die Plugins fast identisch aus. Insofern ist es nicht verwunderlich, dass beide Plugins das selbe Problem haben....


    Ich werde jedenfalls jetzt bei mir die Logik umdrehen: Sobald ich den Pi dazu kriege, meine ts- files sauber und schön in die Medien- Datenbank aufzunehmen, werde ich einfach Filme, die ich mit schönen bunten Bildern sehen will, über den Pi abspielen.


    Inzwischen gibt es ja auch für den Pi module, an die man ein HDMI- Kabel anschliesst, und der sich dann aus den HDMI- Signalen den Input für das Ambilight ausliesst... Vielleicht ist das ja was.


    Oder ich versuche, quasi den Bildschirm- Inhalt per Netzwerk an den Pi zu übertragen (sowas wie ein permanenter Stream des aktuellen Senders an den Pi) und dann dort auszuwerten...


    Mal schauen, wie es weiter geht.

  • Quote

    Original von Tode
    oh sh... Ich habe endlich das Boblight mit meinem Pi am Laufen...


    Hi


    Nach welcher Anleitung installiert ?


    Oder nur RASBMC und das Addon + config ???

    cu mcgyver100
    ---
    Klingt komisch , iss aber sooo !!!

  • Tode
    ne Lösung ohne Dreambox mit HDMI und Pi habe ich mir jetzt mal bestellt, wenn die da ist und ich erste Erfahrungen habe, werde ich hier natürlich mal berichten (wahrscheinlich neuer thread, da das mit Boblight ja nix mehr zu tun hat)


    Solnange machts das alte OE1.6 hoffentlöich noch.....

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • mcgyver100: Installation auf dem Pi muss man mit aktuellem Raspbmc nicht mehr machen, der Daemon ist schon integriert. Man muss allerdings unterscheiden: Es gibt da zwei Komponenten:


    Den boblightd: Das ist die Server- Komponente, die man mittels boblight.conf configuriert und über sudo boblightd -f startet (dann hat man aber den Output des Programms auf der Konsole), oder in die /etc/rc.local einträgt (beides gemäss Anleitung pibob, zu finden mit Google). Dieser Dienst steuert die LEDs


    Den boblight-dispmanx: Das ist der lokale Client auf dem PI, der wird automatisch gestartet, wenn man in der Gui von Raspbmc den Boblight- Support startet... den braucht man aber eigentlich nicht, denn der Client ist ja die Dreambox.


    An der Dreambox braucht man (soviel ich weiss) KEINE boblight.conf, die Konfiguration erfolgt über die gui als Netzwerkclient, dort trägt man nur die IP das PI ein....


    Ach ja: Bei mir war es so, dass das ganze gefreezed ist, wenn ich an den bestimmten Einstellungen (z.B. die Wiederholraten) rumgespielt habe... dann liessen sich die Lichter nicht mehr an / auscchalten, und ich musste die Dreambox rebooten, um den Client wieder wegzukriegen...

    Edited once, last by Tode ().

  • Quote

    Original von Tode
    mcgyver100: Installation auf dem Pi muss man mit aktuellem Raspbmc nicht mehr machen, der Daemon ist schon integriert. Man muss allerdings unterscheiden: Es gibt da zwei Komponenten:


    Den boblightd: Das ist die Server- Komponente, die man mittels boblight.conf configuriert und über sudo boblightd -f startet (dann hat man aber den Output des Programms auf der Konsole), oder in die /etc/rc.local einträgt (beides gemäss Anleitung pibob, zu finden mit Google). Dieser Dienst steuert die LEDs


    OK


    Danke dann kann ich weiter testen.
    Ist es dann egal ob über Sedu/USB oder direkt an die GPIOs ?

    cu mcgyver100
    ---
    Klingt komisch , iss aber sooo !!!

  • die boblight.conf ist dann unterschiedlich, aber prinzipiell sollte es egal sein.
    Ob der Daemon funktioniert, kannst Du ja mit boblight-constant probieren (ebenfalls im pibob- tutorial erklärt)

  • Ok danke


    Ich fang mal an zu testen


    EDIT :


    DANKE !!!!


    Hat auf anhieb geklappt , config rein , reboot und los .
    Mit Stripes direkt an den GPIOs , einfacher gehtz nicht :hurra:


    Jetzt noch alles an die Wand dann mach ich mal Fotos

    cu mcgyver100
    ---
    Klingt komisch , iss aber sooo !!!

    Edited once, last by mcgyver100 ().

  • Hallo Leute, habe den PB Image auf meine VU DUO2 installiert, alles eingerichtet läuft auch soweit prima!
    Nm habe ich das PlugIn Karate Light und das Boblight drauf, aber in dem Configuratinons Menü wenn ich das PlugIn öffne funktionieren die Zahlen von der FB. nicht. Die farbigen Tasten gehen aber.
    Ein Skin Wechsel hat nichts gebracht.


    hat einer vielleicht eine Idee?

  • Evtl. Bissel OT aber :


    Kann man und wenn ja wie lang kann man die DMX Zuleitung verlängern ???
    Habe es mit einem alten USB Kabel ca. 1,5m verlängert , und mit finzt es nicht.
    Evtl darf man ja gar nicht verlängern , dann muss ich mir was anderes ausdenken .
    Dann wohl doch über sedu und USB

    cu mcgyver100
    ---
    Klingt komisch , iss aber sooo !!!

    Edited once, last by mcgyver100 ().

  • Hi Leute,
    nutzt einer von euch diese 12mm ws2801 LED-strings?
    Ich habe hier zwei solcher Ketten von 2 verschiedenen Anbietern, allerdings unterscheiden sich die beiden leider deutlich in den Farbtönen.. eine zeigt blau, die andere hellblau... etc...


    Und was noch viel frappierender ist - keine der beiden Ketten kann richtiges Gelb darstellen... Wenn ich im per telnet die Farbe "FFF00" anzeigen lasse, dann ist es bei der einen Kette ein grün, und bei der anderen eher ein weiß..


    ----


    Kurze Nachfrage – scheinbar kann man die Farben ja in der .conf justieren… Was genau bewirken die Parameter „adjust“ und „gamma“?


    Ciao


    basti

  • Kannst du erkennen, welcher Hersteller hinter deinen WS2801 steckt?


    Ich habe mehrere Meter WS2811 an meinem LCD und diese können tiefblau und auch "Simpsons"-gelb darstellen.


    PS: Ich habe meinen PI mit nem AtMega8 an der DM8k am laufen. Die DM sendet das gegrabbte Bild an den PI. Das Boblight auf dem PI wertet das Bild aus und dann geht es flackerfrei auf die WS2811.


    Mit einem USB-Videograbber kann man auch mittels PI sämtliche Quellen nutzen. Mit einem USB-HDMI-Grabber geht es auch. Die DM8k gibt das Videobild ja parallel über den Video-Out raus.


    MfG

  • Servus Johnes,
    wo finde ich denn den Hersteller? Auf den LEDs selber steht nix.


    Und kannst du mir sagen, was die gamma Einstellung genau bewirkt?


    Letzte Frage - wie genau sieht dein Setup aus? Was macht der Atmega?


    Bei mir hängen die LEDs auch direkt am Raspberry (raspbmc) und werden per LAN vom der dreambox angesprochen.


    ciao


    Basti

  • Der PI macht ärger bei der Übertragung der Signale. So bekommt der AtMega die Daten mittels TTL und übersetzt sie in das Format der Stripes.


    In der boblight.conf ist "output /dev/ttyAMA0" als Schnittstelle drin.


    Ich bin dabei, ein eigenes Board für den PI online zu stellen. (Zum selber nachbauen!) Das Material kostet keine 10€ und entlastet bei 224*3 LEDs den PI, der dabei auch schon an seiner Leistungsgrenze (CPU-Last >90% bei Ausgabe über I2C vom PI. Mit der tty unter 60%!)


    Wenn du den Hersteller nicht in den Bestelldaten hattest, schau dir mal deine Stripes an. Es gibt "gute" und "billigere". Dies erkennt man an der Verarbeitung und Beschriftung. Auch, haben bessere Stripes meist 3M-Klebeband an der Rückseite, billigere haben No-Name-Kleber.


    Mit den Gamma-Werten, kannst du die Gamma-Korrektur vornehmen. Für Veränderungen der Farbwerte, eignet sich die "adjust"-Einstellung besser. Ich konnte die Farben damit besser kalibrieren.


    PS: Auch mit adjust, lässt sich aus einer hellblauen LED keine königsblaue LED zaubern.


    Du kannst ja mal nur wenig blau aufleuchten lassen, indem du nicht mit "Constant" den Wert 255/FFh sendest, sondern nur wenig. 20-50/14h-32h. Ggf. kannst du dann erkennen, ob eine andere der drei LEDs mit aufleuchtet und die Farbe verfälscht. (Die anderen LEDs natürlich mit 00 ansteuern.


    MfG

  • Also bei mir macht Raspbmc _Null_ Probleme. Ambilight funktioniert einwandfrei ohne Zusatzhardware. CPU Last ist auch kein Problem; 1080p Wiedergabe mit DTS etc läuft flüssig.
    Würd ich mir an deiner Stelle mal anschauen.
    http://pibob.nadnerb.co.uk/


    Zu den Stripes: ich habe diese "verkabelten" 12mm LEDs; keine flachen Klebeplatinen.

  • Mal etwas off topic


    Möchte mir nun auch ambilight zulegen da die Philips tv ja nur noch Schrott sind.


    Was denkt ihr lieber mit Dream und sedulight oder extern mit der rasperypi Variante



    Benutze viel die Dream als Multimedia Station da Filme und Co auf dem nas liegen
    Bluray bzw. DVD Player nutze ich eigentlich wenig bis gar nicht. Wenn irgendwann mal ein 3D tv da ist dann kommt bestimmt mal der ein oder andere 3D Film mal dazu aber denke da kann Mann dann auch mal auf ambilight verzichten


    Oder was meint ihr


    Danke schon mal im Voraus

  • Ich habe in der boblight cfg beim Raspbmc im oberen bereich eine IP und einen Port...



    Ich habe das jetzt so verstanden und meine auch es gelesen zu haben das wenn ich jetzt in meiner Enigma2 box... boblight als erweiterung instaliert habe...
    Muss ich in der Einstellung unter Netzwerk genau diese IP eingeben um die signale vom der Enigma2 box an den Raspbmc zu senden...


    aber es geht nicht .... :frowning_face: