Posts by Johnes

    Ist zwar älter, aber ich habe das Problem bei mir gelöst, indem ich via gstreamer-Plugin "rtpmp2tdepay" den Stream kastriere. Um die Last von der Dreambox fern zu halten, habe ich dies auf einen meiner RPi-Server ausgelagert.


    Code
    gst-launch-1.0 --gst-debug-level=3 \
    rtspsrc location="rtsp://IP:554/stream" \
    ! queue \
    ! rtpmp2tdepay \
    ! tsparse \
    ! multiudpsink clients=IP:PORT > /dev/null 2>&1 &


    Bis jetzt konnten alle meine Zicken-Geräte dies wiedergeben!


    MfG

    Dein Board setzt das sicher kaum anders um, als meines. Der Unterschied ist bei uns die USB-Anbindung. Du nutzt den M16U2 des Uno. Ich nutze den FL232RL. Der M16 nutzt das CDC-App von Atmel.


    Ich arbeite aktuell an einer ähnlichen Umsetzung. Aktuell nutze ich 2 IC's. Den FTDI will ich mir noch sparen. Durch die Umsetzung mit CDC-Applikation im µC, wird sich der Chip dann auch via ACM anbinden.


    MfG

    Quote

    Original von digiTaler1
    Hi,
    welche Ambilighthardware nutzt Du?


    Falls du mich gemeint hast: Ich habe mir einen µC (AtMega8) als Wandler programmiert und steuere damit 224 LEDs vom Typ WS2812 an.


    Ich nutze keine konv. kauf-Hardware. War mir damals etwas überteuert. Mein Controller kostet mich 5€... (Und etwas Bastelgeschick! Aber, als Elektroniker für mich kein Problem.)


    DM7080 (DM8000) -> FT232RL -> AtMega8 -> 224x WS2812


    Hab noch nichts gefunden, wo ich meine Hard-/Software vorstellen kann? Wo wäre der richtige Platz? Hier? (Eigentlich nicht, geht ja um das Plugin, nicht um Hardware!)


    MfG

    Ich habe Blitzer vermehrt gehabt, da div. Sender im nicht sichtbaren Bereich (Overscan) weiße/fabige Streifen haben. Ich habe meine Config so angepasst, dass ich jetzt ~1% weiter drin erst ansetze.


    Bei mir blitzt seither fast nichts mehr. (<10x/h)


    Ich habe mal die Ausgabe in eine Datei geschrieben. Die Blitzer bei mir, kommen nicht von der Hardware. Das Plugin sendet es an die Hardware. Sie setzt es nur um.


    Umleiten in File geht mit einem Edit der enigmalight.conf
    output /tmp/dump.out
    (Datei muss existieren! Also vorher anlegen!)


    MfG

    Ich nutze Zuhause kein Windoof. Hab damit etwas Linuxerfahrung. (Also, wenn man das "Erfahrung" nennen kann! Nutze Ubuntu!)


    Ich habe den Server über die Konsole starten wollen, wie ich es bei Linux auf den Lappi mache. Da kam die Fehlermeldung und ich konnte das "functions"-Skript nicht finden. Da habe ich es einfach raus kommentiert. Und siehe da: Läuft!


    Ich habe die 7080 auf der 8k (noch OE1.6, die Tage geht es auf OE2.x) und meinen Lappi frei gegeben. Auch meine 4 Raspberry kommen auf die Box. Anders rum geht es auch. Eigentlich kann alles auf alles zugreifen!


    Wo Netzwerk und Quickbutton sauber laufen, kann ich die 8000 platt machen.


    PS: hosts.deny & hosts.allow sollten auch da sein, falls man mal nicht auf die Freigaben kommt! Ab und an kommt es vor, dass die Freigaben alle nicht erreichbar sind, wenn man keine Zugriffsrechte verteilt.


    MfG

    Ich nutze auch den NFS-Server für meine 7080... Ich habe raus gefunden, dass das Teil nicht startet, weil es die "Source function library" nicht vorhanden ist.


    in der Datei /etc/init.d/nfsserver sind folgende Zeilen zu finden

    Code
    # Startup script for nfs-utils
    #
    # Source function library.
    . /etc/init.d/functions


    Wenn man vor die letzte Zeile ein "#"-Zeichen (Raute) setzt, kommentiert man die fehlende Funktion aus.


    Code
    # Startup script for nfs-utils
    #
    # Source function library.
    #. /etc/init.d/functions


    Nach einem Neustart, sollte der Server jetzt normal anlaufen. Das Script wird für den Start des Servers beim booten ausgeführt. Es bricht mit einem Fehler ab und die Freigaben funktionieren nicht.


    Der gleiche Fehler ist auch in der nfscommon zu finden. (Falls einer Freigaben auf der 7080 mounten möchte!)


    Ich habe noch keine Funktionsstörung festgestellt durch das Auskommentieren.


    MfG

    Hallo,


    ich habe bei mir das Quickbutton modifiziert, da auf der DM7080 das MQB nicht richtig laufen will.


    Das Plugin habe ich so erweitert, dass die Farbtasten (auf kurzem Tastendruck) verändert werden können. Zusätzlich habe ich PIP als Tastenfunktion eingefügt. Die grüne Taste ist bei mir unbelegt gewesen. Das Audiomenü nutze ich selten bis gar nicht. (Steht aber als Option bereit!)


    Vielleicht hat einer eine Verwendung dafür.


    Ich brauchte die kurzen Tasten, da die lange Tastenfunktion von meiner Harmony nicht senden will. Auf den Farbtasten wird bei mir kein "Repeat" gesendet wird. Immer nur ein Mal, danach Funkstille. (Mittels Cam geprüft!)


    Ich nutze alle 4 Tasten mit anderer Belegung. (EPG, Timer, Erweiterungen, PIP)


    MfG
    Johnes


    Die plugin.py & keymap.xml einfach in den Ordner /usr/lib/enigma2/python/Plugins/Extensions/Quickbutton schieben. (Vorhandenen Dateien ersetzen! Alten Dateien als Backup sichern, um es wiederherstellen zu können. Oder vom Feed neu installieren um meinen Mod zu löschen.)

    Files

    • keymap.xml

      (453 Byte, downloaded 6 times, last: )
    • plugin.py

      (16.61 kB, downloaded 8 times, last: )
    • quickbutton.jpg

      (65.1 kB, downloaded 84 times, last: )
    Quote

    Original von holymoly
    Das HDMI In Signal muss über den Videospeicher laufen, ist somit auslesbar und Darstellungsfähig.
    Wenn ich aber sehe, welche Basics noch nicht richtig im EL laufen, bekommt so eine
    Erweiterung (die eh wenige nutzen) momentan keinen Zuspruch von mir.


    Ist es denn so, dass das HDMI-In über die GPU und wieder codiert wird? Wenn es nur mittels ByPass durch geht, nützt das gar nichts.


    MfG

    Quote

    Original von Schmello
    Ist in der nächsten zeit möglich ambilight auch mit dem hdmi in vom receiver zu nutzen?
    Somit hätte man ein perfektes ambilight für alle Quellen super gelöst :-)


    Dürfte in der nächsten Zeit nichts werden. Dafür müsste man ein System bauen, welches vom HDMI-Signal ein Bild wieder ins Videoformat zu bekommen. Sprich: Über HDMI werden digital die Farbinfos gesendet.


    Was man allerdings machen kann ist HDMI-2-SVideo-Konverter -> MPEG2 -> Raspberry -> Ambilight!


    MfG

    Schmello:


    Quote

    Ja Bilder wie du die Leds an den TV angebracht hast.. smile finde das immer ganz interessant zu sehen smile


    Ich habe die LEDs auf einer Leiste montiert und diese an den TV geklebt. Ich werde diese allerdings demnächst anders anbringen. werde sie auf den gewinkelten Außenrand des TV kleben. Den Testaufbau den ich vor ca. 1-2 Jahren montiert habe, habe ich seither nicht verändert! :D


    Wenn ich demnächst wieder am basteln bin, weiß ich schon wie meine Freundin reagiert! :aufsmaul:


    Quote

    Jetzt ist natürlich mein vadder aufmerksam geworden und möchte auch ein Ambilight haben.
    Nur möchte er bei seinem alten nicht Linux Receiver bleiben.. (...)
    Aber kennt jemand ein System was man installieren kann das, das Signal aus dem HDMI ausgang des AV Receivers abgreifen kann?


    Wenn, dann könnte man einen Raspberry her nehmen, diesen mit einem Video2USB Konverter ausstatten. Wenn der Receiver dann einen Video oder Scart-Ausgang hat, diesen direkt dort anschließen. Andernfalls noch einen HDMI2Video-Konverter. Auf dem RPi dann Boblight oder Nachfolger installieren.


    MfG


    Mit den Bildern anhängen klappte das noch nicht so! (Jetzt der 2. Versuch!)

    Files

    • bild2.jpg

      (31.51 kB, downloaded 504 times, last: )
    • bild1.jpg

      (22.99 kB, downloaded 516 times, last: )
    • bild3.jpg

      (14.98 kB, downloaded 478 times, last: )

    Ich habe meine DM8k mit WS2812 (ca. 224LEDs zu je 4 Stk.) über das alte Boblight gefüttert. Angesteuert wird dies über einen AtMega8 (kein Arduino, nur der Prozessor!), vom USB mittels FTDI nach TTL. mit 256kBit/s.


    Ich habe mir vor ner Woche ne 7080HD gekauft und richte die gerade ein. Sie wird die 8k ersetzen und dann mein Backlight befeuern. Die 8k war zu Leistungsschwach, die LEDs alle einzeln zu versorgen. Zusammen mit dem NAS und den anderen Sachen, die auf der Box liefen, ruckelte das Licht vor sich hin. Die 7080 wird hoffentlich alle LEDs ansteuern können. (Aktuell wird vom M8 das Signal vervierfacht.)



    Brauche ich eine spezielle Version des Enigmalight-Treibers? Oder kann ich die IPK nutzen/entpacken.
    Do i need another version of Enigmalight for my 7080? Or can i unpack the ipk?


    PS: Bin nicht so der Softwarespezi für Linux. Kann zwar damit um, kann aber besser Mikroprozessoren programmieren.


    MfG
    Johnes

    Dann mal los! Ohne Problembeschreibung kannst du 10x Fragen!


    Als Netzteil habe ich ein SNT MW100-05 (5V/20A) und SNT MW50-05 (5V/10A) zur Auswahl. Bei meinen >200 LED's sind es im Schnitt 35-45W, die sie ziehen. Erst, wenn ich alle LEDs statisch ansteuere, geht der Strom über 15A richtig hoch!


    Zwei "boblights" sind richtig! Ein Grabber und ein Prozess, der die Farben berechnet.


    Um die CPU-Last runter zu kommen, kann der Daemon der die Farben aus dem Bild ausließt und die LEDs ansteuert, auf einen Raspberry ausgelagert werden.


    PS: Wenn ihr Probleme mit der CPU-Last habt, stellt mal den Intervall höher, sodass effektiv weniger Bilder berechnet werden müssen. Mit weniger fps, kann die CPU-Last ausreichend klein sein, um zumindest diese Bilder zu berechnen. Mit "Intervall 20000" kann es sein, dass die Box nur 2-3 Bilder schafft, weil sie gnadenlos überlastet ist. Mit "Intervall 100000" oder höher, kann sie vielleicht die 10fps schaffen.


    MfG