Enhanced Movie Center (EMC)

  • Habe heute meine 900er zum ersten Mal in Betrieb genommen und bin über das gleiche Problem gestolpert.

    Wäre super wenn man das im EMC Paket eventuell fixen könnte, da scheint wohl die Abhängikeit zu dem python Modul zu fehlen.

    Wird das EMC denn aktuell überhaupt nocht "gewartet"?

    • Official Post

    Ich benutze es auf 920er sowie früher auf der 8K und bin immer noch zufrieden. Dank zombi ist auch das Aussehen des EMC immer noch perfekt. Selbst im Plugin Styles kann man verschiedene Ansichten für EMC einstellen.

    pasted-from-clipboard.png

    pasted-from-clipboard.png

    pasted-from-clipboard.png

    pasted-from-clipboard.png

    pasted-from-clipboard.png

  • Ein Problem mit EMC in Blackhole Image: Der Fortschrittsbalken in der Aufnahmen Übersicht funktioniert wenn ich Aufnahmen von der Festplatte der Dreambox zelbst abspiele, aber nicht, wenn ich Aufnahmen vom NAS abspiele. Was kann die Ursache sein?

  • nein, nicht wirklich.

    Was gibt es den zu warten ? Funktioniert ja soweit alles. :winking_face:
    Abhängigkeiten für die Installation, werden nicht im Sourcecode festgelegt, sondern im installations Paket.
    Und wir haben schon lange keine eigenen installations Pakete mehr gemacht.


    Ein Problem mit EMC in Blackhole Image: Der Fortschrittsbalken in der Aufnahmen Übersicht funktioniert wenn ich Aufnahmen von der Festplatte der Dreambox zelbst abspiele, aber nicht, wenn ich Aufnahmen vom NAS abspiele. Was kann die Ursache sein?

    Wie sieht es bei dir auf dem Original Image aus ? Weil das ist die Referenz, und wenn es da funktioniert, bedarf es eigentlich keine Änderung seiten's EMC.

  • Ich brauche Merlin in Flash und Blackhole mit Barry Allen... In Merlin funktioniert es gut.

    Dann weiss ich nicht, was BlackHole verbogen hat, das es da nicht funktioniert.
    Ich hoffe die beiden Images haben den selben Kernel Stand. Sonst gibt das früher oder später Probleme.

  • Abhängigkeiten für die Installation, werden nicht im Sourcecode festgelegt, sondern im installations Paket.
    Und wir haben schon lange keine eigenen installations Pakete mehr gemacht.

    OK, aber wäre es dann nicht sinnvoll, dass jemand die fehlende Abhängigkeit im Installationspaket nachpflegt? Weil unter OE2.5 ist das nicht mehr standardmäßig installiert.

  • Hallo


    Nachdem das Fehlende Paket nachinstalliert habe:

    --------------------code------------------------

    apt-get update && apt-get install python-requests


    reboot

    --------------------code------------------------

    läuft EMC nun auf meiner DM900.


    Ich habe mithilfe des HDMI Input Plugins, eines Tablets und einem USBCzuHDMI Kabel

    eine Netflix Aufnahme hinbekommen.

    Im EMC-Movielist wird diese aber nicht angezeigt.


    Mit fogender kleinen Änderung in der MovieCenter.py

    (".gst" hinzugefügt):

    -------------------code------------------------

    extVideo = frozenset([".ts", ".trp", ".avi", ".divx", ".f4v", ".flv", ".img", ".ifo", ".iso", ".m2ts", ".m4v", ".mkv", ".mov", ".mp4", ".mpeg", ".mpg", ".mts", ".vob", ".wmv", ".bdmv", ".asf", ".gst", ".stream", ".webm"])

    -------------------code------------------------

    wird die Aufnahme angezeigt und auch abgespielt.


    Kann das bitte jemand prüfen und wenns passt auch einpflegen.

  • Habe Probleme beim Aufrufen meiner Netzwerkshares im EMC, egal ob per SMB oder NFS eingebunden.

    Ging jahrelang gut, nun habe ich meinen Server von Ubuntu 18.04 auf 20.04 aktualisiert und es dauert.

    (von Ubuntu 9 Alpha bis 18.04 jahrelang kein Problem)

    Im Netzwerkbrowser bei Enigma zeigt er alle Shares die online sind und offline (sein sollen) korrekt, das dauert alles ca. eine Sekunde.

    Unter Freigabeoptionen habe ich nur rw stehen gehabt, nach Update Ubunt 18.04 zu 20.04 waren die Freigaben weg.

    Erklärung war klar, es wird im neuen Samba kein SMB1 mehr standardmäßig erlaubt. Bei Änderung der Freigabeoptionen zu rw,vers=2.0 oder rw,vers=3.0 waren Sie wieder da.

    Aber es dauert ewig.

    Unter rw,vers=3.0 dauert es 51 Sekunden Unter rw,vers=2.0 dauert es 48 Sekunden Unter Erzwingung der Version 1.0 mit client min protocol=NT1 server min protocol=NT1 dauert es 28 Sekunden,

    auch trotzdem viel zu lange gegenüber Ubuntu 18.04 mit SMB1 mit vermuteten 4 Sekunden.

    Im Sat-Forum gefunden das man in der Sat-Box die smb.conf abändern soll aus security = user mache security = share Ergebnis: Unter rw,vers=3.0 dauert es 45 Sekunden,

    schneller aber nicht signifikant.

    Die Werte oben habe ich der Dreambox DM920 entnommen.

    Meine andere Clonbox reagiert ähnlich.

    Habe in meiner Not nun die NFS Kernel Tools installiert und die Share per NFS eingehängt.

    Da belieben noch 16 Sekunden übrig die ich warten darf. Mit NFS hatte ich mal vor 6...7 Jahren rumgespielt, da waren es 2 Sekunden...

    Zumindest scheint der Verzeichniswechsel kürzer zu sein wenn ich die Share mit NFS einbinde,

    bei SMB dauert das ja auch dann jeweils geschlagene 50 Sekunden. Bei NFS ca. 3 bis 4 Sekunden. Auch viel zu lange

    Was mache ich falsch, hat Irgendwer eine Idee eo ich ansetzen kann??

  • Hallo Bundy00


    deine Frage verstehe ich nicht glaube ich.

    Also wenn es darum geht das ich mich per ssh mit root von meinem Windows APC auf die DM920 einlogge und dann eingebe

    ls -l /media/meinproblemshare

    oder meinetwegen den mc dort aufrufe und nach /media/meinproblemshare wechsele

    so ist das nicht messbar, da gibt es null verzögerungen in beiden Fällen. Kann mit dem mc (Midnight Commander) auch verzöerungsfrei zwischen den Verzeichnissen wechseln

    Ebenso kann ich das Share von meinem Windows-APC direkt verzöerungsfrei einbinden.

    Mit telnet sehe ich auch null sekunden verzögerung

  • Hallo zusammen,


    nach mühevoller Kleinstarbeit ist meine 7020HD nun wieder soweit, dass man damit TV schauen kann. Nur mit der Wiedergabe der Dateien auf der Platte hapert es noch. Klar, es geht irgendwie, aber nicht so komfortabel, wie es 10 Jahre lang ging. Ich meine, ich hatte den EMC drauf, kann mich aber leider nicht mehr erinnern. Versuchen wollte ich es jedoch gerne, habe allerdings Bedenken, dass es ein Problem gibt, wenn ich mir von "irgendwo" eine Version runterlade und auf die Box lege. Deswegen wollte ich es gerne über das installierte Bluepanel machen, aber damit finde ich diese Erweiterung leider nicht.


    Ich habe als Image das Enigma2 Experimental 2017-02-16 drauf.


    Wenn ich nun über den blauen Button unter GP3 Blue Panel / Addons / Plugins (Extensions)/ schaue, zeigt er mir zwar 173 Stück an, aber der EMC ist nicht dabei. Ich kann auch nach 'center' suchen, bekomme aber nur drei andere Treffer.


    Fehlt mir etwas oder mache ich etwas falsch?


    Vielen Dank

  • Welche GP Version haste denn auf deiner alten Box? beim älteren GP gab es noch die Option "extra Plugins benutzen"
    kann also sein das du das noch hast und einschalten musst damit das am GP Feed aufgelistet wird.

  • Danke, exakt das habe ich nun gemacht.


    pasted-from-clipboard.png


    Ich habe bestimmt 4 Stunden lang rumgesucht und überlegt, ob ich was Offensichtliches falsch mache und dann halt gefragt. In dem Moment, finde ich über google und ein anderes Bord den Link wieder zurück zu dem Eingangspost dieses Threads und sehe obige Zeilen, die dann auch geholfen haben.


    Aber vielen Dank für die superschnelle Antwort. Nun muss ich mal schauen, ob dies auch die Lösung meiner Suche ist :winking_face:

  • Ja wunderbar, klappt wieder, danke :thumbs_up:


    Nachdem ich die Verzeichnis-Zugriffsbeschränkung angepasst habe, kann ich wieder so über die Verzeichnisse navigieren, wie ich es gewohnt bin.


    Nun muss ich nur noch im Bereich der UI nachlegen, weil das aktuelle Skin unterdurchschnittlich aussieht und man als Mensch eher ein Gewohnheitstier ist.