Posts by John McClane

Wir haben aktuell ein Problem mit dem Board und arbeiten an der Lösung...


-> Aktuell bereiten wir das Upgrade auf die aktuelle Version 6 von Woltlab vor.

    trechnisch ist es ein Windows PC mit windows 10 drauf.

    Aber der springende Punkt ist die Digital Signage Software. Die stellt ja auch andere Elemente dar, wie Begrüßungsanzeigen wenn Besuch in die Firma kommt.

    Der TV Stream ist nur eine Komponente, die von der Software dargestellt wird. Wenn Termine mit externen Besuchern anstehen, zeigt sie stattdessen einen Berüßungstext für die Besucher an.


    für die Medienwiedergabe kann keine externe Software genutzt werden in dem System, das macht alles die Digital Signage Software, und die unterstützt eben ausschließlich Streams die per https abgerufen werden können.

    Danke für deine Tipps, ich hab jetzt zumindest gelernt, wie ich die Streams für die Kanäle generell abgreifen kann.


    Aber per http bringt mir leider nichts. Das System (wenn ich jetzt schreibe Connect Signage bringt das auch niemand weiter) unterstützt leider kein http.

    Es unterstützt nur https. Ich weiß nicht wie ich es noch anders schreiben soll.

    OK, ich brauch den HLS und mit der URL http://192.168.1.11:8080/strea…:2B66:3F3:1:C00000:0:0:0: bekomme ich im VLC jetzt den Stream fürs ZDF.

    Mit war das nicht klar, dass man auf angezeigte URL in den Einstellung noch die Referenz für den Kanal anhängen muß.

    Wie gesagt, wenn ich eine Anleitung irgendwo finden würde, wäre das alles viel einfacher.


    Bleibt nur noch das Problem, dass das Digital Signage System kein http unterstützt sondern nur https.

    Einfach https vorne in die URL schreiben funktioniert nicht.

    Sonst wird ja nur das Bild Live übertragen, also alles was du dann auf der 9xx machst siehst du dann auch im VLC.

    Wenn die m3u8 Datei so nehme wie sie ist, oder den in den Streaming Server Einstellungen angezeigten Link direkt in VLC eingebe, passiert da gar nichts. Auch dann nicht, wenn ich in den Einstellungen "Folge Live TV" einstellt.


    Ich habe hier ein grundsätzliches Verständnisproblem, wie das Ganze funktionieren soll.

    murxer Hallo und danke für den Link.

    Aber was meinst du mit "TV Kanäle anwählen"? Versteh das nicht ganz.

    Muß ich die Kanäle wie in deinem anderen Beitrag manuell in die m3u8 Datei reinschreiben?


    Aber was macht dann die Einstellung "Folge Live TV"?


    Dein Plugin kann ich gerne testen, aber ich möchte verstehen wie der Streaming Server funktioniert. Hab leider nirgends eine Anleitung oder ein Wiki gefunden.

    Muß nochmal nachfragen. ich bekomme das nicht zum laufen. nicht mal per http.

    Ich habe HLS aktiviert und wenn ich die URL aufrufe, die mir angezeigt wird, bekomme ich eine m3u8 Datei.

    Deren Inhalt ist aber immer gleich, egal ob ich "TV Kanäle", "Folge Live" oder "HDMI EIngang" einstellt.


    das hier ist der Inhalt der Datei. Da fehlt auch jeder Bezug zur IP Adresse der Box.

    Code
    #EXTM3U
    #EXT-X-VERSION:3
    #EXT-X-ALLOW-CACHE:NO
    #EXT-X-MEDIA-SEQUENCE:1
    #EXT-X-TARGETDURATION:2
    
    #EXTINF:2.040000,
    segment0.ts


    auch wenn ich die URL in VLC direkt eingeben unter "Netzwerkstream öffnen" funktioniert das nicht.


    Ich habe in den Einstellungen RTSP deaktiviert und HLS aktiviert.

    Benutzername und Passwort sind im Moment noch leer.


    Die restlichen Einstellungen sind Default.

    Totales einfrieren ist relativ.

    Nach dem Drücken auf Stop, kommt das Live TV Bild und Ton und das läuft dann auch ewig, die Spinner drehen fleißig, aber das Interface vom EMC kommt halt nicht mehr.

    Ansonsten funktioniert die Box ja einwandfrei. Aufnahmen funktionieren zu 100% auch mehrere Aufnahmen gleichzeitig, Live TV genauso problemlos.

    Abspielen von Aufnahmen und Medienfiles funktioniert ja in der Regel auch. Das Einfrieren ist bisher nur beim Stop der Wiedergabe von Aufnahmen passiert. Bei anderen Medienfiles wie MKV Dateien, bisher noch nicht.


    Von daher ist die Diagnose halt schwierig. Wüßte nicht, welches Hardware-Bauteil hier die Ursache sein könnte.

    Hallo,


    ich hab das im DMM Dreambox Forum schonmal gefragt, aber leider keine Antwort bekommen. Vielleicht kann mir hier jemand was dazu sagen.


    Ich würde gerne eine DM900 nutzen um ein Digital Signage System mit einem TV Live Stream zu versorgen.

    Allerdings unterstütz das System nur HLS über https. Das soll alles lokal im LAN stattfinden.

    Auf der Box ist ein aktuelles originales experimental Image drauf.


    Ist das mit dem Streaming Server realisierbar?


    Ich hab den Streaming Server mal installiert, bekomme aber mit den Standardeinstellungen auch per http kein Ergebnis.

    Gibts da irgendwo eine Anleitung?


    Danke & Gruß

    Bei mir war der Cache bisher aus. Da ich den Fehler nicht gezielt reproduzieren kann, ist das halt schwierig mit der Diagnose.

    Ich habe den Cache aktuell versuchsweise eingeschaltet und beobachte. Dass ich ggf mit der blauen Taste die Anzeige aktualisieren muß ist mir bewußt, ist aber auch kein Beinbruch.

    Mal sehen was passiert.


    Das Image meiner 900er ist aktuell und die einzige "Besonderheit" ist die SSD. In meinen bisherigen Boxen waren immer konventionelle Platten verbaut.

    Hallo,


    danke für deine Antwort, aber leider bringt mich das nicht wirklich weiter.

    Klar kann ich das WebIf per https aufrufen und die Streaming Links sehen dann etwa so aus:

    https://xxx.xxx.xxx.xxx/web/stream.m3u?ref=1%3A0%3A19%3A283D%3A3FB%3A1%3AC00000%3A0%3A0%3A0%3A


    Wenn ich die m3u Datei runterladen und reinschaue steht da folgendes drin:

    Code
    #EXTM3U
    #EXTVLCOPT--http-reconnect=true
    http://xxx.xxx.xxx.xxx:8001/1:0:19:283D:3FB:1:C00000:0:0:0:


    Und hier ist liegt dann das Problem. Hier wird eine http Adresse genutzt.


    Der Player unterstützt aber nur HLS oder MPEG-DASH per https.

    AH, jetzt hab ich kappiert. Das "Filmliste ist skinbar" bezieht sich tatsächlich nur auf den Listenteil, und der hat im original Layout Datum und Uhrzeit.

    OK, damit wird aber die Schrift in der Liste sehr klein. Die Umsetzung wie im Beispiel von zombi oben ist da schöner, finde ich.

    Also ich im Styles "Mid" eingestellt. Mir würde es reichen, wenn in den externen Infos die Uhrzeit des Aufnahmestarts zu sehen ist. In der Liste brauch ich das nicht, das sehe ich ein, dass die zu wenig Platz bietet.


    Im EMC habe ich aber die Option "Filmliste ist skinbar" aktiviert. Ich dachte bisher das muß man setzen, damit nicht die original Liste benutzt wird, sondern die aus dem aktiven Skin.

    Hi,


    ich nutze jetzt auch schon einige Monate diesen Skin und hätte da einen kleinen Verbesserungsvorschlag.

    Ich nutze das EMC, welches mit diesem Skin auch super bedient wird.

    Ich nehme relative viel auf mit dem Autotimer, was aktuell zur Folge hat, dass viele Sendungen aus aktuellem Anlass später beginnen als ursprünglich im EPG geplant. Dadurch habe ich oft zwei Aufnahmen für die aktuelle Sendung. Leider sieht man mit dem Skin im EMC nicht auf anhieb, wann die Aufnahme gestartet ist. Man sieht zwar das Datum in der Liste und in der Detailanzeige (dort wo auch die Sendungsbeschreibung steht) aber nicht die Uhrzeit des Aufnahmestarts. Dazu muß man auf jeder Aufnahme nochmals die Info Taste drücken.

    Wäre es denkbar im Bereich mit der Sendungsbeschreibung zusätzlich zum Aufnahmedatum auch die Uhrzeit das Aufnahmestarts anzuzeigen?