Probleme beim mounten der internen Festplatte

  • Hallo zusammen,


    ich habe ein Problem beim mounten der internen Festplatte. Ich habe die HD per Gerätemanager vom GP 3 ausgehangen und initialisiert, da ich ich bei Aufnahmen zunehmend Aufnahmefehler hatte. Lief auch alles problemlos. Nach dem Booten kam allerdings eine Fehlermeldung, dass eine nicht gemountete Festplatte gefunden wurde und der Aufforderung zu mounten. Das habe ich über den Menupunkt "manuell"gemacht und den Mountpunkt mit media/hdd angegeben. Beim erneuten Booten kamm dann die Meldung, ich soll die Platte initialisieren, dies habe ich versucht, es kam die Fehlermeldung, dass dies fehlgeschlagen ist, da kein Verzeichnis "movies" vorhanden ist. Mit automatisch einhängen klappte es dann nur habe ich jetzt im Enigma das Bild screenshot1.jpg, im GP 3 jedoch das Bild screenshot.jpg.


    Im DCC sehe ich (ich nehme gerade auf), dass in 2 Verzeichnissen gespeichert wird, einmal in hdd/movie und zum anderen in hdd/WDCWD10EVDS63U.


    Please help.


    Vielen Dank im Voraus.


    Beste Grüße


    Plüschohr

  • Wenn man GP3 installiert hat, sollte man das Mounten dem Gerätemanager vom
    GP3 überlassen und die Meldung bzw. das Mounten via Devicemanger von DMM
    links liegen lassen, Wenn du der HDD beim initialisieren das Label "hdd" gegeben
    hast läuft alles bestens. ;)

  • Vielen Dank für die schnelle Antwort, aber 2 Dinge stören mich noch:


    1. Wie im Scrennshot zu sehen hat der Device-Manger ja "hdd" nicht angenommen.
    2. Es wird in 2 Verzeichnissen aufgenommen


    Prinzipiell ist es ja gut, dass das Aufnehmen funktioniert, aber irgendwie muss es doch eine Möglichkeit geben, dass Enigma und GP3 das Gleiche anzeigen und der Mountpunkt hdd/movies heißt.


    VG


    Plüschohr

  • Das Mounten von DMM und von GP3 unterscheidet sich wesentlich, also warum sollten
    die das gleiche Ergebnis erzielen?


    Wenn du deiner HDD das Label "hdd" verpasst, dann wird das Teil auch richtig gemountet
    und funktioniert auch richtig ;)


    P.S. DMM hat jetzt in den letzten 3 Jahren das mounten 3 mal verändert und das sagt
    schon einiges über deren KnowHow :D

  • Leider kann ich im GP3 geräte-Manager die Festplatte nicht umbenennen, nach jedem Booten hat sie wieder den Namen WDCWED10EVDS63U, außerdem kommt immer die angehängte Fehlermeldung


    Was kann ich tun? Würde ggf. ein Flashen meine Probleme lösen? Wäre nicht so dass Problem, da ich nur wenige Plugins installiert habe.

  • Quote

    Original von netman
    Wenn man GP3 installiert hat, sollte man das Mounten dem Gerätemanager vom
    GP3 überlassen und die Meldung bzw. das Mounten via Devicemanger von DMM
    links liegen lassen, Wenn du der HDD beim initialisieren das Label "hdd" gegeben
    hast läuft alles bestens. ;)


    Hallo,


    ich hatte ein ähnliches Problem (gleiche Fehlermeldung). Unter DMM => System => Speichergeräte ließ sich die Festplatte nicht initialisieren. Es waren keine Aufnahmen möglich.


    Nach Umlabeln in "hdd" wie oben beschrieben funktioniert das Aufnehmen nun wieder :-)


    So weit so gut. Im Device Manager vom GP3 'gemounted' funktioniert nun also.


    Aber unter DMM => System => Speichergeräte wird die Festplatte immer noch als 'nicht initialisiert' angezeigt.


    Ist das so richtig und normal? Wenn ja, würde ich gern verstehen, warum das so ist.
    Kann das bitte jemand erklären bzw. nen Link posten, wo das wahrscheinlich schon erklärt wurde?


    Vielen Dank und einen schönen Abend noch!

    Viel Grüße



    Alf


    ===============================================
    == DM8000HD + Sat-Tuner + DVB-T-Tuner = DM800SE = DM7020S ==
    ===============================================

  • Ja diese Anzeige kannst du getrost ignorieren da GP3 die Festplatte per udev gemountet
    hat. Der Devicemanager von DMM weiss ja davon nichts und muniert das an ;)

  • Quote

    Original von netman
    Ja diese Anzeige kannst du getrost ignorieren da GP3 die Festplatte per udev gemountet
    hat. Der Devicemanager von DMM weiss ja davon nichts und muniert das an ;)


    Danke!

    Viel Grüße



    Alf


    ===============================================
    == DM8000HD + Sat-Tuner + DVB-T-Tuner = DM800SE = DM7020S ==
    ===============================================

  • Sorry dass ich dieses Thema noch mal ausgrabe, aber ich habe das gleiche / oder ein ähnliches Problem.


    Habe gestern das neuste icvs geflasht. Wollte dann die Einstellungen die ich auf der Festplatte gespeichert habe wieder herstellen. Ging nicht. OK mach ich später dachte ich mir. Als dann der Einrichtungsassistent zu Ende war, kam eine Meldung mit irgendwas von besserer Geräteerkennung. Habe diese Meldung mit ok weggedrückt und meiner Meinung nach damit auch ignoriert. Habe dann den GP3 Wizzard ausgeführt usw.
    Wollte dann auf die Festplatte zugreifen -> geht nicht. Hab dann im Gerätemanager nachgeschaut. Die Festplatte wird erkannt, ist jedoch nicht eingehängt (Kreuz statt grüner Haken). Wollte sie dann mit "rot" einhängen. Nichts passiert. OK, diesen Thread gelesen und FP neu gelabelt. Geht nicht.
    Nun steh ich da mit einer FP mit fast 1TB Aufnahmen und kann nicht mehr darauf zugreifen. Was könnte ich unternehmen, da ich die FP ja nicht initialisieren kann.


    Bitte um Hilfe.


    lg


    sr

  • Ich habe ebenfalls Probleme, meine neue HDD zu mounten :(


    Initialisieren kann ich sie auch nicht nochmal, weil das Aushängen immer fehl schlägt! Die DM mountet die HDD aber permanent unter /media/ram. Wenn ich es irgendwie durch Zufall mal schaffe, sie unter /hdd/ zu mounten, ist sie beim nächsten Neustart wiederunter /media/ram (oder gar nicht) gemountet.


    Also wie man sich mit solchen Kleinigkeiten manchmal den halben Tag versauen kann... :rot:


    Hat jemand eine Idee, wie ich dem Mistding den Unsinn abgewöhnen kann? Von mir aus per telnet?


    THX Wirbel

    VU+ Duo4k SE VTi & DM 820 GP - MacBook Pro 15" 2012, AppleTV, AVR-Heimkino mit Marantz SR7007 und Canton Ergo 5.1-Set
    Datengrab: Fantec http://bit.ly/1Gk291p
    Mitglied-Nr. 7.625 von ca. 345.000

    Webseite

  • Quote

    Originally posted by choetzu
    selbes problem. gibts keine lösung?


    Die Lösung hieß bei mir bisher (will sagen mit latest OE1.6 oder OE2.0) immer:


    1. Manuell allen Dreck bezüglich der Platte aus der /etc/fstab entfernen und stattdessen eine Zeile nach dem Schema


    Code
    /dev/disk/by-uuid/f91916b7-790b-4e84-9001-3d22078fde52 /media/hdd auto defaults 0 0


    reinpappen. Den richtigen UUID bekommt man mit dem Befehl "blkid".


    2. Sicherstellen, dass in /etc/enigma2/settings die Metadaten auch stimmen, hier z.B.


    Code
    config.storage.f91916b7-790b-4e84-9001-3d22078fde52.mountpoint=/media/hdd
    config.storage.f91916b7-790b-4e84-9001-3d22078fde52.device_info=SATA
    config.storage.f91916b7-790b-4e84-9001-3d22078fde52.device_description=ATA-ST9320423AS (320.072 GB)


    Achtung, dieses File nur editieren, wenn enigma2 angehalten ist (init 4, editieren, init 3).


    Danach ist die Platte dann beim nächsten Booten gemountet und E2 hat keine widersprechenden Ansichten mehr dazu. Traurig, dass man das manuell begradigen muss, aber der E2 Storage Manager ist im aktuellen Zustand wirklich nicht hilfreich (wobei er mittlerweile schon besser ist als in den ersten Versuchen^WVersionen). Wenn das zu kompliziert erscheint, ist es bei installiertem GP3 wohl wirklich am einfachsten, den Zustand der HD im E2 zu ignorieren und das Mount (anhand des Labels "hdd") von GP3 erledigen zu lassen. Ich hab's aber lieber konsistent.


    HTH,
    Andre.

  • Also, meine Platte ist nun wieder gemountet.


    Allerdings musste ich meinen Win7 PC über eine CDRom auf Linux booten, weil ja Win kein ext3 kennt. Konnte dann über Linux die Daten (Filme) auf eine externe Festplatte kopieren.
    Musste dann die Platte im GP3 initialisieren und auf hdd labeln.
    Nun wird sie wieder unter /media/hdd gemountet.


    lg


    sr

  • Hallo,


    ich hole diesen alten Post wieder aus der Versenkung, da ich nicht nochmal einen neuen Thread aufmachen wollte.


    Ich hatte meine Festplatte mit einer Linux Live CD neu partitioniert (4k Alignment) und die Festplatte auch gleich mit xfs formatiert und als "hdd" gelabelt.
    Dann habe ich die Daten (Aufnahmen) wieder zurückgespielt. Jetzt wieder eingebaut in der Dreambox bekomme ich die Platte nicht mehr gemountet.


    Ich habe bereits zwei Versionen in der fstab versucht:


    Code
    /dev/disk/by-uuid/6b47d083-17fe-49fe-9b2e-9750e45aba4c /media/hdd auto defaults 0 0


    Code
    /dev/disk/by-label/hdd /media/hdd xfs defaults 0 0


    Leider ohne Erfolg :-(


    Wenn ich die Box neu starte ist meine Festplatte nicht gemountet.
    Wenn ich aber über Dcc_e2 per FTP auf den Pfad /media/hdd schaue, liegt dort eine skydb.db (wird von einem Plugin generiert). Wahrscheinlich wird ein Pfad im Flash angelegt.


    Ich komme hier echt nicht weiter ... kann mir jemand helfen?


    Danke & Grüße
    Robert

  • Was passiert denn, wenn Du "mount /media/hdd" im Telnet probierst?


    Ich würde bei der Notation mit UUID bleiben.


    Du musst dann mal checken ob in /etc/enigma2/settings die alte UUID noch drin steckt falls Du den DMM Gerätemanager genutzt hast.

  • Hi,


    Code
    root@dm8000:~# mount media/hdd
    mount: can't find media/hdd in /etc/fstab


    Hier die aktuelle fstab:


    Code
    /dev/root / rootfs noatime 0 1
    none /proc proc nodev,noexec,nosuid 0 0
    none /proc/bus/usb usbfs nodev,noexec,nosuid 0 0
    none /sys sysfs nodev,noexec,nosuid 0 0
    none /dev/pts devpts noexec,nosuid,mode=0620,gid=5 0 0
    none /dev/shm tmpfs nosuid,nodev 0 0
    none /var/volatile tmpfs mode=0755 0 0
    /dev/mtdblock2 /boot jffs2 ro 0 0
    /dev/disk/by-uuid/6b47d083-17fe-49fe-9b2e-9750e45aba4c /media/hdd auto defaults 0 0
  • Quote

    Original von __QT__
    Was passiert denn, wenn Du "mount /media/hdd" im Telnet probierst?


    Ich würde bei der Notation mit UUID bleiben.


    Du musst dann mal checken ob in /etc/enigma2/settings die alte UUID noch drin steckt falls Du den DMM Gerätemanager genutzt hast.



    Outputs siehe oben.
    In den Settings ist keine UUID vorhanden nur ein paar Verweise auf /media/hdd
    Ich hatte damals (ext3) den GP3 Gerätemanager benutzt.

  • Ich glaube ich hatte es falsch eingegeben.
    Habe jetzt per Telnet nochmal folgendes probiert:


    Code
    root@dm8000:~# mount /dev/disk/by-uuid/6b47d083-17fe-49fe-9b2e-9750e45aba4c /media/hdd
    mount: mounting /dev/disk/by-uuid/6b47d083-17fe-49fe-9b2e-9750e45aba4c on /media/hdd failed: Invalid argument
  • Quote

    Original von fosgate


    Code
    root@dm8000:~# mount media/hdd
    mount: can't find media/hdd in /etc/fstab


    falsch syntax!


    mount /media/hdd


    verwendest du den DMM oder den GP3 Speichergeräte manager? Nur einen von beiden verwenden - nicht mischen? Wenn du den GP3 Gerätemanage verwendest, der Festplatte das LABEL hdd zuweisen


    mit dem Befehl blkid findest du die korrekte UUID und das LABEL der Platte raus

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

  • Hier noch der Output von fdisk -l