FanControl2 - Lüftersteuerung [05.03.2013]

  • Hallo Cleaner_2999,
    OK, dann ist es irgendwie klar. Es gibt da mehrere Probleme die mit der aktuellen FanControl2 dann leider nicht zu lösen sind. Werde das dann mal zum Anlass nehmen in der nächsten Version die Parametergrenzen weiter aufzubohren. (hoffe auf Wochenende :-) )
    - max Drehzahl lässt sich nur bis 4000 einstellen (somit wird die bei deinem Lüfter mögliche Drehzahl nie erreicht)
    - Regel-Endetemperatur ist fest auf 55°C definiert (es würde also erst bei 55C die max Drehzahl erreicht)
    Da muss ich dich vertrösten. Du kannst aber bis dahin die max Drehzahl auf 4000, min auf 1000 und die Ruhetemp auf kleinen wert (35C) stellen. Das wäre dann der z.Z. maximal höchste Regelbereich.
    Gruß Jörg

  • Ok..werde mich heute nachmittag nochmal damit beschäftigen und noch einige Einstellungen ausprobieren.
    Gruß

  • Doch schon mal wieder eine neue Version (im 1.Beitrag)


    Version 1.1 (08.01.2010)
    - Mehrsprachenunterstützung
    - Lüfterwerte prüfen
    - erweiterter Einstellbereich der Parameter
    - Regel-Ende-Temperatur einstellbar

  • Ich habe diese probleme. In flahs ist Gemini 6.4 an den Drehzahl zeigt immer "0" und die Ventilator schaltet aus nicht. Veltilator ist 3 pin.
    500/1200/43°C/55°C .Kannst du mir helfen was konnte die Prbleme sein?
    Imrisko
    Scholigung wegen die Deutsch.

  • Quote

    Original von Imrisko
    Ich habe diese probleme. In flahs ist Gemini 6.4 an den Drehzahl zeigt immer "0" und die Ventilator schaltet aus nicht. Veltilator ist 3 pin.
    500/1200/43°C/55°C .Kannst du mir helfen was konnte die Prbleme sein?
    Imrisko
    Scholigung wegen die Deutsch.


    Hello Imrisko
    Well then in english. Can you see below "information - hardware" all temperatures? What shows fancontrol to "target xxxx rpm (tt.tC). Have you been waiting times 1 to 2 minutes? You ever can install "tempfan-plugin" by DMM for testing (normal "Add" to download plugin). It is to be found under "Settings - Fan Control". With this you can also set an initial value, regulates fancontrol2 from.You can also try the yellow test button.
    Greeting Jörg

  • Hello joergm6
    Here are my informations from my DB. Fan speed shown 0 rpm but the fan is working.
    Fan rpm current: 0 target:555 /44,5C/


    Iformation-hardware - 44C, 38 C, 32 C, 36C,
    45C, 39C, 37C, 36C
    Type 1 Speed 0 rrpm
    Fan 1 Voltage 255
    Fan 1 PWM 255
    Could you help me to fix the problem.
    Imrisko

  • Quote

    Original von Imrisko
    Type 1 Speed 0 rrpm
    Fan 1 Voltage 255
    Fan 1 PWM 255
    Imrisko


    Hello Imrisiko
    If Voltage and PWM are equal to 255, then the fan is maximally activated. That is not Fancontol problem. It looks like that you have a problem with the hardware.
    -the fan is not working
    -fan with 3pin to 4pin plugged is wrong (think of the right 3)
    -other fault
    Jörg

  • Quote

    Original von ali_0005
    Funktioniert nicht mit OoZooN 20100110


    Hallo ali_0005,
    danke für diese wichtige Information. Da ich kein OoZooN verwende, weis ich das natürlich nicht. Werde bei Gelegenheit mal schauen, ob da was zu machen ist.
    Jörg
    PS: Was passiert denn, Crash oder nichts oder keine angezeigten Werte oder regelt nicht oder ...

  • so OoZoon Problem:
    Geht leider noch nicht mit der Stable-Version (Experimental sollte gehen). Es könnte helfen, unten angegebene Dateien zu ergänzen, zumindest hat es bei mir funktioniert. Es ist bisschen kompliziert aber was anderes fällt mir so schnell nicht ein.


    - Datei mit FTP nach /tmp kopieren
    - dann im Telnet:
    cd /tmp
    tar -xzv -f sensor.tar.gz -C /
    - OoZoon neu starten


    Versucht mal.

  • Quote

    Original von Zing
    jörg


    Alles gelöst, habe die Treiber im flash aktualisiert und jetzt funktioniert die Regelung (und auch die Zielwertanzeige natürlich)
    Danke!


    Hi,


    Zing: Iist das ein ArcticCooling 8025 PWM? Da hab ich nämlich nirgends eine Drehzahlanzeige (Lüfter läuft natürlich, rpm=0). Ist das mit neuen Treibern hinzubekommen?


    Ich würde gern das FanControl2 benutzen, habe jedoch das Gefühl, dass das Einmessen bei rpm=0 nicht so richtg zum Erfolg führt. Oder wird da bei 4-Pin nur PWM-Signal <-> Temp abgeglichen?

  • dstockm der Lüfter von Arctic Cooling nennt sich 8 Arctic PWM


    Ich habe (oozoon im flash) die Treiber aktualisiert, danach gabs auch die rpm Anzeige. (und die Temp Anzeigen der Sensoren unter Hardware).
    Die Regelung funktioniert, relativ träge, ist aber so gewollt und OK.
    Den Lüfter werde ich nochmals tauschen (ist in der Bauhöhe etwas hoch) zB. gegen einen smartcooler LFM 1580 HP, wenns mir gelingt den irgendwo zu bestellen.

  • Quote

    Original von dstockm
    Ich würde gern das FanControl2 benutzen, habe jedoch das Gefühl, dass das Einmessen bei rpm=0 nicht so richtg zum Erfolg führt. Oder wird da bei 4-Pin nur PWM-Signal <-> Temp abgeglichen?


    Immer schauen ob bei "Ziel (tt.tC)" ein Temperaturwert angezeigt wird, wenn 0.0C dann sind die Treiber nicht aktuell.
    Bei 4Pin wird nur PWM und bei 3Pin nur Spannung gegen die Temperatur geregelt. Ist für die jeweils anderen Werte nichts definiert (z.B.mit tempfanplugin), werden diese auf Maximum (255) gesetzt. In der nächsten Version wird man übrigens auch PWM und Spannung einen Startwert zuweisen können.
    Jörg

  • Quote

    Originally posted by joergm6
    so OoZoon Problem:
    Es fehlen hier offensichtlich Komponenten im OoZoon, obwohl diese im CVS enthalten sind. Hoffe das diese irgendwann auch im OoZoon enthalten sein werden.

    Im OoZooN fehlt nichts, nimm doch einfach Kontakt auf mit OoZooN und frage ihm ob er es auf seinem Feed setzt.

    Boxen: im Betrieb die DM7080HD, DM900HD, DM920HD
    Image: u.a. DP Original (unstable)
    Skin...: Verschiedene

  • Habe sensor.tar.gz installiert nachdem ich die originelle tempfan Plugin selbstverständlich erweitet habe. OoZooN neugestartet aber nichts. Sehe nichts im Menu und die *.pyc Dateien werden (wenigstens hier) nicht erstellt.

    Boxen: im Betrieb die DM7080HD, DM900HD, DM920HD
    Image: u.a. DP Original (unstable)
    Skin...: Verschiedene

  • Hallo ni_hao,
    funktioniert das originale DMM tempfan-plugin (unter Einstellungen) auch nicht?
    Die 3 py-Daten liegen jetzt unter /usr/lib/enigma2/python/Components... (dort sind auch mehrere andere Dateien)? Warum werden keine pyc angelegt, schon komisch? Sind die Rechte anders als die anderen py-Dateien?
    Ich nutze Oozoon nur als BA-Flash-Boot und arbeite nicht damit und damit auch keine Erfahrungen. Habe gestern Abend nur fix ein Online-Update gemacht und die Dateien reinkopiert und einmal probiert - ging.
    Vielleicht kann ja mal ein Anderer hier sagen, bei dem es ging oder auch nicht ging im Oozoon.
    Gruß Jörg

  • Ja ich weiß wodie Daten liegen.Die originale DMM plugin geht.
    Habe danach deine Dateien kopiert, OoZooN komplett neu gestartet und kriege dann immer noch die originale zu sehen. Dann habe ich die originale (übers Menu) gelöscht und deine wieder in die Verzeichnisse kopiert, wieder neustart und nichts.
    Habe OoZooN auch mit BA als flash boot.

    Boxen: im Betrieb die DM7080HD, DM900HD, DM920HD
    Image: u.a. DP Original (unstable)
    Skin...: Verschiedene