[gelöst]skin_user.xml Frage zu LCD Display

  • Ich habe Bucks RGB Display sowohl in meiner DM8000 als auch in meiner neuen DM7080 installiert und betreibe beide Boxen mit meinem eigenen Skin.


    Da ich auch ein externes Display mit LCD4Linux benutze, wollte ich auf dem internen Display den gleichen Standbyscreen (Flip Clock) anzeigen.


    Deshalbe ich mir die Hintergrundgrafik (Bild 1) aufgesplittet in einen horizontalen (Bild 2) und einen vertikalen (Bild 3) Rahmen um per Überlagerung das FlipClock Design zu erhalten. Das Ergebnis das auf der 8000er läuft sieht man in Bild 4. Perfekt!


    Normalerweise müsste ich das ja nun 1 zu 1 auf der 7080 übernehmen können, dem is aber leider nicht so.


    So muss ich beispielsweise die horizontale Position des vertikalen Rahmens von etwa der Mitte (Pixel 190) sehr viel weiter nach rechts verlagern (auf Pixel 375). Damit ist die Grafik auf der 7080 mittig, auf der 8000 aber wird sie rechts angezeigt (Bild 6). Ausserdem wird nach kurzer Zeit die Grafik auf der 8000 mit Falschfarben angezeigt (Bild 5). Aber nur die vertikale, obschon ich die horizontale Grafik mit dem gleichen Grafikprogramm auf die gleiche Weise erstellt habe. Ausserdem erscheint auch der Text der Uhrausgabe auf der 8000er nach einiger Zeit (ich glaube es ist beim Minutenwechsel) mit grünem Hintergrund angezeigt (Bild 7).


    Wohlgemerkt, ich habe weder die Grafik noch die Textparameter getauscht: wurde eben noch alles normal angezeigt, wechseln plötzlich die Farben.


    Hat jemand eine Ahnung, was hier los ist. Vielleicht Unterschiede im Treiber für beide Boxen?

    Files

    • 1.png

      (7.1 kB, downloaded 354 times, last: )
    • 2.png

      (912 Byte, downloaded 349 times, last: )
    • 3.png

      (2.31 kB, downloaded 350 times, last: )
    • 4.jpg

      (38.67 kB, downloaded 367 times, last: )
    • 5.jpg

      (48.72 kB, downloaded 356 times, last: )
    • 6.jpg

      (48.35 kB, downloaded 351 times, last: )
    • 7.jpg

      (37.11 kB, downloaded 360 times, last: )

    Edited once, last by Carbonide ().

  • marco777
    danke



    keine Ahnung, ob es daran liegt, aber hast du in deinem Verzeichnis in dem die Grafik liegt auch eine dummy.png?


    Das Display der 7080HD hat die gleiche Einbauposition wie das Display der 7020HD und diese unterscheidet sich von der Position der 8k um ca 20 Pixel.

    Files

    • dummy.zip

      (304 Byte, downloaded 11 times, last: )

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

    Edited 3 times, last by Jogi29 ().

  • Jetzt ist da eine, aber das macht nicht den geringsten Unterschied, oder muss noch etwas in der skin_user.xml geändert werden?


    20 Pixel ist sowieso viel zu wenig, ich habe position=" 375,0" drin damit die Grafik mittig auf der 8000er angezeigt wird.

  • ich hatte geschrieben, dass die Position des Displays sich um ca 20 Pixel unterscheidet bei der 8k und der 7080HD.


    Deine position="375,0" würde ja bedeuten, dass du einen linken Rand von 375 hast und das bei einer Gesamtbreite des Displays von 400 8o
    Alles sehr dubios.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Ich habe den Fehler, so unglaubwürdig es auch ist, gefunden: es war das von mir benutzte Grafikprogramm, das fehlerhafte Dateien geschrieben hat.


    Ich benutzte GraphicConverter 9.2 (unter Mac OS X), nach Update auf Version 9.6 brauchte ich nur die Grafikdateien zu öffnen und neu zu speichern.


    Jetzt gibt's keine Probleme mehr mit falschen Koordinaten oder Farben.

  • Einen halben hab ich fast gefunden :D


    Hoffe dies hilft anderen Zeit bei der Fehlersuche zu sparen, wenn solch völlig unerklärliche Phänomene auftauchen, und sie dazu bewegen, gleich mal die benutzte Software genauer zu testen.