Posts by JollyMäh

    Hallo bauci,


    vielen Dank für deine Nachricht! :)


    Irgendwie ist es schön zu hören, das man nicht alleine mit dem Problem ist. Andererseits scheint es ja tatsächlich ein Problem im Betriebssystem zu sein, wenn es auf der One & Two auftaucht.


    Bislang habe ich noch keine Lösung gefunden. Hatte eigentlich vor, meine 7080 mal durch die Two zu ersetzen. Aber solange der NFS-Server nicht vernünftig läuft steht die Two erstmal in der Ecke. Gelegentlich versuche ich nach neuen Updates ob das Problem gefixt wurde, aber bislang leider nicht.


    Bleibt uns also nur abzuwarten.


    Momentan habe ich noch Hoffnung, da für die Two ja noch nicht einmal ein Stable Image erschienen ist.

    Nicht ganz freiwillig habe ich nun auf der Dreambox 500v2 (OE2.0 / IP: 192.168.178.242) eine Neuinstallation durchgeführt. Allerdings hat es das Problem auch nicht verändert.


    Die beiden Einträge /media/hdd UND /media/hdd/movie kamen zustande nachdem ich auf der Dreambox 500v2 (Client) in der auto.network den Eintrag

    Code
    DM-TWO -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.241:/media/hdd/movie

    einmal ohne "/movie" ausprobiert hatte. Selbst nach dem Zurückstellen, oder der Neuinstallation blieb der doppelte Eintrag auf der Serverbox durch den Befehl showmount -a bestehen. Da ich nicht wusste, wo auf der Serverbox der doppelte Eintrag gespeichert wird, habe ich ein nicht zu altes Backup zurückgespielt. Jetzt zeigt der Befehl showmount -a wieder wie gewohnt:

    Code
    All mount points on dreambox:
    192.168.178.242:/media/hdd/movie
    192.168.178.243:/media/hdd
    192.168.178.246:/media/hdd/movie


    Aber nun zurück zum eigentlichem Problem. In der /etc/exports auf der Serverbox schauts so aus:

    Code
    /media/hdd *(rw,async,secure,no_root_squash,no_subtree_check)

    Der Befehl systemctl status rpcbind.service bringt im laufenden Zustand:

    Code
    ● rpcbind.service - RPC Bind Service
    Loaded: loaded (/lib/systemd/system/rpcbind.service; indirect; vendor preset: enabled)
    Active: active (running) since Thu 2020-12-03 16:06:08 CET; 25min ago
    Process: 1966 ExecStart=/usr/sbin/rpcbind $RPCBIND_OPTS (code=exited, status=0/SUCCESS)
    Main PID: 1967 (rpcbind)
    CGroup: /system.slice/rpcbind.service
    └─1967 /usr/sbin/rpcbind
    Dec 03 16:06:08 dreambox systemd[1]: Starting RPC Bind Service...
    Dec 03 16:06:08 dreambox systemd[1]: Started RPC Bind Service.

    Der Befehl systemctl status rpcbind.service bringt im abgeschmierten Zustand:

    So wirklich schlau, werde ich daraus nicht.


    Nach wie vor habe ich das Gefühl, das der NFS-Server mit dem Betriebssystem der TWO im Zusammenspiel mit einer älteren OE2.0-Software nicht klar kommt. ?(


    Aber trotzdem DANKE für euere Beteiligung und Anteilnahme!!! :thumbs_up::)

    Hallo Bundy00,


    vielen Dank für deine Antwort! Du hast mich zumindest schon einmal auf die richtige Spur gebracht. :)


    Wenn der NFS-Server auf der Dreambox Two (IP: 192.168.178.241) läuft wie er soll, und nur die Dreambox 7080HD (IP: 192.168.178.243) darauf zugreift bekomme ich auf den "showmount -a"-Befehl als Ausgabe:

    Code
    192.168.178.242:/media/hdd
    192.168.178.242:/media/hdd/movie
    192.168.178.243:/media/hdd
    192.168.178.246:/media/hdd/movie

    Erfolgt dann ein Zugriff von der älteren Dreambox 500v2 (IP: 192.168.178.242) und der NFS-Server der Dreambox Two geht wieder in die Knie, bekomme ich auf den "showmount -a"-Befehl als Ausgabe:

    Code
    clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)

    Auf der Clientbox finde ich dann in der Logdatei folgende Einträge:

    Code
    Dec 1 18:44:09 dm500hdv2 daemon.info gdaemon: [gdaemon] Hardware event=262145 device=0:21
    Dec 1 18:44:09 dm500hdv2 daemon.notice automount[753]: >> mount: RPC: Remote system error - Connection refused
    Dec 1 18:44:09 dm500hdv2 daemon.notice automount[753]: >> mount: mounting 192.168.178.241:/media/hdd/movie on /media/net/DM-TWO failed: Bad file descriptor
    Dec 1 18:44:09 dm500hdv2 daemon.err automount[753]: mount(nfs): nfs: mount failure 192.168.178.241:/media/hdd/movie on /media/net/DM-TWO
    Dec 1 18:44:09 dm500hdv2 daemon.err automount[753]: failed to mount /media/net/DM-TWO


    Daraus lese ich, das es wohl ein Problem mit RPC gibt. Gibt es eine Möglichkeit dieses RPC noch näher zu analysieren? ;)

    Sämtliche IP-Adressen der Dreamboxen sind manuell zugewiesen, was bisher noch nie ein Problem war.

    Das Gemini-Server-Update von gestern brachte leider keine Besserung.


    Bislang tritt das Problem immer dann auf, wenn ich von einem OE2.0-Gerät darauf zugreife.

    Solange ich nur von meiner 7080HD (OE2.5) darauf zugreife, läuft der NFS-Server tagelang problemlos.


    Kann man irgendwie ein Log vom NFS-Server einsehen?

    Über systemctl status nfs-server ist leider nichts ersichtlich.

    Hallo zusammen,


    bin seit geraumer Zeit verzweifelt dabei, den NFS-Server auf meiner Dreambox Two vernünftig zum Laufen zu bringen. Installiert wurde er auf dem aktuellesten Experimental Image + GP4.1 (alles neuester Stand) mit Hilfe des Addon-Managers im Blue Panel aus den Gemini Plugins. Freigegeben ist eine externe SSD. Im Blue Panel erscheint dann auch der Status: läuft. Wird nun von einer Dreambox 7080HD (OE2.5) darauf zugegriffen scheint alles wie gewünscht zu funktionieren - Film aufzunehmen oder anzusehen.


    Jetzt zum Problem:

    Versuche ich von einer älteren Dreambox 500v2 (OE2.0) oder Dreambox 800se (OE2.0) darauf zuzugreifen, erhalte ich zunächst die Fehlermeldung das Verzeichnis existiere nicht. Greife ich dann per SSH auf die Dreambox Two zu und sende die Befehle systemctl stop nfs-server und anschließend systemctl start nfs-server kann ich danach auch kurzzeitig von der Dreambox 500v2 und Dreambox 800se darauf zugreifen. Meist wird der Inhalt der externen SSD der Dreambox Two angezeigt und auch die Aufnahmen können kurzzeitig wiedergegeben werden. Allerdings bricht dann kurze Zeit später die Wiedergabe ab, und der NFS-Server ist dann nicht mehr zu erreichen.

    Versucht habe ich schon einiges, z. B. Neuinstallation half leider nicht. Auch über die Parameter die NFS-Version festzulegen schlug fehl.

    Die Dreambox 7080HD wurde über den Netzwerkbrowser (also über die fstab) angebunden. Die OE2.0 Dreamboxen wurden über die auto.network angebunden.


    Kennt jemand ähnliche Schwierigkeiten mit dem NFS-Server auf einer Dreambox Two? Gibt's da noch einen Software-Bug in Verbindung mit älteren OE2.0 Geräten? Oder kann mir sonst jemand weiterhelfen?

    Danke dir! Jetzt hat's geklappt. :)


    Im Gegensatz zu heute morgen habe ich nun zum Ändern der skin.xml das Notepad++ unter Windows genutzt und nicht mehr das MacBook.
    Zudem wurde der Eintrag in Zeile 157 eingefügt und nicht in 170.

    Vielen Dank für die schnelle Antwort! :)


    Habe jetzt mal versucht die Zeile in:
    /usr/share/enigma2/materials.GP4/skin.xml in der Zeile 170 hinzuzufügen. Leider brachte das keine Änderung nach einem Neustart.


    Dann habe ich versucht in
    /usr/share/enigma2/skin.xml in Zeile 128 den Wert von seperation="550" auf "460" zu ändern. Leider brachte das auch keine Änderung nach einem Neustart.


    In welchem Verzeichnis sollte ich die skin.xml ändern?

    Hallöchen,


    seitdem ich in diese Woche sämtliche Updates auf meiner 7080 installiert habe, sind bei den Timereinträgen Texte abgeschnitten (siehe Bild).


    Wurde da grundsätzlich etwas an der Schnittstelle verändert?
    So viel ich weiß, gab es doch kein Update vom Skin Materials!?
    Kann man das durch ein Skin Update wieder korrigieren, oder ist der Fehler in einem anderen Paket?


    LG


    JollyMäh