LCD4linux-Plugin - WLAN-Web / Android / Pearl / Samsung - LCD-Display an der Dream [18.08.2022]

  • Die 5 Dateien habe ich importiert.


    Zu:


    Android:
    - Einstellungen - Sicherheit - Geräteadministratoren - Tasker = aktiv
    - Einstellungen - Bedienungshilfen - Dienste - AutoInput = An


    Bei meinem Tablet ist beides unter "Einstellungen - Sicherheit - Geräteadministratoren" zu finden und da habe ich die Haken gesetzt.


    Unter "Einstellungen- Eingabehilfe-Dienste" wird mir aber Tasker und AutoInput als "aus" angezeigt.


    Aber unter "Einstellungen - Sicherheit - Geräteadministratoren" bei beiden definitiv Haken gesetzt.


    MfG

  • Hallo joergm6!
    Hast Du denn schonmal Feedback bekommen ob Deine Scripte funktionieren wie sie sollen?
    Habe soweit alle Seiten nach Deiner Anleitung gelesen.
    Aber keiner hat sich mit einem Feedback dazu geäußert.
    Wie verfahre ich jetzt weiter?


    MfG

  • Quote

    Original von joergm6
    Edit: wenn etwas "aus" ist und es "an" sein soll, dann muss man das auch einschalten. *Weisheit Ende* ich kann kaum glauben das man das noch erwähnen muss :frowning_face: . Das mag ich nicht beantworten.


    @ joergm6, Du hattest gestern ja nach 22 Uhr Deinen Beitrag erweitert.
    Ich habe Dir gestern schon geantwortet das ich beides unter Sicherheit/.../ aktiviert habe.
    Siehe dazu den Screenshot "Ansicht Sicherheit".
    Komischerweise werden aber beide App's unter Eingabehilfe mit "aus" gekennzeichnet.
    Siehe dazu Screenshot "Ansicht Eingabehilfe".


    Ich habe zwar nicht viel Ahnung von der Materie aber glauben das ich das auf aktiv gesetzt habe kannst Du mir schon.


    Du hast mir im opena.tv diese Variante empfohlen, hatte auch immer gedacht das Du bereit bist Hilfestellung zu geben.
    Das Du Dich aber hier belustigst hätte ich nicht erwartet.


    Wäre schön wenn wir hier respektvoll und im Sinne der Sache weiter machen könnten.
    Wie geschrieben, ich bin auf Hilfe angewiesen.
    Natürlich würde ich mich auch über Tips von anderen Usern freuen die joergm6 seine Anleitung erfolgreich umgesetzt haben.


    MfG

  • Guten Abend!


    Folgendes Ergebnis ist nun bei mir, es scheint nun alles zu funktionieren.
    Aber es gibt noch ein Problem, wenn ich Box ausschalte wird das Tablet dunkel ( soll es ja).
    Wenn Box gestartet ist startet auch das Tablet durch, jedoch ist das Display "erleuchtet schwarz", heißt es wird nichts angezeigt.
    Nach einer kurzen Zeit kommt die App Info von MJPEG Viewer ( Stopp erzwingen etc.)
    Ich mache hier nichts und nach einer Weile ist Display wieder schwarz.


    Habe hier nun versuchsweise die Zurück-Taste des Tablets gedrückt, da kommt der MJPEG Viewer, drücke ich nun hier "Show" zeigt das Display alles OK an.
    Was paßt nun noch nicht?
    Bitte helfe mir doch nochmal.
    Wäre Dir sehr dankbar.


    MfG

  • ich wollte jetzt eigentlich keinen Android Kurs machen, von daher gehe ich davon aus, das man die Einstellung aktiviert, wenn es heisst das es "An" sein MUSS.
    Es MUSS MUSS MUSS AutoInput = An sein, also bitte klicke da drauf, wo jetzt "Aus" steht und schalte den erscheinenden Schalter auf "An" .
    Das hat auch nix mit belustigen zu tun, denn das setze ich da einfach voraus, wenigstens das zu tun was zu tun ist. Du hattest ja selbst erkannt das es "Aus" ist, von daher mochte ich nicht mehr :grinning_squinting_face: ... ist nicht böse gemeint, ging grad nicht anders :winking_face:
    Also nicht aufgeben.....

  • Bitte schau noch mal meinen Post über Dir.
    Es funktioniert nun alles bis auf das mit Show händisch.


    MfG

  • die Tastenbelegung kann sich in den Androidversionen unterscheiden. Momentan bin ich unterwegs und kann nicht wirklich genauer schauen.
    schau mal in die L4L-Kill Mjpeg-App. Da gibt es Autoinput Actions. Glaube da steht id/left_button . Bei mir ist da der Anwendung-Stopp-Button aber rechts. Wenn du das Tasker Video gesehen hast, lerne das mal neu an..... so in der Art
    im obigen Tasker Script
    -vorhandene Zeile AutoInput Action aus dem Taskeditor wählen
    -rechts oben der Stift
    -Easy Setup
    -gehe zu Einstellungen-Anwendungen-Anwendungsmanager-MJPEGviewer (so das du Stop erzwingen Button siehst
    -Tabbildschirm von oben runterziehen
    -Benachrichtigung "Select Field" auf "RE-SELECT" klicken
    -auf das "Stopp erzwingen" klicken
    -mit "ACCEPT" speichern
    -Tasker App aus der laufenden Appliste wieder hervorholen
    -gewünschte Element Element Text:Stopp erzwingen klicken
    -mit Häkchen oben speichern
    -zurück zum Taskseditor


    Das "Show" müsste ja eigentlich passen, aber evtl hast du einen inkonsistenten Zustand, weil du die App selbst gestartet hast oder diese nicht "gekillt" werden konnte. Das Script muss alles selbst machen, Killen und selbst starten. Evtl gibt es auch ein Timingproblem. In der L4L_Mjpeg_Start ist ja eine Pause drin, bevor "Show" geklickt werden soll, evtl mal verlängern.

  • Guten Abend!
    Ich werde noch verrückt.
    Wenn ich heute das Tablet starte wird mir oben zwar der Tasker angezeigt aber die Display Anzeige kommt nicht.
    Destop wird angezeigt.
    Öffne ich den Tasker und gehe unter Tasks auf L4L-Mjpeg Start und da unten links zum Test auf das Dreieck startet alles.


    MfG

  • Ja steht auf ein.


    Komischerweise steht unter Tasker, wenn ich von oben runter ziehe, Keine aktiven Profile, stand aber gestern auch da und trotzdem startete alles automatisch.


    MfG

  • glaub da muss auch nix aktives stehen. Ist bestimmt nur wenn eines wirklich gerade läuft.
    Vielleicht schreibst du mal zusammengefasst, was genau wann passiert (oder eben nicht). Gestern ging ja irgendwas auch automatisch.

  • Quote

    Original von Sense26
    Danke für die Tip's.
    Werde morgen weiter machen und berichten.


    MfG


    Hatte das gemacht, danach ging es nich mehr.
    Vorher noch unter Eingabehilfe Tasker und AutoInput auf ein gestellt.
    War ja gestern noch nicht.


    Da nun nichts mehr ging habe ich im Tasker die 5 Dateien gelöscht, dann auch per PC noch im Ordner Tasker die 5 Dateien durch die aus Deinem .zip ersetzt.
    Dann wieder im Tasker am Tablet hinzugefügt und die IP eingetragen.


    MfG


    Eins ist mir noch gerade eingefallen, als ich bei Eingabehilfe AutoInput auf ein gestellt hatte kam ein Hinweis wegen Sprache, hatte da nun da was auf deutsch gestellt, kann aber nicht genau sagen wo das war, das kam automatisch.
    Da stand was mit Samsung und Google, habe das da auf Google geändert und deutsch ausgewählt.


    MfG

  • das dadurch nix mehr ging wäre aber auch komisch. Die Sprache sollte auch egal sein.
    Wir drehen uns im Kreis, ich weis nicht was passiert und du nicht was man wo/wie schauen/einstellen kann. Keine gute Sitution.
    Vielleicht hilft es, wenn du ein paar Pop-Nachrichten in die Tasks einbaust. Dann sieht man wenigstens optisch, was gerade abgearbeitet wurde. Du kannst (wenn du kannst :grinning_squinting_face: ) an verschiedenen Stellen solche Ausgaben einbauen. Sicherlich in erster Linie in die L4L-Steuerung, die ja hauptsächlich läuft.
    Wenn man vor einer Zeile so eine Aktion einfügen möchte, dann diese Zeile lange halten, es erscheint oben das Menü (3punkte) hier gibt es dann "Aktion Einfügen"
    - dann "Alarm" wählen
    - "Popup-Benachrichtigung" wählen
    - Bei Text etwas sinnvollen eintragen, damit du diese Position daran erkennst
    man kann auch Variablen mit ausgeben (Auswahl mit Klick auf dem Stift)
    z.B. Text = 1.Stelle %Running
    "1.Stelle " ist beliebiger Text
    %Runnung ist die verwendete Variable mit dem Namen Running (Variablen erkennt man an dem % davor)
    %Running und %HTTPR sind z.B. interessante Variableninhalte und wenn man solche Ausgaben in der Zeile vor deren Verwendung einbaut (z.B. vor IF ) dann kann man sehen, ob wirklich erwartete Werte dort enthalten sind.
    Eingefügte Zeilen lassen sich später mit dem "Schere"-Symbol wieder löschen.
    Ich glaube du muss dir bissel Zeit nehmen und herum experimentieren. Für weitere Hilfe fehlt mir ein Ansatz :frowning_face: . Schreibe mal, welche Android-Version du benutzt, evtl habe ich auch zufällig so Eine zum Test. Ich glaube, ich habe die Scripte damals mit Android 4.4 gebaut.

  • Guten Abend joergm6!
    Habe heute das Tablet mal auf Werkseinstellungen zurück gesetzt.
    Alles installiert was nötig und eingestellt.
    Leider startet die Displayeinstellung auch jetzt nicht.


    Was mir auffällt ist das auch das Display nach erscheinen des Taskersymbols (ganz oben) nicht abdunkelt.


    Als ich Dich neulich darauf hin fragte war Deine Antwort:
    "es scheint ja schon etwas zu gehen".


    Wie schon erwähnt, wenn ich im Tasker/TASKS/L4L-Mjpeg Start per Dreieck unten links teste, funktioniert es (das mit dem testen wurde ja im Video beschrieben).


    Irgendwie geht die "Automatik" nicht.


    Nebenbei noch eine Frage, warum kann man den Tasker per Anwendungsmanager nicht löschen?
    "Stop erzwingen" und auch "Deinstallieren" etc. sind alle ausgegraut.


    MfG

  • ich glaube, ich habe gerade was festgestellt. Ich habe mal in die exportierten Scripte geschaut und festgestellt, das auch das PROFILE L4L_Timer scheinbar Scriptcode enthält, was eigentlich als Tasks definiert ist. Mir scheint, das hier der Code doppelt/kopiert vorliegt.
    Gehe mal auf die PROFILE Seite, wähle L4L_Timer und klicke hier auf L4L_Steuerung. Ich denke du wirst hier sehen, es steht immer noch vuduo2 drin, obwohl du das in dem gleichnamigen Task schon geändert hast. Trage dort noch einmal deine BoxIP ein.
    Wenn das so ist, wäre es ziemlich undurchsichtig wie Tasker seine Skripte verwaltet :frowning_face: . Das könnte so Einiges erklären.


    PS: und ja die Tasten in der Appverwaltung sind für den Tasker ausgegraut. Killen kann man ja nur Anwendungen die aktuell laufen. ich denke der Tasker wird Ereignisgesteuert überhaupt erst gestartet und dann wieder beendet (z.B. alle 2min)

  • dann mit ein bissel Infoausgabe auf dem Display (alle 2min) . Da du wohl die oben beschriebenen Popup Nachrichten nicht einbauen möchtest, habe ich das mal gemacht.
    Es werden also alle 2min Ausgaben wie
    Run:0 Http:200
    angezeigt
    Run : MJPEGviewer läuft nicht = 0 / läuft = 1
    Http : Box nicht erreichbar = -1 / erreichbar = 200
    Zudem Anzeige "Start MJPEGviewer" und "Kill MJPEGviewer" und "MJPEGviewer hängt > Kill"
    Die BoxIP sollte also wieder auf "vuduo2" stehen.
    Ich habe den Kill-Task auch auf den Text "Stopp erzwingen" umgestellt, das ist aber primär nicht das eigentliche Problem. Auf meinem 4.4.2 funktioniert das, wie vorher auch.
    Der Text "Stopp erzwingen" ist in den Android-Versionen verschieden und muss angepasst werden. Bei meinem 6.0.1 heisst das "STOPP ERZWINGEN" und ein 4.4.4 "Beenden Erzwingen".