Enigma2 Image for PowerPC Dreamboxes - Howto

  • What bitbake commands did you use for enigma2-plugins ?


    I used these commands :-


    cd /...../build
    source ./env.source
    bitbake -cclean enigma2-plugins
    bitbake -enigma2-plugins


    with my .bb and the attached in /sources.

  • Yes that was exactly the commands I did :) I'm pretty chuffed with that.


    But with enigma2-plugins_cvs.schwerkraft.elitedvb.net__20100724.tar.gz reflecting differences in source date.


    I must admit I have done a cclean world n started again since then though for a fresh start!

  • Quote

    Originally posted by Hejira
    Yes that was exactly the commands I did :) I'm pretty chuffed with that.


    But with enigma2-plugins_cvs.schwerkraft.elitedvb.net__20100724.tar.gz reflecting differences in source date.


    I must admit I have done a cclean world n started again since then though for a fresh start!


    There was no need for that. :)


    I changed the date from the older date. Because I wanted some new plugins.

  • I've changed source date, rebuilt plugins ok n restarted dreambox-image :)



    Edit: I have an image, I wasn't expecting that so quickly!!! I'll see if it boots in BA.

  • Are you sure it is enigma2 ? :D


    You will probably need some patches to boot. Let us know what happens !

    Edited once, last by pcd ().

  • Of course i'm not sure if it's e2 pmsl i'm just n optimist n had to have a go :)


    No didn't seem to boot got to the sharp dream start screen, I could telnet in to reboot.

  • What is the size of the image ?


    I will have to post you some patches. It is late now. When will you again start your trials ?

    Edited once, last by pcd ().

  • image size 27.7MB


    whenever your ready, I'm writing up some notes to help me remember what I've done so far.


    Again I can't thank you enough for help.

  • Hi,


    Attached are the items you need for a e2-cvs image. If this works - I will post the other items for v7.0.


    Please put in the items as here :-


    A_importsE2 -> /tmp/work
    enigma2.bb -> /packages/enigma2
    oe_enigma2_diff.patch -> /packages/enigma2
    dreambox-df2.bb -> /packages/dreambox
    dreambox-image.bb -> /packages/images


    Please check that the scripts in A-importsE2 have permission to execute.


    Cheers, pcd.

    Files

    • e2-cvs.tar.gz

      (7.8 kB, downloaded 9 times, last: )

    Edited once, last by pcd ().

  • log_check: There were error messages in the logfile
    log_check: Matched keyword: [Cannot find package]
    Collected errors:
    Cannot find package enigma2-skin-zombi-hdr3.


    I just commented out for now n I have a new image, BA here we come! :)



    Edit: Ok it gets a bit further, but now caught in a boot loop, The blurred dream boot screen goes to spinning gears but not displayed right, then blue/white vertical lines, back to blurred dream.


    (I'm using SVideo)

  • Please do these telnet commands :-


    init 4
    killall -9 enigma2
    enigma2>/tmp/e.log 2>&1 &


    Then post /tmp/e.log


    Why is the Zombi skin asked for ? Where in my items Zombi skin is mentioned ?

  • skin in dreambox-image


    i also renamed dvb-modules in tar to df2 which I take was right?


    I've been brave n also changed in df2 to this:
    PV_dm600pvr = "${KV}-20090430"


    this was date in my dvb-modules, compiled ok n this is the e.log from that image in BA

  • Is the image on BA ?


    The last line of log says - it needs tuxtxt.ttf.


    You can get any missing stuff like this from the v7.0 image.


    But for now - here it is attached. Please put it in /usr/share/fonts/ :)

    Files

    • tuxtxt.tar.gz

      (41.49 kB, downloaded 6 times, last: )

    Edited once, last by pcd ().

  • Yes image in BA, I copied font from v7 via BA it now looks like it waiting for wizard input but the image is not being displayed properly.


    current e.log attached.

  • I do not know what you did with dvb-modules.bb. It is different from dreambox-df2.bb.


    dvb-modules contains the drivers. Perhaps you lost the drivers. Do the files I provided and bitbake them separately.

  • Maybe I got a bit confused with your files, there was no dreambox-df2.bb only dreambox-dvb-modules.bb so i renamed it to df2 n kept my modules.bb the image built I still have n will test but it looked like it had the same incorrect display.


    I noticed my modules.bb date was newer than yours for 600 n thought I would be brave n have a test if my change would work n build more than anything. Just testing I understand what will happen when I make changes!


    So should dreambox-df2 n modules.bb be the same file as technically I have not yet done this!

  • I checked. Sorry I made a mistake. There is no need for dreambox-df2.


    In dreambox-image.bb - please delete the dreambox-df2 line.


    Then bitbake dreambox-dvb-modules.bb and dreambox-image.bb.


    The image needs dreambox-dvb-modules for drivers. Probably renaming it is causing the problem.

    Edited once, last by pcd ().

  • No worries, I'm convinced in my haste it's my fault somehow, I saw newer date n got a bit carried away.


    not sure I cclean all I needed to.