Enigma2 Image for PowerPC Dreamboxes - Howto


  • I have the same problem for dm7020s for openembeded 1.5.


    Where have to modify to make it wdog-dm7020-1.1 from wdog-dm7020-1.2

  • I think it is \cvs\packages\dreambox\dreambox-wdog.bb file.


    Change this line:


    Code
    PV = "1.2"


    to:

    Code
    PV = "1.1"
  • Quote

    Originally posted by kalehrl
    I think it is \cvs\packages\dreambox\dreambox-wdog.bb file.


    Change this line:


    Code
    PV = "1.2"


    to:

    Code
    PV = "1.1"


    Thanks a lot !!!!


    building again and waiting.........

  • any help with that ???



  • I don't know.
    I've never built enigma2 for ppc boxes.
    I got dreambox-wdog error while building normal. enigma1 image.

  • Quote

    Originally posted by kalehrl
    I don't know.
    I've never built enigma2 for ppc boxes.
    I got dreambox-wdog error while building normal. enigma1 image.


    it's not Enigma2.


    it's Enigma1 openemeded 1.5.


    i believe the problem is that :


    Code
    python: /home/ganasta/dreambox/enigma1/images/opendreambox/dm7020/build/tmp/staging/i686-linux/lib/libz.so.1: no version information available (required by python)


    but don't know what to do

  • Quote

    Originally posted by pcd
    You need python 2.5. Why are you building with python 2.7 ?


    Please post your image build Makefile 1.5.


  • Quote

    Originally posted by pcd
    I used this Makefile. Please change Machine to 7020.


    the files are equal :rolleyes: the only difference are the machine.


    yes by default ubuntu 11.04 have python 2.7 !!!
    but i allready install python 2.5 to compile psyco.


    can i put some code to makefile to force use python 2.5?

  • Quote

    Originally posted by pcd
    No need. The image will have python2.5.


    so what i have to do to finish building with success ?

  • Quote

    Originally posted by geobest
    any help with that ???



  • I have not seen this problem before.


    Please put the attached file here :-


    /home/ganasta/dreambox/enigma1/images/opendreambox/dm7020/build/tmp/staging/i686-linux/lib/


    And try again !

  • thanks for the try.


    But not work



  • in folder you said to put the file have:


    libz.so (Link to shared library)
    libz.so.1 (Link to shared library)
    libz.so.1.2.3 (shared library)


    i don't know if that is something

  • and something more, why go to


    /home/ganasta/dreambox/enigma1/images/opendreambox/dm7020/build/tmp/staging/i686-linux/lib/


    and not to


    /home/ganasta/dreambox/enigma1/images/opendreambox/dm7020/build/tmp/staging/powerpc-linux/lib/


    Regards