Posts by crun

    Hallo,


    bisher nutzte ich für meine DM800 Newnigma2 OS 1.6. Da viele Plugins nicht mehr supportet werden, habe ich die aktuelle Version von Newnigma2 OS 2.0 installiert und soweit neu konfiguriert. Mit Newnigma 1.6 habe ich das Plugin Atmolight in der letzten Version mit Karatelight 16 genutzt. Ohne Probleme und soweit stabil. Dieses läuft auch mit OS 2.0, ich habe allerdings bei HD Videos ziemlich viele Aussetzer. Die CPU Last ist dauerhaft ca. 30%., unter OS 1.6 max. 15%.


    Da Karatelight auch mit Boblight oder jetzt Enigmalight funktionieren soll mit der DM800, dachte ich mir ich teste dieses Plugin mal. Ich bin allerdings sehr enttäuscht, da jetzt die CPU Auslastung dauerhaft zwischen 60 und 80% ist und Videos von interner Festplatte gar nicht abspielbar sind (ruckeln, aussetzer). Ich finde auch keine Lösung in sämtlichen Foren. In der Historie der Updates wird von CPU Auslastung von 10% geschrieben, davon bin ich weit entfernt. Zudem bekomme ich nicht die Einstellung geregelt, dass die Farben richtig wiedergegeben werden. Rot und Grün sind vertausch und lassen sich nicht korrigieren (RGB, GBR, GRB, BRG, .....). Auch die Kanalaufteilung bekomme ich nicht hin. Wobei mich die Feineinstellung, wie Weißabgleich und Verzögerung und Gammawerte noch gar nicht interessieren, da die Performance so schlecht ist.


    Hat vielleicht jemand eine Idee welche Änderungen noch zu machen wären?


    Ich stehe im Moment vor der Entscheidung mein altes Backup einzuspielen, da das aktuelle OS mehr Unannehmlichkeiten als Verbesserung bringen. Sicherlich ist die DM800 nicht die optimale Hardware aber sie sollte nicht schlechter mit neuer Software werden.


    Wenn jemand Ideen hat ich bin gerne bereit zu testen.


    Vielen Dank und trotzdem Daumen hoch :top: für die Bereitschaft und Initiative die hier ehrenamtlich leistet.

    Hallo,
    ich habe karatelight 16 und das atmolight Plugin installiert. Habe das Plugin auf einer dm800hd installiert und es funktioniert bisher gut. Ich habe nur das Problem das beim Weißabgleich der blauwert auf -40 steht und aber bei weißen Szenen der die LEDs sehr blau leuchten. Kann man das noch auf andere weise nachkorrigieren? Vielleicht direkt in einer Datei?
    Danke schon mal für dieses tolle Plugin. Hatte es erst vor ein paar Wochen entdeckt. Bis dahin wußte ich gar nichts davon.


    Grüße und danke

    Hallo Hellmaster,
    es haben jetzt schon mehrere geschrieben das sie Geld gespendet haben und noch keinen Key haben. Eine Antwort konnte ich bisher von Dir nicht lesen. Ich bin seit beginn dieses Plugin's dabei und war einer der sicher mit als erster gespendet hat und hab bisher keinen Key erhalten. Ich werde sicher noch von Dir bedacht.


    Ich freu mich, das Du als einziger in der Dreamboxgemeinde dieses Projekt so voran treibst. Mittlerweile bin ich im Besitz eines Apple TV 3. Wenn du irgendwelche Log's brauchst oder ich da helfen kann sag bescheid.


    Grüße

    Diese laaaangen Wartezeiten bei den Fotos und ruckeln bei Videowiedergabe hab ich auch. Die Wiedergabe von Youtube funktioniert soweit ganz gut. Ich denke es liegt an der schwachen CPU der DM800HD PVR.


    Grüße

    Vielen Dank für deine Aufschlussreiche Erklärung. So tief steck ich natürlich nicht in der Materie. Klingt wenn man es so erklärt bekommt ziemlich logisch. Weißt du ob es einen Benchmark in der Art gibt wie du ihn beschrieben hast? Ich hab das Problem vorerst mit einer 2,5Zoll 80gb Festplatte gelöst die ich noch hatte und jetzt intern verbaut habe. Das hatte ich eigentlich nicht so geplant, wegen der Wärme in dem kleinen Gerät.


    Grüße
    Crun

    Hey Danke, Genial,
    die vielen Backslashes waren es. Ich frag mich wie die da hin gekommen sind. Ich hatte das Script aus dem ersten Beitrag in eine txt Datei kopiert und umbenannt. Komisch. Hier mal meine Werte. Jetzt frag ich mich natürlich warum das ruckelt bei Timeshift von HD Sendern?


    Results for write throughput:
    53.687 Mbit/s with udp,async,wsize=4096
    53.687 Mbit/s with udp,async,wsize=32768
    53.687 Mbit/s with udp,async,wsize=16384
    53.687 Mbit/s with tcp,async,wsize=8192
    53.687 Mbit/s with tcp,async,wsize=4096
    53.687 Mbit/s with tcp,async,wsize=32768
    53.687 Mbit/s with tcp,async,wsize=16384
    48.806 Mbit/s with udp,async,wsize=8192


    Results for read throughput:
    59.652 Mbit/s with udp,async,rsize=4096
    59.652 Mbit/s with udp,async,rsize=32768
    59.652 Mbit/s with tcp,async,rsize=4096
    59.652 Mbit/s with tcp,async,rsize=32768
    59.652 Mbit/s with tcp,async,rsize=16384
    53.687 Mbit/s with udp,async,rsize=8192
    53.687 Mbit/s with udp,async,rsize=16384
    53.687 Mbit/s with tcp,async,rsize=8192


    Nochmals Großen Dank!

    Hallo,
    hat keiner eine Idee? Ich krieg es nicht hin. Ich bin der Meinung das alles richtig eingegebne ist. Wenn den / vor volume1 weg mach dann kommt folgende Meldung:


    root@dm800:/usr/script# ./Speed.sh


    Measuring NFS throughput...
    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: udp, async, wsize=4096
    writing 64 MBytes...
    Success after 30 seconds
    Mount options: udp, async, rsize=4096
    reading 64 MBytes...
    Success after 1 seconds


    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: tcp, async, wsize=4096
    writing 64 MBytes...
    Success after 29 seconds
    Mount options: tcp, async, rsize=4096
    reading 64 MBytes...
    Success after 1 seconds


    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: udp, async, wsize=8192
    writing 64 MBytes...
    Success after 29 seconds
    Mount options: udp, async, rsize=8192
    reading 64 MBytes...
    Success after 1 seconds


    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: tcp, async, wsize=8192
    writing 64 MBytes...
    Success after 29 seconds
    Mount options: tcp, async, rsize=8192
    reading 64 MBytes...
    Success after 1 seconds


    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: udp, async, wsize=16384
    writing 64 MBytes...
    Success after 29 seconds
    Mount options: udp, async, rsize=16384
    reading 64 MBytes...
    expr: division by zero
    Success after 0 seconds


    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: tcp, async, wsize=16384
    writing 64 MBytes...
    Success after 30 seconds
    Mount options: tcp, async, rsize=16384
    reading 64 MBytes...
    Success after 1 seconds


    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: udp, async, wsize=32768
    writing 64 MBytes...
    Success after 29 seconds
    Mount options: udp, async, rsize=32768
    reading 64 MBytes...
    Success after 1 seconds


    mount: 192.168.14.33:volume1/Dreambox failed, reason given by server: Permission denied
    Mount options: tcp, async, wsize=32768
    writing 64 MBytes...
    Success after 29 seconds
    Mount options: tcp, async, rsize=32768
    reading 64 MBytes...
    Success after 1 seconds


    Results for write throughput:
    sed: bad option in substitution expression
    Results for read throughput:
    sed: bad option in substitution expression


    und danach muss ich die Box neu starten weil der mount weg ist. Am mount sollte alles richtig sein, weil ich aufnehmen und wiedergeben kann. Es ruckelt nur bei Timeshift und da wollte ich mal meine Werte wissen.



    Ich bitte um Unterstützung.


    Danke

    Hallo,
    ich hatte eigentlich nur das script kopiert und meine Werte eingetragen.
    Hier sind meine Einstellungen:


    #!/bin/sh
    # IP of your NFS server
    serverip=192.168.14.33
    # exported directory on your NFS server
    exportdir=/volume1/Dreambox
    # mount point on dbox
    dboxmountpoint="/media/net/DS212"
    # filesize to transfer in MBytes.
    # At least 8 MByte. Good values are 32 or 64 MByte.
    # Try 128 to be more accurate (takes much longer!)
    filesize=64
    # block sizes to test in KBytes, possible values are 1 2 4 8 16 32.
    # values have to be separated with spaces. See examples below.
    # blocksizelist="4 8 32"
    # blocksizelist="16"
    blocksizelist="4 8 16 32"
    # wether to enable synchronous reading, writing. Possible values are "yes"
    # or no. Normally synchronous reading or writing should be slower than
    # asynchronous, so to save some time most people would say "no" here.
    enablesynctests="no"



    ##################################################################
    ######## don't edit below this line ########
    ##################################################################


    bs=8192
    count=`expr $filesize \\* 1048576 / $bs`
    wlist=""
    rlist=""
    synctests="async"
    if [ $enablesynctests = "yes" ]; then
    synctests="sync "$synctests
    fi


    echo
    echo "Measuring NFS throughput..."
    for factor in $blocksizelist
    do
    for protocol in udp tcp
    do
    for synchronized in $synctests
    do
    size=`expr $factor \\* 1024`
    bitcount=`expr $bs \\* $count \\* 8`
    umount $dboxmountpoint 2>/dev/null
    mount -t nfs -o rw,soft,$protocol,nolock,$synchronized,rsize=$size,wsize=$size $serverip:$exportdir $dboxmountpoint
    echo "Mount options: "$protocol", "$synchronized", wsize="$size
    echo "writing "$filesize" MBytes..."
    a=`date +%s`
    dd if=/dev/zero of=$dboxmountpoint/test bs=$bs count=$count 2>/dev/null;
    if [ $? = "0" ]
    then
    z=`date +%s`
    duration=`expr $z - $a`
    throughput=`expr $bitcount / $duration`
    echo "Success after "$duration" seconds"
    else
    throughput="Failure"
    echo "Failure"
    fi
    wlist=$wlist$throughput" with "$protocol","$synchronized",wsize="$size"\\n"

    echo "Mount options: "$protocol", "$synchronized", rsize="$size
    echo "reading "$filesize" MBytes..."
    a=`date +%s`
    dd of=/dev/null if=$dboxmountpoint/test bs=$bs count=$count 2>/dev/null;
    if [ $? = "0" ]
    then
    z=`date +%s`
    duration=`expr $z - $a`
    throughput=`expr $bitcount / $duration`
    echo "Success after "$duration" seconds"
    else
    throughput="Failure"
    echo "Failure"
    fi
    rlist=$rlist$throughput" with "$protocol","$synchronized",rsize="$size"\\n"
    echo
    done
    done
    done


    echo "Results for write throughput:"
    echo -e $wlist | sort -nr | sed 's/^\\([0-9]*\\)\\([0-9]\\{3\\}\\)\\([0-9]\\{3\\}\\(.*\\)\\)/\\1.\\2 Mbit\\/s\\4/g'


    echo "Results for read throughput:"
    echo -e $rlist | sort -nr | sed 's/^\\([0-9]*\\)\\([0-9]\\{3\\}\\)\\([0-9]\\{3\\}\\(.*\\)\\)/\\1.\\2 Mbit\\/s\\4/g'



    Danke

    Hallo,


    ich denke mein script läuft. Bei mir kommt nur nicht dieses Ergebnis. Bei mir sieht das so aus:


    root@dm800:/usr/script# ./Speed.sh


    Measuring NFS throughput...
    Mount options: udp, async, wsize=4096
    writing 64 MBytes...
    Success after 14 seconds
    Mount options: udp, async, rsize=4096
    reading 64 MBytes...
    Success after 12 seconds


    Mount options: tcp, async, wsize=4096
    writing 64 MBytes...
    Success after 16 seconds
    Mount options: tcp, async, rsize=4096
    reading 64 MBytes...
    Success after 14 seconds


    Mount options: udp, async, wsize=8192
    writing 64 MBytes...
    Success after 9 seconds
    Mount options: udp, async, rsize=8192
    reading 64 MBytes...
    Success after 9 seconds


    Mount options: tcp, async, wsize=8192
    writing 64 MBytes...
    Success after 12 seconds
    Mount options: tcp, async, rsize=8192
    reading 64 MBytes...
    Success after 12 seconds


    Mount options: udp, async, wsize=16384
    writing 64 MBytes...
    Success after 7 seconds
    Mount options: udp, async, rsize=16384
    reading 64 MBytes...
    Success after 16 seconds


    Mount options: tcp, async, wsize=16384
    writing 64 MBytes...
    Success after 11 seconds
    Mount options: tcp, async, rsize=16384
    reading 64 MBytes...
    Success after 9 seconds


    Mount options: udp, async, wsize=32768
    writing 64 MBytes...
    Success after 7 seconds
    Mount options: udp, async, rsize=32768
    reading 64 MBytes...
    Success after 56 seconds


    Mount options: tcp, async, wsize=32768
    writing 64 MBytes...
    Success after 9 seconds
    Mount options: tcp, async, rsize=32768
    reading 64 MBytes...
    Success after 9 seconds


    Results for write throughput:
    sed: bad option in substitution expression
    Results for read throughput:
    sed: bad option in substitution expression



    Kann mir da jemand sagen was ich falsch mache?


    Danke

    Das Plugin läuft bei mir recht stabil, Bilder und Videos lassen sich gut anzeigen. Es klappt sogar ein Video anzuspielen und dann einen Musiktitel auszuwählen und über die Box wiedergeben lassen.
    Viel Erfolg beim weiteren entwickeln.


    :cool2: :danke:

    Quote

    Original von Jake_Worf
    Ich bin runter und raus hier !


    ;)


    Ich hoffe ehrlich du kriegst das in den Griff.


    Ich verfolge diesen Thread von Anfang an und bin über jeden Fortschritt erfreut. Das was Du machst finde ich echt unfair.
    Ich wäre froh, wenn ich nur ein Stückchen von dem drauf hätte was hellmaster1024 hier macht.


    hellmaster1024: mach weiter so und lass Dich nicht beirren von denen den es nicht schnell genug geht.

    Wenn ich im Telnet bin, wie kann ich den Befehl beenden? Ich muss dann immer Telnet beenden und neu starten. Ich mein ist kein großer aufwand, aber nicht dass im Hintergrund ein Prozess weiter läuft.


    Danke für Info


    Bitte mal detailierte infos zur box, und image!
    und per console folgende zwei befehle ausführen! und die Ausgabe posten!

    Code
    /usr/lib/enigma2/python/Plugins/Extensions/AirPlayer/zeroconfig hallo eth0

    Hallo zusammen,


    ich bin ein bißchen spät dran um ein Medion NAS zu erstehen (zu mindest zu dem Preis von 99,99). Gibt es etwas von der Leistung vergleichbares oder gleiches Model unter anderem Namen?


    Aldi Nord hatte dieses Angebot leider nicht und bei E... kann mann das Gerät gebraucht ab 150€ aufwärts schießen.


    Jemand eine Idee?


    Danke

    Ich muss leider sagen, dass es immer noch ruckelt. Die Aussetzer wie dodo-dk hab ich auch. Hab jetzt auch mal den Speicherort vom USB Stick auf externe Festplatte(esata) geändert.


    Grüße


    Ansonsten Top Arbeit, gefällt mir echt gut....