[Gelöst] ssh-login NUR mit Public-Key

  • Hallo!


    Kann mich jetzt per Public Key an meiner DM600 anmelden, jedoch sowohl mit Benutzerrname + Passwort, als auch per Public Key.


    Ich möchte der Sicherheit wegen aber NUR die Public Key Authentifizierung zulassen, kann aber kein /etc/ssh/sshd_config finden, wo das normalerweise eingestellt wird.


    Ich habe hier im DM7000er-Bereich einen Thread gefunden, bei dem darauf hingewiesen wird, dass man "irgendwo" unter /var/script eine Option "-s" setzen muss, damit das ganze dann geht.


    Da ich kein ssh/dropbear-script finden kann, meine Frage:


    Wo muss dieser Paramter "-s" hin? :wmbiggrin:


    Danke und Gruß!


    Edit:
    Man muss unter /etc/init.d/dropbear am Anfang der Datei hinter "DROPBEAR_EXTRA_ARGS=" das gewünschte "-s" setzen, also ...

    Code
    DROPBEAR_EXTRA_ARGS=-s

    Dann muss die Dreambox neugestartet werden, ein einfaches "dropbear start/stop" hat nichts bei mir gebracht. Danach kann man sich nur noch per Public-Key-Verfahren anmelden.