Posts by hans753

    The image seems to run fine, except the well known bug with the not work channel scan on DVB-C.
    This time the box didn't ask me to run the scan during the wizard.
    But if I start the scan it will crash.
    But it still works this way:
    Tuner Configuration: In German "Typ der Kanalsuche" Set it to Provider.


    I don't need to run Enigma 1, but thank you anyway.

    pcd
    thank you for the tuxtxt hint.


    Do you know if the python script mentioned from above use the /etc/tuxbox/cables.xml
    At least this file exists and has some entries and looks fine to me.


    Do you know who maintains this code?

    Quote

    Originally posted by elmartino
    hans753 solved the scanning issue:
    "The scan seems to work if you change the scanning method.
    It seems to work this way: Tuner Configuration. In German "Typ der Kanalsuche" Set it to Provider."


    Today I installed the new version, too. I can confirm that the problem still exists on the DM600 PVR-C
    I tried to fix the bug, but it didn't work.
    The problem is located in the file /usr/lib/enigma2/python/Screens/ScanSetup.py in line 161, the problem (IndexError: list index out of range)
    This line causes the problem
    tmpstr += data[1]


    The problem is, that data[1] doesn't contain any data.
    It seems like data, doesn't contain any data at all.


    During the wizard the installation of some cable settings failed (missing file).
    I could imagine, that this missing file is needed for the scan and that this is the reason for the failure.


    Does anybody know which file is needed for scanning the cable network?

    I've the same problem with the scan (DVB-C). It always generates a core dump on /hdd. A scan is impossible after a clean installation of the image (including increasing the memory).
    The scan seems to work if you change the scanning method.
    It seems to work this way: Tuner Configuration. In German "Typ der Kanalsuche" Set it to Provider.


    At least it worked this time, I didn't try a second scan.

    Hello pcd,


    I installed your image on my DM600 DVB-C, but from time to time I' ve no sound after switching the channel.
    And the sound is delayed in many cases.


    I switched back to E1, I just want to inform you about the problem.

    Hi,


    bei meiner DM 600 war die Wiedergabe von aufgenommenen Filmen oft asynchron (jedenfalls bei AC3).
    Bei mir hat der Tipp von Digitangel geholfen:
    1.) Die Aufnahme ganz normal starten.
    2.) Vorspulen bzw. Abspielen bis zum Beginn des Films.
    3.) "Pause"-taste drücken
    4.) auf AC3 umschalten
    5.) nach 2-3 sec "Pause"-Taste wieder drücken


    Gruß
    Hans

    Hi,


    ich habe auch die DM600 und habe ein ähnliches Problem, bei einigen Filmen läuft der AC3 Ton einfach nicht synchron.


    Für Ideen wäre ich dankbar.
    Zur Zeit brenne ich mir die Filme dann auf DVD, um sie anzuschauen

    To flash the DM600 via network just switch off the DM600 (remove the plug from the power socket).
    As far as I know you need a DHCP Server


    1. Hold the Power Button and put the plug back into the power socket. I don' t know how long you have to hold the Power Button, 20 seconds should be enough. The othe models need to hold the down button?


    2. Take a look to your DHCP Server, the DM should have get a DHCP IP.


    3. Connect to the DHCP IP oft he DM with the Internet Explorer and just select upload firmware and wait until the box reboots (needs some time).
    For you information, you can also connect using the telnet protocol



    Hans

    The script should now find more addons to backup and will just save some emu files.


    You probably will use the parameter "-A" to save the most important things.
    Changed the userbouquets.tv.epl file for radio and file.


    Known Bugs: Files with special characters and spaces will probably not be saved. I' ve tried some escape tricks, but they didn' t solve the problem.


    Try the script and report the missing things, I think there will be some. But it should be much better than the original one.


    gemini People: What do you think about the script or MartiniB script, will you add id?

    @ MartiniB:
    Sorry, haven' t found your skript. Do you have any idea how to get it in the GP.


    Whats wrong with "sed" from the original script?


    antonbier
    I can add the emu backup, MartinitB done it already. I probably will just add one command switch to save all emu files, not just a particular emu.
    Or you just use the mentioned custom file to backup your needed files, just add the files or directorys into that file.


    Restore should be quite easy, just use a tar -xzf gemini_backup_DD.MM.YYYY.tar.gz -C /
    Haven' t checked the syntax, but this should work with alle images.


    @all:
    But who will put it to the GP and modify the Backup-Plugin in the Blue Panel?

    Hallo,


    ich habe mal die Gemini_backup.sh überarbeitet.
    Hoffentlich hat das noch kein anderer gemacht ;)


    1. Im Bluepanelmenü kann man auswählen was gesichert werden soll, das funktioniert aber nicht oder? => Daher unterstützt das Skript jetzt Parameter => Jemand müste das Blue Panel Plugin anpassen.


    2. Es werden viele Dateien nicht gesichert, z. B. keine Dateien von Samba-v.3.0.23c-r4-11.08.2007, damit das jetzt möglich ist, kann man in die Datei /var/etc/backup_custom.cfg untereinander alle zu sichernden Dateien eintragen, dazu das Skript zusätzlich mit "-c" starten.


    3. Die Datei /etc/resolv.conf wurde nicht gesichert. => Korrigiert (auch einige andere wichtige Dateien scheinen zu fehlen, noch nicht korrigiert)


    4. Das Skript war extram langsam und hat recht viel Platz benötigt, ich habe es ein wenig optimiert (sollte soweit alles stimmen, ich habe aber gerade noch ein paar Änderungen gemacht, also ruhig mal testen).
    Das alte Skript hat 41 Sekunden in den Standardeinstellungen benötigt, das neue Skript braucht nur noch 22 Sekunden.




    Sollte es für gut befunden werden, wie kommt es ins Image rein?

    Hi,


    ich habe es gerade getestet.
    Also wenn ich mir einen TS anschauen will, dann stürzt die Box DM500-C sofort ab (über telnet noch zu erreichen).


    Wenn ich versuche ein TS aufzunehmen, so ist das alt bekannte Problem wieder da, die Aufnahmen sind nicht zu gebrauchen => es geht nur mit ngrab

    Ich hatte den Artikel mal nach Bugs geschoben, jetzt ist wieder hier gelandet.
    Offensichtlich ist es ein Problem von dem neuen Gemini.
    Aber keiner möchte sich das Problem mal anschauen.


    Wen kann man denn dazu mal ansprechen?


    Ich schaue mir gerne etwas an oder teste etwas. Doch leider stecke ich dem Thema zu wenig drin, als das ich wüsste wo man nach dem Problem suchen könnte.

    Hallo,


    ich weiß es gibt schon ein paar Threads zu dem Thema Gemini 3.50 mit DM500 und der fehlerhaften NFS/CIFS aufnahme.
    Ich habe nur die Hoffnung, dass der Bug hierdurch registriert wird.


    Systeminformationen
    DM500-C
    Boardrev: 07
    Gemini 3.5.0
    Die Netzwerkverbindung ist okay, FTP schafft ca. 3-4 MByte/s.


    Wenn ich jetzt versuche die Daten direkt via NFS oder CIFS auf einen Linux Server zu schreiben, so sehe ich ab und an artefakte.
    Beim NFS habe ich schon mit verschiedenen rsize, wsize Werten getestet, ohne Erfolg. Auch habe ich nicht ungewöhnlich viele Fehler bei der netstat -s anzeige.


    Benutze ich udrec um damit einen TS zu schreiben, so ist die Datei okay.
    Es ist nur komisch, dass ich die Datei weder mit der Box noch mit VLC sehen kann, ich muss diese erst demuxen und als mpeg umwandeln.


    Ich frage mich wo das Problem bei NFS über UDP ist. Die Datenübertragung schwankt zwischen 500kbyte/s - 1000kbyte/s. Kann es sein, dass die DM500 nicht mit der CPU Last von NFS klar kommt? Gibt es eine Möglichkeit die CPU Auslastung anzuzeigen?
    Kann man irgendwas optimieren, angeblich soll es ja mit Gemini 3.30 noch funktioniert haben.


    Gruß
    Hans