Posts by jjfuertes

    PCD,


    finally, I can't get image from dm600 E2 on my 7025 with partnerbox plugin. So, I'm trying to work in the opposite direction.


    I saw that partnerbox plugin can be applied to dm600 compiling the following library "servicewebts.so". I was trying to do with the following source code:
    http://www.i-have-a-dreambox.c…ostid=1190238#post1190238
    but I couldn't get it with both Ubuntu crosscompiler and neither with local tools on dm600.


    On the offical Dream forum I saw that you compiled time ago the servicets.so, so, please, could you compile this new library?


    Many thanks in advance,
    JJF.

    Hi Dr. Best,


    first, thanks a lot for this incredible plugin.


    I'm also using PartnerBox on my dm600 with Enigma2 with the "disable" line import servicewebts (like suomipoeka on DM500) so the basic part of your plugin is working, but I really would like to watch the stream.


    I tried to get the source code of "servicewebts.so" on schwerkraft.elitedvb.net in order to try to compile for PPC, but seems that your plugin is not available there anymore.


    Could you please publish the source code again?


    Many thanks in advance,
    JJF.

    Hi PCD,


    first of all, sorry for late reply. I had lot of work this week and returning home really tired.


    I tried your samples with no streaming but..... you can see:


    root@dm600pvr:/usr/bin# cp streamproxyGetpid streamproxy
    root@dm600pvr:/usr/bin# wget -O- http://192.168.1.37:8001/1:0:1:2742:402:1:C00000:0:0:0:
    wget: bad header line: http/1.0 502 Bad Gateway 200 OK
    root@dm600pvr:/usr/bin# cp streamproxyNoauthor streamproxy
    root@dm600pvr:/usr/bin# wget -O- http://192.168.1.37:8001/1:0:1:2742:402:1:C00000:0:0:0:
    wget: bad header line: http/1.0 502 Bad Gateway


    Many thanks for your effort,
    keep in contact,
    cheers,
    JJF

    Hi PCD,


    the errors I published yesterday were with /dev/dvb/card0/demux


    When compiled with /dev/dvb/adapter0/demux , error is always "DEMUX OPEN FAILED".


    I re-tested today with different combinations, and the maximum progress is to reach the "DEMUX PES FILTER SET FAILED" error.


    I'm a bit lost on what can be the reason, but apparently, demux on DM600 with Enigma2 is not working in the same way than DM7025 with Enigma2.


    Regards,
    JJF.

    Hi PCD,


    finally, I discovered many things.


    First, and the most important, it's mandatory to remove the \r\n on each printf sentence, I don't know why, but with it, we are loosing a very nice information returned by the program.


    So, after this, an wget request to port 8001, returned me:
    DEMUX PES FILTER SET FAILED when is in standby mode


    DEMUX OPEN FAILED when switched on and trying to get same channel than watching


    According to the code, this error is raised after a successfull opened DEMUX. Could be that -like you said- demux in DM600 works in a different way than DM7025 or DM800...


    Waiting for your comments,
    regards,
    JJF.

    Dear PCD,
    are you making reference to streamproxy in /usr/bin in your image ?


    That one is not working for me when trying to stream on port 8001.


    If you compiled a new one and do you want from us to test, will be a pleasure.


    Cheers,
    JJF.

    Dear PCD.


    PartnerBox is an enigma2 plugin that enables to edit timers and watch (via streaming) other/s Dreambox/es.


    When you setup your other boxes (maximum 4) you establish if interface is enigma1 or enigma2. In this way the plugin can ask the other partners about channel list and launch the appropiate http request for streaming.


    I'm trying to analyze and recompile streamproxy.c from elitedvb site, and I advanced one step when modified /dev/dvb/adapter0/demux0 to /dev/dvb/card0/demux0 .


    Regards,
    JJF

    pcd,


    thanks for your answer.


    The problems I posted about ipkg are hose ones reported when tried to run "ipkg update".
    I downloaded and apply manual all the needed ipk-s. Thanks for your offer.


    Another problem I discovered is that grab seems to be the bad one and not the one posted here: http://www.i-have-a-dreambox.c…ostid=1099466#post1099466


    And more problems detected is that streamproxy doesn't work so I can't stream channels from dm600.
    For example the execution of:
    wget -O- http://mydm600:8001/1:0:1:7796:424:1:C00000:0:0:0:
    returns:
    HTTP request sent, awaiting response... 502 Bad Gateway 01:18:29 ERROR 502: Bad Gateway.


    Perhaps it's due to the device on dm600 is named /dev/dvb/card0 instead of /dev/dvb/adapter0 like on 7025.


    If anybody hasn't this problem, any help will be really appreciated.


    Regards,
    JJF

    Dear all,


    first of all, thanks for this wonderful image. Developings on enigma2 are easier due to Python.


    My first impression is that 12.1 works better than 12.0.


    Regarding the ipkg configuration, the first link works on both IE and FireFox. The problem is that ipkg update returns an error:


    WARNING: Ignoring unknown configuration parameter: h**p://www.****wnload.nu/df-2/TestImage/


    I tried to change that line adding src official at the beginning of the line, and get another error:
    Downloading h**p://www.****wnload.nu/df-2/TestImage//Packages wget: server returned error 404: HTTP/1.1 404 Not Found An error ocurred, return value: 1. Collected errors: ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /tmp/ipkg-xwceSc h**p://www.****wnload.nu/df-2/TestImage//Packages'


    So seems that an extra / is at the end of the line. Trying to remove it. Another error:
    Downloading h**p://www.****wnload.nu/df-2/TestImage/Packages wget: server returned error 404: HTTP/1.1 404 Not Found An error ocurred, return value: 1. Collected errors: ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /tmp/ipkg-FvnSBA h**p://www.****wnload.nu/df-2/TestImage/Packages'


    In my opinion the "official-feed.conf" file is not suitable for assisted ipkg tasks.


    Regards,
    jjf

    Hi hypnotoad,


    I currently have on flash the official Dream 2.1 from 08/11/2006. On multiboot based on CF, I have Gemini 2.0 and 2.2.


    Same problem happens while booting with any of the images I wrote before.


    In my case, I have a DVB-T on left slot, and DVB-S on right, but I tried with the opposite as well.


    Plugins, the minimum, Multiboot, MGCamd and Evocamd over Gemini. None over official.


    Thanks again for your help,
    cheers,
    JJF.

    Jaco2k,


    I have a similar problem or even worst. The problem is with my DVB-T module. If I'm watching a channel through this tuner and the harddisk enters on sleep mode, the video signal dissapears and the only way to watch it again is press twice the power button.


    My configuration is 1xDVB-S, 1xDVB-T, HDD, CF with Multiboot.


    I tested with two different hard disks, with and without CF inserted, inserting a fan to reduce temperature.


    The only way to watch DVB-T channels is:
    Remove the HD
    or
    enlarge the timeout for HD sleeping and run a cron to scan the HDD with less interval tna the sleep timeout.


    Any help is very well apreciated!


    Regards,
    JJ.

    I have a One For All 9910 and works with it but I needed to download the Dreambox upgrade. I don't know if Philips has a simillar service.


    In any case I think that you can always "learn" the signals.


    Regards,
    JJF.