Posts by Jean-Luk

    naja, hast schon recht, Äppel und Birnen sinds aber nicht, eher alter Boskop, neuer Granny Smith.
    Ein NAS kam in 2016 nicht in Frage, zu teuer und die Kistenmaße warn ungeeignet fürn Phono-Schrank. Hab kein separate Ecke in meiner Beton-Bude, wo man son NAS hinstellen könnte.
    Hab alles in ein schickes schwarzes Desktopgehäuse geschraubt, das die gleichen Abmaße hat wie mein Receiver. alles zusammen für 486 €, incl 256 GB SSD & WD Red 4T (wie gesagt c't-Server-Bausatz aus 2016).
    Wie so vieles ist das alles Philosophie und geschmacks- und anwendungsbezogen..


    um auf das Thema des Threads zurückzukommen: hast du eine Idee, wie in PAM in die dm920 reinbekomme?

    ich hatte den Synology DS109j, der war nicht toll.. das Linux im Gegensatz zu einem Debian total verkrüppelt, alles war woanders und hieß anders, ganz schlimm. Ein WebIf ist mir hier nicht genug.


    Weswegen ich mir - wie du - selbst einen zusammengeschraubt habe.
    Synology ~30-35 Watt
    mein Server: 9 W im Ruhezustand, max 15 wenn er werkelt.. mit Fujitsu DS3400-b, passivkühlung
    gemessen mit Fritz!DECT200

    ja, die dream ist kein vollwertiger server. Jedoch bin ich der Meinung, dass gerade diese Box einen vernünftigen smbd verdient hat, auch weil es nicht nur Linux Anwender gibt.
    Und PAM scheint ja erst ab oe2.5 rausgeflogen zu sein, was man so liest.


    ich habe mich noch bisschen belesen. Wollte es mit einem selbst kompilierten Samba versuchen. Scheiterte aber gleich am nicht vorhandenen Compiler. Spätestens hier enden dann auch meine Linux Kenntnisse.
    Ich schau noch ein wenig, evtl. finde ich jemanden, der mir das compiliert.


    Thema NAS: hatte ich, ist mir zu verdongelt und noch schlimmer verkrüppeltes Linux als auf der Dream.
    Weswegen ich mir den c't-Server aus 2016 zusammengeschraubt habe, der seitdem läuft wien Bienchen und u.a. als Datengrab für Win & Aufnahmen der Dream herhält. Alles was kurz- bis mittelfristig weggeschaut wird, landet aber auf der internen SSD..


    Falls jemanden noch etwas dazu einfällt, ob und wie man PAM nachrüsten kann, wäre klasse!
    Gruß
    Jean-Luk

    Danke, das werd dann mal später recherchieren, ich melde mich wieder..


    Quote

    Original von Bundy00Aber wozu braucht's das im Heimnetz? Alternativ gibt's z.B. "hosts allow = 10. except 10.0.0.12"


    Das tolle an Rechner ist, dass mehrere den nutzen können und dürfen. Eine Beschränkung auf die IP ist keine Benutzersteuerung ;-)

    die logs kommen halt exakt dann, wenn ich in W10 den Datei-Explorer aufmache
    Die scheinen offenbar damit in Zusammenhang zu stehen


    Ich fummel seit Stunden erneut.
    Testhalber habe ich auf beiden Linuxkisten testuser angelegt und eine Freigabe eingerichtet, da ich auf dem Debian-Server das untersuchen kann.


    Die smb.conf sieht nun so aus, ich habe verschiedene Parameter aus irgendwelchen Lösungsvorschlägen reingetan, in der Hoffnung, dass irgendetwas davon hilft:


    wenn ich folgenden mount auf dem Server starte

    Code
    root@srv:~# ls -la /home/testuser/testdir/
    insgesamt 8
    drwx------ 2 testuser users 4096 Jul 4 12:26 .
    drwxr-xr-x 3 testuser users 4096 Jul 4 12:26 ..
    root@srv:~# mount.cifs -v //dm920/test /home/testuser/testdir -o user=testuser,pass=test,vers=2.0
    mount.cifs kernel mount options: ip=192.168.0.12,unc=\\dm920\test,vers=2.0,user=testuser,pass=********
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    root@srv:~#


    Die Rechte auf der dm920

    Code
    root@dm920:~# ls -la /home/testuser/testdir/
    drwx------ 2 testuser users 4096 Jul 4 12:28 .
    drwxr-sr-x 3 testuser users 4096 Jul 4 12:28 ..
    root@dm920:~#


    log auf dem Server

    Code
    journalctl -fm
    Jul 04 14:55:27 srv kernel: CIFS VFS: cifs_mount failed w/return code = -13


    log auf der dm920


    nachdem ich SMB1 unter W10 reaktiert habe, listet der Dateiexplorer nun selbstständig der erreichbaren Computer im Netzwerk auf, das war vorher nicht so


    der log nachdem ich den W10 Dateiexplorer aufmache ist im Anhang: nachdem ich eine Freigabe öffnen will, öffnet sich der Anmeldedialog. egal,was ich da eingebe, nichts funktioniert

    Files

    • log.txt

      (71.47 kB, downloaded 3 times, last: )

    Hallo liebe Helfende,


    Typ : DM920
    DHCP: aus
    IP: 192.168.0.12
    SubnetMask : 255.255.255.0
    Nameserver : 192.168.0.1
    Gateway : 192.168.0.1


    PC
    Betriebssystem : W10 Pro
    Firewall : aktiv


    LAN1


    IP : 192.168.0.30
    rest wie oben


    Fehlerbeschreibung: Ich versuche seit langem die dm920 so zu konfigurieren, sodass sich die entsprechenden User von Win authorisieren.
    Bei meinem Debian-Server zu W10 klappt es wunderbar.


    Auf der dm920 liegt nun wieder die Standard-Konfig der smb.conf. Damit funktioniert auch alles, aber als guest.


    folgende Pakte sind installiert:


    Wenn ich die smb.conf des Debian-Servers benutze (nur die freigaben abgeändert)



    sehen die Fehlermeldungen u.a. so aus:


    noch die samba user:

    Code
    root@dm920:~# pdbedit -L
    nobody:65534:nobody
    guest:4294967295:Linux User
    user1:1001:Linux User
    user2:1000:Linux User
    root@dm920:~#


    Wenn ihr noch mehr Infos benötigt, kann ich gern beisteuern.


    BTW: unter den Linuxen läuft alles mit NFS, ich möchte nur von W10 aus mittels CIFS auf die Linuxkisten zugreifen.


    Ich danke schon jetzte für eure Ratschläge!


    Gruß
    Jean-Luk

    Hallo,
    Die beiden oben genannten Sender habe ich seit heute in der Liste nach einem Scan. Laut Internet Suche sollte das schon seit dem 20.10.15 der Fall sein.
    Allerdings können die Sender nicht getunet werden, “Kanal nicht verfügbar“.
    Kann das jemand bestätigen?
    Kabelnetz von Vodafone in Berlin.


    Gruß
    Ralf

    Quote

    Original von MacDisein
    Schön, dass es jetzt funktioniert.


    Nein, du kannst nachträglich nichts umbenennen lassen, es wird beim Anlegen der Timer der konfigurierte Namensaufbau verwendet - du kannst auch nur zwischen verschiedenen Möglichkeiten wählen - wie genau der Titel und die Beschreibung ist, legt Wunschliste fest, denn die liefern die Informationen.


    Ok, vielen Dank!


    Habe gleich die nächsten Fragen:
    Um mich in die recht umfangreiche Bedienung einzuarbeiten, lese ich die Anleitung von Anz.
    Ich würde vorerst den AutoTimer parallel mitlaufen lassen, evtl auch SeriesPlugin.
    Konkurrieren die 3 Plugins evtl miteinander, sodass Konflikte entstehen können?
    Scannt SerienRecorder die Aufnahmen vom AutoTimer/SeriesPlugin?


    edit: falls es von deinem Plugin gesteuert wird: gibt es einen fall back zu /media/hdd, falls das NAS mal nicht zur Verfügung steht? Wenn ja, kann man das verhindern? Die interne SSD bietet nicht sooo viel Platz, da landen nur die flüchtigen Aufnahmen.


    Gut möglich, dass meine Fragen alle schon von anderen gestellt wurden. Denn bitte ich schon vorab um Entschuldigung, da ich leider keine Zeit habe, den kompletten Verlauf zu lesen.


    Gruß
    Jean-Luk

    Quote

    Original von MacDisein
    Jean-Luk:
    Du könntest versuchen einen anderen SerienRecorder Skin auszuwählen - der "SerienRecorder 1" nutzt tatsächlich die gesamte Auflösung.


    :hurra: :hurra: :hurra: :einschenken:


    einzig der Skin "AtileHD" ist offenbar für blöde Fernseher gemacht worden! Vielen Dank!
    Bei allen anderen Skins sehe ich nie alles.
    Morgen kann ich endlich das Plugin ausprobieren.


    Schon mal die erste Frage vorweg: :tongue:
    Ich habe gesehen, dass man einstellen kann, _wie_ Serien umgenannt werden.
    Als oller Trekkie würde ich gern folgendes tun wollen:
    Dateiname: ENT_S01E01_AUFBRUCH_INS_UNBEKANNTE_TEIL_1
    Anzeige in Filmliste: ENT - S01E01 - Aufbruch ins Unbekannte Teil 1
    Beschreibung: löschen lassen/nichts


    Ist das (auch nachträglich) möglich?


    Gruß
    Jean-Luk

    Quote

    Original von MacDisein
    Jean-Luk:
    Welchen Samsung Fernseher hast du denn genau?


    Hallo MacDisein,


    Danke für die Nachfrage:
    Ich habe den Samsung LE37R72BX/XEC BD37EO
    gekauft 2006


    Ich habe eben nochmal alle VideoModi ausprobiert, die man an der Dreambox unter A/V-Einstellungen findet. Selbst mit 576i, 4:3, womit das TV-Bild vertikal recht stark gestaucht wird, lässt das Overlay deines Plugins völlig unbeeindruckt. Es wird immer - unabhängig vom TV-Bild - formatfüllend angezeigt. Sehr merkwürdig.


    Hast du eine Idee, was ich da machen kann?


    Gruß
    Jean-Luk

    Hallo,


    wie schon einige Male beschrieben, wird auch bei mir das SerienRecorder Overlay nicht formatfüllend angezeigt. Bei mir fehlen unten die Buttons und links und rechts auch ein Teil.
    Hierdurch wird das leider unbedienbar. Mein oller Samsung Flat TV (1280x720) hat nur 16:9, 4:3 und Zoom. Es gibt keine Overscan-Einstellungen o.ä.
    Habe alle Plugins durchprobiert, die ich finden konnte, um das Bild zu zoomen. Hab nichts gefunden.
    Auch ein anderer Skin bringt nichts, myMetrixME, probiert: alle anderen 3 aufgeführten.
    Box: DM800SE, Merlin3


    Hat jemand eine Idee? Würde das Plugin gern benutzen, z.Z. Seriesplugin.


    Gruß
    Jean-Luk

    Quote

    Original von kodo
    Da wird der Switch nicht viel bringen, ein kleiner TP-Link Router mit Gargoyle als Client Bridge wäre da sinnvoller. Ohne Anschaffung wird das nur Gemurkse.


    Ich fummel gern, sollte aber nicht allzu kompliziert sein.
    Ich hatte schon mal an einer anderen Stelle probiert, eine WLAN Fritzbox an einen O2-Router zu binden, was fehlt schlug. Die Fritzbox kam einfach nicht rein ins WLAN.


    Wie funktioniert das mit dem Gargoyle als Client Bridge?


    Das einfachste ist freilich, dem Samsung TV einen passenden WLAN Stick zu spendieren. Aber das ist ja zu einfach ;-).

    Hallo Netzwerk-Profis,


    ein Bekannter bekommt nächste Woche seine dm800se V2.
    Ich werde ihm das einrichten.
    Pferdefuß: alle Endgeräte werden über WLAN an seinem O2-Router betrieben, da der im Flur steht. Bisher hängt nur der PC dran. Nun soll die dm800 und der TV ran. Um zusätzliche Anschaffungen zu vermeiden, hatte ich die Idee, die dm800 als Netzwerk-Bridge zu "missbrauchen", um an die Box den TV über den Netzwerkport der dm800 mit Internet zu versorgen.


    Ich habe bei mir jetzt folgendes getestet:


    Dreambox dm800 HD se
    WLAN USB-Stick an rückwärtigem USB-Port ohne Hub
    IP: 192.168.1.24, wlan0, @DHCP@FB7390
    SubnetMask : 255.255.255.0
    Nameserver : 192.168.1.1
    Gateway : 192.168.1.1
    Verbindung ins Internet und Heimnetz funktioniert einwandfrei


    LAN-Anschluss der dm800 mit Kabel (Crosslink) an ein weiteres Endgerät
    (zu Testzwecken am nebenstehenden BluRayPlayer)
    IP : 10.0.1.1 dm800, eth0
    IP: 10.0.1.2 BR-Player
    SubnetMask : 255.255.255.0
    Ping funktioniert von dm800 --> BR-Player
    Der BR kommt ohne Bridge oder NAT nicht in Internet.


    Einrichtung einer Bridge scheitert
    Fehlerbeschreibung:
    ich habe brctl installiert, funktioniert soweit.
    brctl addbr br0 -> geht
    brctl addif br0 eth0 -> geht
    brctl addif br0 wlan0 ---> geht NICHT --> Meldung "..wird nicht unterstützt.."


    Zahlreiche Recherchen ließen mich wissen, dass das zu kompliziert ist. Ich komme da auch nicht einfach so aus der Ferne ran, wenn mal was ist.
    Nun wollte ich NAT probieren. Ich weiß jedoch nicht, ob das der Kernel unterstützt und wie das eingerichtet wird.
    Hat da jemand Erfahrung?


    Ich bitte um Hilfe!
    Vielen Dank!


    Gruß
    Ralf :einschenken:

    ich hatte das gleiche Problem. Trotz Löschen von vielen Dateien, konnte ich kein Samba-Serer installieren. Ich habe mir eine CF-Card eingesteckt, BarryAllen installiert (mit Oozoon im Flash) und dann GP2 4.7 auf die CF-Card.
    Wie das alles geht, findst du hier im Board in zahlreichen Threads oder im Wiki.


    Zum Thema NAS:
    hab kürzlich auch ein NAS ins Netzwerk gehängt, nu nimmt alles darauf auf, und vor allem kann man die Box runterfahren und trotzdem is noch alles im Netzwerk erreichbar.
    Ich habe folgende Zeile in die /etc/fstab eingefügt:

    Code
    192.168.1.10:/volume1/video /media/nas nfs rw,soft,nolock,intr 0 0


    dabei ist ..1.10 die IP des NAS /volume1/video die freigabe des NAS
    /media/nas das Verzeichnis, in welches es auf der DB gemountet wird, das Verzeichnis nas muss vorher existieren
    die Optionen hab ich einfach hier aus dem Board abgeschriebn, sie funzn ;-)
    "0 0" darf nicht fehlen hinten


    wenn das funktioniert (im telnet: ls /media/nas), kannst du das Verzeichnis als Standardaufnahmeverzeichnis auswählen in den einstellungen der DB
    zu guter letzt noch mit der FB 2x video-taste, Verzeichnis in die Favoritenliste, denn kannstes auch als Aufnahmeverzeichnis bei manueller Programmierung auswählen, und im webif ist es dann auch erreichbar..


    Jean-Luk

    jo, hat geklappt, ich habe denselben eintrag in die fstab des cf-images gemacht
    ich dachte, dass die nich verarbeitet wird, weil da auch die ganzen einträge fehlen, wie z.b. /media/hdd usw..


    und sorry, falls ich mich falsch ausgedrückt hab, beschäftige mich nich oft mit den interner der dream, erst jetzt, als ich mir BA aufs cf installiert hab und ein nas zugelegt hab

    ich will ja nich den flash mounten!
    ich will, wenn das gemini von der cf gebootet ist, auf die fstab des flashs zugreifen
    na egal, wenn das nich anders geht..


    hintergrund:
    der mount vom nas funktioniert im flash aber nich im cf gemounteten image, nu versuch ich rauszufinden, warum


    verzeichnis nas liegt in /media
    mount in der fstab sieht so aus: 192.168.1.10:/volume1/video /media/nas nfs rw,soft,nolock,intr 0 0


    wie gesagt, im oozoon im flash gehts, im gemini4.6 in der cf nich
    hast du eine idee?


    edit: ein manueller mount ins gleiche verzeichnis funzt super
    ich will halt kein automount, da mir das zu lange dauert (~1 min)

    Hallo,


    ich hab oozoon mit ba im flash und gemini4.6 auf der cf
    ich will die mounts in der fstab anpassen
    muss ich jedesmal umbooten, um das zu testen, oder kann ich vom gebooteten gemini auf die fstab zugreifen?
    ich kann das jedenfalls nich finden, die fstab im gemini is wohl nich die richtige


    danke
    jean-luk