Posts by Sven H

    Bis zu einem bestimmten Zeitpunkt hatte es hier ja auch noch mit Arcor funktioniert.

    Kann nur leider nicht mehr sagen ab wann.


    Zumindest hatten wir zu diesem Thema vor fast genau einem Jahr schon intern Kontakt gehabt :winking_face:


    Damals hieß es, dass dieser Fehler gemeldet wird:

    Code
    Fehlermeldung
    Enabling TLS failed

    Ich denke, dass es irgendeine Server-Sache ist.

    Das Forum selbst kann es ja nicht sein, da es im DP-Board und im Merlin-Board ja mit Arcor funktioniert.

    Ja, Arcor war bei mir auch das Problem, obwohl diese Adresse im DP-Board bezüglich der Forumsbenachrichtigungen problemlos funktioniert.

    Von daher denke ich, dass es eine Einstellung/Einrichtung auf dem ihad-Server sein muss.

    Man kann auch das PluginSort nutzen, man muss dann nur wissen, dass man nach einem Sortieren des PluginBrowsers über das normale PluginSort nochmal kurz das BluePanel aufrufen muss, das man dann auch gleich wieder schließen kann.

    Sonst ist die Sortierung nach einem Neustart wieder weg.

    Im GP4-Gerätemanager gibt es in den Einstellungen eine Option "Zeige Änderungen bei Speichergeräten".

    Diese Option ist bei mir deaktiviert. Vielleicht ist diese Option ja bei dir aktiv.

    Vom Namen her könnte die Option ja zu deinem "Problem" passen.

    Er war ja offensichtlich nur auf der Suche bezüglich Infos auf der Homepage.

    Von Kaufen war ja noch nicht die Rede :grinning_squinting_face:


    Aber grundsätzlich gebe ich dir Recht.

    Zum einen müsste die Two bei den Produkten auf der Homepage erscheinen und zum anderen sollte die derzeit aktuellste Box im DP-Shop grundsätzlich verfügbar sein.

    (hinterlässt sonst ein komisches Gefühl)

    Die Homepage wird nicht so oft aktualisiert.

    Das war schon öfter Thema :winking_face:

    (spaßig heißt es dann immer, dass der Praktikant wohl noch keine Zeit hatte)


    Du findest die Two aber im DP-Shop:

    Dreambox Two Ultra HD BT 2x DVB-S2X MIS Tuner 4K 2160p E2 Linux Dual , 319,00 €
    Highlights der Two Ultra HD: 6-Kern Prozessor 53 K DMIPS MALI-G52 GPU 2 GB DDR4 RAM 16 GB Flash 2,4G/5G MIMO WLAN BT 5 0 1 X USB 3 0, 1 x USB 2 0 1x Common
    dreambox-shop.de


    Unter Downloads findest du dort auch Dokumente für die Two.

    https://dreambox-shop.de/https://dreambox-shop.de/Dreambox-2

    John McClane

    Welche Ansicht hast du denn für die EMC-Movielist im Styles-Plugin aktiviert ?

    Ich habe dort "Pig" ausgewählt und habe in der Liste Datum und Uhrzeit.


    Dazu ist es allerdings notwendig, im EMC-Setup fast am Ende bei den Skin-Optionen die Option "Filmliste ist skinbar" zu deaktivieren.

    Dann werden die nachfolgenden Optionen aus dem Setup verwendet, wo du sogar das Format für Datum/Uhrzeit auswählen kannst.

    Vermutlich hast du im /tmp auch einen Ordner "epgload_...".

    Entweder beim dpkg -i den kompletten Dateinamen des deb-Files angeben oder den Ordner umbenennen, so dass er nicht mehr dem Muster epgload_* entspricht.

    Lt. Crashlog hat das Plugin im PluginDescriptor keinen icon-Eintrag :winking_face:

    http://git.opendreambox.org/?p…3ce5e1cb652f;hb=HEAD#l564

    Damit kann der Kodi-Code wohl nicht umgehen.

    Du könntest dem PluginSort manuell so einen icon-Eintrag verpassen

    Beispiel:

    http://git.opendreambox.org/?p…172a2f05e5e4e;hb=HEAD#l72


    oder den Kodi-Code aus der og. py nochmal anpassen (neuer Versuch):


    if not hasattr(p, "iconstr") or p.iconstr == None or p.iconstr.endswith(".svg"):

    Der Crash passiert hier:


    File "/usr/lib/enigma2/python/Plugins/Extensions/XBMCMediaCenter/XbmcEvent.py", line 109, in getPluginsAsJson

    if p.iconstr == None or p.iconstr.endswith(".svg"):

    AttributeError: PluginDescriptor instance has no attribute 'iconstr'


    Da hat ein Plugin keinen iconstr.


    Man könnte die Zeile 109 in der XbmcEvent.py evtl. mal so anpassen:

    if not "iconstr" in p or p.iconstr == None or p.iconstr.endswith(".svg"):


    Wobei ich das jetzt nicht getestet habe und auch nicht weiß, wie der Code da in Zeile 110 weitergeht :winking_face:

    Wenn du APTUpdateNotification nutzt, müsstest du auch die Änderung zu Hit und Ign nicht mehr im Plugin machen müssen.

    Auch meldet APTUpdateNotification bei mir keine Plugins, die ich auf hold gesetzt habe, womit er nur echte Updates anzeigt.

    Das würde mir sogar besser gefallen :winking_face:

    Wie im obigen Edit schon vermutet :grinning_squinting_face:

    Python
                        if line.startswith("Ign ","Ign:"):
                            continue
                        if line.startswith("Get:"):
                            continue
                        if line.startswith("Hit ","Hit:"):

    Da hast du wohl später nochmal händisch versucht, das anzupassen und dabei einen Fehler in den Zeilen 101 und 105 gemacht :winking_face:


    So wäre es richtig (Zeile 101 und 105):

    (bei mehreren Prüf-Werten, muss nochmal eine zusätzliche Klammer drum herum)

    Python
                        if line.startswith(("Ign ","Ign:")):
                            continue
                        if line.startswith("Get:"):
                            continue
                        if line.startswith(("Hit ","Hit:")):

    Es gäbe da auch noch eine Variante in der OPKGUpdateNotification.py :winking_face:

    Poste hier bitte mal deine OPKGUpdateNotification.py


    Edit:

    Wenn man die Anpassung zu "Ign:", "Hit:" falsch macht, kommt genau der Fehler :winking_face:

    falsch:

    if line.startswith("Ign ","Ign:"):

    ...

    if line.startswith("Hit ","Hit:"):


    richtig (mit doppelter Klammer):

    if line.startswith(("Ign ","Ign:")):

    ...

    if line.startswith(("Hit ","Hit:")):

    Wobei nach weiterer Prüfung deine Fehlermeldung eigentlich nur zum APTUpdadeNotification passen würde.

    Aber schauen wir mal.


    Du kannst ja auch im Plugin bei den Controllern (blaue Taste) einen Test (grüne Tasten) laufen lassen und dann das Setup wieder komplett schließen, ob die Meldung dann auch erscheint.

    Dann musst du ggf. nicht so lange warten.

    Bei Test wird auch alles in logfile geschrieben.

    Sieht erstmal unverdächtig aus :winking_face:

    Wo nutzt du das Plugin mit der Fehlermeldung ? (welche Box, welches OE)


    Was hast du aktiviert?

    APTUpdateNotification oder OPKGUpdateNotification? oder beides ?

    Den Fehler-Text deines Screenshots gibt es zumindest nur in diesen beiden Controllern.


    Hier auf der One läuft der Test als PopUp-Meldung ohne Fehler :thinking_face:


    Aktiviere im Plugin doch mal "Log to file" und poste dieses File nachdem die Fehlermeldung wieder erschienen ist.

    Nachtrag:

    Hab mal schnell im Quellcode geschaut.

    Ich glaube, es kommt vom AptUpdateService.


    Poste bitte mal die Ausgabe von folgendem Telnet-Befehl:

    apt-get --just-print upgrade

    Schick mir doch mal per PN deine ganzen Einstellungen im Plugin und vielleicht kurz erklären, was dann wie und wo passieren soll/müsste.

    Ich hab im Moment null Plan von dem Plugin, weil ich es bisher nie genutzt habe :winking_face:

    Vielleicht kann ich es ja hier nachstellen und dann vielleicht auch korrigieren.