Posts by paolee

    Hallo,


    ich wollte eine alte 7020S einem Freund "vererbt". Er konnte die alten Inhalte von der hdd löschen. Danach war keine Aufnahme mehr möglich.


    "Aufnahme wegen eines Schreibfehlers fehlgeschlagen. Bitte eine Dateisystemprüfung durchführen".
    Konnte das Dateisystem nicht aushängen (unmounten)."


    Dann haben wir versucht, die Filesystemprüfung zu machen, aber das umount schlägt fehl:


    "Konnte das Dateisystem nicht aushängen (unmounten)"


    Was kann ich tun? telnet ist nicht möglich, da ich nicht vor Ort bin. Kann die Box ohne Festplattenmount gestartet werden und die hdd danach einfach neu formatiert werden?

    Auch wenn das Thema alt und die Box eine andere ist. Hier läuft noch eine alte 7020S mit Gemini 4.70. Das Suchen im EPG sowie das Finden ähnlicher Einträge auf einer Serie bringt hier auch immer 0 Ergebnisse, obwohl das EPG genug Daten hat.

    Bei mir läuft das letzte Gemini 4.7, E1. Ich weiß, die 7020S ist alt, bei E1 wird nichts neues mehr kommen. E2 hatte ich mal kurz drauf, war mir aber etwas langsam und E1 kann fast alles was ich brauche.


    Nur eine wichtige Funktion scheint nicht zu laufen. Da Gemini 4.7 aber ziemlich ausgereift war, muss ich etwas falsch machen. Ich kann keine Ergebnisse bekommen bei der Suche im EPG. Das EPG ist voll, jeder Sender hat fast 1 Woche Daten. Nun würde ich gerne zu einer Serie alle Ergebniss finden. Aber egal ob ich nur Titel oder auch Zusatztexte suche, das Ergebnis bleibt 0. Auch bei ganz einfachen Strings oder Wörtern, die in vielen Einträgen vorkommen wird nichts gefunden.


    Funktioniert die Suche im EPG vielleicht nur, wenn das EPG irgendwo ausgelagert wird, oder exportiert wird?

    Ich kann es selbst kaum glauben, aber die Odyssee scheint ein Ende zu haben. Nachdem die Picons aus der Statuszeile deaktiviert sind, habe ich das Problem nicht mehr gesehen. Ich hatte zwar zu Anfang nochmal einen Hänger, da habe ich die Picon-Einstellung in der Statusanzeige nochmal verändert, seitdem gab es aber keine Probleme mehr. Es gab zwar nochmal einen plötzlichen Neustart von Enigma, ansonsten läuft die 7020S aber über Wochen stabil mit ca. 2-3 Stunden Playback + 2-3 Stunden Recording pro Tag. 40% der 1T Festplatte sind auch wieder angefüllt, ext3 Dateisystem stabil. Ich habe extra noch einige Wochen gewartet, ob es nicht ein Zufall ist, bevor ich mich hier wieder melde.


    Da hätte ich mir die vielen Adapter-Wechsel, Partitionierungs- und Formatierungsorgien sparen können, und die alte Dream hätte nicht sooft resettet werden müssen.
    Vielen Dank nochmal für diesen wirklich zielweisenden Tip. Manchmal lohnt es sich, hartnäckig zu bleiben.

    Right, that was on 18.01.2013. Sry for confusing. In the meanwhile I did use E1 4.7.
    These days I tried again, flash the same image, but this time it does not start at all. I also tried starting with hdd connected to avoid any different environment which could only be the hdd. But the same thing, E2 doesn't start. Now that I can access via telnet I could check any logs or processes what is cuasing the freeze.

    I did nothing like "Increase memory", I just flashed the Pcd 8.0 image via Bootstrap.
    I'm going to learn how to set up Multi-Boot for the 7020S, and get a CF-Card for that. But maybe that E2 maybe is not suitable for me if not that stable.
    The 2 mv for python did not help to get E2 starting.


    Is this image not appropriate for flashing to internal memory or are all the 7020S so different that it is not starting in my case?

    Ob Giga-Ethernet oder nicht sollte der Dream mit 100MBit eigentlich gleich sein. Netzwerkmäßig macht sie mir aber auch Probleme. Ich habe einen Ovislink WL-5460APv2 im Client-Mode mit Dreambox im gleichen Netz des WLANs, also auch im WISP (Client-Router) mit eigenem Subnetz für die Dream. Beide mal laufen pings mit vielen % Packet loss, die http-Seite baut sich kaum auf, telnet geht, Addon-Downloads dauern ewig. Ein anderes Misterium ist, dass der DHCP-Request im Bootstrap-Mode den Router zum Absturz bringt und wild Requests schickt. DHCP-Requests des laufenden E1 funktionieren aber. Auf dem Ovislink läuft im CLient-Mode kein eigener DHCP-Server, er reicht nur an den AP weiter. Es gibt also nach wie vor nur einen DHCP-Server. Im WISP-Mode mit eigenem DHCP-Server ist es aber dasselbe. Ich musste daher feste IPs für den Bootstrap-Mode vergeben, in E1 hab ich es aber auch fest konfiguriert.
    Es gibt diese Option Netzwerk-Fix in den Einstellungen, die in manchen Umgebungen zu langsame Verbindung beheben soll. Ich weiß nicht, was da passiert, hatte aber beide Einstellungen probiert.

    Habe Gemini1 zurückgespielt. Also die Picons Anzeige war für /etc/picons aktiviert, also nicht auf hdd. Ich habe es nun ganz deaktiviert, mal sehen ob es hilft. Sonst habe ich keine Einstellung finden können, um die Picon-Funktionalität abzuschalten.
    Eigentlich sollten die Picons bei Abspielen von Platte eh keinen Einfluß haben. Beim normalen live-TV-Betrieb hatte ich nie Aussetzer.

    Quote

    If you can ftp - delete the softlinks to Extensions (in /pyrhon/Plugins) and to python2.5 in /usr/lib.


    Ok, I'm logged in via telnet after providing an IP via DHCP.
    Which file need to be deleted exactly? There is no path like /python/Plugins and /usr/lib/python2.5 is no softlink but a directory. Should I delete/move/rename that completely?


    What I did:

    Code
    # mv /usr/lib/python2.5 /usr/lib/python2.5.bac
    # mv /usr/lib/enigma2/python/Plugins/Extensions /usr/lib/enigma2/python/Plugins/Extensions.bac

    Danke für den Tip. Werde ich auf jeden Fall probieren.


    Ich habe gestern probeweise dochmal E2 pcd 8.0 installiert, ob sich damit etwas verbessern lässt. Leider startet die 7020S damit überhaupt nicht.


    Ich boote immer von Flash, habe mich noch nicht damit beschäftigt, von CF oder USB zu booten, und wüsste auch nicht, welchen Vorteil ich davon habe, solange das Image auf Flash passt. Vielleicht bringt das was, wenn man viele Addons möchte. Daher gibt es hier keinen Konflikt zwischen CF und IDE. Gefühlsmäßig sind die Abstürze auch weniger geworden, seit ich Swap deaktiviert habe. Ohne Swap reicht der Speicher scheinbar immer noch, ich verwende eigentlich nur EPG, der passt rein. Und Server habe ich außer telnet/ssh/http/ftp keine.


    Möglich wäre das mit den Picons aber schon, da ich erst nach dem SATA-Einbau auch das Gemini1 4.7 geflasht hatte und mich auch erst seitdem mit dem ganzen Setup und u.a. den Picons beschäftigt hatte.


    E2 pcd 8.0 würde mich auch interessieren, da berichtet wurde, dass nur damit WLAN-Bridges vernünftig laufen. Komischerweise lässt sich die 7020S zwar ansprechen über die WLAN-Bridge, habe sowohl Bridge als auch Router-Modus mit eigenem Netz für die Dreambox versucht. Aber die Verbindung hat trotz gutem Empfang soviele Dropouts, dass sich die www-Seite kaum aufbaut, Add-on Downloads funktionieren nur bei kleinen Größen, brechen oft ab. Verbindung per Cross-Kabel direkt mit dem Laptop ist einwandfrei.


    EDIT: Alternativ werde ich auch eine alte 3,5" 750G PATA Platte testweise einbauen, um jede Unsicherheit mit dem Adapter auszuschließen. Die ursprüngl. 80G Platte hatte auch nie Probleme gemacht. Die 750G hat nicht viel weniger als 1T. Das war glaube ich das größte, was mit Parallel-ATA gebaut wurde, auch wenn man heute manche 1T mit PATA findet, die nachträglich auf den Markt kamen. In der Größenordnung wollte ich nur nicht mehr auf PATA setzen, da diese unverhältnismäßig teurer sind. Außerdem wird die 3,5" wieder lauter, weshalb ich bewusst die 2,5" ausgewählt hatte.

    Quote

    Original von pcdIf you can ftp - delete the softlinks to Extensions (in /pyrhon/Plugins) and to python2.5 in /usr/lib.


    How should I get access if the E2 does not come up? In Bootstrap mode there is no ftp service, only http for flashing.

    Gestern trat das selbe Problem wieder auf. Nach einiger Zeit, ca. 20 Minuten nachdem parallel noch eine Aufnahme gestartet war, stoppte die Wiedergabe, Standbild, man kann einmal noch das Menü öffnen, danach friert die Dreambox ein. Würde man nun ewig warten würde irgendwann die Festplattenfehlermeldung kommen.
    Nach einem Neustart wurde diesmal aber die Festplatte gar nicht mehr erkannt. Ich hatte beim Einbau gestern noch den Jumper JP80 nach rechts versetzt, um die Resetleitung zu öffnen. Das soll auch bei manchen Platten helfen. Diesen werde ich aber wieder nach links setzen, das gab zwar dieselben Probleme, aber gar keine erkannte Festplatte bei Neustart hatte ich damit nicht.


    Um Defekt am PATA-SATA-Adapter auszuschließen, hatte ich die ganzen 100GB beim zurückspielen nachdem die Platte neu formatiert war, diesmal durch den Adapter geschoben, das heisst, USB-PATA Adapter an Adapter an SATA-Festplatte adaptiert. Mit konstant 15-16MB/s gab es da keine I/O-Fehler. Der Adapter sollte also in Ordnung sein.

    Entgegen dieser Beschreibung erlaubte mein fdisk nur den Anfang bei 2048. cfdisk konnte auch nur 63 oder im Maximize Modus 1. parted und gparted konnten fast nur auf Size-Angaben arbeiten. Ich habe es letztendlich hinbekommen mit fdisk im Expert-Menü, dort mit "b" den Start der Daten von 63 auf 8 geändert. Nun ist Start bei 8 und end bei 1953525167. Das passt mit der mod 8 = 7 Regel. Laut cfdisk print ist es:
    First Sector 0
    Last Sector 1953525167
    Offset 8
    Length 1953525168


    ext3 wird natürlich mit 4096 Blocksize erstellt, außerdem mit largefile4, was relativ wenige inodes erzeugt.
    Schneller ist das Filesystem beim Rückspielen der Daten auch nicht, 15M/s über SATA-USB-Adapter. Hängt aber wohl eher an diesem Adapter.

    Auf der Suche, wie man nun die Sektoren bei fdisk genau einstellt, bin ich hierrauf gestoßen: libblkid-or-why-you-dont-need-to-worry-about-4k-disk-format/
    Demnach sollte das auf einem aktuellen Linux eigentlich immer richtig gemacht werden. cfdisk und fdisk erstellen aber immer mit Startsektor 1. Wenn ich bei fdisk 1 oder 8 als Startsektor eingebe, bekomme ich "out of range". 2048 wäre möglich, da verliert man aber unnötigerweise etwas Platz, der sonst für Bootmanager reserviert wäre, den ich hier aber nie brauchen werde.


    Und hier wird erklärt, dass bei fdisk der End-Sektor nicht durch 8 teilbar sein soll, sondern MOD 8 = 7 ergeben soll, da fdisk den Endsektor inklusive anzeigt.

    Ich habe die Festplatte nun ausgebaut. Die bestehende Partition hat laut fdisk -l /dev/sdb1 Start=1 und End=1953520064.
    Ende war durch 8 teilbar, der Anfang war nicht wie vermutet 63 oder wie bei Windows 2048, aber 1 wäre eben auch nicht ideal da nicht durch 8 teilbar.

    Ok, ich werde das befolgen.


    Ich wüsste aber nicht, warum ohne Partitionstabelle cp oder mv nicht funktionieren sollten. Für USB-Sticks habe ich nie Partitionen. Und für ein LUKS device z.B. über ein ganzes Blockdevice erstelle ich auch keine Partition sondern mache ein luksFormat direkt aufs Blockdevice. Auch das entschlüsselte Device versehe ich nie mit einer Partitionstabelle. Ich halte es mit Partitionen so, dass ich nur dann Tabellen erstelle, wenn ich auch Partitionen haben möchte.
    Die Sache mit AF war mir bisher unbekannt. Da kann es natürlich sein, dass man ohne Partition keine Möglichkeiten zum schieben hat, ich werde da mal etwas nachforschen.

    Eine einzige große Partition ist es jetzt auch schon, nur halt nicht aligned.


    Wobei mir dazu gerade einfällt, was spricht eigentlich dagegen komplett auf die Partitionstabelle zu verzichten und das gesamte Blockdevice mit ext3 zu formatieren? Erkennen müsste G1 das eigentlich, zumindest haben andere Linux kein Problem sowas zu mounten. Nur wäre dann überhaupt das Alignment korrekt für AF, denn schieben kann man dann nichts.

    Wie ich fdisk verwende, ist ja nicht die Frage. Aber auf welchem Sektor soll ich die Partition beginnen lassen? Gleich bei 0, oder 8?
    In der heise FAQ lese ich nur, dass es Geschwindigkeitsprobleme gibt, wenn die Sektoren nicht "aligned" sind. Aber ist das ein Bug, dass es Schreibfehler gibt? Heisst das bei E2, nach dem Bugfix kommt E2 auch mit Startsektor 63 zurecht, wobei es wegen Performance anzuraten ist, dennoch durch 8 teilbar anzulegen?


    So oder so, ich würde gerne bei E1 bleiben. E2 gibt es ja für die 7020 inzwischen, das hatte ich aber kurz drauf, war mir zu langsam und zu viel Umgewöhnung. E1 hat alles was ich brauche. Ich hoffe mit der korrekten Partitionstabelle wird auch E1 nun zurechtkommen.


    Edit: Ok, ab Sektor 8 also.

    Endlich eine Spur, das könnte es sein. Danke.
    Wo sollte ich die Partition am besten beginnen lassen, wenn ich sie manuell partitioniere? Sollte fdisk am Rechner das nicht selbst richtig machen? Oder hat nur die Dreambox Probleme mit AF und Sektor 63, Rechner aber nicht?
    Bootsektor brauche ich ja nicht auf der Dreambox, kann ich die Partition dann bei 0 oder gleich bei 8 beginnen lassen?


    EDIT: Guter Artikel über AF bei heise: /FAQ-Festplatten-mit-4K-Sektoren-1378642.html