Posts by flo77

    Hallo Mordillo,


    hast Du Dir schon mal gedanken wegend der erweiterten "Mehruserfähigkeit" gemacht? Weil das Programm ist wirklich spitze, aber das wäre dann eben die Krönung!


    Gruß,
    Florian

    DICKES DANKE schonmal!
    Zu meiner Wuschliste zählen dann die
    - "Multiclient-Unterstützung"
    - der Multithread-Support um auch Mehrprozessorsysteme Auslasten zu können - muss wohl über merere VLC-Instanzen realisiert werden.
    - Evtl. noch die Möglichkeit auch Active X Quellen als Transcoding eingang wählen zu konnen (Webcam) oder Webstreams abgreifen zu können.
    Soll aber natürlich nicht als Forderung gemeint sein, sondern nur als Anregung für freie rrogrammier-Abende ;-))
    Ich stehe natürlich sehr gerne als Betatester zur Verfügung!
    (6 mal Enigma1-Receiver im LAN...)


    Gruß,
    Florian

    Hallo Mordillo,


    ich habe nun das ganz mit der CPU-Last nochmals genau überprüft, ich hatte in meinen Testreihen einen Fehler:
    Mein Eingangsmaterial war 720x576 und und gestreamt habe ich 704x576 lt. vlc.xml.
    Das NG-Plugin ist da durch die Scale=1 option natürlich flexibler und hat das Format richtig angepasst.
    In versuchen war es mir möglich den VLC_x86 Server mehrfach aus verschiedenen Verzeichnissen heraus zu starten, somit könnte ich u.U. doch mehrere Instanzen zum laufen bekommen.
    Kann man irgendwie konfigurieren, dass der Server mit bereits laufenden VLC-Instanzen spricht (meinen Services), oder kann ich evtl. auch VLC aus verschiedenen Verzeichnissen mit verschiedenen Configs (Ports) starten?
    Ich habe festgestellt, dass ich die Pfadangabe zu vlc allerdings nicht dauerhaft ändern kann - spätestens nach dem neustart des x86-Server ist der Pfad wieder auf default-vlc98.
    Außerdem habe ich in der Tat auch das Problem, dass sich z.B. die zu benützende Netzwerkkarte und IP nicht dauerhaft abspeichern lässt.
    Änderungen an Ports, Startverzeichnissen etc. werden übernommen.
    Ist das mir bei mir so?
    Nochmals Dank für Deine super Arbeit!


    Gruß,
    Florian

    Hallo Mordillo,


    ich habe das neue Plugin auf einer DM 600 mit Gemini 4.5 getestet.
    Super Idee!!
    Sehr positiv ist mir dabei aufgefallen, dass der VLC mit dem Plugin deutlich geringere CPU-Belastung bei Trancodierung mit gleicher Bitrate und Ausgangsformat h264 - was ich bisher aber noch nicht verstehe?!?
    Du hast geschrieben, dass du mehrere Clients mit dem Plugin bedienen kannst, sollte dies mit einer laufenden Instanz auf dem Rechner möglich sein? Ich habe einen 8-Kern w2k3 Server und hatte bisher 6 VLC-Instanzen als Dienste auf dem System gleichzeitig am laufen(Mit gesetzter Option Dienst bei Fehler automatisch neustarten ;-). Allerdings stehe ich damit immer vor der Problematik, dass jeder VLC Instanz nur maximal 12,5% der CPU-Leistung zur Verfügung stehen und das ist leider immer etwas knapp, da sieht es mit der neuen Variante besser aus! Hier habe ich beim streaming eines Files von h264 auf die
    Dreambox nur 3 Prozent CPU-Last, statt um die 10 Prozent mit dem "klassischen VLCF".
    Ich habe allerdings das Problem, dass mir das VLCF NG-Plugin auf der Dreambox recht regelmäßig beim Wechsel zu einer anderen Datei crasht. Das erste File läuft immer, beim wechsel zu einem weteren geht es fast immer schief - habe natürlich die Spielbarkeit der Files sichergestellt.
    Diesbezüglich eine Idee?


    Crus
    Soweit ich festgestellt habe, nimmt VLCS_x86 immer zunächst die "primare" Netzwerkkarte, dh.h die die du in Windows unter Netzwerkverbindungen -> erweitert -> erweiterte einstellungeen -> reihenfolge der Verbindung definiert hast (Die oberste).


    Viele Grüe,
    Florian

    Hallo Cepeus,


    ja, das ist richtig,es befindet sich im Multiboot, den ich via FW-Pro installiert hatte.
    Allerdings ist im Flash ebenfalls ein aktuelles CVS Image von Dezember.
    Da ich dies gestern gemeinsam mit dem Gemini 4.6 installiert hatte, bae ich dort noch gar keinen sendesuchlauf gemacht.
    Dies habe ich eben nachgeholt und stehe vor den selben Problem!
    Erstmal nur jeden 2. Sender gefunden - je öfter ich den Suchlauf machte, desto mehr Sender wurden gefunden.
    Leider aber nicht alle.
    Ich habe nun testweise auch noch einen anderen Ausgang des Multischalters getestet - immer das gleich Bild!
    Gemini 4.3 wunderbar - aktulle Images demnach wohl nicht.
    Ratlosigkeit....


    Gruß,
    Florian

    Ich habe mit dem 4.6er Probleme mit der Sendersuche.
    Anlage ist gut ausgerichtet, 100er schüssel, 19,2/13 Grad.
    Mit meinem alten Gemini 4.3 findet die Box alle Sender, mit dem 4.6er verhält sich das ganze seltsam:
    Bei jedem Suchlauf (nun so 10 mal gesucht) fand er auf Astra mal 5 neue, mal 60 neue sender, zulezt aber nun aber keine Neuen mehr.
    Trotzdem fehlt mir z.b. ARD über Astra.
    Wenn ich ohne jegliche physikalische Veränderung das alte Image boote ist alles O.K..
    Kann jemand dieses Phänomen bestätigen?


    (Tuner ist ein LG)


    Gruss


    Florian

    Quote

    Original von smuso


    Aja kann man die Ordner ein wenig eingrenzen. VLCF zeigt mir alle Laufwerksbuchstaben an also C-E. Kann man da ihm nicht sagen das er nur auf einen bestimmten Ordner zugreifen soll?


    danke im Vorraus auf die Antwort


    Dies (mit einschränkung des VLC-Pfades) würde ich auch sehr begrüßen.
    Ich habe VLC auf einem Fileserver laufen, da sollte nach Möglichkeit nicht jeder auf alle Dateien bzw. Verzeichnisse zugriff erhalten können. Falls es in VLC keine Möglichkeit gibt, werde ich eben versuchen mir über NTFS-Berectigungseinschänkungen weiterzuhelfen. (VLC läuft unter Benutzer XYZ, diese wird dann eben auf den Proflies-Pfad der User keine Berechtigungen erhalten... aber erst mal sehen ob dies klappt.)

    Hallo Mordillo,


    mir ist da noch was aufgefallen:
    Wenn ich das VLC-Frontend starte, sich die Platten in meinem Server jedoch im "Spindown-State" befinden, bekomme ich zwar eine Verzeichnisliste - wohl aus den Systemcache - wenn ich dann aber ein file abspielen möchte, dauert es bei mir ca. 20 Sekunden bis das Raid "ready" ist, solange wartet das Plugin aber nicht auf den VLC und es scheint irgendein Watchdog zuzuschlagen und enigmna wird - vermutlich gewollt - neugestartet.
    Wenn die Platten eh laufen ist alles in butter!
    Sind diese "wachtdogs" gewollt - oder ist dies noch ein BUG?
    Falls man jedenfalls diese timeouts auch irgendwie in einer Config selbst anpassen könnte, fände ich super.
    Und dann hätte ich ja wie erwähnt noch das Direct-Input-Streaming auf meiner Wehnachtswunschliste ;-)
    Nochmals: Geniales plugin!
    Läuft bei mir auf 5 Boxen mit 5 Zugehörigen, als dienst auf verschiedenen Ports lauschenden und streamenden VLC-Instanzen....

    Hallo Olli,


    bendenke aber, dass die Kiste, je nach dem, welche Datenrate du Streamen - und welche Formate du decodieren möchtest nicht "zu" einfach sein sollte. Pentium 4 Klasse wäre meinen Versuchen nach schon mindestens empfehlenswert...


    @ mordillo:
    Wünsche ebenfalls einen erholsamen Urlaub. Nochmals Danke für das Plugin!


    Gruß,
    Florian

    Hallo Olli,


    wenn Dein NAS kein so kleines Stand-Allone teil ist, sondern einen Ordentlichen Prozessor drin und ein offenes Betreibssystem drauf hat sollte das funktionieren. ;-)
    Ich denke aber Du meinst eher so eine Tera-Station, oder etwas derartigen, oder?
    Dann wir dir sowieso die Prozessorleistung zum transkodieren nicht reichen.
    Schau mal in den Taskmanager Deines Computers, während du VLC-Streamst. Da hat die CPU sicher einiges zu tun....


    Gruß,
    Florian

    Erst mal ein dickes LOB!
    Funktioniert bei mir - soweit kein Timer in die Quere kommt absolut genial!
    Aber ich hätte da ein Anliegen:
    Es wäre super, wenn man ein "frei-editierbares" event anwählen könnte, wie z.b. nen webstream oder eine direct-show quelle im vlc.
    Ich würde gene das Bild meiner Webcam (USB, direct show kompatibel) auf die Dreambox bekommen. Ich habe dies auch schon manuell über viele Umwege hinbekommen:
    Habe VLC in mehreren Instanzen gestartet, (läuft bei mir als Dienst mit dem Webinterface 3 mal auf verschiedenen Ports (8000, 8001, 8002).
    Wenn ich nun einen Stream manuell mit einer VLC -Instanz auf meiner aktuellen Windows-Sitzung starte (web-Port 8008, dabei den Stream via "stream sichern und komandozeile ":sout=#transcode{vcodec=mp2v,soverlay,senc,vb=1024,width=352,height=288,fps=25,acodec=mpga,ab=64,channels=2,audio-sync}:std{access=http,mux=ts,dst=:9000/dboxstream}" auf port 9000 zur verfügung stelle, danach ein beliebiges File versuche mit Hilfe des Dreambox-Plugins abzuspielen bekomme ich meinen manuell gestateten Stream zu sehen, da VLC zwar mit der Drerambox spricht, aber sich nicht mehr an den Port 9000 binden kann. -> Dreambox empängt meinen Stream, anstatt des eigentlich angeforderten.
    Damit wäre es dann ebenso möglich, webstreams von irgentwelchen TV-Sendern weltweit zu empfangen - wenn vlc diese trankodiert....
    Aber das sollte doch auch einfacher gehen, oder?
    Besten Dank für einen diesbezüglichen TIP - oder auch die Implementation derartiger Funktionen in diese Großartige Plugin!!

    Hallo,


    ich versuche MP´s über eine eigentlich ausreichend performate VPN-Verbindung abzuspielen. Mit dem PC ist dies kein problem - mediaplayer puffert da zu beginn einige sekunden und alles ist gut.
    Die Dreambox hingegen scheint wohl "von der Hand in den Mund" zu leben - hier stockt das abspielen von selbst LQ-MP3s alle paar Sekunden, obwol ich im Durchschnitt zumindest 500Kbit/s über diese Leitung bekomme.
    Irgendwelche Ideen?


    Besten Dank,
    Florian

    Hallo,


    ich habe ein ähnliches Problem.
    In meinem Fall wartet die Box bei einer Aufnahme nicht lange genur, bis die Festplatten meines NAS hochgefahren sind. Somit schlägt die erste aufnahme immer fehl, versucht man es 15 Sekunden Später nochmals ist alles in Ordnung. Wenn ich die Platte vorher durch einen anderen Zugriff "aufweckt" funktioniert es ebenfalls auf Anhieb. Gibt es wirklich keine möglichkeit diesen Timeout höher zu setzen?

    Hallo pippel,


    vielen dank, ich fürchte aber in unserem Fall wird das nicht weiterhelfen. Ich hänge hier an einer 8-Teilnehmer-Anlage, die Schüssel ist optimal Ausgerichtet und hat gute Empfangswerte. nur eber bestimmte Sender funktionieren mit der DM 600 überhaupt nicht, mit anderen Receiver am gleichen Anschluss jedoch 1a.

    Hallo,
    habe gleiches Problem, scheint aber vielen so zu gehen.
    Siehe auch hier mit 4.0 manchmal keine sender gefunden und hier Gemini 4.0 No signal.
    Ich habe alle Probleme in Kombination, keine vernünftige DISEQ - Umschaltung und zusätzlich Probleme auf best. Transpondern.
    Scheint wohl lt. diesen Beiträgen ein BUG im OE zu sein, hoffen wir mal, dass es da bald einen fix dafür gibt.
    Hatte allerdings bislang auch noch keine Zeit zum Downgrade auf das 3.6er...
    Gruß,
    Florian

    Nein, TV ist wirklich "potentialfrei", kein Kabel, keine Verbindung zu irgendeinem Schutzleiter.
    Ich werde aber die Versuche hinsichtlich direkt am Multischalter und direkt an Astra H/H noch durchführen. Mir ist gerade eingefallen, ich könnte ja mal mit meinem Satfinder die DISEQ-Ausgabe der DM600 monitoren, daran habe ich bishern noch gar nicht gadacht. Dennoch ist Ja schon alleine die Tatsache, dass es mit dem einen Recaiver unter meines Erachtens gleichen Bedingungen funktioniert, mit dem anderen hingegen nicht für mich wirklich dubios. Evtl. habe ich auch was Gundlegendes übersehen - möchte ich ja nicht ausschließen.
    Mit "Spannung erhöhen" etc. habe ich auch schon probiert - brachte aber keinen Erfolg. Bei der DBOX hatte ich auch noch im Streamboard tips von Tunertreiber tausch gelesen, aber nie ausprobiert...


    RE Off Toppic:
    Mit der Wavefrontier und guten LNBs sowie verlustarmen DISEQ-Schaltern hat der BBC gei gutem Wetter tadellos funktioniert, habe allerdings keine Empfangswerte parat, kann ich dir aber gerne mal im Laufe der Woche nachreichen. Bei stärkerem Regen oder Schneefall kanns schon mal Probleme geben.
    Hier habe ich erstmals den unglaublichen Tunerqualitätsunterschied zwischen der DM7000 und der 7020 feststellen können. Mit der 7000 hatte ich auch bei gutem Wetter einige BERs, die 7020 keine.
    Muss nochmals sehen, glaube der Astra2 ist ein Single-golden-Interstar - wenngleich diese LNBs keine besonders guten Ruf haben, brachten meine Praxistests im direkten Vergleich mit Invarcom, Sharp und Inverto bei diesem die besten Ergebnisse - spreche allerdings von einer schon 3-Jahre alten Baureihe...