Posts by steve1974

    Quote

    Original von joergm6



    gorgi : wenn ich ne Ahnung hätte....


    Hi Jörg,
    ich glaube ich weiß was Georgi meint. Bei zwei SPF87H an der Box wird nach Neustart meist nur ein Display von beiden erkannt (auch wenn beide im Massenspeicher Mod sind). Geht man dann in das L4L Plugin und startet mit "gelb" die Displays neu kommt auch die Bildausgabe. Meistens werden aber noch die Displays vertauscht (das der Screen vom angedachten LCD1 auf dem LCD2 landet)
    Da die Displays ja nicht gemountet werden bringt es ja auch nichts wenn man über die UUID geht. Hast du da eventuell eine Lösung parat?


    Gruß,
    Steve.

    So, heute kam auch meine Netatmo an, konfiguration ist erledigt und funktionieren tut sie auch.


    Das einzige was ich jetzt noch habe das mir der falsche Standort im Plugin angezeigt wird. Wenn ich in die Android App schaue passt der Standort, und in der Wetterkarte von Netatmo passt er auch, nur im Plugin nicht.


    Gibt es dafür eine Einstelung (die ich bisher nicht gefunden hab)?


    Gruß steve1974.

    plugandplay


    Ich möchte jetzt nicht anmaßend wirken, aber hier müllt niemand den Thread zu. Ich finde es nur komisch das du das letzte mal am 09.06. hier geschrieben hast und dann war Funkstille.
    Aber egal, ich habe hier nur geschrieben weil ich darauf angesprochen wurde, und will dir bestimmt nicht dein "Geschäft" kaputt machen.


    Zur programmierung des Attiny. Ich weiß nicht wie gut du dich mit den Attiny´s und seinen Datenblättern auskennst, aber einen Attiny sauber laufen zu lassen ohne einen externen pullup Wiederstand am Reset und einen Kondensator zur Stabilisierung ist keine sonderlich schlaue Lösung. Die internen pullup Wiederstände gelten von jeher als nicht sehr zuverlässig, und jeder weiß das Spannungseinbrüche bei internen Schaltvorgängen nichts ungewöhnliches sind (dafür auch der Kondensator). Aber jeder so wie es kann.
    Falsch angeklemmt ist er nicht. Seine Versorgungsspannung bezieht der Attiny sauber vom 5V Spannungsstabilisator (mit einer Schaltspannung als Versorgung kann man nicht sauber arbeiten), sein Eingangssignal bekommt er vom mini USB. Wenn man wie du nur die Spannung am Eingang misst und wenn sie 10 sec. anliegt die Ausgangssignale schaltet, läuft man Gefahr (wie bei der VU+ Solo²) das sich das Display bei booten wieder ausschaltet. Wenn du aber eine permanente Flankenerkennung in beide Richtungen hast dann kann der USB Port der Box so oft abgeschalten werden wie er lustig ist und das Display wird immer das machen was es soll.


    Wie gesagt, für mich ist das ganze nur Hobby und solange es die Materialkosten deckt ist es vollkommen ok.


    Gruß, Steve.

    joergm6
    vielleicht ist es einfacher wenn ich mich hier auch nochmal verewige.


    @all
    Ich habe es am Anfang mit J.Depp´s code versucht, bin da aber sehr schnell an die Grenzen gestoßen da manche Boxen (Solo²) beim booten den USB Port mehrfach zu und abschalten und das Display (mit dem Attiny) nur bei jedem zweiten Receiverstart ordnungsgemäß gearbeitet hat.


    Aufgrund der Problematik hab ich den Code komplett neu geschrieben, mit einer Spannungsüberwachung am Signal-Pin. Desweiteren fehlte mir in jeder bisherigen Lösung die korrekte Ausführung der Attiny Anbindung. Um den Attiny auch Prozesssicher betreiben zu können mussten nämlich noch ein Pullup und ein Pulldown Wiederstand in die Schaltung außerdem noch ein Kondensator zur Spannungsstabilisierung.


    Meine Attiny´s (Attiny13) habe ich deswegen auf eine kleine Platine gelötet (zumindest für die 107H). Beim 87H musste ich die Wiederstände und den Kondensator direkt am Chip anlöten, da das Board aus Platzgründen nicht in das 87H passt.


    Beim 105P (nur automatisches Einschalten) sieht die Lösung etwas anders aus.
    Das 105P hat nur (bei angestecktem externem Netzteil) eine 3,3V Versorgung auf dem Board, was zu dem Problem führt das das 5V Signal vom USB Anschluß vom Attiny nicht als High Signal (Logisch 1) gewertet wird weil der Signalpegel über der Betriebsspannung liegt. Aus diesem Grund habe ich dort noch zusätzlich einen 3,3V Spannungskonstanter zwischen USB Anschluß-Board und Signalpin Attiny gebaut, womit das Problem auch behoben ist.



    Wie ihr seht stehe ich für jede Spielerei zur verfügung ;)




    Umgestzte Funktionen:


    SPF 107H: - automatische Aus -Ein-Steuerung ( bei Aus und Einschalten der VU+ (auch Solo2) und auch bei Neustart)
    - automatischer Massenspeichermod (nach Reboot bzw. Aus -Einschalten der VU+


    SPF 87H: - automatische Aus -Ein-Steuerung ( bei Aus und Einschalten der VU+ (auch Solo2) und auch bei Neustart) mit externem Netzteil und auch ohne Netzteil (nur mit USB)
    - automatischer Massenspeichermod (nach Reboot bzw. Aus -Einschalten der VU+ (mit externem Netzteil und auch ohne Netzteil (nur mit USB))


    SPF 105P: - automatische Aus -Ein-Steuerung ( bei Aus und Einschalten der VU+ (auch Solo2) und auch bei Neustart)
    Massenspeichermod wird vom Display selbst aktiviert


    Gruß, Steve.


    EDIT: Wenn jemand nicht ganz so firm im Umgang mit dem Lötkolben ist, baue ich das Display auch um.


    Im Anhang sende ich Euch nochmal ein kleines Video zur besseren Veranschaulichung. Es handelt sich dort um ein SPF 87H wo die VU+ und das externe Netzteil noch an einer Funksteckdose hängen.

    Files

    • 87H_an_Solo².zip

      (34.04 MB, downloaded 311 times, last: )
    • SPF_107H.pdf

      (2.47 MB, downloaded 432 times, last: )
    • SPF-87H.pdf

      (1.74 MB, downloaded 466 times, last: )


    Hi Mamba, auch hier das gewünschte Paket für OE 2.0


    Gruß, Steve.

    Hi Jörg,


    hatte ich auch schon gemacht. Aber egal welche Textdatei er anzeigen soll, das Display häng sofort.


    edit: ich habe eben nochmal eine Textdatei selber erstellt (manuell) und versucht sie in L4L darstellen zu lassen. Das Ergebnis war das gleiche, sowie er diese Datei darstellen soll hängt sich das Samsung weg.


    Hab mal das Log nebenbei laufen lassen, hänge es dir mal an. Vielleicht siehst du ja was, ich kann damit wenig anfangen.


    Gruß, Steve.

    Files

    • L4log.txt

      (8.03 kB, downloaded 15 times, last: )

    Hi Leute,
    ich muss allen Beteiligten erstmal ein großes Lob aussprechen, für die super Arbeit die ihr hier leistet.
    Habe L4L schon von der ersten Version ab auf meiner 500HD laufen, bis auf kleine Anlaufschwierigkeiten, ohne Probleme.


    Nun stehe ich aber vor einem Rätsel. Wollte mir nun eine Textdatei, die von einem Script erzeugt und in /tmp abgelegt wird, anzeigen lassen. Sowie L4L die besagte .txt Datei in /tmp findet, steht das Display. Schalte ich das auslesen der .txt im Plugin ab, reagiert das Display auch wieder.


    Hard- und Software die ich verwende:


    DM500HD
    Merlin3 (OE2.0) neuestes Release
    L4L Version 2.2-r1 mips32el
    Samsung SPF 107-H


    p.s.: das anzeigen von .png Bilddateien geht ohne Probleme


    Vielleicht kennt jemand ja eine Lösung für mein Problem.


    Gruß, Steve.

    Ist wohl ein Bug, wenn du Bouquet-Up Taste drückst schaltet er die Bouquet´s durch. danach geht auch die Bouquet-Down Taste. Nur wenn du Bouquet-Down zuerst drückst passiert gar nichts. Vielleicht könnte sich das mal jemand von den Dev´s anschauen.
    Gruß, Steve.