Posts by morlix

    hi,


    habe gerade etwas komisches festgestellt.


    Ich habe einige Autotimer und wenn ich die Vorschau anschaue, sehe ich das er 3 Timer anlegen würde.


    Wenn ich dann den EPG durchsuchen lasse, sagt er das 3 Sendungen gefunden wurden aber nur 2 Timer angelegt werden.


    Warum ist das so? Ich habe keine anderen Timer die zu dieser Zeit des fehlenden bzw. nicht angelegten Timers laufen würden?


    Wo kann ich hier nach weiteren Infos auf der Box suchen? Gibt es sowas wie ein logfile?


    Grz morlix

    Anpassen solltest du auf jedenfall den folgenden Teil der config.


    Code
    <autoscan use-inotify="auto">
    <directory location="/srv/stuff/movies" mode="inotify" recursive="yes" hidden-files="no"/>
    <directory location="/srv/stuff/music" mode="inotify" recursive="yes" hidden-files="no"/>
    <directory location="/srv/stuff/series" mode="inotify" recursive="yes" hidden-files="no"/>
    <directory location="/srv/stuff/_tmp/movies" mode="inotify" recursive="yes" hidden-files="no"/>
    <directory location="/srv/stuff/_tmp/music" mode="inotify" recursive="yes" hidden-files="no"/>
    <directory location="/srv/stuff/_tmp/series" mode="inotify" recursive="yes" hidden-files="no"/>
    <directory location="/srv/stuff/_tmp/_torrent" mode="inotify" recursive="yes" hidden-files="no"/>
    </autoscan>


    Dieser teil zeigt mediatomb welche verzeichnisse überwacht werden sollen. Sprich alle Dateien in diesen Ordnern werden dir per UPNP zur Verfügung gestellt.

    ssh ist eine sicherere (weil verschlüsselte Übertragung) Variante von telnet.


    Du kannst die ganzen Befehle auch per telnet ausführen, das kommt auf das gleiche raus.


    Als Konfigurationsdatei kannst du entweder die nehmen, welche mit dem IPKG hier aus dem IHAD mitkommt, oder du tauschst die Datei mit der von mir in einem vorherigen Post gezeigten aus.

    Als erstes logst du dich per ssh auf deine Box ein.


    Dann führst du folgende Befehle aus:


    Code
    cd /etc/rc3.d
    ln -s ../init.d/mtb S99mtb


    Die Konfigurationsdatei gehört dann nach "/etc/enigma2/mediatombconfig.xml"


    Der Daemon läuft dann auch wenn deine Box im Standby ist.

    alles klar.


    Hier brauchst du dich doch um das manuelle anlegen der symlinks für den autostart gar nicht kümmern.
    Du kannst doch im Blue Panel den start des Mediatomb einfach einschalten.


    Ich habe jetzt leider gerade keinen Receiver zur Hand, aber da bin ich mir ziemlich sicher.
    Ich schau aber heute abend mal bei mir nach.


    Wichtig für mediatomb ist eine korrekte Config mit mappings der mimetypes.


    Hier mal meine Konfig, welche ich auf meinem Server (nicht die dm) nutze.



    Da sind unter anderem für Samsung LED TVs und die PS3 ein paar Parameter drin, damit diese so gut wie alle Format perfekt abspielen.


    Weiterhin habe ich ein paar Verzeichnisse drin, die von Mediatomb per inotify überwacht werden.
    Sprich alle Files die in diesem Ordner abgelegt sind oder werden, werden automatisch in die Mediatomb db aufgenommen.


    Gruß morlix

    Quote


    Wie kann ich denn bestimmte Datein auf z.B. eine PS3 freigeben, die in verschiedenen Unterordnern in media/hdd/movie liegen?


    Bestimmte Dateien kann man nicht freigeben sondern nur Verzeichnisse.


    Wenn du bei der Konfiguration von Mediatomb hilfe brauchst, sag bescheid.

    Hast du schon ein anderes Kabel probiert bzw. kann es sein, das ein Wackelkontakt auftritt?


    Sofern das unter linux auch passiert, würde mich die Ausgabe von dmesg vor und nach dem Problem interessieren.


    Da dmesg sehr viel ausgeben kann, denke ich hier reichen die letzten 20Zeilen.


    dmesg | tail -n 20

    Vermutlich fährst du hier wirklich leichter wenn du dir für die Entwicklung eine Debian Machine aufsetzt.


    Nutzt du das Suse auf deinem Host oder ist das eine VM?
    Wenn es eine VM ist, die du nur zum entwickeln nimmst, dann würde ich sehr zu debian tendieren.

    Hast du zufällig das DTSdownmix Plugin installiert? Ich glaube mich erinnern zu können, das ich so etwas auch mal hatte als ich DTSdownmix installiert hatte.

    ok aber du hast einen port von extern auf die interne ip der box umgeleitet richtig?


    Ich frage mich warum eine Portweiterleitung von extern auf einen HTTP Proxy gehen soll aber die Portweiterleitung auf die Box nicht.


    Beschreibe doch bitte deine Umgebung nochmal so genau wie möglich.