Posts by svenw1973

    Fred,
    ja es ist die 8k.
    Beschädigungen kann ich nicht erkennen. Das Paket wurde ohne Probleme installiert. Es tritt nicht bei allen Picons auf, aber bei den meisten.


    Trial,
    Gemessen durch Beobachtung von top bzw. nmon beim Umschalten. In jedem Fall geht die CPU kurz nach dem Umschalten hoch. Nur bei z.B. SIXX geht sie wieder runter. Bei Sat 1 oder Pro7Maxx halt nicht.

    Quote

    Originally posted by Fred Bogus Trumper
    Hast du mal die Dateigrößen einzelner Picons verglichen?


    Vileleicht sind die Picons, bei den denen CPU Last hochgeht in 32bit, kann gut sein, dass der 8k dabei die Luft ausgeht ...


    ob 8 oder 32bit, kannst du so rausfinden

    Code
    root@dm7020hd:/# file /path/to/picon/1_0_1_4461_453_1_C00000_0_0_0.png
    1_0_1_4461_453_1_C00000_0_0_0.png: PNG image data, 100 x 60, 8-bit colormap, non-interlaced
    root@dm7020hd:/#


    Code
    root@dm8000:/usr/share/enigma2/piconorg# file
    -sh: file: not found


    Welches Package beinhaltet "file"?

    Ich greife auch auf meinen Owncloud-Server zu. Allerdings nicht per DAV. Das ist mir zu lahm und zu CPU-lastig. Ich mach es per NFS. Das ist wesentlich schonender. Wenn es nur im heimischen Netzwerk ist, dann sollte das Thema Sicherheit nicht so eine große Rolle spielen.


    Gruß,
    Sven

    Hi,


    in diesem Paket sind verschiedene Picons, welche die CPU auf Touren bringen (~50%)
    gp-picon-display-400x160-fullsize-stefanbenno6-astra-19.2e - 150424-r0


    Ein Beispiel ist das von Prosieben MAXX 1_0_1_4461_453_1_C00000_0_0_0.png


    Ich hab das aus dem normalen Picon-Verzeichnis reinkopiert und die CPU war wieder normal.
    Bei Sat 1

    Code
    1:0:1:445C:453:1:C00000:0:0:0

    hat das aber nicht funktioniert. Ich vermute es liegt nicht an der Auflösung, sondern an dem Image selbst.
    Hat jemand eine Idee, warum bei manchen Picons die CPU so hoch geht und wie man das beheben kann?


    Gruß,
    Sven

    Hmmm... Da gibt es bei dmm-HDr2 im Unterschied zu den anderen Skins 3 skin.xml.
    Der Screen InfoBarSummary ist in der skin.xml sogar 2x definiert (id=1 und id=2).


    Leider verstehe ich von dem Skinnen garnix. Hab zwar gerade mal versucht verschiedene Anpassungen zu machen. Das führte aber nur zu Start-Loop bei e2.
    Siehst du, was da krumm sein könnte?

    Danke! Das war es.
    Bei Skin "Default-HD" geht es.
    Bei "DreamMM-HD" geht es.
    Bei "dmm-HD" geht es,
    Bei "dmm-HDr2" geht es nicht.


    Das ist dann wohl was für JackDaniel. *Thread suchen geh*


    Danke soweit erstmal für die Hilfe.
    Gruß,
    Sven


    Edit:
    Es sei denn, dass "(für alle Skins..." bedeutet, dass mir damit hier auch geholfen wird.

    Quote

    Originally posted by m0rphU
    Hast du überhaupt die beiden skin_user Pakete aus dem ersten Post installiert?


    Ja, steht oben. Grundpaket und Rorator.


    Quote

    Originally posted by Jogi29
    welches Image?
    Ist die Anzeige sonst, also bei Plugins in der richtigen Größe?


    Aus meiner Sicht ist sonst alles korrekt. Siehe angehängte Bilder. Das ist ein OE2.0 image.

    Danke!
    Das ist korrigiert. Ich habe das entsprechende Paket mit den 400x160 Picons nachinstalliert. Der Ordner existiert nun und der Symlink zeigt auf den Ordner 400x160.


    ll /usr/share/enigma2/|grep picon
    lrwxrwxrwx 1 root root 34 May 18 13:46 picon_50x30 -> /usr/share/enigma2/picon/minipicon
    lrwxrwxrwx 1 root root 32 May 18 13:49 piconoled -> /usr/share/enigma2/picon/400x170
    lrwxrwxrwx 1 root root 27 May 18 14:20 picon -> /usr/share/enigma2/piconorg
    drwxr-xr-x 5 root root 0 May 18 14:36 piconorg
    lrwxrwxrwx 1 root root 32 May 18 15:12 picon_oled -> /usr/share/enigma2/picon/400x160


    /usr/share/enigma2/ :
    lrwxrwxrwx 1 root root 34 May 18 13:46 picon_50x30 -> /usr/share/enigma2/picon/minipicon
    lrwxrwxrwx 1 root root 32 May 18 13:49 piconoled -> /usr/share/enigma2/picon/400x170
    lrwxrwxrwx 1 root root 27 May 18 14:20 picon -> /usr/share/enigma2/piconorg
    drwxr-xr-x 5 root root 0 May 18 14:36 piconorg
    lrwxrwxrwx 1 root root 32 May 18 15:12 picon_oled -> /usr/share/enigma2/picon/400x160
    drwx------ 3 root root 0 May 18 15:21 Skin_oled



    Jetzt zeigt er das Picon an. Aber nur einen sehr kleinen Ausschnitt oben links in der Ecke.
    Es ist kein kleines Bild, sondern nur ein kleiner Ausschnitt.

    Quote

    Originally posted by Jogi29
    Die Picons für das Display liegen doch bestiommt in "/usr/share/enigma2/picon/400x160", dann muss der Symlink so aussehen:


    Code
    ln -s /usr/share/enigma2/picon/400x160 /usr/share/enigma2/picon/picon_oled


    Das erzeugt einen Link mit dem Namen picon_oled in /usr/share/enigma2/picon mit Verweis auf /usr/share/enigma2/picon/400x160.


    ll /usr/share/enigma2/picon/picon_oled
    lrwxrwxrwx 1 root root 32 May 18 13:49 /usr/share/enigma2/picon/picon_oled -> /usr/share/enigma2/picon/400x170


    Den hatte ich schon. Der wurde automatisch bei der Installation angelegt. Da hatte ich also nix gefrickelt.
    Gibt es ne Möglichkeit sowas zu debuggen? In der e2 Konsolenausgabe sehe ich soweit keine Fehler.

    Hallo,


    zu #1:
    Die HDD ist eine SSD. Latenzen hab ich dabei nicht feststellen können. Mit einer herkömmlichen HDD hätte ich das sicher nicht gemacht.


    zu #2:
    Icons wurden erneut installiert:
    opkg list-installed |grep icon
    gp-icons-nutrix - 0.15-r0
    gp-picon-display-400x170-stefanbenno6-d-a-ch-fullsize-astra-19.2e - 140826-r0
    gp-picon-hd-2d-fullsize-stefanbenno6-astra-19.2e - 150424-r0
    gp-picon-mini-2d-fullsize-stefanbenno6-astra-19.2e - 150424-r0


    Die Picons liegen jetzt im Flash:
    find / -name "picon*" -type d 2>/dev/null
    /usr/share/enigma2/piconorg


    Folgende Symlinks sind gesetzt:
    find / -name "picon*" -type l 2>/dev/null
    /usr/share/enigma2/picon_oled
    /usr/share/enigma2/picon
    /usr/share/enigma2/piconoled


    ll /usr/share/enigma2/ |grep picon
    lrwxrwxrwx 1 root root 32 May 18 12:56 piconoled -> /usr/share/enigma2/picon/400x160
    lrwxrwxrwx 1 root root 32 May 18 12:56 picon_oled -> /usr/share/enigma2/picon/400x160
    lrwxrwxrwx 1 root root 27 May 18 12:59 picon -> /usr/share/enigma2/piconorg
    drwxr-xr-x 3 root root 0 May 18 13:07 piconorg


    grep -e oled -e icon /etc/enigma2/settings
    config.plugins.dmmHDr2SkinSettings.oled_lcd_options=true
    config.plugins.dmmHDr2SkinSettings.oled_path=usr/share/enigma2/picon
    config.plugins.dmmHDr2SkinSettings.oled_foldername=400x160
    config.plugins.dmmHDr2SkinSettings.oled_picon_on_off=true
    config.plugins.AdvancedChannelSelection.big_picons=true
    config.plugins.AdvancedChannelSelection.picons_path=/usr/share/enigma2/picon/


    grep picon /etc/enigma2/gemini_plugin.conf
    str=location_picon=/usr/share/enigma2/picon


    Ergebnis:
    Picons im OLED und links in der AdvancedChannelSelection - Ok
    Picons im OLED bei der Kanalauswahl - OK
    Kein Picon im OLED bei Normalzustand. Nur das kleine IHAD-Logo oben links.


    Fehlt da noch ein Package oder ein Link?


    Gruß,
    Sven

    Hi,
    diesmal im richtigen Thread.


    Bei mir sehe ich leider nur das IHAD Logo links oben im OLED.


    Die Icons sind in /media/hdd/picon


    root@dm8000:~# ll /usr/share/enigma2/picon_oled /usr/share/enigma2/picon /usr/share/enigma2/piconoled /media/hdd/picon/picon_oled
    lrwxrwxrwx 1 root root 32 May 17 21:29 /usr/share/enigma2/piconoled -> /usr/share/enigma2/picon/400x160
    lrwxrwxrwx 1 root root 32 May 17 21:29 /usr/share/enigma2/picon_oled -> /usr/share/enigma2/picon/400x160
    lrwxrwxrwx 1 root root 32 May 17 21:29 /media/hdd/picon/picon_oled -> /usr/share/enigma2/picon/400x160
    lrwxrwxrwx 1 root root 16 May 17 22:05 /usr/share/enigma2/picon -> /media/hdd/picon


    Installiert sind das Paket 1+3 aus Post 1 sowie folgende Pakete:
    opkg list-installed|grep picon
    gp-picon-display-400x160-fullsize-stefanbenno6-astra-19.2e - 150424-r0
    gp-picon-hd-2d-licher.pils-astra-19.2e - 140413-r0


    Was fehlt hier oder ist hier falsch?


    Gruß,
    Sven

    Quote

    Original von marco777
    Er wollte sich nur vor dem Bier drücken das er mir noch schuldet. ..


    Das ist glatt gelogen! Ich hatte dir sogar mehrere Bier für deine Dienstbarkeit zugesagt. Ich war die letzten Monate nur ziemlich im Hamster gefangen. Sollte ich mich nicht freiwillig beim nächsten Stammtisch als Teilnehmer registrieren, so kannst du mich jederzeit per PN an meine offene Gegenleistung erinnern. :404:


    Edith: Ich hoffe die Ironie ist rübergekommen. ;) Wann ist der nächste? Nur damit du nicht verdurstest. :hurra:

    Da kommt Ärger...


    http://www.proofpoint.com/thre…f-a-Iot-driven-attack.php


    Additionally, observing the devices:

      * A vast number of the devices are running embedded linux servers (usually busybox)
      * Some use mini-httpd, some apache
      * Some are ARM devices, some are MIPS (or something very similar) others are based on an embedded Realtek chipset (eg PBO/Masscool/Ryan media players)
      * We believe some are PS3s/Xboxes/WIIs
      * Some are NAS devices (D-LINK and Netgear). One specific brand has open telnet, open ssh and an SMTP server - all unsecurable.
      * We’ve also seen set-top boxes (Dreamboxes, VU Duo2 Plus, and Melita Cable HD)

    exploited.


    Die Frage ist nun, wie stelle ich fest, ob ich betroffen bin und wie entferne ich den Mist ggf. wieder?