Posts by farshad6730

    GP3_skin_mod_HDr2_Army_Smoke_by_Bania_test5



    copy USR to ROOT

    GP3 mount usb devices during enigma2 initilization. During startup enigma2 read all devices with the mount path (with a device unmounted it read /autofs/sdx1) and cache it. After that GP3 change the mountpoints. When a plugin try to read the device use the mountpath cached from enigma2 before GP3 initialization. This is valid for all plugin

    new refrence:
    turksat 42e
    please add in your file

    crossepg@googlecode.com to me:


    Ok... problem found


    To get it working i did this:
    - in gemini setup panel i changed the epg dir to /media/usb
    - saved and reboot
    - edited the file /etc/enigma2/gemini_plugin.conf
    - changed the row "str=epgCacheDir=/media/usb" in "str=epgCacheDir=/media/usb/" (note the last /)
    - rebooted again


    With this procedure it work.
    Now.. about the gemini_plugin.conf i think it's a bug on GP3. Without this fix epg doesn't work anymore. I try to download some epg data from now/next epg but i lose it every reboot.


    I also doesn't understand why they don't use the config "config.misc.epgcache_filename". Some months ago dmm added this configuration option to permit to customize the epg.dat location from plugins. When you choose the db location from crossepg setup it also set config.misc.epgcache_filename to the right path.
    During an enigma2 reboot crossepg use this configuration to discover where copy the new epg.dat


    root@dm800se:~# cat /etc/enigma2/settings | grep config.misc.epgcache_filename
    config.misc.epgcache_filename=/media/usb/epg.dat


    I think this need to be reported to GP3 developers

    crossepg@googlecode.com to me


    After more test with latest GP3 release on latest enigma2 release i can confirm that the problem persist.
    I think the problem is caused because GP3 mount usb devices during enigma2 initilization. During startup enigma2 read all devices with the mount path (with a device unmounted it read /autofs/sdx1) and cache it. After that GP3 change the mountpoints. When a plugin try to read the device use the mountpath cached from enigma2 before GP3 initialization. This is valid for all plugin (from crossepg to mediaplayer).


    Manually settings mount path in fstab all work because the device is already mounted during enigma2 startup.


    Please report the bug to GP3 forum.

    crossepg@googlecode.com to me:


    i tested it and yes, you're right, the device doesn't appear on device list. I did some test and i think this is a bug related to GP3 (or enigma2 itself).


    I formatted and mounted the usb pen through GP3 panel. Then my usb pen was on /media/USBPEN and it was writable.
    When i tried to get the device list from enigma2 api i obtained this:
    -----------
    [<Components.Harddisk.Partition instance at 0x979530>, <Components.Harddisk.Partition instance at 0x979698>]
    /autofs/sda1/
    /
    -----------
    Enigma2 told me the wrong mount path (/autofs/sda1). Obviously the invalid path disappear from crossepg setup because it's not writable.


    This problem doesn't affect only crossepg. Take for example the integrated media player.
    For test purpose i downloaded an avi file on /media/USBPEN via ftp. After that i opened media player and choosed my device "kingstone usb pen". The list is empty and i can't see my avi (this happen because it try to open /autofs/sda1). Instead if i go in "Internal flash" -> "mnt" -> "USBPEN" i can see my avi.


    I think you need to report this bug on GP3 forum.


    For now, to workaround the problem, you can manually change your db path manually editing /usr/crossepg/crossepg.config.
    Remember that every time you go in "configuration" and come back this file will be recreated.

    I Know
    But my question was something else.



    CrossEPG:


    Why the new version(GP3) on the USB does not work? only on the internal hard work!
    But the old versions(GP3), with editing Fastb on the USB was working.



    Two plug (crossepg)and (subtitleplayer), are most commonly used plug Enigma2.


    Please modify mounted up, and the format in GP3


    thanks

    I Know
    But my question was something else.



    CrossEPG:


    Why the new version(GP3) on the USB does not work? only on the internal hard work!
    But the old versions(GP3), with editing Fastb on the USB was working.



    Two plug (crossepg)and (subtitleplayer), are most commonly used plug Enigma2.


    Please modify mounted up, and the format in GP3


    thanks


    Quote

    Originally posted by emanuel
    CrossEPG ist not part of GP3.

    Why does not anyone help?


    CrossEPG:


    Why the new version(GP3) on the USB does not work? only on the hard work!
    But the old versions(GP3), with editing Fastb on the USB was working.

    thanks


    crossepg On the internal hard works well
    Only on USB, for not properly mounted, will not work(in new version of GPS3)


    Please guide
    Or make the next version




    My image:CVS+GP3

    WITH PREVIOUS VERSION OF GP3 WORK
    WITH NEW VERSION OF GP3 NOT WORK


    CVS image is updated more


    Quote

    Originally posted by ahd299
    farshad6730 - why don't you use iCVS image (which is patched for CrossEPG)........as far as I know Gemini plugin has nothing to do with CrossEPG not working with image :)

    USB key mounted as media/usb, linux partition


    In the CrossEPG settings, use USB as download location.
    Select SKY_UK OpenTV or any of the Rytec XMLTV providers.


    CrossEPG will download and parse correctly all titles and descriptions.
    Media/usb CrossEPG gets populated correctly with various db files and extepg.dat.
    The EPG converts correctly.


    but not show EPGs.


    in previous version of gp3(0.29) i must edit fstab for work.
    without Edit this file (fstab) will not work.
    in new version of gp3(0.30) Does not work at all.


    You in this new version, what did??????????????
    * Manager for formatting, setting up or mount devices (BP-> Device Manager)
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    where in manager for formatting????????!!!!!!!


    Previous version was better



    image:CVS+GP3


    Please TEST yourself with this image(CVS+GP3)


    http://dreamboxupdate.com/


    please fix it
    thanks

    please use (device manager beta v1.31 in new dream elite beta v2.0 image) for GP3 for mount devices To solve this problem