Posts by ratzelfatz

    hallo + danke .. aber im moment bin ich ein wenig genervt:
    habe stunden-tagelang dvd-isos's übers netzwerk auf die 8k kopiert und dann covers per emc runtergeladen.


    nun hat er mir 30% aller iso's mit cover.iso's überschrieben .. wenn ich sie umbenenne sehe ich das es jpg's sind.


    super mega sch.. .. jetzt kann ich fast von vorne kopieren.
    das diesbezüglich blöde ist, dass ich alles nach ordnern sortiert habe (also nicht einfach in einem rutsch kopieren kann .. warten, dann nächtes bitte :-(


    hab dann noch die datei-berechtigungen auf 400 gesetzt -> kein effekt


    gibts da eine lösung?


    sorry, danke + gruess

    habs doch noch hin bekommen .. uffa..


    nachdem ich die letzten monate ein wenig update-scheu war, weil mir die box nach gewissen updates nicht mehr gestartet ist, hab ich die update-vorgänge nicht automatisch vollzogen, sondern nach + nach wie es mir logisch erschien + immer wieder mal ein backup gemacht


    nach stundenlangem upgedate, hat er nun auch das geminibluetooth installiert (findet es scheinbar nicht direkt, sondern nur durch abhängigkeiten) .. also, der eimer fliegt jetzt ;-)

    ob über das bluepanel, oder per telnet .. es ist keine installation möglich ..


    root@dm8000:~# opkg install geminibluetooth
    Unknown package 'geminibluetooth'.


    weiss da jemand was?


    habe geminibluetooth_0.17-r2 nirgends gefunden


    hab dann geminibluetooth_0.16-r1_mips32el.ipk gefunden + versucht zu installieren:
    meldet fehler:
    /var/lib/opkg/info/geminidirsync.postinst: line1: ginstall.py: not found
    /var/lib/opkg/info/geminiscreenshot.postinst: line1: ginstall.py: not found
    /var/lib/opkg/info/geminirezapp.postinst: line1: ginstall.py: not found
    /var/lib/opkg/info/geminisambaconfig.postinst: line1: ginstall.py: not found
    /var/lib/opkg/info/geminidreamnetcast.postinst: line1: ginstall.py: not found
    /var/lib/opkg/info/geminiwebcam.postinst: line1: ginstall.py: not found
    /var/lib/opkg/info/geminijukebox.postinst: line1: ginstall.py: not found
    /var/lib/opkg/info/geminiweather.postinst: line1: ginstall.py: not found
    + jeweils: script returned status 127
    configuring blabla
    errors:
    cannot satisfy the following depencies for geminibluetooth:
    kernel-module-nnep, bluez (>=.99), kernel-module-hidp, kernel-module-rfcom, libopenobex (>=1.5), libasound-module-bluez
    cannot install packeage geminibluetooth


    zum ginstall.py-fehler habe ich das gefunden:
    [gelöst] OE2.0 ginstall.py error
    die depencies-fehler krieg ich so aber nicht weg

    natürlich kein quick-format .. das hat mir schnell eingeleuchtet .. wobei unterdessen hab ich überhaupt keine probleme mehr mit den sticks .. mit keinem einzigen und das obwohl ich sie nicht einemal mehr mit dem hp-tool vorformatiere (zumindest solange keine probs auftauchen) .. aber bis zu besagtem abend: nur mit voller formatierung des hp-tools .. ich schwöhrs!


    Quote

    allerdings würde ich das nicht als Backup betrachten


    wieso nicht? wenn alles nicht mehr geht (flash in der box, sticks verloren oder defekt), dann ist das ein super-backup!
    man muss da natürlich beachten, dass die gesamte grösse der sticks gesichert wird, d.h. es lohnt sich bei grösseren sticks sie vorher mit parted-magic zu verkleinern, sonst bringt man sie beim zurückspielen nicht auf kleinere sticks (ausserdem verbraucht man unnötig speicher).


    dass die lfi's auch backups sind ist schon klar .. nur was nutzt mir das, wenn das flash defekt ist, oder kein lowfat-stick mehr vorhanden ist .. naja, dann muss ich neu flashen und oder erst einen lowfat-stick erzeugen .. aber eben viel eleganter: ich zück mein backup und spiel das image zurück .. und bin schon fast raus aus der mühle der abhängigkeiten .. zumindest noch ein wenig freier :hurra: .. ist aber ev. auch ein wenig übertriebene vorsicht .. doch gerade für die dumbo's eine steigerung


    dumbo hab ich als image sichern können .. und zwar mit clonezilla unter linux.
    zuerst dachte ich es funzt nicht, da die gesamt-grösse etwa 80mb war (statt ca. 525mb mit swap) .. dann hab ich es auf einen leeren stick zurückgespielt, in geparted sah es dann auch gut partitioniert aus, also die box damit gestartet .. es läuft .. unglaublich :hurra:
    da muss clonezilla nen ziemlichen kompressor drin haben ..

    hallo mine gute .. schade, dass du meinen post nicht genau gelesen hast:


    Quote

    und zichmal hp-formatiert .

    .. bzw. scheinbar nicht verstanden hast, dass damit das hp-format-tool gemeint ist .. :366:deshalb taufen wir jetzt windos in blindoof um, dann wirds noch einfacher :367:


    unter blindoof gibts ein tool, dass images von usb-sticks erstellen kann .. einfach genial, so kann ich fertige lowfats end-sichern und jederzeit wieder einsetzen!


    weiss jemand ob es was zuverlässiges für usb-sticks mit linux-partitionen, bzw. gemischt-partitionierung gibt?
    weil, ich würde das gerne auch mit den dumbo's machen! :guckstdu:

    ich versteh dann nicht wieso den ganzen abend lang über stunden hinweg immer nur boot-loops mit spendenlogo anzutreffen waren .. 8o
    hab diverse sticks probiert und zichmal hp-formatiert ..
    der einzige unterschied war das schon gepostete UND, dass ich die sticks dann nicht mehr unter vista64, sondern mit dem laptop unter win7-32 mit dem hp-tool formatiert habe .. aber dass kanns ja eigentlich auch nicht sein oder??
    (den strom hat ich zwischendurch auch raus .. man weiss ja nie .. doch ohne effekt)
    ausserdem habe ich dann den vorderen usb-port der 8k verwendet (aus purer verzweiflung) .. als es dann dort das erste mal ging, konnte ich auch die hinteren ports verwenden + sogar einen stick nehmen, der vorher nicht ging .. aber mit einem neuen nfi plötzlich doch geht .. ab jetzt geht alles .. und das ohne update und mit allen sticks :hurra: :unglaublich: :woot: :X: :406:

    habe gestern stundenlang das gleiche problem gehabt und alles mögliche probiert (+ viele seiten threads gelesen) .. wollte mich hier nicht als recherchier-faulen dummy outen :feier: , war aber nahe dran auf zu geben


    kann es sein, dass Lowfat auch dosfstools braucht??


    hab aber hierzu keinen einzigen hinweis gelesen .. nur dumbo hat mich drauf gebracht ..


    also vielmehr kann es nicht sein .. der einzige unterschied war dann noch:
    - ssl84 manuell installiert, wobei er dort meldete, dass es schon up2date ist


    zumindest lief danach alles problemlos .. konnte sogar plötzlich von all den sticks booten, welche ich schon aufgegeben hatte .. habs dann aber nur mit den neu erstellten lfi's getestet


    zumindest scheint es so, dass die formatierung nicht ganz so heikel ist, wie angenommen

    hallo .. wenn ich help aufrufe + dann zu unterst picture-player, dann crashts:
    (ausschnitt logfile)


    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/Components/HelpMenuList.py", line 85, in selectionChanged
    x()
    File "/usr/lib/enigma2/python/Screens/HelpMenu.py", line 41, in SelectionChanged
    self.selectKey(selection[0])
    TypeError: 'NoneType' object is unsubscriptable
    (PyObject_CallObject(<bound method HelpMenuList.selectionChanged of <Components.HelpMenuList.HelpMenuList object at 0x231f730>>,()) failed)
    ]]>
    </enigma2crashlog>


    wollte eigentlich schauen wie ich den screensaver manuell aktivieren kann, aber der fs-pictureplayer wäre natürlich auch nicht schlecht

    auf meiner 8k läufts prima .. hab aber gestern gesehen, dass es auf anderen boxen auch schwieriger sein kann.
    auf einer 800er bringt er beim umschalten der sender skurile fehler, dass scrollen nicht unterstützt würde (dabei passiert doch das gleiche wie auf der fb?) .. kanns leider nicht richten .. hab keine 800er länger zur hand .. notfalls muss man einzelschritte UP, DOWN eingeben ..


    auch war es schwierig den popupblocker zu überlisten (aussert ganz abstellen) .. habs aber damit geschafft:


    als ausführenden link z.b.:
    C:\Portapps\ChromePortable\ChromePortable.exe "\\boxip\Harddisk\Tools\miniwebif\start.html"


    (.. oder den pfad auch direkt ins flash, dann kann die hd ruhen)


    und dann in der exception-list des popupblocker einfach die boxip eingeben

    habe ein kleines html-javascript-tool für browser gebastelt, welches fernbedienungsfunktionen nicht nur direkt aufrufen kann, sondern auch hintereinander abarbeitet


    z.b. brauchbar um in webradio-plugins direkt + gezielt sender umzuschalten ohne zichmal auf die remotecontroll zu tippen, dann warten zu müssen was der scrennshot sagt um dann sender zu wählen ..


    es lässt sich aber einfach jede funktion, die mit der normalen fb aufrufbar ist scripten.


    momentan eingesetzte features:
    - sofort-aufnahme mit shoutcastplugin
    - ausschalt-timer der box ausführen (30 minuten)
    - GUI-restart
    - screenshot (600px breite als png)
    - sofort-auschalten (mit 1x exit, dann off)
    - digital-radio-stationen umschalten
    - direktlink zum webif
    - 3 favoriten-listen ansteuerbar inkl. direktaufruf beliebiger stationen (modifiziertes shoutcast, aber auch webradioFS denkbar)


    im angehängten screenshot ist links das [miniwebif]-panel


    anpassungen, damit es bei euch laufen würde:


    tastenfunktionen.js -> hier 1x eure dreamip eintragen
    panel.html ab zeile 47 -> hier die reihenfolge der tastenaufrufe ändern (bei mir wird beim aufruf des shoutcast-plugins zuerst "exit", "gruen", dann "5" aufgerufen, da ich auf der taste gruen streaming+player-plugins habe und auf der nr.5 dann den shoutcast)
    - dito für panel_fav2.html + panel_fav3.html
    - ausnahme in popupblocker des browsers


    ich hab immer wieder "sicherheits-funktionen" drin, die verhindern sollen, dass die box durch unkontrolliert wiederholte tastenaufrufe blockiert + aus dem tritt gerät (sie verzögern aber leider auch die zeit bis der sender aufgerufen wird):
    - einerseits ein time-out zwischen den aufrufen von 1.25 sekunden
    - wenn der cursor-balken in einer favoritenliste ist, dann muss immer zuerst nach oben gescrollt werden, damit er von zuoberst neu abzählen kann .. das bedeutet: warten (also z.b. 6 favo-seiten nach oben = 6x 1.25 sek. + dann wieder runter zum gewählten sender)!
    - teils hab ich als ersten befehl 'exit' oder 'umschalten auf andere senderliste', um wiederum fehler abzufangen - doch da kann jeder einfach selbst tastenfolgen dazwischen schieben
    - wer aber im dropdownmenu shoutcast schon gestartet hat und dann dieses obere dropdownmenu nochmals aufruft BRINGT die box ev. aus dem tritt .. das beste ist dann: pc und box neu starten, weil dann ev. jeder aufruf spinnt


    der aufruf des rahmen+toolbarlosen [miniwebif] erfolgt über die start.html (mit fensterfunktionen.js), was dann das eigentliche [miniwebif]-popup generiert .. dazu muss man natürlich eine exception im popup-blocker des jeweiligen browsers hinterlegen .. z.b. so:
    file:///dreamip/miniwebif/


    optimiert ist das [miniwebif] auf chrom-portable und auch k-meleon (beides schnelle + schlanke browser)


    ich ruf diese direkt in windoof auf, indem ich in den eigenschaften vom link unter ziel zusätzlich den pfad des browsers eintrage:
    C:\Portapps\ChromePortable\ChromePortable.exe "V:\freigabename\miniwebif\start.html"


    optimierung und ziel:
    statt das in favoritenlisten umständlich wieder an den anfang gesprungen werden muss, wäre es viel einfacher, schneller, stabiler pro aufruf den momenaten "aufenthaltsort" des cursor-balken in jeweiliger favo-liste mitzugeben und damit nicht absolut, sondern relativ den nächsten sender anwählen zu können.


    dieses [miniwebif] lässt sich einfach mit html oder js umprogrammieren und auf die eigenen bedürfnisse masschneidern

    hallo schattenreiter .. danke für die bemühungen .. superb!


    beim rumzirkeln bin ich in der stream-auswahl .. nervt jetzt nicht mehr so, aber der saver beginnt obwohl ich immer noch am radio-sender suchen bin .. also aktiv mit cursor hoch, oder runter fahre .. ist nicht wirklich tragisch


    die zeit übernimmt er jetzt so wie du es sagst, also nach restart des plugins .. kurz nach der neu-installation war das aber nicht so, dort schrieb er auch nicht in die config .. ich nehme an ein einziger gui-restart hat das "problem" aber behoben.


    ich meinte nicht die streamripper-lizenz, sondern die shoutcast-jenige .. welche dieses plugin eben nicht braucht .. ok streamripper-lizenz weiss ich nicht .. aber klar, dass das arbeit bedeutet .. wunderte mich nur, dass da nicht wenigstens eine stellungsnahme besteht ;-)


    danke für den picture-player - freu mich drauf + schau ihn mir bald an


    jetzt mal nur noch wegen der optischen darstellung:
    ich schrieb ja:


    "wenn man in der favoritenliste auf und abwandert, ist der gerade gewählte titel farblich zu wenig klar unterlegt, sodass die auswahl bei mir fast nicht zu erkennen ist. ich weiss wirklich fast nicht, wo ich bin mit der auswahl .. nur ganz knapp kann ich den unterschied zwischen auswahl und hintergrund erkennen .. eigentlich eher fast gar nicht


    wie heisst in der webradioFS.xml der "widget name" für die entsprechende farbgebung?"


    oder ist das anderswo hinterlegt?


    besten dank!

    noch eine frage:


    wenn man in der favoritenliste auf und abwandert, ist der gerade gewählte titel farblich zu wenig klar unterlegt, sodass die auswahl bei mir fast nicht zu erkennen ist.


    wie heisst in der webradioFS.xml der "widget name" für die entsprechende farbgebung?


    und jetzt seh ich noch, dass die codes teils länger als 6-stellig sind - also keine html-farb-codes - was bedeutet:
    backgroundColor="#20343c4f"

    hallo schattenreiter - habs deinstalliert, alle einträge die ich noch gefunden habe gelöscht + dann wieder installiert, reboot, halbe besserung:
    - screensaver nervt und hält sich nicht an die eingegebene zeit (immer ca. 15 sekunden obwohl auf 3 oder 20 gewechselt [diese angaben werden erst nach gui-restart übernommen] - und reinswitchen, wenn ich noch am rumzirkeln bin)
    - abschalt-timer funzt jetzt aber richtig!


    in den setting sind diese einträge jetzt drin:
    config.plugins.webradioFS.wbrScreenSaver=22
    config.plugins.webradioFS.wbrmeld=Bugfix: GS bei aktualisieren der genres wenn in Liste Untergenres
    config.plugins.webradioFS.offtimer_time=33


    was mir noch einfällt: ich hatte pictureplayerFS installiert - einfach mal probiert ob er ev. doch geht .. weil der originale player ein wenig lahm ist .. und es keine alternativen gibt .. den fs-pic-player hab ich aber wieder raus geschmissen, weil er wie befürchtet nicht geht .. hast du ja andeutungsweise deklariert


    frage (falls sie noch nicht gestellt wurde):
    wieso machst du keine streamripper-integration??
    mit freien favoriten-listen ist fs ja unabhängig von shoutcast + braucht somit keine lizenz, bzw. shoutcast kann somit keine bedingungen stelllen .. das sind doch beste vorrausetzungen!

    hier noch ein feedback zu dem was dann noch lief:


    ich hab die box irgendwann auf den estrich gestellt, da eine 8k ran musste.
    dort lag sie ca. 1 jahr und dann kam ich auf die idee sie doch wieder in betrieb zu nehmen.
    also neuestes 1.6er drauf gespitzt und siehe da:
    das menu-problem war fast verschwunden .. es rieselte nur ein klitzeklein wenig hi und da, wenn die box einigermassen warm gelaufen war (nicht störend - nur erinnernd).
    nun steht sie bei einem kollegen mit analog-tv und dort sieht man überhaupt kein geniesel + ich hoffe, dass wenn dann ein flat dran kommt, dass nieseln ganz weg ist .. so im sinne: die zeit heilt alle wunden .. also auf dem guten weg einer art wunderheilung ist ..
    ich bin mir immer noch fast sicher, dass es ein elektronisches problem war (angeschlagene kondenser durch zuviel hitze: da die box ein paar monate 90 grad verdreht aufgestellt war haben die 4 oder 6 grossen kondenser zuviel hitze abbekommen .. waren auch recht schwammig in ihrer lötfassung)
    somit ist hier dicht - thanx 4 all


    p.s. war sicher kein multibootproblem