Posts by Mike012

    Die Farbe kannst du wie folgt einstellen:


    In der Datei "ledmode" unter /etc/grautec/settings kann man die Farbe der LED wechseln, hierzu muss die Datei "ledmode" editiert und der entsprechende Wert laut nachfolgender Liste eingetragen werden.


    0=aus
    1=rot
    2=grün
    3=gelb/grün
    4=blau
    5=pink
    6=türkis
    7=weiß


    Bei der DM70X0HD kann man die Farbe der Led nur bei den Displays V2 und V3 ändern.


    Nachzulesen auf der ersten Seite unter Erläuterungen Punkt 2.


    Edit: Ich sehe gerade du hast keine DM70X0HD Box sondern eine 900er.
    Wie es da aussieht weiß ich leider nicht.


    Gruß
    Mike

    Hallo Jürgen,


    ich habe es jetzt noch mal mit valign="center" getestet.
    Da sieht es bei allen Schriftarten sehr gut aus. Damit meine ich, das die Uhr auf einer höhe mit dem Picon ist.
    Wenn ich mich direkt vor dem Display setze ist da vielleicht ein ganz kleiner Absatz.


    Mein Favorit wäre ja die Schriftgröße 75 beibehalten, und valign="center" .


    Ansonsten würde ich wieder auf 70 zurück gehen und valign="bottom", damit man auch alle drei Schriftarten nutzen kann.


    Die Wetter Grafik und Temperatur passt perfekt.


    Im Anhang ist es mit der Schriftart LoSoS.


    Jetzt darfst du entscheiden.


    Gruß Mike



    Edit: Im Idle Modus blinkt die Powertaste bei einer Aufnahme leider nicht (Skin_Sunny).

    Files

    • screenshot.png

      (63.27 kB, downloaded 503 times, last: )

    Ja, die habe ich jetzt gerade getestet.
    Nur bei den beiden Screens ist das Verhalten vorhanden.


    Die Uhr habe ich auch getestet.
    Es passt leider nur bei der Schriftart "LoSoS".
    Bei den anderen beiden Schriftarten sitzt die Uhr auch höher als das Picon, und damit auch in der Linie2 drin.
    Kann das sein?


    Edit: Ich habe das Verhalten der Powertaste noch einmal mit dem skin_user/03_Kompakt gegengetestet. Da ist das selbe Verhalten wie bei "sunny" zu sehen.
    Es liegt sicherlich an der Grafik im Hintergrund und stört auch nicht.
    Ich nutze diese Grafiken nicht, es ist mir nur beim Testen aufgefallen.

    Hallo Jürgen,


    ich habe deine neuste Version getestet.
    Meine 3 "grünen" sind weg.


    Die Powertaste blinkt nun auch bei einer Aufnahme..


    Was ich festgestellt habe, in den Screens "InfoBarMoviePlayerSummary_Background und MovieSelection_summary_Background" blinkt die Powertaste abwechselnd Rot/Weiß.


    Bei den anderen Screens ist es "normal" an/aus.


    Das du die Uhr und das Wetter änderst, freut mich natürlich.
    Wenn ich mir das so anschaue, ist es natürlich klar das du valign="bottom" so gesetzt hat.


    Vielen Dank für deine Mühe.


    Gruß
    Mike



    Hallo Jürgen,


    ich hoffe es geht dir wieder besser.
    Kannst du schon was zu "meinen" 3 GS sagen?


    Gruß Mike



    Damit bei einer Aufnahme wieder die Power-Taste leuchtet (Skin Sunny), könntest du wieder <layout name="session.RecordState2"> einbauen?


    Den <layout name="session.RecordState"> habe ich so angepasst, das es über dem Wetter liegt.


    <layout name="session.RecordState">
    <widget backgroundColor="oledbackground3" font="LCD1;50" foregroundColor="#FF0000" halign="center" position="7,10" render="FixedLabel" size="175,65" source="session.RecordState" text="REC" valign="center" zPosition="1">
    <convert type="ConfigEntryTest">config.usage.blinking_display_clock_during_recording,True,CheckSourceBoolean</convert>
    <convert type="ConditionalShowHide">Blink</convert>
    </widget>
    </layout>


    Ich hoffe es stört dich nicht, das ich hier so viel ändere bzw. vorschlage.


    Gruß Mike

    Hallo Jürgen,


    ich habe Merlin pur und eine DM7080.
    Du kannst ja mal gegen prüfen, ob du die Fehler bzw. die „grünen“ auch bekommst.


    Ich habe den Skin „Sunny“ ausgewählt.


    Beim Umschalten mit den Zahlentasten der Fernbedienung gibt es einen grünen.
    Fehler im <!--ExtendedNumberZapSummary--> statt pixmap="skin_oled/progress-lcd-03.png"
    sollte da bestimmt pixmap="skin_oled/progress-lcd.png" stehen. Da meine ich die „skin_user_display.xml“.


    In den Screens „InfoBarMoviePlayerSummary_Standard_03.xml“ bekomme ich auch einen grünen. Betrifft im Grunde alle „_Standard_03.xml“ Screens.
    Da habe ich das Problem mit dem „<convert type="Oled_DatumToText">Format:%d.%m.%Y</convert>“.
    Wenn ich das in „<convert type="ClockToText">Format:%d.%m.%Y</convert>“ änder passt es.
    In den Screens“MoviePlayer_summary_Standard_03.xml“ und „MovieSelection_summary_Standard_03.xml“ ist noch ein Fehler mit „<layout name="session.RecordState" />.
    Wenn es „ausgeschrieben wird, wie z.B. in den Screen „InfoBarMoviePlayerSummary_Standard_03.xml“ passt es auch.


    Da mir dein Sunny Skin sehr gut gefällt habe ich das Wetter „Icon“ und die Temperatur um 10 pixel tiefer gesetzt. Die Uhr von der Größe 70 auf 75 erhöht und das valign="bottom" in valign="center“ geändert.
    Dadurch wird die Lesbarkeit und der Platz besser ausgenutzt.


    Das habe ich in „skin_user_display.xml“ (Layout) und den „_Standard_07.xml“ Screens geändert.


    Vielleicht magst du das ja übernehmen.


    Gruß Mike

    Das ist auch alles richtig.
    Ich würde halt nur gerne in der "freien" Ecke eine Grafik haben.


    Können wir aber nach deinen Urlaub mal schauen, was machbar wäre.


    Schönen Urlaub weiterhin.


    Edit: Ich glaube das was ich wollte kann gar nicht gehen, da für beides (TV und Aufnahmen schauen) ja die "EventView_summary" zustädig ist.


    Wenn du aus dem Urlaub zurück bist, und mal ein wenig Zeit hast, habe ich ein "paar" Kombinationen die zu einem Crash führen.

    Hallo Jürgen,


    ich habe den den Skin 03_Kompakt im Einsatz.


    Wenn ich jetzt in der Movie Liste bin, oder eine Aufnahme abspiele und dabei die "Info-Taste" drücke sieht es so aus wie im Anhang.


    Da ich die Farbe "Sender auf schwarz" gestellt habe, bleibt es links oben natürlich leer.
    Der Sender würde durch die länge auch fast nie drauf passen bzw. nicht richtig lesbar sein.


    Wäre es möglich in der Movie Liste bzw. beim abspielen einer Aufnahme da ein Hintergrund (z.B. eine Filmrolle) anzuzeigen?


    Beim Normalen TV schauen wird ja das Picon angezeigt. Es geht natürlich nur um die Anzeige wenn ich "Info" drücke.


    Gruß Mike

    Files


    Ich habe meinen Fehler gefunden. Ich habe die Datei nicht in skin_user_display.xml umbenannt.
    Nun ist skin/user 08/My auch vorhanden und auswählbar.

    Nein.


    Über FTP ist er ja auch erreichbar, und auch etwas "drin".
    Ich kann ihn nur nicht auswählen.


    Daher habe ich extra eine Sicherung ohne DisplaySkin eingespielt und alle
    Updates gemacht.
    Anschließend habe die aktuelle Version inklusive Treiber neu installiert.


    Beim ersten Aufrufen des Plugins war die Auswahl auch nicht vorhanden.


    Dann alles eingestellt und auch den Order My "befüllt".


    Neustart, trotzdem ist skin/user 08/My nicht in der Auswahl.


    Befüllt ist der Ordner wie in der Anleitung die du mir per PN geschickt hast.