Posts by emanuel

    Please look in the u boot environment for the problem


    Hit Enter or space or Ctrl+C key to stop autoboot in the putty terminal console.

    Then enter "env print" and show me the output

    it should look like this:


    ...

    hdmitx phy setting done

    hdmitx: set enc for VIC: 16

    enc_vpu_bridge_reset[1216]

    rx version is 1.4 or below div=10

    Normal bootup

    Net: dwmac.ff3f0000

    Hit Enter or space or Ctrl+C key to stop autoboot -- : 0

    dreambox_two#<INTERRUPT>

    dreambox_two#print env

    ## Error: "env" not defined

    dreambox_two#env print

    1080p60hz_deepcolor=444,8bit

    baudrate=115200

    boot_from_flash=if imgread kernel boot ${loadaddr} 0; then bootm ${loadaddr}; fi

    boot_from_sdcard=if fatload mmc 0 ${loadaddr} dmtwo.img; then bootm ${loadaddr}; fi

    bootargs=logo=osd0,loaded,0x7f800000 vout=1080p60hz,enable hdmimode=1080p60hz fb_width=1280 fb_height=720

    bootcmd=run start_mmc_autoscript; run boot_from_sdcard; run boot_from_flash; run recovery_from_flash;

    bootdelay=1

    colorattribute=444,8bit

    cvbs_drv=0

    display_bpp=16

    display_color_bg=0

    display_color_fg=0xffffffff

    display_color_index=16

    display_height=1080

    display_layer=osd0

    display_width=1920

    dtb_mem_addr=0x1000000

    ethact=dwmac.ff3f0000

    ethaddr=00:09:34:4b:54:33

    fb_height=720

    fb_width=1280

    filesize=1c2046

    gatewayip=10.18.9.1

    hdmimode=1080p60hz

    hostname=arm_gxbb

    initrd_high=7f800000

    ipaddr=10.18.9.97

    jtag=disable

    loadaddr=1080000

    logo_bpp=16

    logo_color_format=16

    logo_height=720

    logo_width=1280

    netmask=255.255.255.0

    none_deepcolor=444,8bit

    outputmode=1080p60hz

    panel_type=lcd_5

    reboot_mode=cold_boot

    recovery_from_flash=if imgread kernel recovery ${loadaddr} 0; then bootm ${loadaddr}; fi

    rpmb_state=0

    sdr2hdr=2

    serverip=10.18.9.113

    start_mmc_autoscript=fatload mmc 0 1020000 autoexec.img && autoscr 1020000

    stderr=serial

    stdin=serial

    stdout=serial


    Environment size: 1362/65532 bytes

    dreambox_two#




    also you can boot direct from uboot:

    dreambox_two#fatload mmc 0 1020000 autoexec.img && autoscr 1020000

    A bootlog with e.g. with putty would be helpful. We could see whether it is due to the sdcard or whether it is due to the uboot env.


    connect box via miniusb dev to pc
    e.g. using putty:

    Select the menu item "Connection -> Serial" and set the correct COM port (previously seen in the device manager)

    Set speed to 115200

    Data bits are given the value 8

    Stop bits have the value 1

    Set parity to NONE


    In the menu item "Session-> Logging" on the right, select the value "All session output" and select the file

    Finally press the "Open" button

    The android 9 works just as well on the dreambox two as it does on the dreambox one. There is no difference. It's best to make a boot log, then you can see more. Best of all without an upgrade first. The sd carte must be recognized, that is the most important thing.

    ich hab scandisk >class 10 original img, aber auch viele andere langsame sd.


    Hab da nie Probleme, dass enigma die erkennt.

    Die sdcarte ist nach der Installation ja in mehrere Partitionen und mit verschiedenen Dateisystemen.


    Beim installieren des Android wird deine sdcard ja auch erkannt.


    eventuell musst länger warten nach dem reinstecken, mit fdisk -l kannst ja immer schauen ob die gefunden wurde.


    oder mal ein und ausstecken, aber erst mit fdisk schauen, dass die nicht erkannt wurde vor dem rausziehen.

    klar, dann bist Du im Android.


    Das script sollst Du aber in enigma ausführen.


    SD raus, Box ins enigma booten, sd rein, im telnet mit fdisk schauen ob die sd eingehängt wird. Dann das script starten.

    jetzt hat die Box die sd gefunden, probier es halt nochmal.


    Da fehlt aber was von der Ausgabe:


    die sdcard sollte ja mit:


    /dev/mmcblk1p4 (partition 1 VFAT = boot)

    /dev/mmcblk1p2 (partition 2 EXT4)

    /dev/mmcblk1p3 ...


    Partitionierung & Formatierung angezeigt werden.

    :rolleyes:

    Entweder steckt die sdcarte nicht richtig, oder die ist hin/deformatiert?


    Ich würde die Box mal runterfahren sd raus, hochfahren, reinstecken und noch mal mit fdisk nachsehen ob die nun erkannt wird.


    /dev/mmcblk1 wäre die sdcard

    da findet die box die sdkarte nicht.


    gib vorher mal

    Code
    root@dreambox ~/# fdisk -l


    ein und poste die Ausgabe