Posts by Franky-Boy

    Ich denke, dass es für Dokus doch einfacher ist, ein manuelles Hintergrundbild zu erstellen.


    Für meine zahlreichen Serien wäre es aber vergleichsweise viel Aufwand. Warum liefert denn eigentlich das TMDb Plugin bei der Suche von Serien nur Filme als Ergebnis? Wenn ich bspw. bei der Serie "Westworld" das TMDb Plugin nutze, kommen als Suchergebnis nur Filme. Das Plugin "THeTVB" liefert gar keine Suchergebnisse.

    Quote

    Original von zombi
    Du kannst dir eine der 14 Hauptansichten selbst skinnen und da dann auch ein default Bild angeben ,das ist dann ein statisches Bild was du wie mit zpos. usw. halt anzeigen lässt wenn kein Backdrop da ist.


    In welcher Zeile wird denn definiert, welches Hintergrundbild bei der Hauptansicht verwendet wird? Hier ein Auszug aus dem Skin Nuke.FHD:


    Code
    <screen backgroundColor="transparent" flags="wfNoBorder" name="AdvancedMovieSelection" position="0,0" size="1920,1080" title="AdvancedMovieSelection">
    <ePixmap pixmap="Nuke.FHD/bg/ams.png" position="0,0" size="1920,1080" transparent="0" zPosition="-1" />
    <eLabel backgroundColor="background" font="Regular; 30" foregroundColor="title" position="22,8" size="580,40" text="Select a movie" transparent="1" />
    <widget backgroundColor="background" font="Regular; 26" halign="left" position="40,97" render="Label" size="1100,40" source="Title" transparent="1" valign="center" zPosition="1" />

    Eine Detailfrage an die Skinner: Man kann ja mit dem TMDb Plugin bei Spielfilmen festlegen, dass ein Hintergrundbild bei der Filmbeschreibung angezeigt wird, was sehr chic aussieht. Bei anderen Aufnahmen, welche nicht per TMDb eingepflegt werden (wie Dokus, Nachrichten, Sport), ist der Hintergrund trist und grau, da kein Hintergrundbild vorliegt.


    Wo kann man in der skin.xml festlegen, dass bei der AMS-Navigationsseite ein Standard-Hintergrundbild angezeigt werden kann. Dieses Bild könnte ich dann auf die Dreambox hochladen und es würde immer beim Navigieren durch AMS angezeigt werden.


    Ich hatte ursprünglich einige Skincomponents im MyMetrixPlugin entfernt und zudem vergessen, auf "Skin speichern" zu drücken. War wohl mein Fehler, ich habe es inzwischen richtig konfiguriert und gespeichert.


    Drei Fragen verbleiben dennoch:


    1. Das Datum im Skin wird bei mir in Englisch (Sunday statt Sonntag etc.) angezeigt. Gibt es einen Workaround, um die Sprache auf Deutsch umzustellen?
    2. Der Skin MetrixHD greift offenbar auf den Ordner /usr/share/enigma2/XPicon/picon für die Infobar-Picons zu. In welchem Format (220x132 etc.) erwartet der Skin die Picons in den einzelnen Einstellungen (Small, Medium, etc.), um diese unskaliert darstellen zu können?
    3. In den Einstellungen zum OpenStore steht was von "fehlende Picons herunterladen" und man die Quelle der Picons bestimmen. Was hat es damit auf sich?

    Hat super funktioniert! Der Skin und seine Anpassungsmöglichkeiten sind ja genial. Im OpenStore gibt es viel zu erkunden. :P


    Wie sieht es überhaupt jetzt mit Updates für das Haupt-Plugin selbst (MyMetrixPlugin) aus, welches ich über https://github.com/iMaxxx/OpenStore/releases installiert habe? Werden diese automatisch gezogen, oder muss ich von Zeit zu Zeit hier wegen Updates vorbeischauen und die Files manuell installieren?


    Edit: Leider hatte ich einen GS bei der Konfiguration von MetrixHD Skin (siehe Anlage).

    Quote

    Original von homer_simpson
    du speicherst die zip Datei,und entpackst sie danach. und per ftp kopierst du die mymetrix Datei in den extensions ordner auf deiner box.danach die box neustarten das wars.
    du brauchst nur die Datei vom github nicht von der ersten seite.


    Ich verstehe das so:


    1. Ich kopiere die Dateien aus der "OpenStore-2.1a" ZIP per ftp auf die Box. Dort wird in /usr/lib/enigma2/python/Plugins/Extensions/MyMetrix das MyMetrix Plugin installiert.
    2. Nach dem Neustart von E2 kann ich im MyMetrix Plugin die neueste Version von MetrixHD herunterladen und installieren bzw. konfigurieren als auch auf den OpenStore zugreifen.
    3. Zukünftige Updates für den Skin MetrixHD werden über das Plugin gehandelt.


    Ist das so korrekt?

    Wie installiere ich denn jetzt die aktuellste Version dieses Skins und des Open Store auf einer Dreambox 7020HD (Merlin Image)?


    Wenn ich es richtig verstehe, muss ich zunächst nur die Dateien aus dem Starpost installieren (welche aber schon etwas älter sind), doch mir ist nicht klar, wie ich die Dateien unter folgendem Link


    https://github.com/iMaxxx/OpenStore/releases


    einbinden kann.


    Über ein kurzes "How to" würde ich mich freuen.


    Danke.

    Leider kann ich mit keinem neuen Log mehr dienen: Beim Versuch, den Default Merlin Skin (Default-HD.grey.ME) wieder zu Testzwecken zu installieren, ist mir wohl ein Fehler unterlaufen und dadurch der GAU eingetreten: ich musste Merlin neu installieren (Dauer-Loop beim booten)!


    Nach dem Neuflash funktioniert MST nun auch mit elegance.HD perfekt. Ich tippe mal, dass der Fehler durch den von mir ursprünglich deinstallierten und damit fehlenden Default-Skin (Default-HD.grey.ME) verursacht wurde, kann es aber leider nicht mehr testen.


    Trotzdem danke für Deine Mühe.

    @marthom


    Ich habe soeben nachgeschaut: Im MST Verzeichnis


    /usr/lib/enigma2/python/Plugins/Extensions/MerlinSkinThemes


    __init__.py
    __init__.pyo
    MerlinPreviewScreen.py
    MerlinPreviewScreen.pyo
    MerlinSkinInfo.py
    MerlinSkinInfo.pyo
    MerlinSkinThemes.py
    MerlinSkinThemes.pyo
    plugin.py
    plugin.pyo


    liegt zu jeder *.py Datei eine *.pyo Datei. Den Log werde ich am kommenden Freitag durchführen, kann aber bis dato mit einem älteren Log dienen, welchen ich beim Skin LN.HD-ME vor ein paar Wochen bei dem gleichen Problem gemacht habe.


    Eventuell hilft das bis dahin auch:


    http://board.dreambox-tools.in…719&viewfull=1#post118719


    Im oben verlinkten Merlin Board hattest Du seinerzeit ja auch schon was dazu geschrieben. Ich bin nicht sicher, ob ein erneuter Log mit elegance.HD was anderes zu Tage fördert:


    http://board.dreambox-tools.in…723&viewfull=1#post118723


    Gibt es noch einen anderen Speicherort für eine eventuell vorhandene skin_user.xml außer /etc/enigma2 ? Ich nutze tatsächlich eine skin_user.xml, welche ich aber jeweils aus dem o.a. Verzeichnis lösche und neustarte, bevor ich MST teste.

    Ja, der Skin selbst läuft bei mir problemlos. Zudem habe ich alle Skincomponents auf dem Merlin Feed installiert.


    Ich werde es nächste Woche nochmals testen, doch wohl erst Ende der Woche, da ich verständlicherweise das Wohnzimmer nicht ständig blockieren kann.

    Quote

    Original von marthom
    Was Du noch testen kannst:
    Es sind ja für die InfoBar 3 Varianten in der themes.xml. entferne mal das 2. und 3. so dass nur noch das erste stehen bleibt (also immer das kmpl. <screentheme>).


    Also, soeben getestet. Ich habe die 2 und 3. Variante gelöscht und nur die erste Variante vom Screen-Theme "Infobar" drin gelassen. Der Fehler trat wieder auf. Also muss das Problem in diesem kurzen Code sein: