Posts by shumifan50

    Before you try to access the camera from the Dreambox, you MUST use the string you are setting up in the config file from a browser and it MUST RETRIEVE A SINGLE IMAGE FROM THE CAMERA. If you dont get this to work, then IPCAMVIEWER will not work and will cause your box to hang.
    The strings to retrieve a snapshot (jpg) is different for each camera and you have to find the correct string for your camera. The default config only works for Foscam cameras.

    OK. It seems there must be a memory leak or something similar then. I will look at the problem when I have a chance.
    HOWEVER:
    I need a bit more information:


    1. How many cameras are connected?
    2. Which view are you in or are you switching views?
    3. Makes of cameras.
    4. Which image and which version?
    5. PM me your config file after blanking out the username/passwords.
    6. Are you running the latest version of IPCamViewer (not the one at the start of the thread)?


    Cheers
    shumifan50

    Dreami2:

    Quote

    After 15 minutes at 250 ms there are problems and nothing works

    Keep increasing the time until it works. If it doesn't work at 2000 ms then let me know as it will need looking at.


    Quote

    Can IPCamViewer be set to start in red mode3 every time?

    No. I will look at that in the next release. Just busy right now so I don't have time.

    Quote

    Cam Image size be adjusted in multi-cam mode.


    No. This will require a big change.

    Dreami2 :
    As I said 2 posts ago, try increasing the update interval. Very few, if any, LANs/Cameras will cope with an update interval of 64ms. Increase this to at least 250ms if you are on a local LAN. If you are accessing over the internet increase the interval to at least 2000ms. Keep increasing the interval until you no longer get lockup and then decrease it in small steps until you find the shortest interval that is stable for your setup. This interval will vary by setup as different people run different software and plugins.


    If you reach 2 seconds on a local LAN and it is still not stable, please let me know as then there might be a different problem on the DM8000 that I will have to look at, if I can manage to borrow a DM8000.

    Carinthia:
    I suspect that you are running a DM800. They suffer from the 'gears' whenever anything uses any CPU. I suggest that you increase the update interval to something like 1000 or 2000ms to use less CPU. Also if the camera is not on your local LAN high update speeds will lock up the viewer as the requests will take much longer to service.
    Let us know what box this is running on and how the camera is connected - I can't see it from your posted config.

    Quote

    {command}{foscam.up}{/decoder_control.cgi?{command={0&onestep=1} {command}{foscam.down}{/decoder_control.cgi?{command={2&onestep=1} {command}{foscam.left}{/decoder_control.cgi?{command={6&onestep=1} {command}{foscam.right}{/decoder_control.cgi?{command={4&onestep=1} {command}{foscam.zoomin}{/decoder_control.cgi?{command={6&onestep=1}


    What are those red characters doing in the {command} string - they are not part of foscam requests.


    The supplied ipkg comes with a conf file that fully supports foscam cameras, why are you changing it? Just add your levelone camera EXACTLY as tsPrenge shows, especially

    Quote

    {command}{Levelone.snapshot}{snapshot.cgi?user=admin&pwd=xxxxxx}


    as the levelone might not support http challenge response.
    Please also read the rest of this thread as most config problems have been exensively discussed.

    If your camera supports it, this form of {command} line is more efficient than leaving the username and password on the camera line, as it avoids the challenge by the camera to get the username and password:


    {command}{Levelone.snapshot}{snapshot.cgi?user=admin&pwd=xxxxxx}


    This becomes painful if you have more than one camera with different username/password as you will have to set up different camera types( {command} lines) for each camera, or (best solution) change all cameras to use the same username/password.


    Note that username:password@.... format is NOT supported. This is not a standard http protocol.

    StefanH2 :


    Any IP address can be accessed by the plugin, including domain names. It must be noted that when you access external cameras, it will be wise to increase the update interval as external networks are typically much slower than internal LANs, even if you have broadband - remember the camera sending the image is limited by the upstream speed not the downstream speed of the connection.
    A valid camera line would be:
    {camera}{myserver.mydomain.com:8080}{cam}{description}{user}{password}


    I have not tested this myself, but the interface should resolve DNS names.


    Furthermore:
    If anybody has a camera that supports https I would appreciate if they could test if it works when you change the protocol in the conf file to https (and of course set the camera for https). I suspect that this should work, but I dont have a camera that can do https.

    moofy:
    The following will produce a logfile that should highlight the error.


    Please do the following: (the bits inside the quotes are the commands to enter without the quotes) followed by enter
    1. Telnet to the dreambox and log in as root/<your password>
    2. enter "init 4"
    3. "ps | grep enigma" - check whether this shows any "/usr/bin/enigma2" entries. The | is above the \ next to left shift key (in case you wonder).
    4. If 3 does not show any "/usr/bin/enigma2" entries carry on otherwise go back to 2 or for each entry enter "kill <very left hand number>" and then go to 3.
    5. "enigma2 > /media/hdd/IPCamViewer.log 2>&1"
    - replace /media/hdd/.... with your hard disk if different but DO NOT PUT IT IN /tmp or elsewhere in your flash, it must be hard disk or USB drive as it might get big.
    6. Wait about 2 minutes and go to dreambox. Start IPCamViewer from the remote.
    7. If you get the spinner, wait about 30 seconds, go to the telnet session and enter "init 4"
    8. copy the file from /media/hdd/IPCamViewer.log to your PC and post it here and I will have a look at it(or PM it to me). Remember to remove user/password nut be careful not to insert or remove spaces from the logfile.


    I am really interested in getting to the bottom of this as if it is an IPCamViewer problem, I need to improve error reporting.

    issingo:
    Does "http://192.168.6.105:80/snapshot.jpg?user=admin&password=admin" work when you enter it from a browser. I guess it is wrong as you use
    "http://192.168.6.105:80/snapshot.jpg?account=admin&password=admin" in the text part. Note that it is not "user" but "accoun...."


    The command has to be one that works from your browser EXACTLY. Note that you can still speicify credentials on the {command} rather than the {camera} line, but you must still supply a user/password on the camera line even though they will not be used. Specifying credentials on the {command} line is more efficient than on the {camera} line as it avoid the challenge/response of http; However the format user:password@...... is NOT supported on the command line.

    moonsorrox:
    I cannot understand why it does not work for you as it works fine on all my images/dreamboxes. But here are the relevant entries in /etc/enigma/settings:



    config.ipcam.pipWidth=192
    config.ipcam.pipPosX=1070
    config.ipcam.pipHeight=144
    config.ipcam.pipPosY=570


    Remember to use a Linux style editor that does not insert carriage returns in the end of the line.



    When you press menu, does it show the 4 entries related to PIP and then when you change them and press green and exit IPCamViewer, then press Menu again, did it change the entries back or are they as you adjusted them?

    The settings from the remote are saved in the main Enigma2 settings file at
    /etc/enigma2/settings


    The entries for IPCamViewer is
    config.ipcam.xxxxxxx
    where xxxx is the specific setting


    If you edit this file make a backup before editing as it is shared by all plugins and enigma2.


    The position and size of the PIP can also be editied by pressing "MENU" on the remote and changing the settings by hand. Remember to press green afterwards to save the settings.

    moonsorrox:


    {camera}{10.0.xx.xx}{Eingang}{Resse}{user}{pw}
    results in
    camera10.0.xx.xxEingangResse Invalid cam type in {camera}=Eingang
    this should be:


    {command}{mobotix.snapshot}{/record/current.jpg}
    {command}{mobotix.protocol}{http://}
    {camera}{10.0.xx.xx}{mobotix}{Resse}{user}{pw}


    and remember to remove all spaces from lines.

    moofy :
    I will do that in the next release. I am just trying to gather as many faults as possible before I make another release. At the moment the following is identified:
    1. Better parsing of the conf file with better error reporting.
    2. Recovery/Error reporting when the first camera does not respond. The second and subsequent cameras work fine if they time out - it is only a problem when there is only one camera and it does not respond.
    3. Corrected documentation as noted earlier on this thread.
    4. I will try to include as many cameras as possible in the conf file to make setup easier. To this end it would be nice if you have a working camera to post the conf file here (remember to remove passwords/IP addresses)
    5. I am planning some enhancements when I have a bit of time available.


    Important notice:
    The release has now been moved from OpenPli to here as they have removed the ticketting system and I really cant be bothered to work out how to post the plugin there.