Posts by ritzMo


    Gemini, richtig?


    Zur Verringerung der Abhängigkeiten habe ich die von enigma2-skins entfernt. Damit ging allerdings ein bump der benötigten enigma2 Version hervor.


    Kurz:
    Gemini hat noch kein Screwed Stone II, das der VLCPlayer allerdings benötigt.


    Fix: Pixmaps der Buttons in VlcConfig.py und (ich glaube es war) VlcPlayer.py auf welche ändern, die du auch hast...
    Alternativ kannst du auch button_* aus /usr/share/enigma2/Nemesis.Skinsuite.Shared nach /usr/share/enigma2/skin_default kopieren.


    *EDIT* Rechtschreibung korrigiert, Quote gekürzt.

    Wenn du von einem "selbsterstellten" Image redest, sollte sich das bereits in deinem Feed befinden.
    Und da es hier eingentlich um das aktuelle Image von OoZooN geht, hat das hier auch nichts verloren. Solltest du das ipkg nicht in deinem Feed finden kannst du mir eine PM schreiben und ich werde dir dann einen entsprechenden Link zukommen lassen.

    Quote

    Original von skills
    jo monentan haut da wohl einiges nicht hin, ich bekomme bei selbsterstellten Image immer:


    Du hast scheinbar die Abhängigkeiten vergessen....


    Code
    ipkg install twisted-web
    Quote

    Original von guano30
    [...]
    Denke ja das du das Menu meinst, oder?


    Ja, das ist das Menü.
    Nein, wir sprechen nicht über die gleiche Version.


    Die Änderungen hat lexx vor 3 Tagen ins CVS eingecheckt, sind also in älteren Paketen nicht enthalten.


    Neutrino Steuerung ist afaik nicht vorhanden, aber du kannst vermutlich manuell das Pauli-Plugin installieren (gibts das noch? war doch dafür, oder ? ;)).


    Bzgl cccam:

    Quote

    Original von OoZooN
    i have tested all packs with the image from 6th of october. if you use the full image, you have first deinstall the dccamd emu plugin. if it is installed, it will block the installation of other emupacks.


    Und genau das sagt auch deine Fehlermeldung: dcccamd blockt die Installation von cccam und letzteres lässt sich dadurch nicht installieren.


    Wenn die Version die aktuelle aus dem CVS ist sollte in den Einstellungen die Option "Subtitle Overlay" zu sehen sein. Wenn Subtitles funktionieren, dann nur mit dieser Option aktiv. Da ich hier keine Subtitles vorliegen habe kann ich das allerdings nicht testen, aber ich gehe mal davon aus, dass lexx das getestet hat, bevor er es eingecheckt hat.

    Ich sagte ja, die für dich relevante Änderung entstammt dem OE und nicht dem CVS. In der Regel benutzen Images mit neuerem Datum auch neure Snapshots von OE und CVS. Hier scheint allerdings das OE vergessen worden zu sein. Als End-User ist der Unterschied auch im Prinzip unwichtig, aber es gibt ihn nunmal und daher kann so ein Fehler leider auch schon mal auftreten.
    Genauere Angaben kann ich aufgrund fehlender Tests meinerseits nicht machen. Aber hauptsache die 7025+-User sind gewarnt ;)

    Naja, Videotext ist im OE gefixt worden. Da wurde wohl das aktualisieren vergessen. Auch der CVS-Snapshot war bei Veröffentlichung nicht "state-of-the-art", ich hoffe allerdings mal, dass der enigma2-plugins Snapshot zum selben Zeitpunkt wie der von enigma2 gemacht wurde (oder früher). Sonst besteht die Gefahr, dass SimpleRSS nicht funktioniert (da ich relativ fix mit den Änderungen in E2 mitgezogen bin - wurde ja eh von mir verzapft :P).
    Getestet habe ich das allerdings nicht, da ich das nach Einsicht der Patches nicht unbedingt für nötig gehalten habe, wenn es eh nur zum testen gewesen wär (dafür wird meine Box zu viel benutzt). Weiterhin relativ solide, auch wenn ich hier und da in Änderungen eine Verschlimmbesserung sehe - also aus Sicht eines Programmierers gesehen ;)


    Also weiter so, aber das nächste mal das Image nicht an einem Tag rausbringen, an dem so viel an E2 gebastelt wird. Das macht das arbeiten für andere nicht unbedingt leichter :)


    *EDIT* Die Änderungen könnten natürlich auch absichtlich nicht mit ins Image aufgenommen worden sein, dann wurde das aber falsch beworben :D


    Wie OoZooN einige Posts vorher geschrieben hat, hat er einen rollback gemacht - wirst das Paket also jetzt auf seinem Feed nicht mehr finden (ja, schlechtes Timing - Gibt da so ein Sprichwort mit vielen Köchen und Brei ;) aber der Küchenchef ist hier OoZooN und so bleibt uns vorerst nichts anders über als mit der alten Version vorlieb zu nehmen).


    Und ein MediaPlayer ipkg wäre nicht sonderlich spannend... Ist ja nur die alte MediaPlayer.py mit ein paar zusätzlichen Zeilen ;) - Wenns unbedingt sein muss kann ich aber das ipkg aus meinem Feed fischen und hier uppen, ich würde dir aber dazu raten zu warten, bis OoZooN sein OE wieder im Griff hat.


    Hab grad nochmal fix geschaut:

    Code
    <item text="Media player" entryID="media_player"><screen module="MediaPlayer" screen="MediaPlayer" /></item>


    Ist die Zeile die du löschen musst.


    Das Plugin sollte einfach wie andere Plugins installiert werden können (Im Plugin Browser grün drücken und dann unter extensions den MediaPlayer anklicken).


    Quote

    Original von OoZooN
    das ist ein fehler im webif. es gab da gestern ein update aber der hat meinen patch von vorgestern scheinbar überschrieben bzw ich habe ihn nicht reinkopiert.


    ich bastel grad an ner übgangslösung


    Da komm ich grad nicht mit. Beim WebIf ist jetzt kein Fix mehr nötig um es wieder ans Laufen zu kriegen da mein Patch eingecheckt wurde. Die Menu.py hat soweit ich mich erinnere nix mit dem WebIf zu tun (ausser man nutzt die RC :))


    *EDIT*


    Er nutzt denselben MediaPlayer wie jeder andere. Bzgl. Installation siehe oben.

    Quote

    Original von gutemine
    aus dem Media Player wird gerade ein Plugin im CVS, der ist daher auf Wanderschaft und da sind noch nicht alle Pfade richtig angepasst - python editieren oder auf Update warten würde ich sagen :-)


    Das ist er schon geworden und bei mir so eine ganze Zeit stabil im Einsatz.


    Das Crashlog lässt auf eine fehlerhafte menu.xml schließen, woher der Fehler allerdings kommt kann ich dann auch nur mutmaßen.... Würde dann auf ein fehlerhaftes Update tippen. Aus irgendeinem Grund wurde die alte MediaPlayer.py zwar entfernt aber die neue menu.xml nicht hinzugefügt. Workaround: Von Hand in die xml-Datei und die Zeile für den MediaPlayer löschen. Dann das Plugin installieren, damit er wieder im Hauptmenü zu finden ist.

    Quote

    Original von OoZooN
    [...]aktuell gibt es nämlich noch das problem das mit dem oe erstellte plugins ihre dependencies verlieren.


    Stimmt so nicht mehr. Sie verlieren zwar die Dependencies aus der Control, diese werden aber über feste Definitionen in der .bb gesetzt.

    Quote

    Original von OoZooN


    maybe the sources have changed? ask the author of this patch.


    Yes, they have - but the author (aladin25) is still on vacation. I rewrote (yes, rewrote - not synced) this patch for newer snapshots but as I did not see the need I did not publish it (unless for one site and of course my svn).


    If there is a need I can see if I have the time to put something together, but this is better taken somewhere else (pm or thread of plugin).

    Quote

    Original von OoZooN
    desweiteren gab es heute reichlich änderungen im cvs und damit einhergehend, müssen die externen plugins angepasst werden.
    das webif funktioniert zb mit der enigma von heute nicht. wenn ich das update online machen soll, müsst ihr es bitte hier sagen, dann aber mit den einschränkungen leben bis die plugins voll angepasst sind.


    Das einzige Plugin, das noch angepasst werden muss, ist das WebIf. Der Patch dazu liegt in meinem SVN und kann gerne von dir verwendet werden. Ich will mich aber nicht in den Code der Entwickler einmischen und checke es deshalb nicht ein.

    Dann ist das hier im falschen Bereich gepostet. Gucke, ob es bereits bei den Verbesserungsvorschlägen zu Gemini Images geposted ist und wenn nicht kannst du es dort anhängen.


    Nein.... DIESES Plugin gibt es nur für Enigma2 Boxen.
    Es gibt ein anderes Plugin namens VLCF für Enigma1 Boxen, das denselben Zweck erfüllt.

    Quote

    Original von joey833
    auch meine Frage hierzu: Läuft das Vlc Plugin auf der DM500. Auch auf die Gefahr eines Doppelpostings interessiert mich das, da in der Downloadbase und auch über Download über die Box in den Beitexten"für alle Boxen" steht.


    [...]


    Es wäre außerdem wirklich nett, wenn ein Profi mir den Unterschied zwischen Enigma1 und Enigma2 Boxen erklären würde. Bin erst seit knapp einem halben Jahr Besitzer einer Dream, hab zwar schon einiges gelesen, aber diese "Bezeichnungen" der Dream hab ich noch nicht mitbekommen oder "überlesen".


    Wenn du den Unterschied nicht kennst wirst du ihn (richtig erklärt) vermutlich nicht verstehen, also reiße ich das mal an:
    Enigma(1) ist das ursprüngliche "Betriebssystem" der Dreambox. Es ist allerdings ein wenig in die Jahre gekommen und hat für die aktuell "größte" Box, die DM7025, eine schwerwiegende Beschränkung: Es wird nur ein Tuner unterstützt.
    Deshalb wurde für diese und für folgende Mehrtunerboxen ein neues "Betriebssystem" geschrieben, das logischerweise als eine Art Weiterentwicklung Enigma2 heißt. Allerdings ist Enigma2 keine Weiterentwicklung sondern eine komplette Neuentwicklung bei der sogar (in Teilen) die Programmiersprache gewechselt wurde (der Kern ist weiterhin in C++, der Rest allerdings in Python geschrieben).
    Enigma2 wird von Dream aus bis jetzt nur auf der DM7025 verwendet, einige Bastler benutzen es allerdings auch auf der DM7020 und der DM600.


    Würde Enigma2 jetzt auch auf der DM500 laufen, würde das Plugin vielleicht (das Plugin sicher, bei der Streaming-Funktion möchte ich keine Aussage machen) auf der DM500 laufen. Da ich es aber für eine schlechte Idee halte auf dieser "kleinen" Box Enigma2 zu verwenden - und auch davon ausgehe, dass dies nicht geht - ist die Antwort auf deine Frage ein klares: Nein.


    Das "für alle Boxen" impliziert bei einem Enigma2-Plugin "auf denen Enigma2 läuft" ;)



    Der Verweis auf das VLCF-Plugin war aber korrekt. Das ist nämlich quasi dasselbe nur eben für Enigma1.


    Quote

    Original von elfenliebe
    Weiss jemand wie man das vlc plugin im lt image zum laufen bringt?


    Habe die beiden tar.gz installiert, neustart.


    Wenn ich das vlc plugin nun aufrufen möchte komt ein bluescreen :(


    Die Aussage "es tritt ein Fehler auf" ist keine adäquate Fehlerbeschreibung. Wenn du einen BSOD bekommst hänge doch bitte das Crashlog an, zu finden als /media/hdd/enigma2_crash*.log


    Und soweit ich weiß hat das LT-Image doch das Stream2Dream-Plugin. Das erfüllt denselben Zweck, wenn ich mich recht entsinne - ist aber eine Weile her, lies dir also am besten das Release Announcement durch, da stand das drin.


    *EDIT* Inhaltlich etwas erweitert.