Fritzbox Anrufmonitor ohne Modifikation der Fritzbox

  • Hi,
    nochmal die Frage:
    Hast Du die unveränderte Version aus dem 1. Posting genommen? Die fritzbox_msg_new_v082_3


    Dann einfach nach /tmp kopieren, ,cd /tmp, chmod 755 fritzbox_msg_new.sh eingeben und dann fritzbox_msg_new.sh start eingeben. Wenn das so geklappt hast kannst Du das Script fest installieren.


    ciao

    ---
    7020, Combo, Solo2, Ultimo

  • Quote

    Original von xlord
    Was sagt eigentlich "type /etc/init.d/fritzbox_msg_new.sh" ?
    Sollte liefern:
    /etc/init.d/fritzbox_msg_new.sh is /etc/init.d/fritzbox_msg_new.sh


    Hallo an alle !
    Es kommt genau das was du geschrieben hast.


    mrwilli


    Ich starte es vom Stick. Habe es aber auch schon im Flash probiert. Gleicher Fehler.


    @Trail


    Habe die Datei aus dem 1. Posting genommen. Habe es gerade nach dem wie du es beschrieben hast probiert. Leider wieder der gleiche Fehler " :
    -sh: fritzbox_msg_new.sh: not found


    mfg

    Image :
    Im Flash : Gemini 4.5
    Auf USB : Gemini 4.5


    Nokia dbox2 -> Keywelt


    FritzBox 7113

  • Gib das mal ein. Obwohl es eigenlich egal sein sollte, wo es steht. Hast du unter var/script noch andere Scripte, kannst du die denn aufrufen.


    root@dreambox:~> cp /etc/init.d/fritzbox_msg_new.sh /var/script


    root@dreambox:~> /var/script/fritzbox_msg_new.sh start

  • Quote

    Original von mrwilli
    Gib das mal ein. Obwohl es eigenlich egal sein sollte, wo es steht. Hast du unter var/script noch andere Scripte, kannst du die denn aufrufen.


    root@dreambox:~> cp /etc/init.d/fritzbox_msg_new.sh /var/script


    root@dreambox:~> /var/script/fritzbox_msg_new.sh start


    Hallo


    Habe es eingegeben wie oben beschrieben.
    Nach cp etc/... kam nichts. Ist soweit ja ok.
    Bei der nächsten Eingabe (var/...) kam wieder "not found"


    Habe mit FileZilla geguckt. Datei ist aber vorhaden (Rechte 755) siehe auch Anhang


    mfg


    edit: Lesefehler !
    Habe gerade printer_script.sh gestartet. Kam nichts. Keine Fehlermeldung oder sonstiges. Also müßte es jetzt laufen. Warum läft nur das Fritzbox script nicht ?!?!?

    Files

    Image :
    Im Flash : Gemini 4.5
    Auf USB : Gemini 4.5


    Nokia dbox2 -> Keywelt


    FritzBox 7113

    Edited 2 times, last by deabolo ().

  • Hallo
    Habe folgendes zum


    root@dreambox: ~> awk: cmd. line:1: Unexpected token


    diese fehlermeldung kommt bei meiner Dream7000S wenn ich das scipt bei meinen Nabilosatimage in
    var/script

    habe wenn ich es aber in
    etc/init.d
    bekomme ich keine fehlermeldung (awk: cmd. line:1: Unexpected token)
    das script läuft aber ich bekomme keine anrufmeldung auf den Bildschirm angezeigt wohl aber beim test das Hofbräuhaus


    Habe das Gemini 4.5 im flash und das NabiloDarkstar 2 auf den Stick
    Das ganze mit Telnet durchgeführt aber auch mit Openpanel wobei ich da auch auf den Bildschirm die meldung bekamm das der Callmonitor läuft.
    Aber wie gesagt bekomme ich keine meldung auf den schirm wenn mich einer anruft .


    Wenn ich das Gemini auf den Stick habe und das ganze in
    var/script habe geht alles wunderbar
    Habe übrigens keine Fritzbox sondern einen Speedport W900V geht also auch das nur zur Info.


    schreibe dies nur wegen der fehlermeldung:
    awk: cmd. line:1: Unexpected token


    mfg

  • Hi Friedrich,
    >Aber wie gesagt bekomme ich keine meldung auf den schirm wenn mich einer anruft .
    Hast Du den Port 1012 der "Fritz" mit #96*5* am Telefon freigegeben? Ich weiß allerdings nicht ob es mit einem original Speedport geht. Aus einem Speedport kann aber mehr oder weniger eine Fritz machen dafür schau mal bei ip-phone-forum nach.


    ciao

    ---
    7020, Combo, Solo2, Ultimo

  • Hi
    Mein Speedport W900V hat Original Firmware drauf und zeigt mir auf den Display meinesSinus 500i auch an wenn ich #96*5* eingebe Callmonitor an
    und bei eingabe #96*4* Callmonitor aus


    Wie ich geschrieben habe geht es mit den Gemini Image 100%tig nur eben mit NabiloDarkstar 2 nicht.

  • Quote

    Original von friedrich
    Wie ich geschrieben habe geht es mit den Gemini Image 100%tig nur eben mit NabiloDarkstar 2 nicht.


    Ja, die Erfahrung musste ich leider auch machen. Gleiche Situation wie bei Dir: Das Script läuft aber ein Anruf wird optisch nicht signalisiert. Wäre schön, wenn man das noch irgendwie hinbekommen würde.


    cu rolf

  • Quote

    Original von rolf


    Ja, die Erfahrung musste ich leider auch machen. Gleiche Situation wie bei Dir: Das Script läuft aber ein Anruf wird optisch nicht signalisiert. Wäre schön, wenn man das noch irgendwie hinbekommen würde.


    cu rolf


    M. E. liegt das dann eher am Nabilo-Image und nicht am script!
    Die Visualisierung erfolgt ja über die camd-message, wenn die Nabilo-images dies nicht bieten, wirst du dort auch nie ne visuelle Ausgabe erhalten!


    Da ich selbst nur gemini-images nutze und Nabilo nicht kenne, weiss ich leider nicht ob es dort die camd-message gibt bzw. wie diese dort initialisiert wird!


    good luck :einschenken:

    DM7000s + 500GB hdd
    DM8000 HD DMOE2.0+GP3.2/flash + 1TB hdd+ Sandisk Extreme III 4GB SDHC
    DM920 UHD 4K 1x DVB-S2 FBC + 1TB hdd

    Edited once, last by SuPerfrEa|< ().

  • hallo
    wie binde ich es denn ein, so dass ich es net immer von hand starten muß via telnet.
    es wäre schön wenn der monitor gleich beim neustart der box mit hoch fährt

  • moin:)


    soo habe es auf meiner dream installt und via telnet gestartet alles oki soweit.


    kommt ein anruf rein geht sofort der ton weg nur leider sehe ich kein popup fenster wo ich sehe wer mich anruft.


    was habe ich verkehrt gemacht?


    gruss

  • Ist der Script immer noch so resourcen-fressend oder läuft der jetzt einiger Maßen?

    The true way is M E R L I N !

  • Hier mal ein Bug der bei der DM600 auftritt


    Eine Zeile muss abgeändert werden:


    elif [ "$DREAMTYPE" = "DM600PVR" ]; then



    Ich weiß allerdings nicht ob es an meiner Konfiguration liegt, hab das Image GP4.2 auf SSD (CF) über BarryAllen



    Wenn man eine SSD in der DM600 hat sollte man auch die Zeile darunter am besten in folgendes abändern:


    FRITZCACHE=/ba/fritzbox.cache

  • Quote

    Original von rolf


    Ja, die Erfahrung musste ich leider auch machen. Gleiche Situation wie bei Dir: Das Script läuft aber ein Anruf wird optisch nicht signalisiert. Wäre schön, wenn man das noch irgendwie hinbekommen würde.


    cu rolf


    Bei mir leider auch.....Ton wird abgeschaltet, aber das war's dann auch schon.


    Ist hier vielleicht irgendwwas falsch?

  • Quote

    Original von deabolo
    Hallo !
    Habe mir die Mühe gemacht die Image meiner 7000er (im Flash und aufm USB Stick) neu zu machen. Habe dann das Felxmenue über BP installiert. Die Fitzbox_msg_new.sh nach /etc/init.d kopiert. Ausführbar gemacht (755). Bei der Eingabe von /etc/init.d/fritzbox_msg_new.sh start kommt wieder "not found" ??? Ich weiß nicht weiter :353:


    Hatte ich auch, danach habe ich das Originalfile mit Ultraedit32 editiert ohne DOS-konvertierung und dann gings ;)

  • @American/hukk
    Der screenshot sieht i.O. aus, hast du im script user und passwort angegeben ?
    Da die Ausgabe über camd-message läuft solltest du auch nochmals in den cam-einstellungen nachschauen!
    Nutzt du ne Cam, denn ich hab k. A. obs auch ohne geht...!
    Bei mir läuft die CCam (getestet mit 2.0.8 - 2.0.10) und camd3 damit gehts..


    Ihr müsst einen Editor nehmen der Unix-kompatibel ist (ich nehm Notepad++)!
    Für das script brauchste kein flexmenue, einfach nacvh /var/script/ kopieren Rechte auf 755 und per telnet oder über openpanel starten!




    todie04
    Mach mal looki look HIER!!!!!
    Auf der Seite hab ich beschrieben was zu tun ist, damit sich das script (über Openpanel) mit der fb starten und stoppen lässt!
    So mach ich das auch, funzt super...!

    DM7000s + 500GB hdd
    DM8000 HD DMOE2.0+GP3.2/flash + 1TB hdd+ Sandisk Extreme III 4GB SDHC
    DM920 UHD 4K 1x DVB-S2 FBC + 1TB hdd

    Edited 4 times, last by SuPerfrEa|< ().

  • Passwort, alles ist drinn


    Ich benutze Gbox2.1b damit sollte es auch gehen.


    Ich habe folgendes wenn ich Fritzcall starte:


    root@dm600pvr:~> /var/script/fritzbox_msg_new.sh test 089906426
    Testing the script: /var/script/fritzbox_msg_new.sh
    089906426
    Searching for 089906426 in cache file...


    NAME nach Cache Suche: STAATLICHES HOFBRÄUHAUS IN MÜNCHEN
    ADRESSE nach Cache Suche: Hofbräuallee 1 81829 München
    Searching for phone number: 089906426 resulted in: STAATLICHES HOFBRÄUHAUS IN MÜ
    NCHEN
    Standbystatus: 0
    wget: server returned error 401: HTTP/1.1 401 Unauthorized
    root@dm600pvr:~>



    Es wird nichts ins /tmp/ geschrieben...wieso?!


  • user und pw für die dream??? und anstatt der 127 muss dann die ip der dream rein ?


    als editor nehm ich proton32

  • Quote

    Original von hukk
    user und pw für die dream??? und anstatt der 127 muss dann die ip der dream rein ?


    als editor nehm ich proton32


    Genau das, und auch deine Festnetznummer (bei Ziel)!
    Haste denn vor dem rüber kopieren nicht ins script geschaut?
    Dort ist doch jede Zeile komentiert!


    Zusätzlich musste ich noch in folgender Linie (wget kommt mehrmals im script) bei "user" und "passwort" dieses anpassen!


    Code
    wget -q -O /dev/null "http://user:passwort@$ip/cgi-bin/xmessage?caption=Skript%20gestartet&body=FritzBox!%20Callmonitor%20gestartet&timeout=3"




    Proton kenn ich nicht, wie gesagt hab Notepad++ das gibt es HIER!!!


    Ist freeware und läuft auch unter vista bestens...

    DM7000s + 500GB hdd
    DM8000 HD DMOE2.0+GP3.2/flash + 1TB hdd+ Sandisk Extreme III 4GB SDHC
    DM920 UHD 4K 1x DVB-S2 FBC + 1TB hdd

    Edited once, last by SuPerfrEa|< ().

  • Fritzbox Callmonitor v0.82_3 gestartet
    ---Folgende Optionen sind gesetzt---
    Debugmodus: 0
    Ueberwachte Rufnummern: xxx und xxx
    Alle Rufnummern ueberwachen: 1
    Eingehende Anrufe ueberwachen: 1
    Ausgehende Anrufe ueberwachen: 0
    Verbindungsende ueberwachen: 0
    IP Adresse der Dreambox: 192.168.1.97
    Anzeigetimeout: 8
    Anzeigewennaus: 1
    Übersichtsseite: 1
    -------
    wget: .168.1.97: Unknown server error <--- ka in welcher zeile finde den fehler ned


    bin am verzweifeln


    vorher ging zumindest der ton aus nun gehts ned mehr
    und in welcher zeile muss ich die ip vom router und das passwort eingeben


    hab alles unter init.d gespeichert


    gruss


    -----------------------------------------------------------------------------


    testanruf getätigt


    20.11.08 18:57:17 Ausgehend: von xxxxx auf xxxxxx
    wget: .168.1.97: Unknown server error
    [: 0: unknown operand
    xxxxxxxx
    Searching for xxxxxxxxxx in cache file...


    gruss

    Edited 2 times, last by hukk ().