Remote control conflict between my DM 7020 and DM500

  • I have problem my DM 7020 and Dm500 are next to each other in the same room. The DM 500 remote does not conflict on the DM7020 , If I use the DM7020 remote it will bring up different screens, for example if I press the exit button on the DM7020 it will activate the help screen on the DM 500. Can you please help me to fix the remote control conflict between my DM 7020 and DM500.

  • well you have two options. you can install dreambox switch plugin which will disable remote on whatever box it is running on, remote will work again with default code 2069.I have a dm7000s and a dm600c myself and this is what i do -put one box on standby and other powered on. when you press power button standby box powers on and powered on box goes to standby.

  • This is a translation of a procedure in this thread: Fernbedienung umstellen codieren da 2 boxen nebeneinander


    Please note that these instructions are ONLY FOR THE BIG RCU (DM70xx,DM600,DM800), not for the smaller ones.



    It's possible to have up to four boxes in one room, because there are four sets of remote commands (called levels). Be careful or you may end with an unusable RC.


    Things you need:
    - an FTP-Client (software)
    - a unix-compatible texteditor (for OS X "Textedit" is fine)


    First you have to change the RC level of the Dreambox:


    - Download the following file to your PC: /etc/init.d/bootup
    - Open the file and add one of the following line at the very end of the file:


    echo 1 > /proc/stb/ir/rc/mask0
    echo 2 > /proc/stb/ir/rc/mask0
    echo 4 > /proc/stb/ir/rc/mask0
    echo 8 > /proc/stb/ir/rc/mask0


    (For other boxes than the DB7025 it's "mask" at end instead of "mask0".

    "echo 1..." sets the box to level 1, "echo 2..." to level 2 and so on.
    Every line represents one of the levels. Give each box a different level and write down which box is set to which level.


    - Restart the box.


    Now you have to change the level of your RC:


    First you have to unlock your RC:
    - Press the "DREAM"-button on your RC.
    - Press and hold "Shift"-button until there are two flashes of the "DREAM"-button
    - Press the following buttons one after another: 9 8 2
    Now the "DREAM"-button should flash four times. If it flashes only two times your RC was already unlocked. The unlock again just repeat the three steps above.


    Now you programm your RC:
    - Press the "DREAM"-button
    - Press and hold the "Shift"-button until there are two flashes of the "DREAM"-button.
    - Enter the corresponding code (press one button after another):
    If you added "echo 1 ...." to your box the code is: 0 0 3 1
    If you added "echo 2 ...." to your box the code is: 0 0 3 2
    If you added "echo 4 ...." to your box the code is: 0 0 3 3
    If you added "echo 8 ...." to your box the code is: 0 0 3 4


    Finally lock your RC again:
    - Press the "DREAM"-button on your RC.
    - Press and hold "Shift"-button until there are two flashes of the "DREAM"-button
    - Press the following buttons one after another: 9 8 2


    The good about this procedure: The settings stays after a reboot.
    The bad: If you install another image on your box you have to change the "boot" file again.

    Philips 37PF9731D | Onkyo TX-NR708
    3 x DM820HD
    T90: 13°, 19.2°, 23.5°, 28.2°
    SRG | HD+ | ORF

    Edited 3 times, last by neelix ().

  • Thanks for this.


    I have a DM7020 and DM600.


    I changed the mask on the DM600 (btw it's called 'mask', not 'mask0') and set the level on one of the RCs and everything worked OK as described.


    But there is no /proc/stb directory on my DM7020, therefore no mask to change. Both boxes are Gemini 4.0 - on the DM7020 it's on a usb stick, on the DM600 it's in flash.


    So, will this trick work on the DM7020??

  • Hi guys, I've been using this setup for some time now because I have 2 DM7025's stacked. However, I've been looking how to do it automatically at start up for ages. I would normally telnet the commands to each box after a reboot and all works fine. I've added my command to the file mentioned and rebooted, it appears it is not executed. If I manually do it , its fine.


    Any ideas what might be wrong here please ? This would be massively useful for me and many others I'm sure.


    Thanks MCC

  • @ percivjr


    Strange, my 7020 with newest Gemini has this directory (my Gemini is on a CF card). May be you should restart the box.
    There was another user who had the same problem as you. He reinstalled the image. After that /proc/stb/ was there.


    About the "mask": Thanks, I edited my post.



    B16MCC


    And the changes you made are still in bootup? Have you saved and uploaded the file with the added line?

    Philips 37PF9731D | Onkyo TX-NR708
    3 x DM820HD
    T90: 13°, 19.2°, 23.5°, 28.2°
    SRG | HD+ | ORF

  • Yes mate the file contains the line


    echo 2 > /proc/stb/ir/rc/mask0


    which I've added as the last line in the file. I've checked permissions , I've tried at both 755 and 777. When rebooting the box it still responds to both remote channels. Rechecked the file after reboot and it does contain the added line. As always I enter the command manually and I get the desired effect. It will not do it from boot up.