Upd 4.17.9/05.12.19>Plugin ipRec Fernprogrammierung/Remote recording via tvtv.xx,tvinfo.de

  • Hey,
    ich habe die gleiche Fehlermeldung mit GP3.3 inkl. Online Update.


    Nach der Installation fährt die Box nicht mehr hoch (bleibt bei ca. 90% hängen), oder dauert es einfach nur ewig.

    There´s no life without dreams... but sometimes it could be a nightmare...

  • Hi,


    ich habe gerade das Update 4.7.4 Online gestellt.


    Dieses Update löst,


    - Lange Bootvorgänge durch Crashlogs, die keinen Bluescreen auslösen.


    - Normalerweise kein Bluescreen mehr beim Booten


    - Pobleme in Verbindung mit Barry Allen behoden


    - Hänger bei der Bedienung über die Fernbedienung deutlich reduziert


    - rmwolf's Problem sollte beseitigt sein


    Noch existierende Probleme:


    - ipRec läuft nicht Originalimages vor 2008.


    - Bei eingeschalteter blinkender Uhr zur Aufnahme, können Aufnahmen verloren gehen.


    ************** english ****************


    This Update solve the following Problems:


    - Long Booting times during startup, with a crashlog and without Bluescreen.


    - Bluescreens during startup are solved


    - Long waiting times using the remote control considerably reduced


    - Problems with Barry Allen solved


    - rmwolf's would be solved


    Unsolved problems:


    - ipRec doesn't works with original Images from dream earlyer then 2008


    - when ipRec works with a switched on blinking clock during recording, the running recording could be breaks.


    Viele Grüße, best regards


    einen fröhlichen Ostermontag


    Aladin


    PS: Das Plugin gibt es hier.


    You find the Plugin here.

  • Hey,
    leider ist mein Problem noch nicht erledigt...


    Folgende Konfig habe ich:


    GP3.30 inkl. OnlineUpdates und div. Plugins via BA 4.4.9 gebooted.


    Der Fortschrittsbalken bleibt irgendwann stehen.
    Die Spinner laufen weiter.
    Nach insgesamt ca. 7min geht es dann weiter.


    Das iprec.log sagt folgendes:
    [INFO] iprec: Debug: on -> 22:20:00
    [INFO] TVinfo.Get: Interface: tvinfo is off -> 22:25:02
    [INFO] CleanFilm: Exit -> 22:25:15
    [INFO] AddTimer: lfWrite2: False -> 22:25:15
    [INFO] AddTimer: lfWrite3: False -> 22:25:15
    [INFO] Klack.Get: Interface: klack is off -> 22:25:15
    [INFO] CleanFilm: Exit -> 22:25:28
    [INFO] AddTimer: lfWrite2: False -> 22:25:28
    [INFO] AddTimer: lfWrite3: False -> 22:25:28
    [INFO] TVTV.Get: Interface: tvtv is on -> 22:25:28
    [LINK] TVTV.Get: http://www.tvtv.de/cgi-bin/Web…e=csv&access=xxxxxxxxxxxx -> 22:25:28
    [INFO] TVTV.Get: ready -> 22:25:31
    [INFO] SearchServiceName: NeuerSynRef rtl 1:0:1:1F41:319C:13E:820000:0:0:0: gefunden ! -> 22:25:52
    [INFO] AddTimer: Write Setup -> 22:25:52
    [INFO] CleanFilm: Exit -> 22:25:53
    [INFO] AddTimer: lfWrite: False -> 22:25:53
    [INFO] AddTimer: Add Die Liga der außergewöhnlichen Gentlemen -> 22:25:53
    [INFO] AddFilm: rec -> 22:25:53
    [INFO] AddFilm: Film -> 22:25:53
    Traceback (most recent call last):
    File "/bin/iprecd", line 311, in <module>
    iprecSynch()
    File "/bin/iprecd", line 10, in __init__
    self.Synch()
    File "/bin/iprecd", line 302, in Synch
    Hook(self.SynchHook)
    File "/usr/lib/enigma2/python/Plugins/Extensions/ipRecService/xmltools.py", line 80, in Hook
    if (hook(interface)):
    File "/bin/iprecd", line 294, in SynchHook
    self.AddTimer(list)
    File "/bin/iprecd", line 284, in AddTimer
    if self.AddFilm(timer,serviceRef,title,sparte,start,end,rec,IsNoadChannel(self.setup,GetRefName(self.setup,serviceRef))):
    File "/bin/iprecd", line 189, in AddFilm
    LogDebug(self.setup,"INFO","AddFilm","ON: %s %s" % (title,serviceRef))
    UnicodeDecodeError: 'ascii' codec can't decode byte 0xdf in position 19: ordinal not in range(128)
    [INFO] ipRecDispatch: ReadFilmData Begin -> 22:26:09
    [INFO] ReadFilmData: start CheckService -> 22:26:09
    [INFO] ipRecDispatch: ReadFilmData End -> 22:26:09
    [INFO] TVinfo.Get: Interface: tvinfo is off -> 22:26:16
    [INFO] CleanFilm: Exit -> 22:26:30
    [INFO] AddTimer: lfWrite2: False -> 22:26:30
    [INFO] AddTimer: lfWrite3: False -> 22:26:30
    [INFO] Klack.Get: Interface: klack is off -> 22:26:30
    [INFO] ipRecDispatch: Start -> 22:26:39
    [INFO] IsNextRecording: NextStartTime: 03/25/08 18:13:00 -> 22:26:39
    [INFO] ipRecDispatch: Ok -> 22:26:39
    [INFO] ipRecDispatch: End -> 22:26:39
    [INFO] CleanFilm: Exit -> 22:26:51
    [INFO] AddTimer: lfWrite2: False -> 22:26:51
    [INFO] AddTimer: lfWrite3: False -> 22:26:51
    [INFO] TVTV.Get: Interface: tvtv is on -> 22:26:52
    [LINK] TVTV.Get: http://www.tvtv.de/cgi-bin/Web…xxxxxxxxxxxxxxxxxxxxxxxxx --> 22:26:52
    [INFO] TVTV.Get: ready -> 22:27:03
    [INFO] SearchServiceName: Ref rtl 1:0:1:1F41:319C:13E:820000:0:0:0: gefunden ! -> 22:27:49
    [INFO] CleanFilm: Exit -> 22:27:53
    [INFO] AddTimer: lfWrite: False -> 22:27:53
    [INFO] AddTimer: Add Die Liga der außergewöhnlichen Gentlemen -> 22:27:53
    [INFO] AddFilm: rec -> 22:27:53
    [INFO] AddFilm: Film -> 22:27:53
    [INFO] AddFilm: ON: Die Liga der außergewöhnlichen Gentlemen 1:0:1:1F41:319C:13E:820000:0:0:0: -> 22:27:53
    [INFO] AddTimer: lfWrite2: True -> 22:27:54
    [INFO] AddTimer: Write Timer -> 22:27:56
    [INFO] AddTimer: lfWrite3: True -> 22:27:56
    [INFO] CheckDelete: Start Die Liga der außergewöhnlichen Gentlemen -> 22:27:56
    [INFO] ipRecDispatch: ReadSerienInit Begin -> 22:28:11
    [INFO] ipRecDispatch: ReadSerienInit End 0 sec -> 22:28:11


    Ein über tvtv.de gesetzter Timer wurde auch nach zweimaligem Neustart nicht übernommen.
    Nach nochmaligem Neustart (und der schon erwähnten Pause von ca. 7min.) wurde der Timer übernommen...(siehe logfile im Anhang).


    Werde diese Kombi morgen mal im Flash testen.


    Kann ICH da noch was testen oder liegt es an BA bzw. was für Infos kann ich Dir ggf. noch zukommen lassen ?


    Gruß Jürgen

    Files

    • ipRec.zip

      (937 Byte, downloaded 33 times, last: )

    There´s no life without dreams... but sometimes it could be a nightmare...

    Edited 3 times, last by elektronikfreak ().

  • Ich habe heute erst von deinem Plugin erfahren und es gleich testweise installiert.


    Konfiguriert habe ich es mit tv-info.de - leider hat sich die Box einzige später mit einem Bluescreen verabschiedet.
    Offenbar lag ein Problem mit den Serientimern vor, ich habe diese jetzt abgeschaltet und bisher läuft alles wie es soll.


    Hier der relevante Auszug aus dem Crashlog:




    MacDisein

  • Hallo, ich habe leider keine CF Karte in meiner Dream, also würde ich die XML Dateien gern woanders auslagern.


    Ich habe versucht bei der Konfiguration einfach einen anderen Pfad (/etc/tuxbox/config) anzugeben, jedoch ohne erfolg.
    Die zugehörigen Dateien wurden leider nicht erstellt.


    Eventuell kann jemand die XML´s hier Posten damit ich sie selbst einfügen kann.
    Oder sind diese Dateien sogar leer, so dass ich einfach nur eine leere Datei erstellen muss?


    EDIT:
    Hat sich erledigt, ich konnte dem Basteldrang nich wiederstehen und hab jetzt ne CF Card drin. :D


    Aber man kann die Lösung ja der Vollständigkeit halber trotzdem noch hier Posten... wär vielleicht ganz gut.


    MfG


    demacus


  • Hi,


    du scheinst nicht up to date zu sein. Das aktuelle Update 4.7.4 sollte dein Problem lösen.


    Viele Grüße


    Aladin


  • Hi,


    ich nehme an du hast vergessen das Verzeichnis 'config' zu erstellen.


    Viele Grüße


    Aladin


  • Ich habe die Version 4.7.4 - wie ich ja geschrieben hatte, habe ich erst am Releasetag von deinem Plugin erfahren und du hast auf deiner Homepage ja nur den Download zur aktuellesten Version.


    Der Crash ist also mit der 4.7.4 entstanden.



    MacDisein


  • Hi MacDisein,


    wir können dein Problem nur Lösen, wenn du mir auch noch die Loginformationen und die Konfiguration schicken würdest.


    Gehe dazu wie folgt vor:


    1. Mit telnet einlogen
    2.'iprec set debug on' eingeben
    3.'iprec set link off' eingeben
    4. killall -9 enigma2
    5. Warten bis BP ensteht
    6. iprec copy setup
    7. Aus /tmp alle ipRec* Dateien in eine ZIP-Datei packen und mir per PM-Schicken.


    Mit diesen Maßnahmen erhalte ich viele hilfreiche Informationen. Deine Zugangsdaten sind aber entfernt worden. Du kannst/solltest es nochmal prüfen.


    Vielen Dank und Grüße


    Aladin

  • Ich habe heute die Box mit eingeschaltetem Debug Mode von ipRec laufen lassen - aber bisher kein Absturz - vielleicht war es Zufall oder lag daran, dass es frisch installiert war. Komischerweise ist jetzt auch ein Eintrag in der Serientimerliste.



    MacDisein

  • Hi,


    ich hoffe bei euch leuft alles super. In den nächsten 14 Tagen bin ich in Urlaub. Ich melde mich danach wieder, wenn Probleme auftauchen sollten einfach posten.


    Viele Grüße


    Aladin

  • Auf einem Dreambox 7025+ C habe ich gerade installiert:
    - Gemini2 v3.3
    - ipRec 4.74


    Ich habe die ipRec Installation und Konfiguration gemäss der 4.74 Anleitung
    durchgeführt (sehr klar - besten Dank!).
    Auch war die Registierung bei tvtv.ch schnell erledigt.


    Beim ersten Gehversuch sind doch zwei Probleme vorgekommen:


    1) Mit Fernbedienung-Menu -> Erweiterung -> ipRec Service
    stürzt Enigma ab mit einer Crash Meldung. Dies scheint geleich zu sein
    wie bei rmwolf (mein crash log vorhanden falls Ihnen nützlich). Momentan
    scheint diess mir aber nicht so wichtig, da ich gar nicht ungern mit
    dem Consol arbeite (habe mit iprec --help einiges gesehen). Hat die
    GUI ingendwelche Funktionalität, die nicht im Consol vorhanden ist?


    2) ipRec findet (bei mehreren Versuchen) nie den richtigen Kanal:
    - falscher Sender wird aufgenommen
    - error message during startup "Kanalanordnung muss geprüft werden"
    - Eintrag in ipRecSetup.xml
    <channelmap>
    <channel info="WARNING" name="skymoviesmoderngr" ref="1:0:1:1266:7EA:2:11A0000:0:0:0:" refname="skynewsuk(cable)"/>
    <channel info="WARNING" name="skymoviesclassics" ref="1:0:1:1266:7EA:2:11A0000:0:0:0:" refname="skynewsuk(cable)"/>
    </channelmap>


    Ich bin zur Zeit auf die Suche nach einer Lösung für das zweite
    Problem.


    In ipRecService.xml scheinen die Kanäle richtig angeordnet zu sein:
    root@dm7025:/tmp> grep -i classic ipRecService.xml
    <service channel="Sky Classics" ref="1:0:1:10D1:7D7:2:11A0000:0:0:0:"/>
    root@dm7025:/tmp> grep -i cable ipRecService.xml
    <service channel="Sky News UK (Cable)" ref="1:0:1:1266:7EA:2:11A0000:0:0:0:"/>


    In ipRec.log jedoch falsch angeordnet, zum Beispiel:
    [LINK] TVTV.Get: http://www.tvtv.ch/cgi-bin/Web…BkUIqZTD8CKce88UEuA%3D%3D -> 14:14:23
    [INFO] TVTV.Get: ready -> 14:14:29
    [INFO] SearchServiceName: SoundexNeuerRef skymoviespremiere 1:0:1:1266:7EA:2:11A0000:0:0:0: gefunden ! -> 14:14:41


    Hier wird sky movies premiere mit Sky News UK verbunden!


    Ich suche einen Rat, ob das Problem bei mir liegt (falsche
    Konfiguration?) oder bei ipRec selbst. In jedem Fall bin ich bereit,
    die Sache weiter nachzugehen. Das Konzept von ipRec finde ich genial!
    Hoffentlich funktioniert es bald bei mir.

  • Hi,


    ich habe gerade ein Update für Enigma 2.5 online gestellt.


    Die Version 4.7.x ist für Enigma 2.4.


    Die Version 4.8 ist für Enigma 2.5.


    Ihr findet das Update hier.


    Hi jkaelin,


    zu 1. ich benötige den Crashlog.


    zu 2. Über "Kanalzuordnungsfehler prüfen" kannst du die Kanalzuordnung korrigieren.


    Viele Grüße


    Aladin

  • Aladin,


    Danke für die Antwort:
    zu 1. ich benötige den Crashlog.
    -> an 4 Mai per PM geschickt


    zu 2. Über "Kanalzuordnungsfehler prüfen" kannst du die Kanalzuordnung korrigieren.
    -> Gibt es eine Möglichkeit, die Zuordnung zu prüfen ohne die GUI, die zur Zeit bei mir wegen Punkt 1. nicht läuft? Vielleicht ein Hinweiss wo ich die Datei finde bzw. welcher Befehl ich vom Konsol ausführen kann?


    Grüsse,
    jkaelin

  • Hi jkaelin,


    die Senderzuordnung sollte über das OSD-Menü stattfinden.


    Wenn ich den Crashlog habe, kann ich dir sicher weiterhelfen.


    Viele Grüße


    Aladin

  • Hi jkaelin,


    ich habe mittlerweile deinen Crashlog erhalten.


    Die Fehlermeldung deutet darauf hin das du Gemini 3.4 installiert hast.


    Dann wird dir ipRec V 4.8 helfen. :)


    Viele Grüße


    Aladin

  • Aladiin,


    Besten Dank für den Hinweiss, das OSD Menü mit ipRec Version 4.8 funktioniert einwandfrei. Auch konnte ich jetzt die Kanalzuordnung für englische Sender jetzt korrigieren.


    Ein anderes Problem habe ich aber jetzt gefunden. In tvtv.ch sind die Senderzeiten CET (ausser BBC World, die scheinbar aus der Reihe tanzt und London Zeit benützt). Die über ipRec eingetragenen Aufnahmezeiten am Dreambox werden aber trotzdem eine Stunde früher verschoben. Die Aufnahme erfolgt dann zur falschen Zeit. Gibt es eine Möglichkeit dies mit ipRec zu korrigieren? (Ein manuelles Eingriffen auf den Dreambox Timers scheint schwierig zu sein).


    Aufnahmen von deutschen Sender mit ipRec funktionieren sehr gut und sind auch sehr genial. Mit Dreambox, tvtv und ipRec wird es endlich Schluss mit dem "Channel Surfing".


    Übrigens, ipRec hat am Anfang das Dreambox manchmals ziemlich lahmgelegt. Ich habe dann eine Swap-Datei (128 MB) angelegt. Nacher zeigt es sich keine Verzögerung mehr.


    Gruss,
    jkaelin

  • Hi jkaelin,


    in dem /tmp Verzeichnis findest du die Datei ipRec.log. Diese Datei enthält einen Link zu deinen TVTV Daten. Führe diesen Link im Firefox, Internet Explorer oder einem anderen Browser aus.


    Ich bitte dich mir das Ergebnis wieder per PM zuzuschicken.


    Viele Grüße


    Aladin

  • Hallo,


    habe Gemini 3.2 installiert. Hatte vorher das tvtv Plugin installiert und war bislang auch sehr zufrieden damit. Lief stabil und zuverlässig. Nachdem nun aber bei manchen Sendern die Aufnahmen nicht mehr korrekt übernommen wurden (von exotischeren Sendern wie tve etc.) und die Einträge im Serientimer tlw. unerklärbar und nicht mehr entfernbar (=bluescreen) waren, bin ich nun zu IPrec gewechselt. Bei IPrec hat sich ja einiges getan und wesentlich verbessert. Vor allem das tvtv Optionsmenü ist nun einfacher und und die Option "Aktion nach der Aufnahme" auch eine gute Erweiterung. Dass man keine Channellist mehr braucht ist natürlich der Hammer denn das war wirklich immer eine grosse Pein wenn tvtv mal wieder dachte die Sendernamen ändern zu müssen und somit eine wichtige Aufnahme nicht durchgeführt werden konnte...


    Doch leider habe ich auch ein kleines Problem damit:
    Gemini 3.2 - Habe vorher tvtv deinstalliert, dann iprec 4.8 installiert. Hat nicht funktioniert (irgendein file nicht gefunden beim Aufruf des Menüs - V4.8 braucht wahrscheinlich Gemini V3.3+ ?!?). Also iprec 4.8 wieder deinstalliert und 4.7.4 installiert. Hat dann gleich nach dem ersten Neustart (der ca. 5-10 Minuten(!!!) gedauert hat auch funktioniert. Nachdem auch ein erneuter Neustart so lange gedauert hat (dachte das evtl. nur der erste zwecks irgendwelchen Abgleichen so lange dauert) habe ich die Option "Synchronisieren beim Starten" auf "Nein" gestellt. Das hat aber leider auch nicht zu den bisherigen Startzeiten mit dem tvtv Service geführt (ca. 1-2 Minuten) sondern es dauert immer noch sehr viel länger als mit dem tvtv Plugin (3-5 Minuten). Was nun wesentlich länger dauert ist der Prozess wo er "loading gemini" hinschreibt. Und da Gemini leider doch des öfteren einen Reboot benötigt (z.B. Mediaplayer will nicht mehr abspielen) ist das ziemlich öde (1-2 Minuten sind ja schon ohnehin lang genug)...


    Hat jemand einen Tip? Gibt es hierfür eine Lösung?


    Danke,
    HH