LED blinken lassen bei Aufnahme DM 600

  • Hi


    source hab ich (adenin.c), wie man so was compiliert - keine Ahnung...


    Ich habs nu anders gelöst, hab mit dem led-skript als Vorlage die enigma_main etwas geändert, nur ausprobieren kann ich im Moment nicht, meine Mutter erwürgt mich...(Mainz bleibt Mainz...).

  • Geht genauso wenig - liegt wahrscheinlich an meinen überragenden programmierkenntnissen (würg...) - bzw. nicht vorhandenen...

  • Ich hab echt keine Ahnung was du da falsch machst.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Hm, kannst ja schlecht in meine Box kucken...


    Spaß beiseite, was mich nur wundert, ist das wenn nur der Treiber geladen ist, beim in Standby gehen die rote kurz angeht und dann wieder die grüne...
    Auch wenn Dir nix einfällt, trotzdem danke für die Hilfe!!

    Edited once, last by stibbich ().

  • Schick mir mal den Treiber, den Du zZ verwendest.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Das ist der von der ersten Seite hier...


    Hab nun mal mit verschieden Images rumgespielt...
    originales cvs Fehler
    Merlin Fehler
    PB Fehler
    Gemini hat was eigenes drin, blick ich nicht durch, wie das geht, nirgends ein Zusätzlicher Treiber oder sonst was zu erkennen...


    Immer nach anleitung eingebaut, mit Skript ist die Funktion einwandfrei, wird das Skript entfernt, bei standby kurz rot, dann wieder grün.
    Irgendwie scheint der Treiber zu denken, die Box ist an, warum kann ich nicht erkennen...

    Edited once, last by stibbich ().

  • Hast Du die von hier ? Weil, weiter oben gibt es eine ältere Version.
    Also der Treiber macht überhaupt nix von selbst!. Das ist, sozusagen, nur der Lichtschalter, der bisher gefehlt hat. Da muss man ganz bewusst drauf zugreifen.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • OOooooooouuuuuuuuuhhhhhhh....


    War mir gar nicht aufgefallen, daß das 2 verschiedene sind...


    Ich dachte ersteres ist das gleiche, nur ohne skript - dem ist aber nicht so...
    Mit dem gehts dann auch richtig.


    DANKE!!!


    :kaffee:

  • Moins...


    Ich muss den Thread hier nochmal aufwärmen:


    Seit dem Kartenwechsel von P* damals (letztes Jahr) gabs immer wieder mal Aussetzer (5-7 Sekunden) bei Aufnahmen, mal häufiger, mal seltener.


    Habs nun analysiert und festgestellt, dass es mit großer Wahrscheinlichkeit an der blinkenden LED liegt. Entferne ich das Skript, kann ich - zumindest vorerst - keine Aussetzer mehr feststellen.


    Die von mir verwendete CCcam (mit -dv im Telnet gestartet) meldet, dass bei diesen Aussetzern die Verbindung zum /dev/sci0 verloren geht, der Kartenleser wird resettet, die Karte neu gefunden und wieder hinzugefügt, dann funktionierts wieder ne Weile, mal länger, mal kürzer. Ich vermute nen Zusammenhang zwischen dem Blinken (Zugriffe auf /dev/tRNA) und den Zugriffen auf das /dev/sci0 (vermutlich schreibend - also EMMs).


    Vor dem Kartenwechsel war es deutlich seltener, dass solche Aussetzer auftraten, da ist es mir nie aufgefallen, aber seit die Schlüsseldaten häufiger wechseln (früher xx Sekunden, jetzt 7 Sekunden - Quelle weiß ich nicht mehr, habs mal irgendwo aufgeschnappt), passierts immer häufiger, letztens 5 mal in einer 45 minütigen Aufnahme, das ist ärgerlich, weil die Aufnahmen zerhackstückt werden.


    Kann das jemand nachvollziehen und/oder bestätigen?


    Schade, war ein witziges und informatives Feature!


    -==[Schubsi]==-

    DM600PVR Kabel 250 GB, Sagem DBox2 1xI

    Edited once, last by schubsi ().

  • Kann ich im GP 4.6 selbst steuern, welche LED bei einer Aufnahme blinkt?

    Eee Box B202 Debian, DM600C GP 4.6, DM600C Neunigma2 v2.8.1, Acer Aspire One D150 Ubuntu, HP dc5700 CMT Debian, WRT54GL Tomato 1.25, X301 Win 7 Ultimate

  • schubsi
    Ich denke mal eher, das cccam sich daran stört, das noch jemand das Netzwerk benutzt.
    Da kann ich aber nichts daran ändern.


    marty1976
    nein.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • adenin


    Quote

    schubsi
    Ich denke mal eher, das cccam sich daran stört, das noch jemand das Netzwerk benutzt.
    Da kann ich aber nichts daran ändern.


    Du meinst den WGET-Befehl? Ansonsten war bei meinen Tests nämlich kein weiterer Netzwerkzugriff (DBOX2 war aus).


    Ich habe die Hoffnung, dass der Schreibzugriff auf die LED /proc/tRNA/led/ledxx im Sekundentakt stören könnte, genau dann wenn auf /dev/sci0 geschrieben werden soll... (das wäre die Rettung für dieses Feature).


    Ein Workaround wäre, den Status von /proc/tRNA/led/ledxx vorher abzufragen, bevor ein erneuter Schreibzugriff erfolgt. Allerdings lege ich mir zur Zeit bei der IF-Zeile die Karten, hab zu wenig Erfahrung mit der Shell :-/


    Kannst Du mich bitte in die richtige Richtung "schubsen"? :-)


    -==[Schubsi]==-

    DM600PVR Kabel 250 GB, Sagem DBox2 1xI

  • Die Abfrage ist von gutemine.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Manche Sachen holen einem wieder ein :-)


    Das Problem ist das das blinken durch abwechselndes schreiben von 0 und 1 gemacht wird, sobald du damit aufhörst ist auch aus mit blinken :-)


    mach mal top in telnet um zu sehen wer dir da wirklich die CPU wegfrisst. Wobei wenn ich mich recht erinnere hat z.B. das Gemini Image ein /tmp/.recording file während eine Aufnahme läuft, da könnte man sich das wget auch sparen und mit if [ -f /tmp/.recording ]; then
    arbeiten um rauszufinden ob aufnahme läuft, der Ansatz übers webinterface ist sicher nicht der einzig seligmachende.


    Oder in dem man nachsieht ob der Plattenplatz kleiner wird kann man auch laufendeAufnahme rausfinden (das standby2deepstandby shell script macht das z.B. um zu verhindern bei Aufnahme runterzufahren)


    Am einfachsten ist aber um zu sehen ob es hilft erstmals das blinken halt langsamer zu machen (sleep verlängern oder reintun), dann blink es halt aber langsamer :-)


    LG
    gutemine

    Edited 3 times, last by gutemine ().

  • Das blinken wird sicher nicht langsamer :bl:
    Es kommt höhstens zu einer Verzögerung des Ein- und Ausschalten des Blinken.


    0 -> LED aus
    1 -> LED ein
    2 -> LED blinkt

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • adenin


    Quote

    Das blinken wird sicher nicht langsamer


    Genau das war mein Ansatz: Auch wenn es keine "Statusänderung der Box" gibt, wird permanent geschrieben, mein Plan:


    Wenn led status 1 hat und es soll "1" geschrieben werden, dann lass es einfach sein.


    Ich erhoffe mir durch weniger Schreibzugriffe auf /proc/tRNA/led/ledxx weniger Konfliktsituationen, während emms der Karte in /dev/sci0 verarbeitet werden, weil stattdessen z. B. nur sleeps durchgeführt werden.


    Ich habe gestern auf der Kommandozeile mit


    Code
    if [ 'grep 1 /proc/tRNA/led/ledgr | wc -l' -eq 0 ]; then echo 'ja';fi

    experimentiert, erhalte aber den Fehler

    Code
    [: grep 1 /proc/tRNA/led/ledgr | wc -l: bad number


    Ist abgeschrieben, ohne zu wissen, was ich da eigentlich mache, schon klar, aber ich habe ja schon zugegeben, dass ich mit der shell zu wenig Erfahrungen habe... :rolleyes:


    Deshalb ja meine Bitte, mir nen Tipp zu geben, wie ich den Status von /proc/tRNA/led/ledxx mit einer if-Anweisung abfragen kann, um dann abzuzweigen...


    GuteMine

    Quote

    mach mal top in telnet um zu sehen wer dir da wirklich die CPU wegfrisst.


    Habe ich bereits gemacht, keine Auffälligkeiten erkennbar, habe auch keine "aufregenden" Sachen zusätzlich zu laufen, CCcam macht im Höchstfall 13% load, der Rest so gut wie gar nichts.


    Meine Analyse ergab, wenn das recorderled.sh nicht läuft, bleiben auch die Aussetzer aus, ergo könnens eigentlich nur die regelmäßigen Schreibzugriffe auf die LEDs sein, die da stören. Und die könnte man reduzieren, weil sich der Status während einer Aufnahme selten ändern dürfte (bis auf seltenes EIN/AUS der Box)...


    Komme alleine nicht weiter, Hühühühülfe! :-)


    -==[Schubsi]==-

    DM600PVR Kabel 250 GB, Sagem DBox2 1xI

  • Verantwortlich für die Aussetzer ist offensichtlich das adenin.ko, das Modul, welches die LEDs ansteuert.
    Es kollidiert offensichtlich beim Hardwarezugriff mit den schreibenden Zugriffen der CAM /dev/sci0)


    Nur wenn die Schreibzugriffe ganz abgestellt werden, gibt es keine Aussetzer mehr. Hab mir erstmal damit beholfen, die Schreibzugriffe zu minimieren und den Status der roten LED auf Dauerleuchten statt blinken zu setzen.


    Ich werde es mal beobachten...


    -==[Schubsi]==-

    DM600PVR Kabel 250 GB, Sagem DBox2 1xI

  • wenn du cat /proc/tRNA/led/ledxx eingibst, kriegst du dann einen 1er oder 0er zurück ?


    Dann ginge es so:


    STATUS=`cat /proc/tRNA/led/ledxx`
    echo $STATUS
    if [ $STATUS -eq 0 ]; then
    echo "aus"
    else
    echo "an"
    fi


    Und ja natürlich macht adenin das blinken im Treiber selber, ich meinte nur das Anstoßen des blinken wird langsamer wenn du seltener nachsiehst ob aufnahme läuft - schäm

    Edited 3 times, last by gutemine ().

  • GuteMine


    Danke für die Tipps, habe das Skript etwas umgemodelt:


    1. Das Auslesen des LED-Status erfolgt nur 1 mal pro Durchlauf


    Bash
    #!/bin/sh
    while [ 1 ]; do
    led1=`cat /proc/tRNA/led/ledgr`
    led2=`cat /proc/tRNA/led/ledrd`

    2. Bevor ein Schreibzugriff erfolgt, wird erst verglichen, ob der gewünschte Wert nicht bereits gesetzt ist:


    Code
    if [ "$led2" = "0" ]; then
    # do nothing
    echo >/dev/null 2>&1
    else
    echo 0 > /proc/tRNA/led/ledrd
    fi

    3. Bei Status Aufnahme wird nicht Wert 2 (für Blinken) geschrieben, sondern Wert "1" für Dauerleuchten. Da das adenn.ko beim Zustand "Blinken" ständig Schreibzugriffe macht, kam es zu den beschriebenen Fehlern der Smartcard.


    Ich hatte die Befürchtung, dass bei massiven fehlerhaften Schreibzugriffen auf die Smartcard diese geschrottet werden könnte, daher verzichte ich lieber auf das informative Blinken.


    Ferner habe ich nun die Abo-Karte mittels Smartreader+ an meinen Linuxserver gekoppelt, um mal zuschauen, ob die Probleme (Aussetzer) weg sind, wenn der interne Kartenleser nicht mehr verwendet wird. Hatte jedoch noch keine Zeit, dies ausgiebig zu testen...


    -==[Schubsi]==-

    DM600PVR Kabel 250 GB, Sagem DBox2 1xI

    Edited 2 times, last by schubsi ().