[closed] Wally West für Barry Allen auf der 7025, 7020 , 800, 8000

  • also wenn du im letzten OoZooN den update gemacht hast damit auch die aktuellen Treiber mit dem IDE Fix drinnen sind dann ist das ein Verhalten wie es nicht auftreten sollte. Ich würde aber mal vermuten du hast dir mit dem ständigen Abschalten nach den Freezern längst das Filesystem sowohl der CF karte als auch der Hardisk versaut. Womit man auch nicht sagen kann ob die backups noch funktionstüchtig sind.


    Ich würde mal filesystemcheck auf alles machen und schauen was er da so meldet.


    LG
    gutemine

  • habe mir angewöhnt, filesystemcheck nach jedem Crash zu machen. Boote dann vom Flash und mache den Check über BA. Als Meldung steht immer nur dass ca. 4% nicht zusammenhängend sind.
    Ach ja, Festlatte habe ich keine, aber ein NAS. Habe aber auch die Probleme wenn ich es nicht gemounted habe.
    Sonst läuft alles bestens. Nur diese dummen Abstürze. Habe daher derzeit die Box staändig laufen, da Standby diese Probleme macht.


    lg



    Reinhard

  • Quote

    Original von gutemine
    wenn du die timers.xml verlinkst und der link deutet ins leere hat BA jetzt eine korrekturfunktion das eine leere timers.xml angelegt wird (weil sonst enigma2 crashed), kann sein das die noch einen bug hat da relativ neu. Wobei das nichts mit WW zu tun hat.


    Also erstmals sag mir ob du gesharte timers verwendest :-)


    Und wenn du neu link der timers.xml im BA auswählst sollte er erkennen wenn schon eine da ist und zu der wieder verlinken (aber zurückkopieren geht natürlich auch)


    Ich habe 2 7025er, und auf der einen hatte ich mal eingestellt gemeinsame Verwendung. Auf der anderen aber nicht und auf beiden ist der Effekt gleich.

    DM920UHD-S-C 2TB, DM7080SSCC 2TB/1TB, DM One S-C 2TB, LG OLED65B7D, Denon AVR-4000X,55LX9500. Yamaha RX-V685, Synology DS212J 6TB, ATC2TB,DS214-Play 8TB DX213 6TB

    Edited once, last by dreambox66 ().


  • Und wenn du vom Flash bootest hast du diese probleme nicht ?

  • beim Booten vom Flash habe ich diese Probleme nicht. Kann hundert mal vom Standby einschalten und die Box schmiert nicht ab. Habe dort auch alles eingerichtet, inkl. Mount.
    Hättest du noch eine Idee?

  • na ja sowas debuggen wird mühsam - normal müsstest du von CF booten, init 4 machen und enigma2 eingeben um es von hand zu starten im telnet und dann solange herumtun bis die box wieder einfriert und dann posten was du im telnet zuletzt als enigma2 output hattest.


    Benutzt du WW überhaupt - sprich ist der bootmanager disabled damit alles aus der FAT partition geladen wird statt vom Flash, oder fährst du mit bootmanager im klassischen BA Modus mit Kernel und Treibern vom Flash ?


    LG
    gutemine

    Edited once, last by gutemine ().

  • Quote

    Original von gutemine
    na ja sowas debuggen wird mühsam - normal müsstest du von CF booten, init 4 machen und enigma2 eingeben um es von hand zu starten im telnet und dann solange herumtun bis die box wieder einfriert und dann posten was du im telnet zuletzt als enigma2 output hattest.


    Benutzt du WW überhaupt - sprich ist der bootmanager disabled damit alles aus der FAT partition geladen wird statt vom Flash, oder fährst du mit bootmanager im klassischen BA Modus mit Kernel und Treibern vom Flash ?


    LG
    gutemine


    nochmals danke für deine Hilfe. Ich boote ohne Bootmanger. Wird eigentlich beim Booten alles von der CF in das Memory geladen und von dort gearbeitet, oder wird manchmal im Betrieb auf die CF zugegriffen? Frage deshalb, weil vielleicht habe ich ein Timingproblem mit der CF.
    Möchte nochmals einen Test machen und ein Image von der CF neu im Flash übers WebIF installieren. Kann ich das einfach so machen?


    lg


    Reinhard

  • nein, das betriebssystem greift wenn es sachen startet immer wieder auf den Flash und damit auch auf die CF Karte zu (dafür wird ja flash oder Cf gemountet). Natürlich kannst du nfi images die du von Images auf Cf erstellt hast auch wieder auf den PC FTPen und übers WebIF Flashen, das ist ja die Idee hinter einem nfi file.


    Ausprobieren kannst du das schon aber ich denke die werden im Flash genauso sauber laufen wie die anderen Images die du ausprobiert hast.


    Timing Probleme im Treiber am IDE bus kannst du eigentlich ja gar nicht haben wenn bei dir am IDE keine Festplatte hängt weil die CF Karte dann ja allein ist. Und wenn die auftreten müsstest du evt vorher mit dmesg schon kernel error kriegen wo er meldet das er IO Probleme hat.


    LG

  • wahrscheinlich hast du auch keinen Rat mehr. Soll ich eine andere CF-Karte testen? Vielleicht har sie hardwaremässig was.


    lg


    Reinhard

  • Irgendwann gehen auch mir die Ideen aus, also insofern ja ich weis nicht ob ich dir helfen kann.


    Ohne input oder wenn ich es nicht reproduzieren kann ist es halt auch schwer zum fixen. Ich bin nur kein Freund einfach irgendwelche Sachen auszuprobieren, statt die Ursache rauszufinden und diese zu fixen oder wenn das nicht geht zu vermeiden.


    Natürlich kannst du andere CF probieren, aber was soll es bringen wenn du nicht weist was der Grund für die Hänger ist ? Weil wenn es hilft - schön, glück gehabt, wenn nicht hast du nur unnötig Geld ausgegeben :-(


    LG
    gutemine


    PS: das andere Problem mit der verlinkten timers.xml sollte jetzt im BA 4.3 r4 (hoffentlich) gefixed sein.

    Edited 2 times, last by gutemine ().

  • Danke, ich weiß dass du helfen würdest. Habe das Ganze nochmals überprüft und das Image in den Flash gespielt, Geht nun einwandfrei, kann beliebig hintereinander in den Standby schalten. Hatte auch vorher das Problem, dass manchmal beim Zappen der gleiche Absturz passierte. Auch das ist weg. Treiber, Kernel alles ist gleich. Kann doch nur an der CF oder am Bus liegen.


    lg


    Reinhard

  • Habe mal ne Frage dazu.


    Ist mit BA und WW möglich Image 1 mit Treibern aus dem Flash zu starten und Image 2 mit den Treibern des Images 2.
    I1 und I2 wären dann auf der CF Karte.


  • Habe noch eine Frage bitte. Nach dem Flashen ist BA natürlich weg. Ist es richtig, dass ich nur BA nochmals installieren muss und nicht WW.


    Danke, Reinhard

  • Quote

    Original von Hamilton
    Habe mal ne Frage dazu.


    Ist mit BA und WW möglich Image 1 mit Treibern aus dem Flash zu starten und Image 2 mit den Treibern des Images 2.
    I1 und I2 wären dann auf der CF Karte.


    Ja - Im Prinzip schon du musst nur jeweils den bootmanager disablen und enablen, dann kannst du abwechselnd jedes Image mit Flash kernel und Treibern oder eigenem Kernel und treiber starten.


    Und zu anderen Frage, du brauchst WW eigentlich nur 1x zum Partitionslayout machen, sprich wenn du ein neus image in den Flash tust reicht BA nochmals zu installieren. Wobei WW auch so clever ist wie BA und erkennen würde das für Ihn nichts mehr zu tun ust (und die Cf karte lassen würde wie sie ist). Ausserdem muss man nach dem neuflashen auch schon seit einigen Releases nicht mehr das BA ipk nochmals installieren folgendes reicht:


    cd /media/cf
    ba.sh patch


    ABER es ist aber im falle der Verwendung von WW auf /media/cf nur das Fat, (und das mounten von /media/ba noch nicht in der fstab) womit du dann eben sehr wohl das ipk vom BA neu installieren müsstest


    wobei auch WW ipk neu installierne gehen würde wie oben schon erklärt, und dann nachher reicht wieder:


    cd /media/ba
    ba.sh patch


    Also nicht verwirren lassen, es kann den images eigentlich nichts passieren egal wie do es nach dem Flashen machst.


    PS: Und wenn doch hast du einen Bug gefunden den ich fixen muss :-)


    LG
    gutemine


  • habe versucht BA nochmals zu installieren. Kommt die Fehlermeldungm dass man vom Flash gebootet haben muss. Hab ich aber.

  • Ein nfi backup geflashed ?


    mach mal wenn du vom Flash gebootet bist:


    rm /.*info*


    Und dann probiere es nochmals

    Edited once, last by gutemine ().


  • Danke hat geklappt. Unglaublich was man alles wissen muss.


    lg


    Reinhard

  • GuteMine


    Mit Multiboot bin immer noch zufreiden, und da die Unabhängigkeit der einzelnen Images mir wichtig war, habe nie auf BA umgestellt.
    Nun wäre die Unabhängigkeit der Images mithilfe von WW ja möglich.


    Gibt es irgend eine Einschränkung oder Nachteil mit BA & WW gegenüber Multiboot ?

  • na ja das meiste habe ich schon am Anfang des Threads geschrieben, reicht das nicht als Erläuterung ?


    thowi hat halt nicht mehr viel lust am Multiboot weiterzubasteln und macht nur mehr das nötigste, neue sachen wird es also dort kaum mehr geben.


    Und nachdem Multiboot immer das squashfs wegschmeisst (macht auch sinn wenn du ext3 in eigenener Partition hast) brauchen halt die nfi backups recht lange.


    Und dadurch das die images keine eigenen Partitionen mehr haben hast du halt auch mit WW immer noch den chroot ansatz vom Barry Allen. Wem das stört der sollte aber keine OE 1.5 Images mehr benutzen, weil dort macht DMM das auch um aufs unionfs umzuswitchen. Durch die 1 Partiton hast du halt ein bischen mehr Risiko wenn deren Filesystem was weil dann alle images weg sein können hat - aber das problem hat FWZ auch - ab und zu hilft dann nur mehr neu formatieren - aber dafür kann BA ja in nfi sichern :-)


    LG
    gutemine

    Edited once, last by gutemine ().