AutoTimer Plugin

  • Ja die kann ich vom NAS restoren. Wird mir das am Abend anschaun mit welcher Version man nicht mehr speichern kann.

    -->
    openwrt + minicom + screen = 24/7 Bootlog

  • Der Diff vom web-data mit einem backup for 3 tagen:


    Ab welcher Version es nicht mehr geht... kann ich aber erst Zuhause am Abend testen. Bzw. morgen. Vielleicht geht es ja nur bei mir nicht. Gibt ja noch andere OE2.0 tester ;)

    -->
    openwrt + minicom + screen = 24/7 Bootlog

    Edited 3 times, last by Schnello ().

  • Quote

    Original von Schnello
    Kann es sein das man aktuell das save/check labeled series in filterlist: nicht mehr speichern kann? Ich aktiviere es und drücke speichern aber nach dem reload ist es immer abgewählt.


    OE2.0 letzte Version von hier aus dem Thead


    Also bei mir funktioniert das speichern unter OE2.0.
    Hab den Autotimer komplett neu installiert, und dann die letzte Version von diesem Thread installiert.


    Mit freundlichen Grüßen

  • Commodus
    Danke für's Gegenprüfen.


    Schnello
    Hast du das jetzt evtl. von einem anderen PC getestet?
    Änderungen der web-data benötigen meist einen echten Browser-Refresh, den man für solche Fälle wohl mit "STRG+F5" erreicht.
    Hatte ich vorher auch noch nicht gewusst.
    Das war der erste Tipp von betonme als ich letztens die Probleme mit dem webinterface hatte.

  • Sven H
    Free idea...
    Use parameter timer.series_filter_list for each timer instead "/etc/enigma2/autotimer_filter.txt".
    Sample - timer.tags

  • hier wieder ein kleines Update:
    - Anzeige des Inhalts der „autotimer_filter.txt“ jetzt im Plugin über die TV-Taste möglich
    - beim Ändern von Timern wurden im searchLog fälschlicherweise die Angaben des veralteten Timers (Beginn, Name) gelistet
    - entfernte Timer (bei aktivierter Option „nicht existierende Einträge entfernen“) werden jetzt auch im searchLog erfasst (zumindest rein theoretisch - ich konnte das Entfernen eines Timers noch nicht simulieren/provozieren)
    - es werden jetzt die letzten 5 Suchläufe im searchLog gespeichert (Anzeige im Plugin per Info-Taste) - in der Abschlussmeldung wird jedoch nur der letzte Suchlauf angezeigt


    Als Anlage die aktuellen Dateien für OE2.5 und OE2.0
    Wie immer nur verwenden, wenn bereits der AutoTimer 4.1.7 installiert ist !!!


    Ich bin wie immer für Tests und Rückmeldungen dankbar ;)

  • hier wieder eine kleine Ergänzung: ;)

    • inhaltlicher Fehler beim Schreiben der searchLog behoben
    • neue wählbare Optionen für die searchLog-Datei in den globalen Einstellungen:
      - Speicherort der searchLog (in „/tmp“ wird die searchLog bisher bei jedem Neustart gelöscht)
      Auswahlmöglichkeiten: <like autotimer.log>(defaut),</tmp>,</etc/enigma2>
      - max. savecount for last searches (wie viel letzte Suchläufe gespeichert bleiben sollen, min. 5 - max. 20)
    • im searchLog wird jetzt das Hinzufügen eines neues Timers mit (++) gekennzeichnet, wenn der Eintrag gleichzeitig auch zur Filterliste hinzugefügt wurde
    • erweitertes Auswahl-Menü beim Verlassen der Autotimer-Übersicht mit der Exit-Taste bzw. der roten Taste
      (ohne zu speichern), obwohl Änderungenan den AutoTimern vorgenommen wurden:
      - Schließen ohne speichern (bisherige Option)
      - Schließen und Speichern mit anschließendem Suchlauf (neue Option - analog Speichern mit grüner Taste)
      - Schließen und Speichern ohne sofortigen Suchlauf (komplett neue Funktion)
      - Abbrechen (bisherigeOption)


    Als Anlage die aktuellen Dateien für OE2.5 und OE2.0
    Wie immer nur verwenden, wenn bereits der AutoTimer 4.1.7 installiert ist !!!

  • Hallo Leute.


    Hab hier ein Problem.
    Erstelle einen Autotimer über das EPG und speichere den dann.
    Danach kann ich in dem erstellten Autotimer eintrag den Aufnahme Tag (zb: Dienstag) nicht mehr ändern.
    Muss den Autotimer eintrag löschen und neu anlegen.


    Gruß pepsifreak

    Gerüchte werden von Neidern erfunden, von Dummen verbreitet, und von Idioten geglaubt.

  • Wo liegt denn genau dein Problem?
    Passiert nichts beim Löschen oder kommt ein Fehler?
    Oder findest du die Stelle nicht, wo du den Wochentag löschen könntest?


    Für Letzteres:
    im entsprechenden Autotimer die Gelbe Taste für die Filter
    Dann bei „Filter“ auf „Wochentag“ wechseln mit rechts/links
    dann erscheint der Wochentag darunter und den kann man dann mit der gelben Taste löschen

  • Kurzes Feedback zur Version 4.1.7d funktioniert einwandfrei unter OE2.0


    @pepsifreak
    Den Aufnahmetag solltest du im Timer Editor mit links und rechts auf der Fernbedienung einstellen können.


    Mit freundlichen Grüßen

  • Commodus


    Danke für das Feedback.
    Freut mich, dass es auch unter OE2.0 keine Probleme macht. ;)
    Gar nicht so einfach die Version anzupassen, wenn man es selbst nicht testen kann.


    So langsam gehen mir die Ideen aus.
    Der nächste größere Schritt wäre dann wohl die Umstellung von Textfiles (searchLog + Filterfile) auf eine Datenbank.
    Aber dazu müsste vorher noch das SeriesPlugin angepasst werden, so dass die Daten der Serie (Serienname, Staffel, Episode, Folgenname) getrennt und vor allem variabel recherchierbar abgelegt werden können.

  • hier die nächste Stufe: ;)

    • Anzeige der Filterlisteneinträge in Listenansicht innerhalb des Plugin-Layouts mit folgenden Funktionen
      (bisher wurde nur der Inhalt der autotimer_filter.txt als Gesamttext angezeigt):
      - Löschen von Filterlisteneinträgen möglich (gelbe Taste)
      - Hinzufügen/Ändern von Einträgen vorbereitet (funktioniert noch nicht – blaue Taste/OK-Taste)
      - Sortierung der Filterlisteneinträge (über die TV-Taste):
      * alphabetische Sortierung der Filtereinträge (default beim Öffnen der Liste)
      * Originalreihenfolge der Filtereinträge in der autotimer_filter.txt
      * Sortierung nach der Timerzeit der Filtereinträge


    Als Anlage die aktuellen Dateien für OE2.5 und OE2.0
    Bitte nur verwenden, wenn bereits der AutoTimer 4.1.7 installiert ist !!!


    Edit: Version für OE2.0 neu bereitgestellt, da es beim Start des AutoTimer zu einem GS kam

  • Hallo Sven


    Mit Version AutoTimer_4.1.7e_OE2.0_SeriesPlugin_Filter bekomme ich wieder einen Greenscreen beim öffnen des Plugin über das Erweiterungs Menü
    Anbei der Auszug aus dem crashlog:



    mfg

  • Nur beim Öffnen über das Erweiterungsmenü?
    Also wenn du du das Plugin ganz normal über den Pluginbrowser startest, dann kommt kein GS?
    Edit: ich glaube, du meinst den Pluginbrowser, Erweiterungsmenü ist bei mir die blaue Taste, wobei ich da den AT von dort gar nicht starten kann ;)


    Für OE2.0 ist immer schwierig, da ich das sozusagen blind übertrage, ohne es testen zu können.
    Von daher bin ich da bei OE2.0 auf Tester angewiesen ;)


    Nachtrag:


    Lösche mal in der AutoTimerFilterList.py im oberen Bereich das [ , TemplatedListFonts ] (die Klammern sind nur hier zur Abgrenzung.
    Dann sollte die Zeile mit [ , parseFont ] enden


    Dann noch kurz darunter die beiden Zeilen löschen:


    tlf = TemplatedListFonts()
    self.l.setFonts(0, gFont(......


    Dann die Änderungen speichern und einen GUI-Neustart nachen ;)

    Gruß
    Sven

    Edited 2 times, last by Sven H ().

  • Hi Sven,
    ja ich meinte den Pluginbrowser.


    Hab deine Änderungen wie beschrieben ausprobiert, leider wieder mit einem Greenscreen.



    Seltsam das sich sonst noch niemand gemeldet hat der das oe2.0 update installiert hat.


    mfg