AutoTimer Plugin

  • Quote

    Original von latte
    Hi,


    betonme
    kannst du bitte eine Funktion in den Autotimer einbauen der verhindert das der Autotimer ausgeführt wird EPGRefresh läuft?
    Seit dem ich den Starttimeout auf 10 Minuten gesetzt habe wird die 7080hd nach EPGRefresh wieder ausgeschaltet.
    Wenn ich den Starttimeout wieder auf 3 Mimuten Stelle ist die 7080hd am anderen Morgen wieder an. Die 7080hd wird ja 5minuten vor dem EPGRefresh gestartet und dann 3 Minuten später der Autotimer irgendwie scheinen die sich in die Quere zu kommen.

    Schau ich mir mal an

  • Verstehe ich das richtig?
    Ihr wollt nicht, dass autotimer während eines epgrefresh, das inkludiert auch "nach der eigentlichen Durchführung, aber bevor der Aufruf fertig ist" läuft?
    Damit wäre die Funktionalität "Autotimer nach Aktualisierung" vom epgrefresh indirekt deaktiviert, und somit unnötig.


    Ich dachte mir, dass die aktuellen Probleme der beiden Plugins auf der 7080 "nur" durch ein threading-Problem entstanden sind, wieso dann dieser (kontraproduktive) Workaround? Der (vermutlich bessere) Workaround wäre ja schon beschrieben: Starttimeout vom Autotimer auf 10 Minuten, oder höher.

  • Quote

    Original von joe128
    Verstehe ich das richtig?
    Ihr wollt nicht, dass autotimer während eines epgrefresh, das inkludiert auch "nach der eigentlichen Durchführung, aber bevor der Aufruf fertig ist" läuft?
    Damit wäre die Funktionalität "Autotimer nach Aktualisierung" vom epgrefresh indirekt deaktiviert, und somit unnötig.


    Ich dachte mir, dass die aktuellen Probleme der beiden Plugins auf der 7080 "nur" durch ein threading-Problem entstanden sind, wieso dann dieser (kontraproduktive) Workaround? Der (vermutlich bessere) Workaround wäre ja schon beschrieben: Starttimeout vom Autotimer auf 10 Minuten, oder höher.

    Hi,


    nein nach dem EPGRefresh ist nicht betroffen. Es geht nur darum, das der AutoTimer nicht während dessen schon anfängt zu suchen und danach gleich nochmal.


    Gruß

  • Hi,


    es muss bei meiner Konfiguration irgendwo der Wurm drin sein. Immer wenn ich mehr als 30 Sekunden beim Transponderscan eingebe schaltet sich die 7080hd nicht richtig aus.
    Bleibe ich unter oder genau bei 30 Sekunden schaltet sich die 7080hd aus. Es spielt auch keine Rolle wieviel Transponder gescannt werden.
    Das komische ist aber wenn ein Durchlauf stattfand kann ich die Transponderzeit hochsetzen und dann geht die 7080hd auch aus, deshalb ist es fast unmöglich ein Log zu erstellen.
    Die Box ist aber soweit fertig das die Uhrzeit die während des Scans im Display zu sehen ist aus ist und nur noch die LEDs der Tuner leuchten.
    Per Telnet kann ich auch rebooten also scheint die Box nicht komplett zu hängen.

  • Moin zusammen,


    ich hätte das gern mal ein Problem, das mir hier ziemlich Arbeit gemacht hat ... :frowning_face:


    Und zwar hat AutoTimer mir beim jeweils ersten Aufruf der AutoTimer-Config über "Menü" -> "Erweiterungen" -> "AutoTimer" fast regelmässig gesagt, dass meine Konfigurationsdatei defekt sei. Im freundlicheren Fall wurde der Aufruf dann abgebrochen und wieder die Liste der Erweiterungen angezeigt. Startete man AutoTimer unmittelbar darauf noch ein zweites Mal, wurde die Liste ganz normal geladen und die Einträge konnten auch normal bearbeitet werden. Auch wurden die Timer korrekt gefunden und in die Timer-Liste eingetragen.


    Im unfreundlicheren Fall waren nach der Meldung gerne mal alle AutoTimer weg. Unschön. Vorsichtig formuliert. :frowning_face:


    Nun denn, die Fehlermeldung:


    Konfigurationsdatei defekt - not well formed (invalid token) in line 5 column 68


    An dieser Stelle war in der autotimer.xml aber (auf den ersten Blick) nix Tragisches, nur ein Boolscher Operator, und der kann ja kaum das Problem sein - so dachte (und irrte) ich.


    Anyway - nach viel Hin und Her konnte ich den Fehler sogar ganz ohne AutoTimer-Einträge reproduzieren. Und zwar kommt AutoTimer anscheinend nicht mit Sendereinschränkungen auf ein Bouquet á la "Satellit" und "Kabel - Kanäle FTA" klar.


    Szenario: Man nehme eine beliebige autotimer.xml, egal ob mit oder ohne Timer, also gern auch default. Dann gehe man in die AutoTimer-Voreinstellungen -> [Sender bearbeiten] -> "Sender-Beschränkungen: aktivieren" -> "Bearbeiten: Bouquet" -> [Neu] -> [Satelliten] -> "Kabel - Kanäle FTA" -> [Ok] -> [Ok] -> [Speichern]


    Hierbei wird eine autotimer.xml geschrieben, die in etwa so aussieht:

    XML
    <?xml version="1.0" ?>
    <autotimer version="7">
    
    
     <defaults avoidDuplicateDescription="3">
      <bouquet>1:7:0:0:0:0:FFFF0000:0:0:0:(satellitePosition == 65535) && (numCAIDs == 0) && (type == 1) || (type == 17) || (type == 22) || (type == 25) || (type == 134) || (type == 195) ORDER BY name:Kabel - Kanäle FTA</bouquet> <!-- Kabel - Kanäle FTA -->
     </defaults>
    
    
    </autotimer>


    Startet man die AutoTimer-Config mit dieser .xml, kommt obiger Fehler.


    Wäre schön, wenn das behoben werden könnte ... :)


    Danke!


    Cheers, Magpie


  • Aber

    Code
    epgrefresh.isRunning()

    müsste auch nach dem Aufruf vom Autotimer noch true liefern. Also denke ich schon, dass dies davon betroffen ist.

  • Danke für die gute Vorarbeit.


    Kannst du bei Dir folgende Änderung testen.
    Danke

  • Done. Tut. :winking_face:


    :danke:


    Frei nach Wilhelm Busch ("Ein Wunsch erfüllt, kriegt automatisch Junge") wäre es jetzt noch besonders schön, wenn das WebPlugin damit auch umgehen könnte. :)


    Zwar löscht es die autotimer.xml nicht mehr sofort, seit die Ampersands als HTML Sonderzeichen codiert sind, aber es liest sie auch nicht ein (ewiger Wartekringel).


    Ach ja: Beim Anlegen/Editieren eines Timers kann man (auch vorher schon) als Einschränkung auf's Bouquet lediglich "Favourites (TV)" auswählen, nicht aber die restlichen, im DM-GUI möglichen wie "Aktueller Transponder", "Kabel - Kanäle", "Kabel - Kanäle FTA", "Kabel - Anbieter", "Kabel - Neu" (wobei mich derzeit lediglich "Kabel - Kanäle FTA" interessieren würde :)).


    Cheers, Magpie

  • Das dachte ich mir schon.


    Mit Endlos Laden, meinst du schon das WebInterface, wenn du den entsprechenden AutoTimer öffnen willst?


    Teste mal mit der Version im Anhang.


    Was sendet Dir dein Receiver. Im Chrome EntwicklerKonsole mit F12 öffnen, dann Network Tab auswählen: Im WebIf den AutoTiemr auswählen, jetzt muss im Network Tab eine neue Anfrage mit Antwort zu sehen sein:


    Paket auswählen, Rechte Seite den Inhalt des Tabs Response kopieren - Danke



  • Testen würde ich gerne, aber entweder sehe ich ihn nicht, oder da ist kein Anhang ... :)


    Mit endlos warten meinte ich nicht einen einzelnen Timer, denn die Liste wird gar nicht erst angezeigt.
    Ich bekomme lediglich die Titelzeile - die beiden Rahmen für Liste und Details bleiben beide klein und leer.
    Das könnte aber auch daran gelegen haben, dass ich das erste &amp; gleich schon in den Voreinstellungen stehen habe, also noch vor dem ersten Timer-Eintrag.


    Web-IF testen kann ich erst, wenn ich wieder daheim bin. Muss dann nur mal schauen, wo sich das im Firefox versteckt.


    Cheers, Magpie

  • Moin,


    für die Akten: In Firefox <Alt> -> "Tools" -> "Web Developer" -> "Network"


    Die neue AutoTimerConfiguration.py hat keinen Unterschied zu der von gestern gebracht, das WebIF bleibt leer (siehe Anlage), im übrigen unabhängig davon, ob in den Defaults das Bouquet "Kanäle - FTA" drinsteht oder nicht sowie egal welcher Timer es verwendet. Sobald es irgendwo in der autotimer.xml vorkommt, lädt das WebIF sie nicht mehr.


    Hier der (leicht gekürzte) Output:



    Cheers, Magpie


    P.S.: Auswahl eines anderen Bouquets als "Favourites (TV)" geht nach wie vor nicht (mit "herkömmlicher" .xml getestet)

  • Hi,


    hab es bei mir mal ausprobiert.


    Mit der 7080 habe ich diese Probleme nicht.


    Teste mal die Änderungen aus dem Anhang.


    Wenn du die Browser Konsole offen hast, bekommst du da irgendwelche Fehler, beim Öffnen der entsprechenden AutoTimer?

  • Aaalso ... mit der letzten .py werden die AutoTimer jetzt auch im WebIF eingelesen und angezeigt, allerdings nicht ganz korrekt:
    Sobald eine wie auch immer geartete Bouquet-Einschränklung (BE) definiert ist (per AutoTimer-GUI an der DM), steht im WebIF immer "Favourites (TV)" drin.
    Insbesondere z. B. die BE "Kabel - Kanäle FTA" taucht im WebIF nirgendwo auf, weder in der Anzeige einer damit bestehenden BE, noch in der Auswahl-Liste.
    Und nach einer Änderung an dem Timer wird die BE auch auf "Favourites (TV)" umgebogen.


    Fehlermeldungen gibt's keine - oder zumindest keine, die sich mir offenbaren würden. :)


    Was mir noch aufgefallen ist: Das WebPlugin schreibt auch die "normale" BE anders zurück, als es sie einliest. Selbst wenn man an der BE selber nix geändert hat,
    wirft es z. B. die Zeichenkette "(type == 1) :tired_face: (type == 17) :tired_face: (type == 22) :tired_face: (type == 25) :tired_face: (type == 134) :tired_face: (type == 195)" weg.


    Beispiel vorher:

    Code
    <timer name="Snooker" match="Snooker" enabled="yes" avoidDuplicateDescription="3" overrideAlternatives="1">
      <bouquet>1:7:1:0:0:0:0:0:0:0:(type == 1) || (type == 17) || (type == 22) || (type == 25) || (type == 134) || (type == 195) FROM BOUQUET &quot;userbouquet.favourites.tv&quot; ORDER BY bouquet</bouquet> <!-- Favourites (TV) -->
      <tag>Snooker</tag>
     </timer>


    nachher:

    Code
    <timer name="Snooker-Test" match="Snooker-Test" enabled="yes" avoidDuplicateDescription="3" overrideAlternatives="1">
       <bouquet>1:7:1:0:0:0:0:0:0:0:FROM BOUQUET &quot;userbouquet.favourites.tv&quot; ORDER BY bouquet</bouquet> <!-- Favourites (TV) -->
      <tag>Snooker</tag>
     </timer>


    Mal noch ne Frage: Wo schreibt das WebIF die Timer eigentlich hin? In /etc/enigma2/autotimer.xml landen sie nämlich erst nach einem Neustart der DM
    bzw. nach dem Aufruf (und Prüfung der Timer) per AuoTimer-GUI an der DM (meine ist übrigens eine 7020HD).
    Ich vermute mal, dass AutoTimer die cached? Kann ich die noch irgendwie flushen?


    Cheers, Magpie


    P.S.: Ich bin ab morgen ne Woche offline, also bitte nicht wundern, wenn nix mehr kommt, ich melde mich dann spätestens nächstes Jahr. :winking_face:
    Und falls wir uns nicht mehr lesen sollten: Bis hierher schon mal herzlichsten Dank und allerseits ein Frohes Fest und Gutes Neues Jahr! :feier:

  • Hi, immerhin nähern wir uns der Lösung an.


    Die autotimer.xml wird grundsätzlich beim Herunterfahren von E2 gespeichert.
    Zusätzlich nach jeder Suche und wenn man den Editor mit Speichern verlässt.
    Zukünftig auch, bevor man das Backup über das WebIf herunterlädt.


    Fehlermeldungen von JavaScript würde man in der Konsole sehen, ein Popup gibt es nicht.


    Update:
    Versuche mal bitte folgendes.


    Erstelle einen neuen AutoTimer mit der GUI nicht mit dem WebIf!
    Füge als Filter dein Bouquet "Kanäle Test FTA" hinzu.
    Öffne mit dem Browser:
    http://box_ip_or_name/autotimer


    Und schicke mit bitte das Ergebnis oder zumindest den Ausschnitt mit dem Bouquet.


    Danke

  • Kann es sein, dass AutoTimer unter OE2.2 ein Hochkomma Problem hat?


    Ich habe die selbe autotimer.xml genommen.
    Auf der 8000 suchen lassen und auf der 7080HD.
    Alle Sendungen die ' enthalten wurden von AutoTImer unter OE2.2 nicht im EPG gefunden. Auch nicht über Einstellungen -> Vorschau, obwohl vorhanden


    Fiel eigentlich hier auch UTF-8 Auswahl raus?

    Best Enigma2 Plugins:
    TV Charts Plugin, EPGRefresh, AutoTimer, VPS Plugin, SeriesPlugin

  • Quote

    Original von muelleimer321
    Kann es sein, dass AutoTimer unter OE2.2 ein Hochkomma Problem hat?


    Ich habe die selbe autotimer.xml genommen.
    Auf der 8000 suchen lassen und auf der 7080HD.
    Alle Sendungen die ' enthalten wurden von AutoTImer unter OE2.2 nicht im EPG gefunden. Auch nicht über Einstellungen -> Vorschau, obwohl vorhanden


    Fiel eigentlich hier auch UTF-8 Auswahl raus?

    Hi, auch die EPG Suche im WebInterface hat das Problem. Gib das mal bitte an DMM weiter? Danke