NFS Testergebnisse

  • Quote

    Original von bughunter
    Das hat nichts mit dem Netzwerk zu tun bei Gruftolm, das ist ein bekannter Bug im Kernel 2.6.18 . Benutz mal die Boardsuche dazu.....


    DMM sollte es fixen mit einem neuen Kernel am besten, wir warten ja schon ewig während andere schon bei 3.1 sind.......... ;)


    Danke.


    Dann kann ich ja noch Jahre probieren.

    7020HD mit OE 2.0 und HDD WD 2 TB intern
    500HD mit ICVS und HDD WD 2 TB extern sata
    800HD mit OE 2.0 und HDD WD 500 GB extern USB

  • Quote

    Original von gruftolm
    DB8000 und DB800se:
    Mit Images vor 3.2.x gab es bei allen Einstellungen mit "udp" geruckel und mit "tcp" lief es einwandfrei.
    und mit Images ab 3.2.x ist es noch genau so. Hier muß bei mir "tcp" im Protokoll stehen, sonst ruckelt es.


    Das ist normal, upd schmeißt die Pakete ins Netzt ohne auf eine Bestätigung zu warten.
    TCP bestätigt alle Pakete und sollte deshalb für sichere Datenübertragung benutzt werden, also auch grundsätzlich für NFS V3. Udp kann man für mini Anfragen an DNS oder Time Server also für relativ unwichtige Mini Pakete benutzen , aber egal googel mal nach Unterschied TCP / UDP.
    Ansonsten sind deine Ergebnisse echt gut, denn sie zeigen ein Problem mit Kernel 2.6.18 mit NFS und TCP die es auch bei Red Hat gab. Vielleicht liegt dieses Problem ja hier auch vor. Aber das finden die Jungs von DreamMultimedia bestimmt bald.

    ===> Keine Support per PN <===

    ===> Pay-TV entschlüsseln ohne ein gültiges Abo ist illegal <===

  • Results for write throughput:
    76.695 Mbit/s with udp,async,wsize=16384
    76.695 Mbit/s with tcp,async,wsize=16384
    67.108 Mbit/s with udp,async,wsize=8192
    67.108 Mbit/s with udp,async,wsize=32768
    67.108 Mbit/s with tcp,async,wsize=32768
    59.652 Mbit/s with tcp,async,wsize=8192
    44.739 Mbit/s with udp,async,wsize=4096
    41.297 Mbit/s with tcp,async,wsize=4096


    Results for read throughput:
    89.478 Mbit/s with tcp,async,rsize=8192
    89.478 Mbit/s with tcp,async,rsize=4096
    89.478 Mbit/s with tcp,async,rsize=32768
    89.478 Mbit/s with tcp,async,rsize=16384
    67.108 Mbit/s with udp,async,rsize=8192
    67.108 Mbit/s with udp,async,rsize=32768
    67.108 Mbit/s with udp,async,rsize=16384
    53.687 Mbit/s with udp,async,rsize=4096



    Am besten also tcp und 16384 für wsize und rsize, richtig?

    7020HD mit OE 2.0 und HDD WD 2 TB intern
    500HD mit ICVS und HDD WD 2 TB extern sata
    800HD mit OE 2.0 und HDD WD 500 GB extern USB

    Edited once, last by AltGr ().

  • Laut Werten ja.


    Kannst ja noch was anderes Probieren.
    Die optimalen Einstellungen werden
    normal automatisch ausgehandelt.


    Enferne rsize und wsize und tcp aus
    der auto.network.


    Starte Box neu und geht dann mit telnet
    nach /media/net/deinmountpunkt


    Dann gibt mount ein und poste mal die
    Ausgabe. Dann siehst was ausgehandelt wurde
    und vergleich es einmal deinen obigen Werten.


  • Und was wurde nun ausgehandelt?

    7020HD mit OE 2.0 und HDD WD 2 TB intern
    500HD mit ICVS und HDD WD 2 TB extern sata
    800HD mit OE 2.0 und HDD WD 500 GB extern USB

    Edited 2 times, last by AltGr ().

  • Quote

    Original von AltGr


    Und was wurde nun ausgehandelt?


    Du musst in das Verzeichnis telneten,
    sonst wird der mount wieder ausgehängt nach 5 Sekunden.

  • Quote

    Die optimalen Einstellungen werden normal automatisch ausgehandelt. Enferne rsize und wsize und tcp aus der auto.network. Starte Box neu und geht dann mit telnet nach /media/net/deinmountpunkt Dann gibt mount ein und poste mal die Ausgabe. Dann siehst was ausgehandelt wurde und vergleich es einmal deinen obigen Werten.


    Quote

    Du musst in das Verzeichnis telneten, sonst wird der mount wieder ausgehängt nach 5 Sekunden.


    Lieber mfgeg,
    könntest Du das Verfahren bitte noch mal erklären, ich komme mit den telnet-Befehlen nicht klar. Habe es mit putty und DCC versucht.


    Vielen Dank!

    Meine aktuellen Boxen: DM 7080 HD, DM 500 HD mit USB, 2x 820 HD, VU+ solo²;
    ausgemustert: DM 7020, DM 500s, DM 800 HD, Xtrend 4000

  • NFS Testergebnisse


    Einfach in die Netzwerkmount gehen mit
    ftp, oder telnet, oder dem Dateibrowser, damit man den Inhalt sieht vom NAS.


    Dann ein mount machen via telnet.
    Und eben die Optionen müssen natürlich aus der auto.network raus,
    wie Protokoll und rsize und wsize Werte.


    Und dann kann man kucken und vergleichen mit dem NFS Test.

  • sorry mfgeg,
    ich bin dazu zu blöd :-)


    wenn ich per telnet in das Verzeichnis
    /media/net/NAS-Filme
    gehen will, dann bekomme ich ein "Permission denied".


    Ich blicke im Moment gar nicht mehr durch:

    Quote

    Einfach in die Netzwerkmount gehen mit ftp, oder telnet, oder dem Dateibrowser, damit man den Inhalt sieht vom NAS.


    Vom PC aus komme ich per ftp (speedcommander) auf den Ordner media/net/ NAS-Filme und sehe den Inhalt. So weit so gut. Aber warum das erforderlich ist, verstehe ich nicht.


    Quote

    Dann ein mount machen via telnet.


    Damit komme ich nicht klar.
    Und was hat der telnet-Befehl (putty) mit ftp aus Schritt 1 zu tun?


    Quote

    Und eben die Optionen müssen natürlich aus der auto.network raus, wie Protokoll und rsize und wsize Werte.


    das hatte ich zuvor gemacht.



    Irgendwie sitze ich auf der Leitung.......

    Meine aktuellen Boxen: DM 7080 HD, DM 500 HD mit USB, 2x 820 HD, VU+ solo²;
    ausgemustert: DM 7020, DM 500s, DM 800 HD, Xtrend 4000

  • Hmm das ist aber nicht gut, wenn du eine Fehlermeldung kriegst.
    Die auto.network muss natürlich schon so sein, dass du das Gerät mounten kannst.


    Hier geht das ohne Probleme um in das /media/net/NAS Verzeichnis zu hüpfen,
    via telnet. Eben man kann auch mit der Box und einem Dateibrowser oder ftp in das Verzeichnis gehen.


    Mann muss einfach in einem /media/net/xxx Verzeichnis stehen, sonst wird nicht gemountet
    und dann sieht man leider auch keine mount Optionen.

  • na egal, ich gebe es auf für heute


    cu

    Meine aktuellen Boxen: DM 7080 HD, DM 500 HD mit USB, 2x 820 HD, VU+ solo²;
    ausgemustert: DM 7020, DM 500s, DM 800 HD, Xtrend 4000

  • Das hat der test ergeben:



    Das wird ausgehandelt, wenn ich nichts eintrage in der auto.network:


    Quote

    192.168.0.35:/i-data/d3b7cfaf/nfs/Wohnzimmer on /media/net/WOHNZIMMER type nfs (
    rw,vers=3,rsize=16384,wsize=16384,soft,nolock,proto=udp,timeo=7,retrans=3,sec=sy
    s,addr=192.168.0.35)


    Ist es nicht besser, dass stets automatisch aushandeln zu lassen?
    Oder soll ich udp, 16384 manuell eintragen?

    7020HD mit OE 2.0 und HDD WD 2 TB intern
    500HD mit ICVS und HDD WD 2 TB extern sata
    800HD mit OE 2.0 und HDD WD 500 GB extern USB

  • update gemacht (experimental) ?

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Besser oder nicht. Du siehst ja anhand der
    Werte, dass nicht verkehrtes gemacht wird.


    Also kannst du getrost das automatisch machen lassen.


    Und du siehst auch, wenn man dem Test glaubt, dass
    falsche Werte schlechtere Performance geben würden.


    Also wenn es damit klappt, sehe ich keinen Sinn, daran was zu ändern,
    oder manuell einzutragen.

  • Quote

    Original von emanuel
    update gemacht (experimental) ?


    Meinst Du mich?

    7020HD mit OE 2.0 und HDD WD 2 TB intern
    500HD mit ICVS und HDD WD 2 TB extern sata
    800HD mit OE 2.0 und HDD WD 500 GB extern USB

  • Hallo,


    ich denke mein script läuft. Bei mir kommt nur nicht dieses Ergebnis. Bei mir sieht das so aus:


    root@dm800:/usr/script# ./Speed.sh


    Measuring NFS throughput...
    Mount options: udp, async, wsize=4096
    writing 64 MBytes...
    Success after 14 seconds
    Mount options: udp, async, rsize=4096
    reading 64 MBytes...
    Success after 12 seconds


    Mount options: tcp, async, wsize=4096
    writing 64 MBytes...
    Success after 16 seconds
    Mount options: tcp, async, rsize=4096
    reading 64 MBytes...
    Success after 14 seconds


    Mount options: udp, async, wsize=8192
    writing 64 MBytes...
    Success after 9 seconds
    Mount options: udp, async, rsize=8192
    reading 64 MBytes...
    Success after 9 seconds


    Mount options: tcp, async, wsize=8192
    writing 64 MBytes...
    Success after 12 seconds
    Mount options: tcp, async, rsize=8192
    reading 64 MBytes...
    Success after 12 seconds


    Mount options: udp, async, wsize=16384
    writing 64 MBytes...
    Success after 7 seconds
    Mount options: udp, async, rsize=16384
    reading 64 MBytes...
    Success after 16 seconds


    Mount options: tcp, async, wsize=16384
    writing 64 MBytes...
    Success after 11 seconds
    Mount options: tcp, async, rsize=16384
    reading 64 MBytes...
    Success after 9 seconds


    Mount options: udp, async, wsize=32768
    writing 64 MBytes...
    Success after 7 seconds
    Mount options: udp, async, rsize=32768
    reading 64 MBytes...
    Success after 56 seconds


    Mount options: tcp, async, wsize=32768
    writing 64 MBytes...
    Success after 9 seconds
    Mount options: tcp, async, rsize=32768
    reading 64 MBytes...
    Success after 9 seconds


    Results for write throughput:
    sed: bad option in substitution expression
    Results for read throughput:
    sed: bad option in substitution expression



    Kann mir da jemand sagen was ich falsch mache?


    Danke