Very Simple Flashing Assistant DM600PVR DM500+

  • Vorraussetzung:
    Box hängt an einem DHCP Server, oder der Box wurde über das Bios eine fixe IP erteilt!

    Für Windows XP mit .netFramework 2.0



    Wie immer auf eigene Gefahr und etwas, wirklich etwas, Geduld



    ´07 (c) mordillo


    //edit 23.09.2007 - Reboot funktionalität hinzugefügt


    //edit 24.09.07 Anhang wegen Überarbeitung vorübergehend entfernt


    //edit 25.09.07 Datei wieder angehängt


    //edit 03.11.2007 goes to VSFA - 600pvr_500plus
    IP Checker (Abfrage welche IP´s im Netz aktiv sind) und ein paar Design Ups eingebaut


    //edit 05.11.07 Sprachselektor Deutsch-English hinzugefügt


    //edit 17.12.07 2 kleine Bugs behoben

  • warum nennst du es Flashassistent (nur) für 600 ?


    Auf der 7025 (und wahrscheinlich auf der 7020 auch) funktioniert er genauso da du ja praktisch nur das bestehende WebIF aufrufst, rm /boot/* machst und dann rebootest !


    Im Prinzip funktionert es also für jede OE basierende Box wo der secondstageloader wenn er keinen kernel findet aus verzweiflung das FlashWebIF aufruft.


    Und noch kleiner Tipp zum weiter verhübschen - wenn das Flashen fertig ist kannst du dich nochmals mit telnet einloggen und wenn du die richtigen Keysequenzen schickst (4x nach rechts 4x runter und dann Enter damit Save Settings und reboot ausgewählt ist) kannst du am Schluss auch noch einen Reboot after Flash Knopf im Assistenten dazumachen :-)


    Und so könntest du auch die fixe IP Adresse vom Assistenten aus einstellen.


    LG
    gutemine2

    Edited 9 times, last by gutemine ().


  • Jo, das mit den anderen Boxen ist klar, aber da gibt es ja andere adäquate Möglichkeiten.


    Mit dem reboot nach dem flashen wollt ich machen, war mir aber zu albern ;) Das sollte dann noch jeder hinbekommen.


    Fixe IP geht so nicht, da ja beim ersten mal die IP vom DHCP kommen muss... Wohin sollte man sich dann per telnet verbinden...

    Meine Rechtschreibfehler unterliegen der GPL

  • Hast recht, manchmal (immer ?) denke ich nicht nach - ohne ip keine ip sozusagen ;-)


    Und die Couch potatoes die nicht gerne aufstehen und die Box ein/ausschalten und zu dumm sind selber mit telnet die box remote neuzustarten würden es dir wahrscheinlich danken wenn es auch einen restart knopf nach dem reboot im Tool gäbe.


    PS: Barryallen 4.0 kriegt das Feature die 600er und die anderen Boxen wo er läuft (702*) so in den WebIF Flash modus zu zwingen übrigens auch, wobei man es da eigentlich dann nicht mehr braucht weil gleichzeitg wird der 4.0 dann auch extract eines nfi image in den Flash können (muss man aber schon von CF gebootet sein - sich selbst überschreiben geht zwar theoretisch, ist mir aber zu mühsam) :-)


    LG
    gutemine2

    Edited 2 times, last by gutemine ().

  • Quote

    Original von mordillo
    Vorraussetzung:
    Box hängt an einem DHCP Server, oder der Box wurde über das Bios eine fixe IP erteilt!
    Für Windows XP mit .netFramework 2.0


    Hi,


    ebenfalls getestet mit Windows Vista 64Bit und meiner DM600 aber auch mit meiner DM7025. "Alles nicht OK..." Sorry, Asche auf mein Haupt. Ich komme zwar in Vista auf das WebInterface aber beim Aufrufen des Flashinterface kommt eine Fehlermeldung. Danach muss ich das Programm im Taskmanager beenden. Also mit Vista funktioniert es leider nicht.


    Und noch ein Nachtrag: nachdem ich erfolglos mit Vista versucht habe die DM600 zu flashen startete die Box auch nicht mehr. Trotz Box kurzfristig vom Netz zu trennen blieb nur noch die rote Kontrollampe an und der Bildschirm blieb dunkel. Betriebssystem am PC auf XP gewechselt und das Tool wieder gestartet, und... es erscheint das Flashinterface ohne Wartezeit und ich konnte sofort das Image erfolgreich flashen.



    romeo-golf

  • Ich habe das Tool mehrfach getestet und ich finde das es unter XP und für die 7020 richtig gut funktioniert. Eine automatische Reboot-Sache fände ich persönlich trotzdem gut, würde das ganze Abrunden und Komplett machen, zumal man dann auch wirklich den Komfort hätte, nicht aufstehen zu müssen.

  • Es scheint, nach Updates durch Microsoft, jetzt auch mit Vista problemlos zu laufen. Jedenfalls konnte ich mit dem Assistenten unter Vista die Box ohne Komplikationen flashen. Nur so zur Info.

  • Könnte man mit dieser Methode auch ein Backup einer 7020 auf die 600 er einspielen?
    Grüsse

  • Denke nicht, denn man kann ja auch keine Windows-Installation von Rechner a auf Rechner b portieren, wenn die beiden Rechner nicht identisch aufgebaut sind...
    Und da 7020 != 600 wirds wohl mit keiner Methode klappen!

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Quote

    Original von mattys
    Könnte man mit dieser Methode auch ein Backup einer 7020 auf die 600 er einspielen?
    Grüsse


    Wie m0rphu schon sagte: Das geht überhaupt nicht (Wenn es um ein komplett Image geht) Settings und so geht schon, aber nicht hiermit.

    Meine Rechtschreibfehler unterliegen der GPL

  • na ja mit Barry Allen kannst du ein 7020 Image auf der harddisk der 600er auspacken falls du (mehr als) settings, etc da raus klauen willst - aber booten würde ich es nicht :-)

  • Ok,dann werd ich mich mal dranmachen wieder alles genauso zu installieren wie es auf der 7020 läuft.Ich dachte nur das eszwischen den 600er und 7020 keine Riesenunterschiede gäbe.Schade ist nur das man ganze 2 h daran wieder sitzt alles wieder so zu confen..(samba/sämtliche flexmenüscripte,plugins,setting....u.s.w.)
    Ich dachte es würde dran scheitern das es mit fw erstellt ist.... :tongue:
    Aber eine Frage hab ich trotzdem noch.Ich habe bei meinem Router DHCP deaktiviert.Ich habe der 600er im Menü/Netzwerk....eine feste IP verpasst.Wenn ich nun das Tool und auf Verbindungstest gehe.komme ich sofort aufs WI der Box.Also müsste ich sie auch ohne weiters flashen können...oder nicht richtig?Weil im Bios der Box hab ich noch nix eingestellt.Oder weiss die Box nach dem reboot dann nicht mit welcher IP sie das WI öffnen soll?Hoffe hab mich einigermassen ausgedrückt.
    Grüsse

  • das WebIF der box wenn sie gebootet ist und das zum Flashen ist nicht das gleiche (1x vom enigma1, 1x im Bios integriert), wenn du aber DHCP verwendest kriegt die box aber wahrscheinlich in beiden Fällen die selbe IP adresse und du hast keine Connection probleme. Auf der 600er ist es halt nicht so einfach am LCD nachzusehen welche IP sie gekriegt hat :-)

  • Hallo


    ich hab folgendes Problem
    ich hatte meine 600 zum hädler zurückgeschickt, weil sie nicht mehr hochgefahren ist und ich sie nicht mehr flashen konnte.
    jetz hab ich sie zurück und sie funzt auch soweit, mit orginalem dmm image.
    ich würde aber natürlich gerne gemini drauf haben.
    also wollte ich sie seriell flashen mit dreamUp. aber wenn ich die box an den strom gebe kommt in dream up nur "Found injectible at position usw." und nichts rührt sich mehr (normalerweise sollte ja der bootloader auf die box geladen werden und ein fenster zum image auswählen kommen.... oder?)


    weiß da jemand weiter?


    könnte es sein dass irgendwas mit der RS232 nicht stimmt?


    braucht man bei diesem Tool hier keine verbindung über RS232?
    Nur Verbindung über LAN?


    ich wollte es ausprobieren, aber bei der sicherheitsabfrage hab ich irgendwie muffensausen bekommen, ich hab kein bock die box nochmal einzuschicken (3-4 wochen ohne dream)


    was meint ihr? soll ich dieses tool mal ausprobieren? besteht da eine gefahr?


    vielen dank schon mal


    mfg sir quickly

  • Das Tool kommt zwar komplett ohne R232 aus, aber es löscht den bisherigen Bootloader! D.h. wenn etwas schief geht, brauchst du auf jeden Fall ein Nullmodemkabel um das Image mit DreamUp auf die Box zu flashen.
    Wenn du einen DHCP-Server in deinem Netzwerk hast (z.B. ein Router) sollte es mit dem Tool klappen. Bevor du das aber probierst würde ich sicherstellen, dass dein R232-Port nicht defekt ist (oder hast du einen USB-R232-Adapter? damit gibts wohl die meisten Probleme) und dein Nullmodem-Kabel auch in Ordnung ist.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • vieln dank schon mal für die schnelle antwort


    ich benutze schon einen usb adapter... aber als ich die box neu bekommen hab funzte das flashen mit demselben usb-adapter und nullmodemkabel...
    ich schau jetz mal dass ich einen pc mit "richtigen" COM Port auftreibe, um den usb adapter ausschließen zu können.
    greetz
    sir quickly

  • Hallo ich würde gerne dasProgramm ausprobieren, habe es runtergeladen aber es funktioniert nicht. Bekomme nur eine fehlermeldung programm konnte nicht inizilisiert werden. Was kann ich machen ?? Oder mache ich etwas flasch?

  • Welches Betriebssystem haste? Hast du das .Net-Framework 2.0 installiert?

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul: