Lost in Translation

  • Na dann melde ich mich doch mal hier...
    Also habe jetzt diverse Funktionen ausprobiert... Leider klappt doch noch nicht alles so problemlos, wie ich zuerst dachte....
    Zum einen, kann ich die box nur per reboot befehl im telnet dazu bewegen wieder was anzuzeigen, nachdem BA die Meldung "Barry Allen restarts Enigma2 now..." kommt... Sind wahrscheinlich nur Probleme mit irgendwelchen Befehlen...
    Außerdem konnte ich die Funktion timers nicht nutzen, da BA nach enigma2-Pfaden sucht, die unter E1 natürlich nicht existieren...
    P.S.: Habe allerdings noch die r5 in Betrieb...

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Quote

    Original von m0rphU
    Na dann melde ich mich doch mal hier...
    Also habe jetzt diverse Funktionen ausprobiert... Leider klappt doch noch nicht alles so problemlos, wie ich zuerst dachte....
    Zum einen, kann ich die box nur per reboot befehl im telnet dazu bewegen wieder was anzuzeigen, nachdem BA die Meldung "Barry Allen restarts Enigma2 now..." kommt... Sind wahrscheinlich nur Probleme mit irgendwelchen Befehlen...
    Außerdem konnte ich die Funktion timers nicht nutzen, da BA nach enigma2-Pfaden sucht, die unter E1 natürlich nicht existieren...
    P.S.: Habe allerdings noch die r5 in Betrieb...


    Ja, die engima restarts sind ja eigentlich auch fürs enigma2, die Enigma1 restarts funktionieren daher noch nicht so ganz - stoppen schon, starten nicht :-(


    Kannst du von hand enigma1 auf deiner box sauber mit init 4 stoppen und mit init 3 das enigma wieder starten ?


    Und ja timers sharen geht unter enigma1 (noch) nicht, weil unter E1 die Aufnahme ja nicht in eine timers.xml geschreiben werden aber dafür testen wir ja jetzt auch hier auf breiter basis, weil diese Sachen zu eliminieren ist nicht wirklich schwer.


    Wenn du mir also sagst wie das timer file unter E1 heisst und wo es liegt ist das aber schnell eingebaut, genauso der richtige e1 restart (bis dahin hilft immer reboot).


    Und für backup/restore legt man am besten ein swapfile an (ba.sh swapon) damit solange man durch enigma1 stoppen nicht genug memory spart die box dabei nicht hängenbleibt.


    Und sonst ist nicht viel unterschied zur r6, nur das LCD output problem beim bootmanager auf der 7020 sollte gefixed sein (und auf der 600er hat man das ja gar nicht).


    Ich denke wenn genug User mittesten ist die know bugs liste schnell gefüllt und auch gefixed, das ging mit den wenigen Usern/Mitbastlern in der Bastelstube einfach noch nicht.


    Und auch das Multiboot downloadcenter wird im Moment noch nicht sinnvoll funktionieren weil dort nur 7025 sachen ageboten werden. Aber das macht auch erst Sinn wenn der Rest wie vom Enigma2 gewohnt funktioniert, dann gibt es eine r7 für beide Plattformen und die kits sind endlich in sync :-)


    LG
    gutemine

    Edited 3 times, last by gutemine ().

  • Zu den Timern: Habe eine /etc/enigma/timer.epl gefunden in der offensichtlich dir Timer gespeichert sind (habe natürlich auch per notepad mal nachgesehn)...
    Wegen den reboots: bin leider noch nicht so lange in der dreambox und linux ecke unterwegs... wie kann ich das mit den inits testen? also welche befehle brauch ich?

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Quote

    Original von m0rphU
    Zu den Timern: Habe eine /etc/enigma/timer.epl gefunden in der offensichtlich dir Timer gespeichert sind (habe natürlich auch per notepad mal nachgesehn)...
    Wegen den reboots: bin leider noch nicht so lange in der dreambox und linux ecke unterwegs... wie kann ich das mit den inits testen? also welche befehle brauch ich?


    OK, ich bau dir das in die ba.sh ein.


    Und zum starten stoppen - einfach intelnet eingeben:


    ps
    init 4
    ps (um zu sehen ob enigma prozesse nicht mehr laufen)
    init 3
    ps


    Ist einfach schon zu lange her das ich eine enigma1 box hatte ..


    LG
    gutemine2

    Edited once, last by gutemine ().

  • so, probier mal das ba.tar.bz2 auf /tmp FTPen und dann auspacken mit:


    cd /
    bunzip2 /tmp/ba.tar.bz2
    tar -xvf /tmp/ba.tar


    Dann solltest du ein neues ba.sh auf /media/ba haben bei dem die timer.epl statt der timers.xml mit timerlink und timercopy auf /media/ba zwischen Images gesharte wird durch verlinkung oder kopieren


    Ich habe aber keine Ahnung ob es wirklich geht - das müsst Ihr rausfinden ...


    EDIT: Anhang entfernt da im r6 kit weiter oben jetzt beinhaltet

    Edited 3 times, last by gutemine ().

  • Also init 4 sorgt schonmal dafür, dass enigma stoppt... allerdings bringt init 3 rein gar nichts...
    Mit ps hab ich aber das script /usr/bin/enigma.sh gefunden, mit dem ich wieder ein wunderschönes enigma bekomme ;)
    aufgrund meiner mangelnden Linux-Kentnisse hab ichs aber noch nicht hinbekommen, das script im hintergrund zu starten... sollte aber doch eigentlich kein problem sein!?
    Habe jetzt auch mal probiert die geänderte ba.sh reinzuladen, hat aber nicht geklappt... Habe zuerst deine Befehle ausgeführt, hatte danach seltsamerweise aber immer noch die alte ba.sh auf der box... Habe dann probiert die Datei aufm PC zu extrahieren und manuell per ftp reinzuladen... das war scheinbar verkehrt denn jetzt kann die sh gar nicht mehr ausgeführt werden...

    Code
    root@dm600pvr:/media/hdd# bunzip2 /tmp/ba.tar.bz2
    root@dm600pvr:/media/hdd# tar -xvf /tmp/ba.tar
    media/ba/ba.sh
    root@dm600pvr:/media/hdd# ba.sh
    /bin/sh: Can't open
    root@dm600pvr:/media/hdd#

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • hatt das cd / vor dem auspacken vergessen, sorry musst nochmals auspacken.


    Ich sagte ja das das runterfahren funktioniert, nicht aber das starten :-)


    Das enigma.sh script sollte vom init process im Hintergrund ausgeführt werden, weil sonst ist es ein child vom telnet und du kannst dich nicht mehr ausloggen :-)


    Poste mal den output von cat /etc/inittab, da müsste drinnestehen bei welchem runlevel das enigma startscript angeworfen wird.


    LG
    gutemine2

  • Danke für deine Geduld mit mir!! Bin auf dem Gebiet scheinbar nen totaler noob...
    Hat jetzt geklappt... ob die Timer denn auch korrekt übernommen werden sag ich gleich...
    Hier die Ausgabe:


    Soweit ich das sehe startet enigma im level 2 oder?

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • genau. probier mal init 2 und berichte ob die enigma prozesse dann wieder laufen wenn du mit ps nachschaust


    Wenn ja dann kriegst du noch ein neues ba.sh wo das auch angepasst ist. Und wenn die timer dann auch funktionieren zu sharen und du sonst nichts an bugs findest dann bau ich halt einen neuen r6 kit wo das alles gefixed ist und alle haben wieder ein bischen mehr Freude :-)


    LG
    gutemine2

    Edited 4 times, last by gutemine ().

  • Gut, das mit init 2 funktioniert gut und die timer werden auch super übernommen...

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Quote

    Original von m0rphU
    Gut, das mit init 2 funktioniert gut und die timer werden auch super übernommen...


    Na dann probier den r6 kit oben nochmals runterladen, da sollten dann beide fixes drinnen sein - und berichten ob enigma1 dann richtig wider restartet nach backup/restore,...


    Gute Nacht
    gutemine2

  • Stoße schon wieder auf ein Problem:

    Code
    root@dm600pvr:/
    # cd /tmp/root@dm600pvr:/tmp
    # ipkg install /tmp/enigma2-plugin-extensions-barryallen_0.3.2-r6_powerpc.ipk
    ipkg: *** Couldnt kill old gunzip process *** aborting
    root@dm600pvr:/tmp#

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • komisch, wenn ich das file runterlade ist es bei mir auch 2k kleiner als das original, vieleicht ist da was schiefgegangen - habe es nochmal neu raufgeladen, bitte nochmals probieren.


    LG
    gutemine2

    Edited once, last by gutemine ().

  • Gut das File war offensichtlich wirklich fehlerhaft...
    Hat jetzt gut geklappt... Auch die Fixes wurden gut übernommen, aber nach der Installation kommt zwar die Meldung, das enigma2 nen reboot macht, aber hier is der fix scheinbar noch nich übermommen...

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Quote

    Original von m0rphU
    Gut das File war offensichtlich wirklich fehlerhaft...
    Hat jetzt gut geklappt... Auch die Fixes wurden gut übernommen, aber nach der Installation kommt zwar die Meldung, das enigma2 nen reboot macht, aber hier is der fix scheinbar noch nich übermommen...


    Danke, auf das postinstallationsscript hatte ich vergessen, na ja wir fixen ja auch noch die kleinen Bugs für die r7 wo dann hoffentlich auch der Bootmanager für die 600er funktionieren wird :-)

  • Dank Eurer Hilfe und den inputs aus dem DMM Board sollte mit dem jetzt gerade neu gepostete BA 3.2 r6 kit jetzt auch mit enigma1 Images im Flash der bootmanager problemlos funktionieren. Head.ko tauschen, etc sollte jetzt nicht mehr nötig sein (ausser man will ein E2 image auf Cf karte tun und E1image im Flash lassen - an der Lösung dafür wird aber noch gearbeitet)


    Nur mit enigma1 Image im Flash sollte Barry Allen auf der 7020 jetzt praktisch genauso funktionieren wie auf der 7025.


    Durch das fehlende enigma1 Plugin ist man zwar ein bischen eingeschränkt (wobei im telnet alles funktioniert), mit dem bootmanager zum Image auswählen und seinem instant extract feature (einfach nfi file auf /media/ba FTPen, reboot und das image wird beim booten von dort ausgepackt und gleich gebootet) kann man aber praktisch schon arbeiten wie von der 7025 gewohnt !


    Auf der 600er kriegt man zwar noch keinen Output vom Bootmanager, theoretisch sollte man jetzt aber schon blind in den 12 sek wo das BA Logo am TV gezeigt wird die Images auswählen können (0...9 bzw. die Farbtasten als Imagenummer 10,11,12, wobei 0 ist der Flash, und dann gleich nachher OK drücken)


    Also bitte Testen und berichten !


    PS: Ich hoffe das ist auch jetzt das letzet Mal das Ihr die version r6 nochmals runterladen müsst, die nächste version r7 wird dann hoffentlich auch einen funktionierendne Bootmanager für die 600er beinhalten - mal sehen ob wir das auch noch schaffen.

    Edited 3 times, last by gutemine ().

  • so, die Version 3.2 r7 ist jetzt zum testen online.


    Bei der sollte jetzt der Bootmanager vom Barry Allen auf der 7020 und 600PVR genauso wie auf der 7025 funktionieren und das OHNE head.ko tauschen - dies also bitte nicht mehr tun


    Und danke an die Leute die den Bootmanager auf diesen Boxen portiert und gestetet haben !


    Bitte um Input und Feedback wenn Ihr noch Sachen findet die nicht richtig funktionieren, weil ich hätte gerne das die nächste Version r8 dann ident zum Barry Allen auf der 7025er ist und wir dann endlichdie Version 3.2 releast auch für die PowerPC Boxen abhschließen können !


    LG
    gutemine2

    Edited 2 times, last by gutemine ().

  • Hi gutemine.


    Only a stupid question because i understand nothing at all.


    does barryallen power pc work in Enigma1? Must I install an e2 img to run barry on 7020 or 600pvr?


    Sorry, but you know, my german.......


    My 7020 lives happy in its flashwizard world, but i've just buy a 600pvr, so i'd like to test this......


    Thanks a lot
    ;)

  • Hi *all


    Erst mal BESTEN DANK fuer das BA fuer die Dream 600.


    Kriegte das Teil prima zum laufen mit 2 Images.


    Hab nfi-Backup vom Flash und vom HD-Image gemacht.
    Danach das HD-Image geflasht und nun kommt das Problem:
    Ich kann BA nicht mehr installieren Installer motzt:
    **************************************************************
    root@dm600pvr:/tmp> ipkg install /tmp/ba.ipk
    Installing enigma2-plugin-extensions-barryallen (0.3.2-r7) to root...
    Barry Allen should be installed/upgraded ONLY when booted from Flash, Sorry !
    preinst script returned status 1
    An error ocurred, return value: 1.
    Collected errors:
    Aborting installation of enigma2-plugin-extensions-barryallen
    **************************************************************
    Hab dann versucht BA von Hand von der HD zu entfernen. Leider ohne Erfolg. HD neu formatiert, auch das hilft nix.


    Irgendwo ist eine Info im Flash, dass nicht vom Flash gebootet wurde.


    Auf der 7025 gibt's flashboot.bat. Geht hier natuerlich nicht.


    Weiss jemand wo die Info woher gebootet wurde gespeichert ist ?


    Danke fuer eure Hilfe.


    Gruss
    Markus