*update* playDVD Plugin v0.55 - erweiteretes Startplugin zu dreamdvd v0.82

  • Hallo zusammen...


    lange ist nichts passiert... aber es ist mal wieder Zeit für kleines Update zum playDVD Plugin..


    Changelog:

    • bug mit dem nicht immer speicherndem "Moviepath" behoben
    • bug verlassen des Config Menus mit "save&close" (ohne vorher die Inputbox mit OK zu bestätigen) behoben
    • es können mehrer Verzeichnisse durch Komma "," getrennt als Moviepath angegeben werden
    • und noch ein paar Kleinigkeiten die mir grad alle nicht mehr einfallen...


    Was ist playDVD???
    Das könnt ihr hier nachlesen : playDVD Plugin v0.50 - erweiteretes Startplugin zu dreamdvd v0.82


    Jetzt wünsche ich euch viel Spaß mit playDVD v0.55


    axo.. Installation:
    tarball einfach auf box kopieren (am besten nach /tmp) und übers bluepanel im gemini manuell installieren oder von hand, also per telnet auf die box, iin das tmp verzeichniss wechseln und dann folgendes eingeben:
    für die dm 7000: tar xjf playDVD_7000_v0.55.tar.bz2 -C /
    für die dm 7020: tar xjf playDVD_7020_v0.55.tar.bz2 -C /



    [Blocked Image: http://www.doingitright.de/luke_s/playDVD_0.55_settings.jpg]

  • testet auch mal jemand ?? oder geht es bei allen *kopfkratz*


  • huups hab ich da was vergessen???
    eigentlich nicht... ich hatte es doch getestet mit pfaden die nicht existierten...
    weisst du wie du ans debug log vom enigma kommst ??? schick mir mal bitte den teil des logs ab plugin menu...
    merci

  • ich habe keine Probleme :P


    Quote

    (Das uninstall von Version 0.51 musste ich per ftp löschen wie oben beschrieben.)


    das hatte ich auch, es wird bei der Installation von Version 0.55 eine uninstall 0.51 und 0.55 angelegt.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Hallo


    Ich habe über SMB mein NAS-Laufwerk an die DM7000 angeschlossen. Das Abspielen von DVD's ab NAS funktioniert aber leider nur mit Rucklern. (Bild und Ton). Swapfile ist auf 64 MB auf USB-Stick (habs extra nochmals neu angelegt).


    Das Abspielen von MPEG Dateien ab NAS funktioniert hingegen wunderbar. Kann mir jemand einen Tipp geben, woran das liegen kann.


    Vielen Dank zum Voraus


    Schaagi

  • Quote

    Originally posted by luke_s


    huups hab ich da was vergessen???
    eigentlich nicht... ich hatte es doch getestet mit pfaden die nicht existierten...
    weisst du wie du ans debug log vom enigma kommst ??? schick mir mal bitte den teil des logs ab plugin menu...
    merci


    Wahrscheinlich war ich zu voreilig mit dem Posten: heute kann ich es nämlich nicht reproduzieren. Enigma stürzt heute nicht ab, wenn das Zielverzeichnis nicht vorhanden ist. (d.h. bei mir wenn ich den NAS nicht gemountet habe.)


    Habe ich gestern irgendwie ein Fehler gemacht? Ich weiß es nicht. Sorry, falls durch mich Unannehmlichkeiten entstanden sind.



    Schließlich möchte ich dir und Seddi danken: eure plugins zusammen machen aus der Dreambox 70x0 ein noch mächtigeres Multimedia-Maschine.



    mfg


  • wie ist das NAS denn angeschlossen ???? bzw wie kommt die box auf das nas ?? lan kabel oder wlan ?

  • Hi Luke_S


    Das NAS-Laufwerk ist über LAN 10/100 MBit und über Switch (kein Router) mit der Dreambox verbunden.


    Das NAS ist ein Raidsonic NAS900-B und der neuesten Firmware V48B1. Habs auch schon mit V47 versucht. Gleiches Resultat. Leider lässt sich das NAS nur über SMB mit der Dreambox verbinden. CIFS und NFS gehen nicht.


    Habe zum Versuch mal eine DVD auf die lokale Festplatte der Dream geladen. Und siehe da, es geht ohne Ruckler. Demzufolge muss es sich um ein Streaming-Problem handeln.



    Gruss
    Schaagi

  • Hurra, habs selber rausgefunden. Es lag nicht am NAS, sondern daran, dass ich unter DREAMDVD den AC3-Ton auf OFF hatte. Dann musste die Dreambox den Ton selber nach PCM konvertieren. Das war für die CPU offensichtlich zuviel.

  • Hi,



    ich habe mit dreamdvd und playDVD installiert und es hat auch anscheinend geklappt. Das Verzeichnis /hdd/dvd existierte und die DVDs, die dort lagen, wurden auch abgespielt.


    Jetzt habe ich in der Config aber anstelle der /hdd/dvd /mnt/dvd eingetragen, da ich dorthin meine Festplatte von meinem W2000 PC hinmounte. Jetzt läuft playDVD aber überhaupt nicht mehr :-(


    Immer wenn ich playDVD starten möchte, stürzt Enigma ab, d.h. es startet sich neu. Ich komme nicht mal so weit, die Einstellungen wieder rückgängig zu machen :-(


    Deinstallieren und Neuinstallieren hat leider auch nix gebracht. Muß ich neu flashen? Gibt es eine Datei, die ich vielleicht mittels telnet editieren kann, um den Normalzustand wiederherzustellen?



    KILIAN

    Signaturen sind doof und stinken


  • ouch... warum passiert mir sowas beim testen nicht??? ich hab das doch auch mit verzeichnissen gestetet die nicht existieren... komisch...
    ich nutze die config vom enigma um die werte abzuspeichern...
    kannst du mir mal das enigma debug log von dem absturz schicken ???
    danke

  • kilian



    Die Datei die den Pfad enthält heißt 'config' und sie liegt unter
    /var/tuxbox/config/enigma/config


    Du kannst sie gegebenenfalls mit einem linux-kompatiblen Editor editieren. Danach muss du jedoch enigma neustarten, sonst werden die alten Daten zurückgeschrieben.
    Zum Neustart von enigma folgende Zeile per telnet eingeben:
    killall -9 enigma



    luke_s


    Bei mir ist es seitdemmnicht mehr vorgekommen. (Ich habe es jedoch die letzten Tage nur wenig benutzt.)


    mfg

  • hasa@netcabo.pt


    Hallo,


    nachdem es ja DreamDVD nicht für die Dream 7025 gibt, wird es wohl auch playDVD solange nicht für die 7025 geben, da es ja nur zusammen funktioniert.

    :laola:Gruß Black2Jack :laola:


    DM7080 DVB-S & DM820 DVB-S & DM800SE V2 DVB-T jeweils 2TB HDD/4GB USB & akt. Experimental & QNAP 639Pro

    Edited once, last by Black2Jack ().

  • Danke für die beiden wunderschönen Plugins :danke:


    Auch meine Dream ist nun DVDtauglich. Es ist einfach super, dass es läuft. Ein Traum wurde war.


    Ich habe es geschafft mehere sambamounts in playDVD zu sehen. Aber leider nur die iso-Dateien. Mir werden keine Ordner angezeigt (VIDEO_TS). Wie ist das mit dvd-dirs in der config gemeint ?

  • beispiel


    /hdd/meine_flime/film1/video_ts
    /hdd/meine_filme/film2.iso


    also musst du /hdd/meine_filme angeben und bekommst dann film1 und film2.iso angezeigt.. in der fileliste