[Update 4.18.2/06.02.2018] Plugin Noad:Entfernt Werbeblöcke aus Aufzeichnungen/Removes advertisment

  • Hallo Alladin


    Ich habe jetzt die Datei /media/hdd/noad/files/queue.txt gelöscht,und dann Noad mit einer Sendung neu gestartet,nun heiß es >noad ist aktiv< :hurra:
    Also wird wohl meine Datei bearbeitet.


    Jetzt stellt sich mir die Frage,wie lange die Datei braucht (19 Minuten,1 Werbung), bis sie fertig ist.


    Kann man das irgendwo in einer Prozentanzeige sehen,oder muß ich warten,bis es heißt >noad ist fertig<.


    Schon mal Danke für deine Hilfe soweit.


    Gruß
    Skywalker1912

  • Hallo zusammen,


    habe noad_4.16.5_Mipsel.ipk installiert. Bekomme jedoch folgende Fehler im Log ausgegeben:


    >>>>>>>> noad start 20120124 0030 - ProSieben - Switch reloaded
    *************** noad ***************
    Thursday,01.01.1970 01:00:19 start noad-0.6.0 for /tmp/noad/tmp/20120124 0030 - ProSieben - Switch reloaded.rec
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpeg2video @ 0x14efa80] mpeg_decode_postinit() failure
    [mpegts @ 0x14543f0] max_analyze_duration 5000000 reached at 5000000
    [mpegts @ 0x14543f0] Could not find codec parameters (Unknown: none ([5][0][0][0] / 0x0005))
    [NULL @ 0x15022c0] start time is not set in estimate_timings_from_pts


    1.) Da mit noad 0.6.0 gearbeitet wird, muss wohl die Datei erst konvertiert werden. Muss dazu libmpeg2 installiert werden? Oder was muss man noch tun?
    2.) noad 0.7.2 ist verfügbar. Damit kann wohl direkt die TS-Datei bearbeitet werden. Damit sollte die Werbemarkierung schnell erledigt sein. Ich bin neu in der Linux-Welt und habe keine Ahnung wie man das umsetzen kann. Auf der http://noad.heliohost.org sind nur Source-Dateien. Kann einer von Euch die mipsel-Datei erzeugen?
    3.) Ich kann NOAD nur über das Aladin-Menü-Plugin aufrufen. Es sind keine Einträge im Timer- oder Schnetteditor-Menü zu finden. Auch wird das Plugin nicht im Plug-In-Editor aufgeführt. Wie kann ich dies lösen?



    Viele Grüße


    Mrs Currywurst


  • Hallo nochmal,


    habe in einem anderen Forum gefunden wie libmpeg2 installiert werden kann. Jetzt meldet er bei jedem Film sofort: "Noad ist fertig". Aber natürlich sind keine Marken zur finden.


    Leider kann ich auch Noad nicht deinstallieren um es noch einmal neu installieren zu können:


    et9x00 login: root
    root@et9x00:~# ipkg remove Noad
    -sh: ipkg: not found


    Wie gesagt kenn mich mit Linux leider noch nicht aus. Vielleicht kann mir einer einen Tip geben.


    Ich arbeite mit einem XTrend 9200 und OpenPli 2.2.2012


    Viele Grüße


    Mrs Currywurst

  • Hi Mrs Currywurst,


    das Problem liegt an einer Unverträglichkeit im Mpeg Format. Irgent etwas verhindert das Scannen der Aufnahme. Ich habe mehrere Aufnahmen auf Pro 7 getestet und alle liefen normal. Daher denke ich das dein Problem ein einmaliges Problem darstellt.


    Neuinstallieren und libmpeg2 benötigst du nicht, weil das Problem an deiner beschäditgen Aufnahme liegt.


    Viele Grüße


    Aladin

  • Quote

    Original von Mrs Currywurst


    et9x00 login: root
    root@et9x00:~# ipkg remove Noad
    -sh: ipkg: not found


    bei der et musst du opkg statt ipkg eingeben ;)

  • Hi freak4all,


    Super, vielen Dank für die Info .


    Bin neu in der Linuxwelt. Ist irgendwo ein Crash-Kurs verfügbar? Ich würde gerne verstehen was ich tue!


    Viele Grüße


    Mrs Currywurst

  • Hi Aladin,


    Danke für Deine Antwort. Es funktioniert aber bei keiner Datei (und die lassen sich abspielen). Dank freak4all kann ich jetzt installieren + deinstallieren. Habe Noad noch einmal deinstalliert und erneut installiert. Logfile weiter unten. Scheinbar sind kleine Fehler aufgetreten. Obwohl die installation erfolgreich durchgeführt wurde, habe ich immer noch den gleichen Effekt. Wenn Du keine andere Idee hast, werde ich die Box am Wochenende auf Werkseinstellungen zurückstellen und alles noch einmal neu einrichten.


    Gruß


    Mrs Currywurst


    root@et9x00:/var/volatile/tmp# opkg install /tmp/noad_4.16.5_mipsel.ipk
    Installing noad (4.16.5) to root...
    cp: can't stat '/usr/lib/enigma2/python/Screens/TimerEntry.py': No such file or directory
    cp: can't stat '/usr/lib/enigma2/python/RecordTimer.py': No such file or directory
    Configuring noad.
    cp: can't stat '/usr/lib/enigma2/python/Screens/TimerEntry.py.orig': No such file or directory
    cp: can't stat '/usr/lib/enigma2/python/RecordTimer.py.orig': No such file or directory
    can't find file to patch at input line 3
    Perhaps you should have used the -p or --strip option?
    The text leading up to this was:
    --------------------------
    |--- TimerEntry.py.orig 2009-12-25 14:30:40.000000000 +0100
    |+++ TimerEntry.py.neu 2010-01-02 14:45:38.000000000 +0100
    --------------------------
    File to patch:
    Skip this patch? [y]
    Skipping patch.
    3 out of 3 hunks ignored
    can't find file to patch at input line 3
    Perhaps you should have used the -p or --strip option?
    The text leading up to this was:
    --------------------------
    |--- RecordTimer.py.orig 2009-12-25 14:30:40.000000000 +0100
    |+++ RecordTimer.py.neu 2010-01-03 17:58:27.000000000 +0100
    --------------------------
    File to patch:
    Skip this patch? [y]
    Skipping patch.
    5 out of 5 hunks ignored
    patching file plugin.py.orig
    Hunk #5 succeeded at 219 (offset 1 line).
    cp: can't stat 'TimerEntry.py.orig': No such file or directory
    cp: can't stat 'RecordTimer.py.orig': No such file or directory
    ************************************************************
    ********** Installation erfolgreich abgeschlossen **********
    ************************************************************

  • Hi Mrs Currywurst,


    wie gesagt ich glaube nicht das eine neue Installation das Problem löst. Ich glaube vielmehr irgendetwas an deinen Filmdateien ist nicht so ganz im Standard. Welchen Tunertyp (dvb-s,dvb-c,dvb-t) hast du ?


    Viele Grüße


    Aladin

  • Hi Aladin,


    ich musste sowie so alles neu installieren, da nach einer Installation beim Starten immer neu gebootet wurde.


    Es funktioniert aber immer noch nicht. Aber ich habe eine Logdatei gefunden. Siehe Anhang.


    Es handelt sich um einen Twin DVB-S-Receiver (Xtrend 9200).



    Viele Grüße


    Mrs Currywurst

  • Hi Mrs Currywurst,


    wie gesagt deine Aufnahmen haben Fehler die den avcodec zum Absturtz bringen. Hierbei können wir nur auf ein Update vom avcodec warten. Neuinstallation oder reinstallation wird wie bereits gesagt dein Problem nicht lösen.


    Ich verstehe allerdings nicht, dass du aleine die Probleme haben solltest. Bei mir mit dvb-c läuft alles und du bist der einzige Sat Anwender, der solche Probleme hat. Das ist schon merkwürdig.


    Viele Grüße


    Aladin

  • Hi Aladin,


    in der Logdatei steht das Noad 0.6.0 verwendet wird. Du arbeitest wahrscheinlich mit PES-Dateien oder?


    Da unter OpenPli TS-Dateien abgespeichert werden müßte wahrscheinlich die Datei
    a.) in das alte VDR-Format konvertiert werden
    b.) oder besser noad 0.7.2 verwenden. Damit kann wohl direkt die TS-Datei bearbeitet werden. Nur habe ich keine Ahnung wie man das für OpenPli bekommt. Hast Du dazu die Möglichkeit oder könntest Du mir mitteilen welche Schritte durchgeführt werden müssen?


    Auf der Noad-Seite, die gerade down zu sein schein, hatte ich mal eine Windows-Version von 0.7.0 runtergeladen. Da war auch avcodec-52.dll dabei.
    Wäre das der neue Codec? Kannst Du damit etwas anfangen?


    Viele Grüße


    Mrs Currywurst

  • Hi Mrs Currywurst,


    ja ich habe Noad 0.6.0 als Grundlage verwendet. Aber ich habe es soweit verändert, daß es TS mit MPEG2 und H264 Material verarbeiten kann. Eine Konvertierung nach pes mache ich schon lange nicht mehr.


    Wenn du Lust hast, kannst du Noad 0.7.2 nehmen und für die Dreambox anpassen. Vieleicht hast du dann sogar weniger Probleme. Ich würde mich freuen, wenn sich andere an der Entwicklung von Noad beteiligen würden.


    Viele Grüße


    Aladin

  • Quote

    Original von aladin25
    Ich würde mich freuen, wenn sich andere an der Entwicklung von Noad beteiligen würden.


    Viele Grüße


    Aladin


    Hallo,


    mit Logomine gäbe es ein Grobkonzept die Logoerkennung quasi "online" zu machen. Das Projekt würde ich gerne mal wieder ausgraben. Vielleicht könnte man da zusammenarbeiten.


    Frage: gibt es irgendwo das noad 0.72 mipsel-binary-Paket zum Downloaden?


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Noch ein Nachtrag aladin25,


    kannst du das noad-binary mal strippen? Geht runter von 31 MB auf 9 MB. Man könnte es damit fast wagen, das Plugin komplett im Flash zu installieren.


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • Quote

    Original von mamba0815
    Noch ein Nachtrag aladin25,


    kannst du das noad-binary mal strippen? Geht runter von 31 MB auf 9 MB. Man könnte es damit fast wagen, das Plugin komplett im Flash zu installieren.


    Mamba


    Wie strippt man? Mir sagt strippen so gar nichts.


    Viele Grüße


    Aladin

  • Beim GCC ist ein "strip" binary dabei.Beim OE ist das auch dabei ... "mipsel-oe-linux-strip".


    "strip removes or modifies the symbol table attached to the output of the assembler and link editor. This is useful to save space after a program has been debugged and to limit dynamically bound symbols."


    Im Prinzip entfernt es also Debug Symbole im Binary.


    Was anderes: ich habe nun einige Movies durchrechnen lassen (sie erscheinen in der "fertig.txt"), aber er scheint keine cut-marker einzufügen, d.h. ich sehe keine im Movie-Modus. Wo kann ich nach dem Fehler suchen?

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Quote

    Original von mamba0815
    Was anderes: ich habe nun einige Movies durchrechnen lassen (sie erscheinen in der "fertig.txt"), aber er scheint keine cut-marker einzufügen, d.h. ich sehe keine im Movie-Modus. Wo kann ich nach dem Fehler suchen?


    Hi,


    die Schnittmarken werden nur im Schnitteditor angezeigt. Das geht so, video Taste - Aufnahme auswählen - Menütaste tippen - Schnitteditor auswählen.


    Wenn dort keine Schnittmarken zu sehen sind, ist etwas nicht in Ordnung. Dann könnte eventuell die Logdatei mir etwas sagen. Die Log-Datei ist unter /media/hdd/noad/files zu finden.


    Viel Erfolg


    Aladin

  • Hallo.


    Ich habe eine Date ausgewählt und diese steht nun in der Warteschlange. Dort steht wartend auf Noad. Wie kann ich nun starten?


    Gruß,
    Dog6574