4. Einfügen eines eigenen Downloadservers

  • Ich hänge nun leider auch seit Tagen fest.Folgender Code liegt auf dem Server:



    Ich bekomme immer ein Xml Parse Error. Nun hätte ich gerne gewusst was die mindest Angaben sind und was alles zum Xml Parse Error führen kann,ausser einem xml Fehler denn oben hatte ich gelesen das jemand nen falschen Pfad hatte und das auch zu einem Xml Parse Error führt ! Werden denn alle gemachten Angaben vorm Download überprüft ? kann ich mir fast nicht vorstellen.Was ist mit Checksumme und Grösse?
    Ich habe es auch schon ohne die erste Zeile versucht,klappt auch nicht und den Pfad 100mal überprüft,der ist richtig,wäre über Hilfe sehr dankbar!


    [EDIT]Habe nun auch nochmal die Rechte auf dem Server frisiert, aber daran kann es nicht liegen,habe sogar einen Unixconformen Editor verwendet,was aber auch bei xml und nem http-Server quatsch sein sollte. Also kann es nur an den Attributkombinationen in der Server.xml liegen und da bräuchte ich mal ne Tip wie die zusammenhängen

    DM500S & DM600 PVR-S mit Gemini 4.00 auf Astra 19.2
    Cam's: CCcam / Camd3 / MGCamd
    Sonst.: VLCF / ngrab

    Edited once, last by black_jack ().

  • Mittlerweile bin ich mir sicher das es an den Werten liegen muß, oder etwas an das ich noch nicht gedacht habe,denn ich habe mir eine funktionierende userlist.xml besorgt und die passende server.xml ausgelesen, meine genauso angepasst und beim Original Läuft es Problemlos und bei mir läuft die selbe Struktur nicht ?(
    Bin immer noch nicht schlauer was die Zusammenhänge in den einzelnen Datenfeldern betrifft.

    DM500S & DM600 PVR-S mit Gemini 4.00 auf Astra 19.2
    Cam's: CCcam / Camd3 / MGCamd
    Sonst.: VLCF / ngrab

  • Habe die checksumme 2 mal kontrolliert die stimmt, habe gearde ein weiteres mal deine anleitung gelsen und nochmal alles aus meiner server.xml rausgemommen auser url, name, description kann aber erst um 14h an die box um zu testen.
    Wird denn die md5 schon VOR dem herunterladen überprüft ?? das würde ja bedeuten das beim Aufruf des xml alle Urls auf vorhandene Dateien und diese auf die Checksumme überprüft werden.Aber um die Checksumme zu überprüfen muß doch die Datei auf der Box sein oder ??

    DM500S & DM600 PVR-S mit Gemini 4.00 auf Astra 19.2
    Cam's: CCcam / Camd3 / MGCamd
    Sonst.: VLCF / ngrab

  • Wäre die Cheksumme falsch würde es bis zum Download
    gehen und dann mit nem Fehler Checksumme falsch abbrechen.


    Xml Parse Error kommt meistens wenn das Format der Deiteien nicht stimmt. Die Dateien müssen in utf-8 sein sonst geht nix.


    Dieses Problem hatte ich anfangs auch.

  • Ahh ich seh gerade das deine ersten beiden Zeilen Falsch sind Lösch die Mal raus.

  • Ich häng dir mal meine beiden an es ist nur der Servername ge XXXXX
    sonst unverändert.

  • Danke für die schnelle und gute Hilfe, ich habe nun endlich das Problem gefunden. Meine server.xml funktioniert. Der Fehler lag an einer Domainweiterleitung ! Ich habe eine Domain mit Weiterleitung auf nen free-Http. Gebe ich meine domain + pfad an läuft es mit allen Browsern wunderbar aber die Box packt das nicht.Gebe ich direkt den pfad des free-Http an klappt es. Vielleicht ist hier irgendwann mal ein Bugfix nötig/möglich !
    Ach ja und ob die ersten beiden Zeilen meiner xml drin sind oder nicht ist egal, funktioniert mit beidem,habe ich extra nochmal getestet.

    DM500S & DM600 PVR-S mit Gemini 4.00 auf Astra 19.2
    Cam's: CCcam / Camd3 / MGCamd
    Sonst.: VLCF / ngrab

    Edited 2 times, last by black_jack ().

  • Weiteres Problem schein auch Copy/paste im Server.xml zu sein obwohl ihc nen unixconformen Editor hatte,wollte die xml nicht geparst werden als ich z.B Namenstring hineinkopiert hatte.

    DM500S & DM600 PVR-S mit Gemini 4.00 auf Astra 19.2
    Cam's: CCcam / Camd3 / MGCamd
    Sonst.: VLCF / ngrab

  • Hallo,


    Quote

    Original von black_jack
    Weiteres Problem schein auch Copy/paste im Server.xml zu sein obwohl ihc nen unixconformen Editor hatte,wollte die xml nicht geparst werden als ich z.B Namenstring hineinkopiert hatte.


    Da können wir nix machen, wir machen meist auch nur "Copy/paste" ich zumindest unter
    LInux, wenn das bei Dir nicht geht, muste halt einen anderen Editor versuchen,
    liegt ja dann wohl eher am Editor und nicht am Gemini.... ;)


    Achja, und Mr. Bunny macht das glaube ich auch unter Windows, also geht es da auch.
    Muss also dein Editor oder eben ein User-Problem sein (kleiner Scherz, nicht ernst nehmen) :wmbiggrin:

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Ich wollte damit auch nur meine Probleme darstellen, damit der Nächste der ein Problem hat, das mal überprüfen kann und nicht sofort verzweifelt, denn manche sachen erklären sich nicht sofort, wie z.B: sowas blödes wie Copy/Paste. Das is mir klar das das einr "Usererror" ist ;) und kein Gemini-Fehler.
    Aber das Problem mit der Domainweiterleitung, habe ich nicht verstanden.
    Habe meinen Server momentan super am laufen, und bin sehr zufrieden :)

    DM500S & DM600 PVR-S mit Gemini 4.00 auf Astra 19.2
    Cam's: CCcam / Camd3 / MGCamd
    Sonst.: VLCF / ngrab

  • @ All


    Leider bekomme ich es nicht gebacken.
    Habe immer noch irgentwelche Fehler.


    Wenn ich die Zeile ( http://192.168.178.50:8080/addons.xml ) im Explorer eingebe sehe ich sie.
    Aber auf der Dreambox 7025 kommt " Keine Einträge vorhanden "


    Muß ich noch ein Verzeichniss oder wie oder so angeben ???
    Was muß ich noch ändern ???


    Gruß CSM


    Kann mir denn keiner helfen.

    Dreamboxen
    Box 1 u. 2 : Dreambox 800S ; Box 3 : Dreambox 8000SS
    Sat : WaveFrontier T90 in Arbeit ,Fuba 85cm A19/H13 mit 2xLNB an 9/8 MS A23 1xLNB mit SUR 211 F

    Edited 2 times, last by csm ().

  • @ All


    Habe versucht mir einen eigenen Server zuerstellen.
    Denke mal das es soweit funktioniert.
    So nun zu folgendem Problem
    - Tragball erstellt
    - Auf den Server geladen
    - kann es auch herrunterladen und installieren


    - es werden aber nicht alle Rechte verteilt die ich brauche
    - z.b. bei MGCAM die mgcam auf 755


    Was könnte ich da machen um diesen fehler weg zubekommen ???


    Gruß CSM

    Dreamboxen
    Box 1 u. 2 : Dreambox 800S ; Box 3 : Dreambox 8000SS
    Sat : WaveFrontier T90 in Arbeit ,Fuba 85cm A19/H13 mit 2xLNB an 9/8 MS A23 1xLNB mit SUR 211 F

    Edited once, last by csm ().

  • Wenn du keine PC mit linux im laufen hast, dann kannst du deine eigene tarball über die Box per script zusammen packen. Da werden die rechte ordnungsgemäß eingesetzt.


    5. Automatisches erstellen von Gemini-Tarballs


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Habe gerade mal hier mitgelesen und mir auch einen eigenen Server gebastelt.
    Hat nach einigem Hin und Her aber alles geklappt.
    Super - Danke!!!!


    Satmax

  • Eine Frage hätte ich jetzt noch:
    wo finde ich bei der DM 500plus die Datei useraddon.xml ?
    Unter /var/tuxbox/config/ ist da nichts zu finden.
    Die 500plus hat ja eine etwas andere Verzeichnisstruktur.

  • Die sollte gleich wie bei der 600 sein also in ECT

  • Danke,
    werde dort nachschauen, wenn ich die 500plus wieder mal hier habe.
    Satmax


    P.S.:
    Hatte die Box jetzt da: es passt /ect/useraddon.xml
    Danke

  • Ich hab auch mal bischen rumgespielt und habe folgenden Problem mit der server.xml


    Hier erstmal meine server.xml




    Wie zu erkennen ist, sind mehrere Einträge vorhanden. (Plugin und Skins)


    Wenn ich die server.xml so verwende wie dargestellt, bekomme ich die Fehlermeldung: parse XML error


    Ändere ich die server.xml ab, und benutze nur einen Eintrag, egal welchen, entweder Plugin oder Skins, funktioniert alles einwandfrei mit dem Download.


    Wo ist der Fehler?


    thanks

    99% aller Fehler sind Bedienungsfehler!
    Geht nicht-Gibt`s nicht! ;)

  • Hallo,
    Du hast ein paar <Plugin></Plugin> und <list></list> zuviel.
    So habe ich es gemacht und es funzt.



    Gruß Satmax