How-To: auto.hotplug (alt - Automount.conf)

  • hab das mal geändert auf :


    Dream7025 -fstype=nfs,rw,soft,udp,nolock,rsize=8192,wsize=8192 192.168.0.8:/media/hdd/movie


    brauch ich passwort und benutzer bei nfs ??
    man ich bin echt ein doofsack 1!


    dank für eure geduld !!


    fredi

  • macherstmals cat /etc/exports um zu sehen ob das directory überhaupt exportiert wird vom NFS sonst ist nichts mit (auto) mounten :-)

  • also leute danke nochmal,habs jetzt hinbekommen !! hatte einen anfängerfehler drinnen, hatte leerzeichen beim namen am anfang im automount befehl !!


    mfg
    fredi

  • Quote

    Original von heblinsky
    Ok, habe mir überlegt, die Sache mit NFS einzurichten:
    Leider kann ich dort aber kein User und kein Passwort eintragen.
    Wenn ich den Rest aber eingebe, so sehe ich unter automount das Verzeichnis, aber es friert ein, wenn ich darauf klicke.


    hy
    genauso verhält es sich bei mir.
    ich finde es alles sehr verwirrend und es gibt keine klare "anleitung" wo was zu stehen hat. wirklich schade. es wäre eine tolle sache wenn das funktionieren würde, aber als relativer laie diesbezüglich hat man wenig changse.
    auch tagelanges probieren/lesen brachte nicht den erfolg. ?(

  • Brauchst kein Benutzer und PW. Die Zugriffskontrolle geschieht über das reguläre Dateiberechtigungssystem des NAS.


    Brauchst in der conf der Dream sowas:


    Code
    qnap -fstype=nfs,rw,soft,udp,nolock,rsize=8192,wsize=8192 192.168.1.23:/share


    NFS Server muss aber laufen auf dem Qnap.
    Freigabe muss erstellt sein und Zugriffsrechte angepasst.

  • Hallo,
    es haut wieder nicht hin, nachdem ich letzens Infos updaten wollte.
    Ich hab nun sowohl im Flasdh als auch im USB-Stick Gemini 4.1 installiert und Samba nachinstalliert.
    Meine Freigabe sieht so aus:
    [Blocked Image: http://img212.imageshack.us/img212/6167/snapjt5.th.jpg]


    Den Ordner Externe finde ich sowohl über FTP als auch über die Dreambox, die Unterordner/Daten werden jedoch nicht angezeigt, es erscheint nur folgendes:
    [Blocked Image: http://img370.imageshack.us/img370/169/snap1gz2.th.jpg]
    Verrückt ist auch, daß im Plue-Panel unter der Rubrik Plugins nur noch vier Erweiterungen (Tuxbox, Email...) angezeigt werden.
    Ich meine, daß hier Samba früher angezeigt wurde.
    Generell finde ich Samba nicht bei den Plugins , nur mittels FTP unter etc.
    Was ist nuin los, hat jemand vielleicht einen Tipp?
    Ich sitze jetzt hier schon geschlagene 6 Stunden und komme nicht weiter.
    Viele Grüße und Dank,
    Marc.-

  • Hi,
    ich glaube du verwechselst eventuell ein wenig die Dienste für das was du machen möchtest, bzw. suchst dann damit auch an der falschen Stelle?
    Unter welchem BS läuft deine Freigabe "Marc" (cifs deutet auf Windows hin)?
    Wozu Samba auf der Dream (damit kannst du vom Win-PC aus auf die Dream zugreifen)? Wenn das so laufen soll, kein Problem, nur hat der automount nix mit Samba auf der Dream zu tun.
    Samba ist ein Dienst der nicht unter den Plugins erscheint. Er wird nur per conf-Datei konfiguriert, dann sind die Freigaben im Netz sichtbar.

    Meine Projekte: TVB-Parser, WebIF-Expert, DreamBox-Offline-Timer, StandBy2DeepStandBy...

  • Hi,
    wie Du siehst bin ich Laie, der zwar bemüht, jedoch schwer von Kapee ist.
    Man sagte mir, daß ich für die Automount-Funktion Samba installiert haben muss. Da ich im Keller auf meine Netzwerkfestplatte zugreifen möchte habe ich es installiert.
    Ich hab gestern noch ein wenig rumexperimentiert und hab den Fehler gefunden: es fehlte eine Leerstelle in der Freigabe, und zwar vor der Netzwerkadresse.
    Somit funktioniert nun wieder alles.
    Dennoch vielen Dank für Deine Hilfe.
    Was meinst Du, würde ich es hinbekommen, Filme mit meinem Wissensstand auf meinen Computer zu senden, um sie dort zu brennen?
    Oder soll ich lieber die Finger davon lassen?
    Als Software stände mir Nero 7 in der VV zur Verfügung.
    Viele Grüße,
    Marc.

  • Jeder hat mal klein angefangen :D
    Die Aufnahmen auf den PC zu bringen ist auch nicht wirklich schwer. Hier kannst du z.B. Samba auf der Dream nutzen --> am PC siehst du dann einfach z.B. den movie-Ordner deiner Dream und kannst kopieren/löschen/umbenennen/brennen... wie du lustig bist
    Oder halt per automount den PC/Festplatte mit einbinden und dann z.B. mittels TuxCommander einfach von der Dream aus rüberkopieren...
    Oder mittels DCC direkt von der Dream runterladen...
    Oder mittels WebIF direkt von der Dream runterladen...
    Oder, oder, oder... :)

    Meine Projekte: TVB-Parser, WebIF-Expert, DreamBox-Offline-Timer, StandBy2DeepStandBy...

  • Hallo zusammen,
    nachdem ich den kompletten Thread nun mehrmals durchgelesen habe, funktioniert Automount bei mir immer noch nicht.


    Folgende Hardware ist vorhanden:
    DB600-S mit Gemini 4.3 (im Flash!)
    IP: 192.168.0.102


    Qnap TS-209 pro (mit NFS!) Firmware 1.1.5.
    IP:192.168.0.101


    Wenn ich per Automount qnap -fstype=nfs,rw,soft,udp,nolock,rsize=8192,wsize=8192 192.168.0.101:/dreambox den NAS mounte erscheint im Autmount-Ordner (wie schon oft beschrieben) nur ein leeres Verzeichnis.


    Ich habe beide Boxen (DB600 und NAS) jeweils neugestartet. Ich habe den Ordner /dreambox als NFS-Verzeichnis freigegeben. Habe dort wahlweise die IP der DB600 (192.168.0.102) eingetragen, sowie das Feld freigelassen (und somit allen Geräten den Zugriff gewährt.


    Ich bekomme aber in keinem Fall das Verzeichnis angezeigt, welches sich innerhalb des NAS unter /dreambox befindet.


    Im Forum wurde bereits angesprochen, dass man den Dienst Automount innerhalb des BP starten soll bzw. darauf überprüfen soll. Ich finde jedoch nix im BP bei Gemini 4.3.


    Was mache ich denn nur falsch?


    Besten Dank für die Tipps.
    Beste Grüße
    Michael

  • svr1 -fstype=nfs,nolock,rsize=8192,wsize=8192 192.168.0.101:/Public


    sollte in die automount.conf stehen in/etc


    obwohl dein beitrag sehr alt ist kan es sein das andere dieses nutzen können.


    chiao

    bin nicht sicher, ist Anne Will ministerin?

    Edited once, last by Tonskidutch ().

  • Hallo zusammen,


    nachdem ich den kompletten Thread nun mehrmals durchgelesen habe, funktioniert es nur zum teil Automount.


    Hardware:
    Dreambox 7000 S mit Gemini 4.4 auf Stick
    ip: 192.168.178.13
    Automount.conf auf Dream7000:


    7020 -fstype=nfs,rw,soft,udp,nolock,rsize=8192,wsize=8192 192.168.178.013:/media/hdd/movie


    Dieser zugriff auf der hdd der 7020 funktioniert.



    Auf der 7020 S mit Gemini 4.4 auf CF
    ip: 192.168.178.11
    Automount.conf auf der Dream7020:


    7000 -fstype=nfs,rw,soft,udp,nolock,rsize=8192,wsize=8192 192.168.178.011:/var/mnt/hdd/movie


    Dieser zugriff leider nicht.
    NFS läuft auf beide Images.


    Wo ist mein Fehler??

    --------------------------
    Gruss celina
    --------------------------

  • lies mal HIER da ist es genau beschrieben.

    LG
    Karl

    «Einen Menschen erkennt man daran wie er wird, wenn er was wird»


    __________________________________________________________
    Dreambox 8000HD SSCS HDD +CF 8 Gb, Merlin
    Dreambox 7020HD SC HDD
    Dreambox 500 HD S
    Dreambox 7025 SC HDD +CF 2 Gb
    Dreambox 600 S
    NAS = 2x Synology DS109 3 TByte
    TV= Samsung UE40ES6300
    SAT = 45° Ost - 30° West


    [SIZE=7]Dieser Beitrag wurde schon vor Veröffentlichung 8 mal editiert.[/SIZE]

  • Hallo zusammen,


    ich würde gerne meine Aufgenommen filme/serien etc die ich mit ngrab aufgenommen habe (auf den pc) über die box wieder abspielen.


    leider weiß ich gar nicht wie ich das anstellen soll. könnt wer mir vllt schrtt für schritt erklären was ich zu tun habe?


    Dreambox 500 C mit engima 4.10


    gruß,

  • hallo hoffe ihr könt mir helfen, habe ne dm7025 und 800er.
    versuche jetzt gegenseitig auf die festplatten zuzugreifen.
    hab schon paar sachen die hier stehen versucht aber es will einfach nicht.
    7025: 192.168.1.21
    800 :192.168.1.22
    wenn ihr mir helfen könntet was ich genau im nfs und in der automount eingeben muss ich kriegs einfach nicht hin.


    netzwerk ist ok komme auf beide boxen drauf.


    danke im vorraus

  • falls du ba nutzt, musst du unter ba/einstellungen/treiber laden die kernel und treiber in den flash laden!!

  • nach der Anleitung von EgLe HIER musst du es hinbekommen.

    LG
    Karl

    «Einen Menschen erkennt man daran wie er wird, wenn er was wird»


    __________________________________________________________
    Dreambox 8000HD SSCS HDD +CF 8 Gb, Merlin
    Dreambox 7020HD SC HDD
    Dreambox 500 HD S
    Dreambox 7025 SC HDD +CF 2 Gb
    Dreambox 600 S
    NAS = 2x Synology DS109 3 TByte
    TV= Samsung UE40ES6300
    SAT = 45° Ost - 30° West


    [SIZE=7]Dieser Beitrag wurde schon vor Veröffentlichung 8 mal editiert.[/SIZE]

  • hab mir das angeschaut aber es will einfach nicht. ba ist nciht drauf kernel module sind geladen verstehe es einfach nicht mein home cs funktioniert also ist ne verbindung zwischen den boxen da.


    muss ich im nfs 192.168.0.0
    oder
    192.168.1.0


    meine ip sind
    192.168.1.21
    192.168.1.22


    bei der 7025 und 800 muss ich doch bei beiden dann den gleichen ordner auf der hdd angeben oder??

  • So, jetzt "möchte" ich auch mal um Hilfe bitten.


    Habe eine 7025 und am PC eine ext. Festplatte (Maxtor One Touch4).
    Auf dieser habe ich ein Verzeichnis
    I:\Dreambox 7025, darin sind Filme.
    Unter Vista Freigabe erstellt: //MEIN-PC/Dreambox 7025
    Mein PC hat die IP: 192.168.1.45


    Dann habe ich unter automount.conf bei var/etc folgendes eingegeben:


    Extern -fstype=cifs,rw,soft,rsize=8192,wsize=8192,user=root,password=dreambox ://192.168.1.45/Dreambox 7025


    Wenn ich dann auf der Dreambox 7025 auf VIDEO - VIDEO gehe, dann kann ich wohl auf automount (Extern) gehen, es passiert aber nichts, Verzeichnis leer?


    Weiss jemand, was bei mir falsch läuft?


    Gruss und Danke
    Marcel

  • Hallo,


    Ich glaube mich zu erinnern dass ich auch mal ein Prob damit hatte.
    Lag an dem Leerzeichen im Pfad.
    Versuch mal auf Dreambox7025 zu ändern.


    grüße
    chris