Daemon für Tuxmail startet nicht

  • Ich habe das Problem, dass bei Aufrufen des (neuesten) Tuxmail-Plugins bei Betätigung der Mute-Taste die Meldung erscheint "Daemon nicht geladen", obwohl der Autostart aktiviert ist. Beim Starten scheint der Daemon nicht zu starten. Hat jemand eine Idee, woran das liegen könnte? Andere Inet-Anwendungen wie Tuxwetter etc. laufen einwandfrei.


    Mein tuxmail.conf sieht wie folgt aus:


    STARTDELAY=30
    INTERVALL=15


    LOGGING=Y
    LOGMODE=S


    SAVEDB=Y


    AUDIO=Y
    VIDEO=1


    LCD=Y
    OSD=G


    SKIN=1


    TYPEFLAG=1


    CONFIGCODE=
    ADMIN=Y


    MAILCACHE=5
    MAILDIR=/tmp/
    SECURITY=


    WEBPORT=80
    WEBUSER=Dreambox
    WEBPASS=Root


    NAME0=xxxxx
    POP30=
    IMAP0=imap.1und1.de
    USER0=xxxx
    PASS0=xxx
    SMTP0=smtp.1und1.de
    FROM0=xxx@online.de
    CODE0=
    AUTH0=2
    SUSER0=xxxx
    SPASS0=xxx
    INBOX0=

  • Wie lautet denn genau der Befehl, den ich per Telnet eingeben muss?

  • Tatsächlich. Hatte ich übersehen, dass das der Befehl ist. Danach startet der Daemon problemlos. Sieht so aus:


    TuxMailD 1.38 started [16.08.2006 - 20:37:35]
    TuxMailD <store max. 5 mails in /tmp/>
    TuxMailD <check 1 Account(s) every 15min with Logging in Single-Mode>
    TuxMailD <no Spamlist found, Filter disabled>
    ~ > TuxMailD <restore Mail-DB>

    ~ > TuxMailD <no Status for Account 0>
    TuxMailD <Account 0 = 001(000)/001 Mail(s) for XXXX>


    Damit ist das Problem aber nicht gelöst, dass der Daemon nicht automatisch startet. Woran könnte das liegen?

  • Ja, ist auch alles korrekt eingestellt. Hat auch mit meiner Testmail geklappt, wie das Protokoll bei Telnet oben zeigt.


    Nach einem nochmals soeben durchgeführten Neustart wurde der Daemon automatisch gestartet. Muss man den Daemon denn grundsätzlich einmal manuell per Telnet starten, damit der Autostart zukünftig automatisch erfolgt? Hoffe, dass der Daemon jetzt weiterhin selbständig startet, denn das Scriptbeispiel


    if [ -e /var/etc/.tuxmaild ]; then /Pfad zum Daemon/tuxmaild; fi


    wird doch automatisch durch Aktivierung des Autostarts erzeugt oder muss ich dies manuell eintragen? Wenn ja, wo genau?

  • das wird automatisch in eine init datei eingetragen, wo die genau liegt kann ich jetzt nicht sagen.


    Eigendlich sollte ein zwingender einmaliger telnet Start nicht notwendig sein - hat bei Problemen aber immer geholfen.
    Bei mir hat´s auch mal mehrere reboot´s nach der Installation gebraucht k.a. warum.


    Bei mir hat das dann mit Autostart immer funktioniert, aktuell hab ich aber kein tuxmail drauf, da ich jetzt einen Pushmaildienst auf´s Handy verwende.


    ist aber echt ein super Teil von LazyT u. Robspr

  • Quote

    ...wird doch automatisch durch Aktivierung des Autostarts erzeugt oder muss ich dies manuell eintragen?


    Nein, das wird eben nicht erzeugt! Es wird auf der <7020 nur die dort erwähnte Datei "/var/etc/.tuxmaild" erstellt/gelöscht...

  • aber manuell in die Init eintragen muß man trotzdem nichts.


    @LazyT: das heißt die er eintrag in die Init erfolgt bei der Installation des Plugins oder? und wenn "/var/etc/.tuxmaild" nicht existiert kann der dämon von der Init nicht gestartet werden.