Fehler ab Gemini 2.20 -- Unterbrechung bzw. Abruch von NFS Aufnahmen

  • Hi,


    nach langem Austesten möchte hier eine Anfrage an die Spezialisten stellen.
    Also ich nenne ein DM 7000 S mein eigen und haben seit seinem Erscheinen nur das Gemini Imange genutzt. Was besseres habe ich noch nicht gesehen.
    Ich habe keine Platte in der Box, habe aber eine NFS Freigabe als /hdd gemountet. Die Aufnahe auf diese Freigabe hat immer einwandfrei funktioniert. Seit Gemini 2.20 bricht die Aufnahme immer wieder einmal ab, um wenige Zeit später wieder erneut einzusetzten, dabei wird eine neue Datei erzeugt und entsprechend mit "gleicher Name(1)" im Daten Menü angezeigt. Später angesetzte Timeaufnahmen werden dann gar nicht mehr gemacht. Es passiert auch bei längeren Aufnahme (Spielfilm) immer nur einmal pro Aufnahme. Manchmal bald am Anfang manchmal später. Beim einfachen anschauen ohne Aufnahme habe ich noch nie Fehler erhalten. Ich habe es zuerst mal auf den Server geschoben. Und habe einen neuen Server angeschlossen. Leider blieb der Fehler bestehen. Ich habe die Emus rausgeschmissen und nur das blanke Gemini laufen lassen - der Fehler blieb. Ich habe das Gemini auf einen Stick installiert statt es im Flash laufen zu lassen - wieder keine Änderung. Ich habe ein Orginal Image installiert - Fehler behoben. Ich bin mir sehr sicher, dass der Fehler bei Gemini 2.10 noch nicht auftrat, werde es aber noch mal aufspielen um sicher zu gehen.
    Aber ab Gemini 2.20 tritt der Fehler bei mir reproduzierbar auf. Wie es bei einer Aufnahme auf eine interne Festplatte ist, kann ich wegen fehlender Platte nicht sagen.


    Hat jemand eine Idee woran es liegen könnte, bzw. wie ich Abhilfe schaffen kann? Wenn ich zur Zeit Aufnahmen habe, wechsel ich vorher das Image, aber ich möchte eigentlich liebe mit Gemini arbeiten.


    Schon besten Dank im Voraus

  • Bei mir passiert exakt das Gleiche !


    Nach der Installation von Gemini 2.4 haben die ersten 2 Aufnahmen einwandfrei geklappt, die nächsten beiden waren leider wieder in 2 Teile aufgeteilt.


    Auch bei mir bricht der erste Teil zu nicht vorhersagbaren Zeitpunkten ab, mal nach 500 MB, manchmal auch schon nach 80 MB. Ich nehme auch nur per NFS auf und schiebe die Daten auf einen Debian-Linux Server.


    Wenn jemand ne Idee hat, ich wäre sehr dankbar !


    =)


  • Hi,


    ich benutze das Gemini 2.20 auf ´nem Stick und nehme genauso wie du auf eine NFS-Freigabe auf.


    Habe überhaupt keine Probleme! Es wird nur eine Datei erstellt, egal wie lange ich aufnehme. Das ganze läuft bei mir fehlerfrei seit ca. 3 Wochen. Ich habe seitdem bestimmt 25-30 Aufnahmen unterschiedlicher Länge gemacht (von 50 Minuten bis 3 Stunden bzw. von 1GB bis ca. 10GB)


    Alles bestens. Ich weiß, das hilft dir nicht weiter... :368:


    Mal ne blöde Frage: Du hast doch die maximale Dateigröße auf <16GB gestellt, oder?


    Ciao, HC

    2x500HDSE (Merlin3+GP3.2), 1x7020HD (Merlin3+GP3.2), 1x800HDSE (Merlin3+GP3.2), VU Duo, QNAP TS-219PII, LG 50PH6608, Philips 42PFL7674, Toshiba 46TL963G

  • Quote

    Original von HomeCoach
    Mal ne blöde Frage: Du hast doch die maximale Dateigröße auf <16GB gestellt, oder?


    Ciao, HC


    Die Dateigröße ist auf 1 GB eingestellt.
    und die Unterbrechung geschieht nicht an einer Dateigrenze mal sind die 1024 MB Datein auf der Platte und die Unterbrechung kommt erst in den zweiten oder dritten Gigabyte


    minorum

  • Quote

    Original von minorum
    Die Dateigröße ist auf 1 GB eingestellt.
    und die Unterbrechung geschieht nicht an einer Dateigrenze mal sind die 1024 MB Datein auf der Platte und die Unterbrechung kommt erst in den zweiten oder dritten Gigabyte
    minorum


    Ändere doch mal auf die Maximalgröße (16GB) und probiers nochmal. Vielleicht gibt´s da nen Bug? Hast du es nochmal mit dem alten Gemini 2.1 probiert?


    HC

    2x500HDSE (Merlin3+GP3.2), 1x7020HD (Merlin3+GP3.2), 1x800HDSE (Merlin3+GP3.2), VU Duo, QNAP TS-219PII, LG 50PH6608, Philips 42PFL7674, Toshiba 46TL963G

  • Zunächst mal laufen keine Aufnahmen stabiler, als jene auf eine interne HDD in der DM-7000S. Von daher würde ich dringendst empfehlen, auch eine interne zu verbauen, wenn man schon die 7000er sein eigen nennt.


    Bei meiner DBox2 streame ich auch per NFS und hatte zu Beginn die gleichen Probleme wie ihr. Sprich, die Dateien werden an manchen Stellen einfach zerstückelt, mal öfter, mal seltener. Zwischen den Stücken fehlt auch immer ein kleiner Teil, so daß die Aufnahmen eigentlich unbrauchbar sind, selbst wenn man die Einzelteile wieder zusammenflickt.


    Grund bei der dbox2 war auf jeden Fall die Netzwerk-Performance! Wie habt ihr denn die Dreambox mit dem NFS-Server-PC verbunden? Direkt per Cross-Over oder über nen Switch? Eventuell sogar noch per Wlan? Wieviel Traffic hat euer Switch so im Schnitt zu handeln? (hängt womöglich ne ganze WG dran usw.?)


    Die Dbox2 ist ja bekannt für ihre schwachbrüstige Netzwerk-Performance (10 MBit Half-Duplex). Dennoch habe ich nach kleiner Optimierung der Cache-Werte für Read und Write immer fehlerfreie Aufnahmen hinbekommen!


    Mountet mal mit read=20480 und write=30720! NFS Server Version 3 ist dafür nötig, aber den hat wohl ohnehin fast jeder! Mit diesen Einstellungen konnte ich wie gesagt immer fehlerfrei streamen von DBox2 auf Debian-Server! Mit den Standardparametern von 80xx konnte ich weder unzerstückelt aufnehmen noch ruckelfrei abspielen!


    Gruß,
    Billy

    500HD (C) | SKY komplett | netcologne | unitymedia allstars
    twitter.com/marco79

  • Quote

    Original von BillyBlue77
    Zunächst mal laufen keine Aufnahmen stabiler, als jene auf eine interne HDD in der DM-7000S. Von daher würde ich dringendst empfehlen, auch eine interne zu verbauen, wenn man schon die 7000er sein eigen nennt.


    Naja. So pauschal kann man das ja wohl nicht sagen. Bei mir und bei allen Bekannten jedenfalls stimmt das so nicht. Zum einen sollte man immer erst ein Zusatznetzteil einbauen, wenn man mit ner internen Platte arbeitet und sobald ein Emu im Spiel ist, sei es SCAM oder CAMD3, gibt´s sehr, sehr häufig Probleme mit den Aufnahmen.


    Seitdem ich übers Netzerk auf NFS streame, gehören diese Probleme bei mir der Vergangenheit an. Und bei mir hängen zwischen Dreambox und NFS-Server 1 Router und 2 Switches!


    Quote

    Original von BillyBlue77
    Bei meiner DBox2 streame ich auch per NFS und hatte zu Beginn die gleichen Probleme wie ihr. Sprich, die Dateien werden an manchen Stellen einfach zerstückelt, mal öfter, mal seltener. Zwischen den Stücken fehlt auch immer ein kleiner Teil, so daß die Aufnahmen eigentlich unbrauchbar sind, selbst wenn man die Einzelteile wieder zusammenflickt.


    Klar. Ich hab auch 2 DBoxen. Die Probleme kenn ich auch.;)


    Quote

    Original von BillyBlue77
    Grund bei der dbox2 war auf jeden Fall die Netzwerk-Performance! Wie habt ihr denn die Dreambox mit dem NFS-Server-PC verbunden? Direkt per Cross-Over oder über nen Switch? Eventuell sogar noch per Wlan? Wieviel Traffic hat euer Switch so im Schnitt zu handeln? (hängt womöglich ne ganze WG dran usw.?)


    Wie gesagt. Bei mir sind´s: 1 Router und 2 Switches!


    Quote

    Original von BillyBlue77
    Die Dbox2 ist ja bekannt für ihre schwachbrüstige Netzwerk-Performance (10 MBit Half-Duplex). Dennoch habe ich nach kleiner Optimierung der Cache-Werte für Read und Write immer fehlerfreie Aufnahmen hinbekommen!


    Mountet mal mit read=20480 und write=30720! NFS Server Version 3 ist dafür nötig, aber den hat wohl ohnehin fast jeder! Mit diesen Einstellungen konnte ich wie gesagt immer fehlerfrei streamen von DBox2 auf Debian-Server! Mit den Standardparametern von 80xx konnte ich weder unzerstückelt aufnehmen noch ruckelfrei abspielen!


    Ich aber schon.


    Ähem .... Ausserdem geht´s hier nicht um die DBox2 sondern um die Dream. Das kann man überhaupt nicht vergleichen.


    Und bei mir läuft das alles wunderbar. Bei minorum übrigens bis zur Gemini 2.1 auch.


    Ciao, HC

    2x500HDSE (Merlin3+GP3.2), 1x7020HD (Merlin3+GP3.2), 1x800HDSE (Merlin3+GP3.2), VU Duo, QNAP TS-219PII, LG 50PH6608, Philips 42PFL7674, Toshiba 46TL963G

  • Quote

    Original von HomeCoach
    Naja. So pauschal kann man das ja wohl nicht sagen. Bei mir und bei allen Bekannten jedenfalls stimmt das so nicht. Zum einen sollte man immer erst ein Zusatznetzteil einbauen, wenn man mit ner internen Platte arbeitet und sobald ein Emu im Spiel ist, sei es SCAM oder CAMD3, gibt´s sehr, sehr häufig Probleme mit den Aufnahmen.


    Kann ich wiederum gar nicht bestätigen! Meine Dream läuft seit 2,5 Jahren ohne Zusatznetzteil und ohne Kondensatorkabel. Das gleiche bei meinem Onkel und bei meinem Freund. Kenne nur einen, der ein Zusatznetzteil in seiner Dreambox drin hat. Liegt vielleicht auch daran, daß alle ne Samsung-Platte verbaut haben. Ich habe täglich 3-4 Timer-Aufnahmen am laufen mit camd3, Probleme gibt es nicht. Auch Scam hat noch nie versagt.


    Ist doch irgendwie logisch, daß die Übertragung via Netzwerk fehleranfälliger ist als die interne. Sind eben sehr viele Faktoren, die so ne Netzwerkübertragung beeinflußen (Kabel, Hardware,...). Außerdem kannst du Netzwerke nicht mit Netzwerken vergleichen und Switches nicht mit Switches! Zerstückelte Aufnahmen sind eben oft ein Problem der Netzwerk-Performance! Mehr wollte ich mit dem Vergleich der dbox-2 nicht sagen.


    EMU-Aufnahmen gehören natürlich immer gesondert betrachtet. Aber dazu werden hier im Thread keine Aussagen gemacht, also ist davon auszugehen, daß grundsätzlich keine Aufnahmen klappen (auch nicht FTA). Kann mir jedoch kaum vorstellen, daß Aufnahmen mit nem bestimmten EMU intern versagen, per NFS aber funktionieren!

    500HD (C) | SKY komplett | netcologne | unitymedia allstars
    twitter.com/marco79

  • Quote

    Original von BillyBlue77
    Kann ich wiederum gar nicht bestätigen! Meine Dream läuft seit 2,5 Jahren ohne Zusatznetzteil und ohne Kondensatorkabel. Das gleiche bei meinem Onkel und bei meinem Freund. Kenne nur einen, der ein Zusatznetzteil in seiner Dreambox drin hat. Liegt vielleicht auch daran, daß alle ne Samsung-Platte verbaut haben. Ich habe täglich 3-4 Timer-Aufnahmen am laufen mit camd3, Probleme gibt es nicht. Auch Scam hat noch nie versagt.


    Bei mir bzw. bei uns schon ;(


    In meinem Bekanntenkreis gibt´s keinen, der eine Box ohne Zusatznetzteil hat. Bei meinem Schwager u.a. auch. Wir haben beide ne Box der 4. Generation (jetzt mit Zusatznetzteil) und haben es mit verschiedenen Samsungs (SV0802N,SV1203N,SV1604N), ner Maxtor 5A300J0, und schließlich mit ner 100GB Notebook-Platte von Fujitsu probiert. In jeder möglichen Kombination, mit Kondensatorkabel, mal ohne, mal mit Zusatznetzteil, mal ohne. Mit der Notebook-Platte funktionierts (logischerweise) bei beiden Boxen am besten, aber auch nur mit Kondensatorkabel, dafür ohne Zusatznetzteil.


    Quote

    Original von BillyBlue77
    Ist doch irgendwie logisch, daß die Übertragung via Netzwerk fehleranfälliger ist als die interne. Sind eben sehr viele Faktoren, die so ne Netzwerkübertragung beeinflußen (Kabel, Hardware,...). Außerdem kannst du Netzwerke nicht mit Netzwerken vergleichen und Switches nicht mit Switches! Zerstückelte Aufnahmen sind eben oft ein Problem der Netzwerk-Performance! Mehr wollte ich mit dem Vergleich der dbox-2 nicht sagen.


    Ist schon klar. Aber mit der Gemini 2.1 lief bei minorum ja noch alles. Deswegen scheidet das Netzwerk als Fehlerquelle aus, wenn er am Netzwerk selbst doch nichts geändert hat.


    Quote

    Original von BillyBlue77
    EMU-Aufnahmen gehören natürlich immer gesondert betrachtet. Aber dazu werden hier im Thread keine Aussagen gemacht, also ist davon auszugehen, daß grundsätzlich keine Aufnahmen klappen (auch nicht FTA).


    Jepp.


    Quote

    Original von BillyBlue77
    Kann mir jedoch kaum vorstellen, daß Aufnahmen mit nem bestimmten EMU intern versagen, per NFS aber funktionieren!


    Doch, bei mir ist das genauso. :)

    2x500HDSE (Merlin3+GP3.2), 1x7020HD (Merlin3+GP3.2), 1x800HDSE (Merlin3+GP3.2), VU Duo, QNAP TS-219PII, LG 50PH6608, Philips 42PFL7674, Toshiba 46TL963G

  • Ich hab noch ein wenig getestet, im Moment scheint es mir, als würde es per CIFS besser klappen. Ich hab jetzt 4 Aufnahmen a etwa 2,5h gemacht, und das Problem ist noch nicht wieder aufgetreten.


    Mal weiter beobachten... =)

  • Quote

    Original von RangerOne
    Ich hab noch ein wenig getestet, im Moment scheint es mir, als würde es per CIFS besser klappen.
    Mal weiter beobachten... =)


    Auch auf die Gefahr hin gesteinigt zu werden: Was für ein Filesysten ist CIFS?
    Und wie und was für einen Server muß ich dafür konfigurieren.




    Der Hinweis mit der Netzwerkperformance könnte weiterhelfen. Zwischen Dreambox und Server sind zwei Switches aber es dürfe eigentlich nichts ausmachen, da ja ein Switch direkt verbindet und nicht auf alle Leitungen wieterleitet wie ein Hub. Auf der einzigen 100mbit Leitung die von der Box und einem PC zugleich benutzt ist eingentlich nicht genug Betrieb das es zu einer Störung kommen könnte. Aber ich werde mal den andern PC abhängen.


    Auserdem bleibt ja immer noch die Feststellung das es mit dem Original bzw. mit dem CSV Image funktioniert.
    Evtl bekomme ich die Woche noch eine Festplatte zum testen.

  • CIFS ist im Prinzip SMB, also Samba. (einfach die bisherige NFS Freigabe auch per Samba freigeben und dann CIFS statt NFS an der Dreambox einstellen)


    Zu CIFS :


    http://samba.sernet.de/samba-mfaq-3.html



    Ich hab mittlerweile übrigens mehr als 10 Testaufnahmen von mehr als 2h gemacht, und das Problem ist noch nicht wieder aufgetaucht. =)



    Das es ein Problem der Netzperformance ist glaube ich eigentlich nicht, bei mir gabs das Problem unabhängig davon, was sonst im Netz passiert (oder auch an der Dreambox war es egal ab ich nur aufgenommen habe, oder auch gleichzeitig einen anderen Film abgespielt habe)

  • hallo,



    ich habe jetzt mal auf dem Server auch SMB installiert und nehme über CIFS auf. Siehe da, die Fehler sind bislang nicht mehr aufgetaucht. :)
    Ich hoffe mal es bleibt so.


    Von daher wäre das Verhalten von Gemini identisch wie bei RangerOne. Ich würde von daher es nicht auf die Netzwerkperfomance schieben. Irgendwo dürfte dann mit NFS etwas nicht stimmen. Entweder auf der Server Seite oder auf der Dreambox Seite.
    Bei mir läuft der Server unter Suse 10.0
    Wie sieht das denn bei euch aus?

  • Hi,


    bei mir läuft der NFS Server unter XP Pro.


    Ciao, HC

    2x500HDSE (Merlin3+GP3.2), 1x7020HD (Merlin3+GP3.2), 1x800HDSE (Merlin3+GP3.2), VU Duo, QNAP TS-219PII, LG 50PH6608, Philips 42PFL7674, Toshiba 46TL963G

  • Also das bei mir Aufnahmen abbrechen habe ich auch. Allerdings nur, wenn die GUI noch sichtbar ist und ich auf Aufnahme drücke. Aufnahmen funktionieren bei mir nur, wenn die GUI nicht mehr sichtbar ist (kannst die Zeit ja mal auf 2 Sek runterstellen) und ich dann auf Aufnahme (also den Radio button) drücke. Dann mal mindestens 15 Sekunden warten, bevor du mal wieder auf einen Button klickst bei dem die GUI erscheint (z.B. "OK"), dann siehst ja den roten blinkenden Punkt. Bei mir läuft OMNI-NFS Server auf W2K-AS, Splitgröße auf 4GB und im MountManager unter Extras noch nfsvers=3
    Funktioniert eigentlich fast problemlos :-)


    cu Beppo