The Gemini Project 4.2

Wir haben aktuell ein Problem mit dem Board und arbeiten an der Lösung...


-> Aktuell bereiten wir das Upgrade auf die aktuelle Version 6 von Woltlab vor.
    • Official Post

    Vielleicht haben es Einige schon mitbekommen. Mit dem letzten Update vom GeminiBluePanel kommt jetzt eine Meldung (new GP).


    Wir möchten euch das neue GP4.2 vorstellen.

    Von der Oberfläche hat sich nicht all zu viel geändert aber unter der "Haube" ist vieles neu, was eine neue Versionsgebung rechtfertigt.

    Wir empfehlen eine komplett neue Installation des aktuellen Images + des GP4.2 wie im WIKI beschrieben.


    Das GP4.2 ist voll auf Streaming ausgelegt. Fast alle Streamanbieter können einfach per Fernbedienung der Kanalliste hinzugefügt werden. Zusätzlich kann man einfach den Streams oder DVB-Sendern ein Online-EPG zuordnen.


    Die meisten Funktionen werden über Dreamnetcast realisiert oder werden über das Menü in der Kanalliste ausgeführt. Dreamnetcast ist jetzt modular aufgebaut. Programmierer können zusätzliche APIs oder Playlisten als LIBs für Dreamnetcast bereit stellen. Dreamnetcast bringt folgende LIBs schon mit. Laut.fm, Radio-Browser und YouTube. Viele weitere LIBs können über den AddonManager nachinstalliert werden. Die Favoriten-Verwaltung in Dreamnetcast ist extrem erweitert worden. Es gibt jetzt 7 Favoriten-Ordner z.B. für Serien oder Live-Streams.

    Das Online-EPG kann durch den User mit eigenen Quellen erweitert werden.

    Ein Beispiel ist die Datei "/etc/enigma2/netcastepg_gemini.json". Eigene Quellen bitte in einer neuen Datei mit dem Namen "/etc/enigma2/netcastepg_wasauchimmer.json" speichern.


    Ansonsten sind in vielen Plugins, Fixe und teilweise neue Funktionen hinzugekommen.

    Es wird keine Updates mehr für das GP4.1 geben. Wer jetzt Angst wegen seiner "alten" Dreambox hat... Das GP4.2 gibt es für alle MIPSEL, ARMHF und ARM64 Boxen.

    Wer, wie oben vorgeschlagen, kein neues Image aufspielen möchte geht bitte folgendermaßen vor.

    AddonManager->Gemini Plugins->geminifeedupdater. Das Paket installieren. Nach eine Reboot wieder in den AddonManager und ein komplettes Upgrade durchführen.


    Im aktuellem Enigma selbst werden einige Streams nicht störungsfrei laufen aber Abhilfe ist unterwegs. :winking_face:


    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • Weitere Infos und Bilder zum GP4.2 Release.


    Wichtig für Skinner !!!


    Skinner die in ihrem Skin die Gemini globals geskinnt haben müssen den neuen globalen name="gcommanderlist_biglist_small" hinzufügen damit ihr Skin unter GP4.2 nicht crasht.

    Desweiteren werden die Screens name="GeminiTBoxPicture" und name="PackageInfo" nicht mehr benötigt .

    Es gibt auch 3 neue Screens ,zum einen ist das der neue globale name="gcommanderlist_biglist_small" sowie die beiden

    name="GBPinBox" und name="GPMessagebox".

    --------------------------------------------------------------------------------


    So kommen wir zu den Plugins bzw. Änderungen :


    Addonmanager

    - Dieser ist erneuert und bietet die Suche und Aufgaben jetzt auch direkt auf dem Hauptschirm ,desweiteren gab es einige interne Änderungen


    GP Backup:

    - Das GP Backup kann jetzt auch täglich oder wöchentlich ein Backup automatisch erstellen ,dies kann man im Backup Plugin aktivieren/deaktivieren.

    Manuelles Backup so wie bisher geht klar weiterhin. :)


    GP RSS Reader:

    - Der RSS Reader kann wieder mit personalisierter Anmeldung umgehen und im maindesc wird jetzt deutlich mehr Text angezeigt ( eventuell für Skinner interessant die für mehr Text und weniger scrollen ihren Skin anpassen möchten)


    GP Widgets :

    - Das Widgets hat für die Piconverwaltung nur noch 2 Einstellungen

    Kanalliste-Infobar = alles im Skin wo der originale Piconrenderer aufgerufen wird

    Display = Picons im Display der Box ,sofern es der genutzte Skin unterstützt


    GP MQTT:

    - Unterstützung für TSL-Verbindungen


    Netcast: ( Netcast hat die umfangreichste Neuerung bekommen ,das Netcast ist komplett neu )

    - Hauptseite des Netcast hat sich um viele Fav. Ordner erweitert

    - Netcast bietet von Haus aus nicht mehr alle Netcast Erweiterungen direkt ,da sie jetzt modular und über den GP Addonmanager nachladbar sowie auch deinstallierbar sind.

    - Netcast bietet viel Anbieter jetzt über API an und nicht nur über Playlisten,Playlisten gehen weiterhin so wie bisher auch.

    - Netcast integriert sich ins DreamOS und bietet an direkt Sender oder ganze Senderbouquets aus Netcast heraus in die Kanalliste (TV sowie Radio) zu geben (meist direkt mit dem Senderlogo wenn vom Anbieter mitgegeben).

    - Netcast bietet weiterhin an direkt in der Kanalliste oder im Netcast selbst Senderlogos zu vergeben für Streams und DVB sowie EPG setzen für DVB aber auch Streams ,dabei geht dann TVG-ID oder DVB EPG von Sendern die man auch über Sat usw. bekommt.

    - Netcast hat einen eigenen EPG Loader mit diesem kann der User sich externen EPG laden und diesen auch erweitern mit weiteren EPG Anbietern ,dies geschieht über die netcastepg_.....json die der User in etc/enigma2 nutzen und selbst erstellen kann.

    - Netcast schreibt den EPG direkt in die epg.db des DreamOS und somit ist der Senderepg auch über die EPG System und Plugin Ansichten anzeigbar. (dazu aber eine wichtige Info , bei mit netcast hinzugefügten Sendern kann kein Timer erstellt werden und auch keine Aufnahme getätigt werden ,dies ist Systembedingt und kann nur Dream ändern)


    - Über das abspielen im GP Player kann mit REC aber eine Aufnahme getätigt werden ,Timer erstellen geht aber nicht.

    - Netcast kann um weitere Streamanbieter erweitert werden ,dies geht als Playlist wo die Anbieter in eine netcastserver_....json eingetragen werden.

    - Ist man mit dem Cursor auf einem Netcastanbieter (API) so kann man mit BLAU oder Menütaste die Einstellungen aufrufen und hat für diesen Anbieter sofern sie zur Verfügung stehen noch zusätzliche Anbieter Einstellungen.


    Alle alten Netcast Datein in etc/enigma2 (dreamnetcast....) können gelöscht werden ,diese Datein werden nicht mehr abgefragt .

    Auch gibt es jetzt eine netcastfavo.bin wo eure Fav. und Sortierung usw. abgespeichert wird (diese Datei kann man nicht manuell bearbeiten).


    Eine netcastfavo.json kann dennoch eingesetzt werden ,die dortigen Einträge werden immer an das Ende der Fav Liste gesetzt.


    Es gibt sicherlich noch viele weitere Dinge die ich schreiben könnte ,aber schaut euch erstmal das neue GP4.2 an ,testet die einzelnen Plugins alle mal durch und wenn Fragen sind ,hier ist das Heimatboard des GP Projekt und hier werden auch alle Fragen dazu beantwortet (sofern es nicht gegen die Boardregeln dieses Boards verstößt).


    Habt viel Spaß beim entdecken neuer Dinge im GP4.2 :310: :winking_face:

  • Bei einer Neuinstallation und des installieren des geminilocale ,gibt es ab sofort nur noch 3 Gruppen (in der Art der gapps) ,also pico,mini und best.

    Bedeutet man kann sich aussuchen welches der 3 Gruppen man als Erstinstallation installieren möchte und alle weiteren Sachen dann später über den GP4.2 Addonmanager.



    PS.

    Wer Fragen zum GP4.2 hat bitte einen eigenen Thread hier im Forumbereich eröffnen mit der Frage damit man zum einen das alles übersichtlicher gestallten kann für ALLE User und auch schneller helfen kann.

  • Ich habe mich bei meiner 920er für ein Gemini-Update entschieden und eben einmal durchgespielt.


    1. Via geminibackup eine Sicherung erstellt (sicher ist sicher :) )

    2. Gemini-Addonmanager gestartet und gewartet, ob mir Updates vorgeschlagen werden (es gab keine)

    3. geminifeedupdater installiert

    pasted-from-clipboard.png

    4. Warten bis der automatische Enigma2-Neustart erfolgt. (Das geht in der Tat automatisch :top: )

    5. Box startet neu

    6. Nach dem Neustart bin ich nochmals in den Addonmanager und es wurde mir eine Aufgabe vorgeschlagen

    pasted-from-clipboard.png


    7. Aufgabe gestartet und Enigma danach neu gestartet


    Das wars auch schon. Völlig problemlos und ohne eine Ungereimtheit. Jetzt freue ich mich über die neuen Funktionen und habe direkt erst einmal die automatische Imagesicherung eingeschaltet.

    __________________________________________________________


    Auch ich wünsche Euch viel Spaß mit dem neuen GP4.2


    Danke an all Diejenigen die an diesem Projekt mitgewirkt haben und viele Stunden ihrer Freizeit für unser schönes Hobby gespendet haben.

    :danke:

  • Ich habe jetzt schon zwei Mal geminifeedupdater installiert und wieder desinstalliert. Das klappt, aber ich sehe keine "Aufgaben". Ich habe eine DM920 mit neuestem experimental Image und auch sonst alles up-to-date.

  • Sind alle deine feeds auch in Ordnung?

    Wenn es nicht der fall ist. kann es schon zur Problem führen.


    per telnet apt-get update angeben, und schauen ob da ein Fehler vorhanden ist.


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.2 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: Logitech K600 ~ DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • alle gp4-unstable-*

    Schau dir das Datum an, und dann weißt du ob upgedatet worden ist.


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.2 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: Logitech K600 ~ DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Sind alle deine feeds auch in Ordnung?

    Wenn es nicht der fall ist. kann es schon zur Problem führen.


    per telnet apt-get update angeben, und schauen ob da ein Fehler vorhanden ist.

    Ja, da gibt es einen Fehler mit Gutemines Feed (apt.fury.io). Was mich die schon Nerven gekostet hat, aber ich benötige absolut das EPGLoad Plugin, denn sonst hab ich kein EPG bei UK Sendern.

    Da verzichte ich eher auf GP4.2 :pouting_face:

  • Wenn du da sein feed behalten möchte trotz Fehlermeldung, dann schalte es ersmal aus um das update ausführen lassen können.

    Einfach verschieben und wieder einfügen nach Neustart.

    Image Sicherung würde ich erstmal machen :)


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.2 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: Logitech K600 ~ DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Nach dem automatischen e2-Neustart gab es bei mir auf der One im AddonManager auch keine aktiven Aufgaben.

    (nur ein Update für ein gehaltenes DP-Plugin)


    Bei mir wurde wohl alles im Hintergrund geupdatet.

    Also nicht nur die Feeds, sondern auch gleich die GP4-Plugins, die hier in aktueller Version vorliegen.


    Carbonide

    Schau doch einfach mal im AddonManager bei den Gemini-Plugins, welche Versionen du da installiert hast.


    geminicomm hab ich hier in Version 2.8-r7.0

    und gemininetcast in Version 2.1-r4-0


    Keine Ahnung, ob die Versionen bei der One dann zur dm9x0 identisch sind, aber dann können ja andere User mit einer dm9x0 sagen, ob deine Versionen passen.

  • geminicomm hab ich hier in Version 2.8-r7.0

    und gemininetcast in Version 2.1-r4-0


    Keine Ahnung, ob die Versionen bei der One dann identisch ist, aber dann können ja andere User mit einer 9x0 sagen, ob deine Versionen passen.

    geninicomm ist bei mir 2.2-r0.0 und gemininetcast 1.5-r1.0