Probleme mit satipclient auf DM7020HDv2

  • Hi zusammen!


    Ich versuche gerade, SAT>IP auf meiner DM7020HDv2 zusammen mit einem AVM FRITZ!WLAN Repeater DVB-C zum Laufen zu bekommen. Ich hab Gemini3 auf dem neuesten verfügbaren DMM experimental Image (20161019) installiert, das satipclient Paket nachinstalliert und mir eine /etc/vtuner.conf angelegt. Das Problem ist jetzt, dass bei der Kanalsuche nicht nur nix gefunden wird, sondern dabei überhaupt keine Pakete zum SAT>IP Server gesendet werden (mit tcpdump überprüft). Das satipclient Debug-Log (-l 4) sieht unauffällig aus (was mich stutzig macht, da ohne den Versand entsprechender Pakete ja eigentlich keine erfolgreiche Session zustande kommen kann).

    Da das satipclient IPK für die DM7020HD ja anscheinend von OpenATV übernommen wurde, hab ich auch zur Kontrolle mal ein OpenATV 7.1 Image installiert. Damit tuts einwandfrei. Ich würde das ganze aber lieber basierend auf nem DMM Image umsetzen, da die Lösung für meine Mutter gedacht ist und ich sie falls möglich nicht an eine neue Bedienung gewöhnen müssen will. Ich hab auch mal versucht, das satipclient Binary aus der aktuellen OpenATV auf dem DMM Image zu benutzen aber da passen die Library-Abhängigkeiten nicht.

    Liest hier evtl. ein Gemini-Entwickler mit, der ne Idee hat, was da los sein könnte? Mein nächster Schritt wäre sonst, mal ein Build-Environment aufzusetzen und zu versuchen, den aktuellen Stand von GitHub (oe-alliance/satip-client) zu bauen. Den Aufwand würde ich mir aber gerne ersparen, falls es eine einfachere Lösung gibt.