Sat>IP DVB-T auf DM7080 empfangen

  • Hallo,

    Ich beschäftige mich seit kurzem auch mit dem Thema Sat>IP. Ich habe eine externe DVB-T Antenne installiert, und möchte eigentlich kein Kabel vom Dach bis zum Verteiler im Keller verlegen, wenn ich unter dem Dach das DVB-T(2) Signal gleich mit einem Raspi und DVB-Hat abreifen kann.

    Über TVHeadend stelle ich das Signal dann im Haus zur Verfügung. Die Streams laufen auch auf meiner Dreambox 7080 (zappen dauert etwas, aber für die Sender habe ich kein EPG).

    Also möchte ich TVHeadend jetzt auch als SAT>IP Server laufen lassen und das Signal dann im SAT>IP Client in der Dreambox abgreifen.

    Das funktionniert auf meinem Rechner mit VLC schon sehr gut, aber das SAT>IP Plugin erlaubt mir kein scannen eines DVB-T(2) Tuners, sondern nur DBV-S(2).

    Gibt es eine Möglichkeit das zu erweitern?


    Danke im voraus.

    • Official Post

    Nimm mal die angehänte vtuner.conf, pass die IP Adresse an und kopiere die Datei dann auf Deine Box nach /etc/


    VORHER DIE DORT VORHANDENE SICHERN!!!


    Mach ein Reboot und versuch dann nochmal die Kanalsuche...

  • Danke für die Datei, ich habe sie angepasst, nach /etc verschoben und neu gestartet. Als sat>ip tuner sehe ich jetzt einen dvb-t Tuner mit der richtigen IP Adresse.


    Allerdings kann ich keine Sendersuche starten. Der virtuelle Tuner wird weder in der Tunerkonfiguration angezeigt, noch kann ich bei einer manuellen Suche auf ihn zugreifen.


    Was habe ich falsch gemacht?

  • Ein kurzes Update: Ich muss mich leider verbessern. Mit VLC klappt es auch nicht, es funktionniert nur, wenn ich auf meinem PC auch TVH als Client installieren. Der kann dann auf die Streams zugreifen.


    VLC gibt mir als Fehler immer aus, dass er den Port (554) nicht erreichen kann, dabei spielt es keine Rolle, welchen Port ich in TVH vergebe. Demnach kann meine Dreambox den Server wohl auch nicht erreichen, und mein Problem hat nichts mit der Box, sondern eher mit meinem Netzwerk zu tun. Ich suche weiter, und berichte wenn ich eine Lösung gefunden habe... (...falls :winking_face: )

    • Official Post

    Hast Du auch einen Tuner im SAT>IP Client zugefügt?

  • Ja, ich habe deine vtuner.conf genommen(und an meine Realität angepasst -> IP Adresse vom TVH Server), die wird auch in der Sat>IP Konfig angezeigt. Wenn ich dort auf "Hinzufügen" klicke, wird aber nichts angezeigt. Und bei den Tuner selber wird auch kein vtuner angezeigt (Dort sehe ich nur meine 2 DVB-S2 Tuner und die 2 DVB-T Tuner die fest in der Box verbaut sind.


    Ich gehe davon aus, dass der Tuner nicht angezeigt wird, weil auch über die vtuner.conf TVH nicht erreicht wird. Aber ich sehe im Moment noch nicht woran es liegt (ausser einem Fehler in meinem Netzwerk, aber welcher? (Vielleicht liegt es daran dass der TVH Server über Wlan ins Netzwerk angebunden ist, die Dreambox aber über Kabel? (Ich kann TVH aber über das WebIf erreichen)


    Der Sache werde ich auch noch nachgehen, bin aber für jede Idee, Denkanstoss dankbar! :winking_face:

  • Heute hatte ich mal wieder etwas Zeit um mich mit der Konfiguration zu beschäftigen.

    Ich habe TVHeadend neu auf einem Raspberry Pi 3b+ aufgesetzt und den per Lan-Kabel mit meinem Netzwerk verbunden. In TVH habe ich dann den Port 9983 für den Sat>IP Server gewählt. Mit VLC kann ich jetzt auf die Sender zugreifen die mein Raspi empfängt.


    Auch auf meiner Dreambox 7080 bin ich etwas weiter gekommen. Ich habe ein anderes Format für die vtuner.conf genommen (siehe Datei im Anhang).

    Damit wird der Tuner jetzt auch angezeigt und ich kann ihn auch für einen Scandurchlauf nutzen.


    ABER: Er findet keine Sender :frowning_face:


    Anfangs hatte ich den "tuner_type" noch auf DVB-T2 stehen, aber da wurde der Tuner zwar korrekt unter SAT>IP als DVB-T2 Tuner angezeigt, bei den Tuner stand er aber als DVB-S2 Tuner und wollte demnach auch nur wie ein Sat-Tuner scannen. Nachdem ich wieder "tuner_type:DVB-T" eingestellt habe, wird der virtuelle Tuner auch wieder korrekt erkannt.


    In TVH habe ich die Einstellung sicherheitshalber auch geändert, dass ein DVB-T Tuner im SAT>IP Server zur Verfügung steht und kein DVB-T2 (wie ursprünglich vorgesehen). Es werden aber dennoch keine Sender gefunden.


    Wie immer bin ich für alle Denkanstösse dankbar, wie ich erfolgreich einen Senderdurchlauf hinkriege (oder ist das am Ende mit der 7080 nicht möglich?)

  • vielleicht hilft dir das hier weiter > https://dreambox.de/board/inde…read/21974-dm7080-dvb-t2/


    Den beim VLC wird wohl der PC das dekodieren softwaremässig machen was ja die DM7080 nicht kann.

    Deshalb werden wohl keine Sender gefunden.

    Gruß Ketschuss


    Boxen: DM900UHD; DM920UHD; DMTwo alle Merlin
    Team-Member Project Merlin - we are opensource
    Primetab T13B mit Ubuntu 21.10/Win10,Homeserver Ubuntu 20.04

  • Danke für den Hinweis. Den Verdacht hatte ich auch schon, aber es gibt noch einige DVB-T Sender (nicht T2) die ich dann trotzdem empfangen sollte, da sie auch über die internen DVB-T Tuner in der Dreambox gehen. Die internen Tuner hängen nur an einer Zimmerantenne, mit beschränkten Empfangsmöglichkeiten, während der Raspberry Pi an einer Aussenantenne hängt, die wesentlich mehr Sender (auch DVB-T) empfängt als die Zimmerantenne. Und da ich kein Kabel vum Speicher zu den Receiver ziehen möchte, dachte ich, sat>ip wäre eine Möglichkeit.


    Ich suche weiter...

  • ich nutze zwar TVHeadend für SAT>IP DVB-S/2, aber dort wird er auch nicht via Suche gefunden, bei mir läuft TVHeadend auch auf dem richtigen Port für SATIP (554).

    Sprich ich muss die Config immer via Hand vornehmen.


    Wichtig ist, wenn TVH nicht als Root läuft wird von TVH der Port immer auf einen anderen gesetzt.

    Ich nehme die Zeile immer raus und setze das ganze mit setcap um:

    https://github.com/tvheadend/t…/satip/server.c#L564-L567


    kann jetzt deine Erfahrung mit Linux nicht einschätzen.

  • Danke für deine Nachricht. Das sprengt meine Linuxkenntnisse, aber dann werde ich mich eben einlesen müssen. Man lernt ja nie aus :winking_face:

    Ich "bastele" weiter und halte euch auf dem Laufenden.


    (Gestern bin ich kurz noch einmal auf meine Raspi-Zero Konfiguration zurückgegangen, die läuft auch weiter im VLC auf meinem PC, die Dreambox zeigt den virtuellen Tuner aber nicht in der Tuner Konfiguration an (unter sat>ip Tuner steht er aber drin, mit der richtigen IP Adresse).


    Also wieder zurück auf mein Raspi 3b+ über Lan, der wird in der Tuner Konfig auch nicht mehr gefunden, trotz mehrerer Neustarts und löschten und neu anlegen der vtuner.conf. Es könnte wahrscheinlich so einfach sein, wäre ich nicht so ein DAU :winking_face: )

  • ich nutze zwar TVHeadend für SAT>IP DVB-S/2, aber dort wird er auch nicht via Suche gefunden, bei mir läuft TVHeadend auch auf dem richtigen Port für SATIP (554).

    Sprich ich muss die Config immer via Hand vornehmen.


    Wichtig ist, wenn TVH nicht als Root läuft wird von TVH der Port immer auf einen anderen gesetzt.

    Hallo noch einmal,


    Ich hatte jetzt etwas Zeit um mich noch mehr mit dem Thema auseinander zu setzen.

    Soweit ich das verstehe: Standard Port für TVH als SatIP Server ist 554, der aber voraussetzt, dass TVH dann als Root ausgeführt wird. Ansonsten wird automatisch der Port 9983 benutzt?

    Und genau die vier Zeilen entfernst du aus dem Code (in der Datei server.c). Bedeutet das, dass du TVH neu kompilierst? Ich sehe nicht, in welcher Datei ich die Zeilen entfernen müsste.


    Könnte ich nicht auch in der Dreambox den richtigen Port (9983) angeben?


    Und was die hinzugefügte tvheadend.service macht, erschliesst sich mir leider auch nicht :frowning_face: Ich finde deren 7 auf meinem Raspi. Müsste ich die alle ersetzen?


    Im Moment bin ich aber wieder quasi am Anfang, ich habe den satip client (2 Packete) komplett entfernt, die Box neugestartet, die Satip Packete neu installiert (aus dem Plugin Manager im Bluepanel) und meine vtuner.conf neu auf die Box geschoben. Die Box noch einmal neu gestartet.


    Ich sehe jetzt zwar in den Einstellungen den Menüpunkt SatIP, in dem auch der Server mit der richtigen IP Adresse drin steht. In der Tunerliste taucht der virtuelle Tuner aber nicht auf, und ich verstehe nicht warum...


    Irgendwo sitze ich auch der Leitung :frowning_face:


    Wer kann mir weiterhelfen (ich fürchte, ich benötige eine Schritt für Schritt Anleitung, im Moment verrenne ich mich immer weiter)


    Danke im voraus!

  • Ich habe noch nicht aufgegeben, komme aber leider nicht weiter. Ich denke, ich habe im Moment zwei Probleme, die nicht direkt miteinander zu tun haben, und mich dennoch aufhalten.


    Problem 1: Der virtuelle Tuner den ich in der vtuner.conf angelegt habe, wird nicht (mehr) in der Tuner Liste angezeigt. Woran das liegt habe ich nicht herausfinden können, auch ein Entfernen vom Plugin und eine Neuinstallation hat nichts gebracht. Rechte falsch gesetzt? (die vtuner.conf hat 644 als Rechte, ich habe es auch schon mit 755 probiert, ohne Erfolg)


    Problem 2: Als der Tuner vor langer Zeit doch einmal in der Tunerliste stand, konnte ich keinen Suchlauf durchführen, bzw. es wurde kein Sender gefunden. Das könnte in Zusammenhang mit dem "falschen" Port in TVH stehen. Gibt es keine Möglichkeit den Client zu "zwingen", einen anderen Port als den Standard Root Port für SAT>IP zu nutzen?


    Danke im voraus für zusätzliche Denkanstösse, die mich wieder mit kleinen Schritten weiter bringen.

  • hmm also habe selber auch mal probiert via SAT>IP - DVB-T2 - zum laufen zu bringen und TVHeadend. leider hat es nicht geklappt.

    Da ich aber SAT und Kabel habe, nicht weiter mit beschäftigt. Es geht doch mehr oder weniger eher um das Fehlende EPG oder?

    bei SATIP ist bei mir zumindest die Umschaltzeit ähnlich wie beim HTTP - Stream.


    Da du ja eh einen kleinen Minirechner hast, könnest du folgendes machen:

  • Im Moment nutze ich in der Tat den http-stream von TVH und verlinke die Sender gleich in der Favoriten-Liste mit den jeweiligen streaming URLs. Umschaltzeiten sind in der Tat schnell genug, dass ich damit leben kann.


    EPG ziehe ich mir über die Service-Referenzen der jeweiligen Sender, sofern sie auch über Sat empfangbar sind. Klappt auch soweit, ausser dass ich erst auf den Sat Sender schalten muss, damit der das EPG lädt, und dann stehen die Daten auch für den http-stream zur Verfügung. Da es sich dabei um die französichen DVB-T Sender handelt (bzw. die aus Belgien), die über Sat verschlüsselt ausstrahlen, gehe ich den Umweg über DVB-T für den unverschlüsselten Empfang. Das EPG der Franzosen ist über Sat aber auf die aktuelle Sendung und die kommende beschränkt.


    XMLTV habe ich so für Plex und Jellyfin eingebunden, klappt auch gut. Überschreibt ein EPGload Plugin nicht alle EPG Daten meiner Box? Die EPG Daten aus dem realen Sat Empfang (FTA-Sender) die ich nicht über DVB-T Empfange, möchte ich nur ungerne verlieren. Was auch der Grund ist, warum ich den Weg noch nicht gegangen bin. Aber wenn du mir sagst, dass ich beide nutzen kann, scheint mir das die bessere Option zu sein, in der Tat :winking_face:


    Ansonsten geht es mir auch um den Lerneffekt (war schon eine schöne Bastelei um die Sender aus TVH an Plex zu übergeben und das Proxy richtig zu konfigurieren), aber wenn es von vorne herein nicht möglich ist, ist es am Ende verlorene Liebesmüh. Ich wollte minisatip testen, aber da ich hier schon scheitere, fürchte ich, dass der Schritt noch weniger Erfolg bringt.


    Danke für die Hilfe, und wie gesagt, eine Bestätigung dass mir am Ende die EPG Daten aus dem Sat-Empfang (für die Sat-Programme) und TVH (für die DVB-T Programme über http-streaming) zur Verfügung stehen hilft schon sehr weiter...

  • Ah stimmt, das hatte ich nicht bedacht. Also erst EPG aus TVH über das epgload Plugin aktualisieren, und EPGRefresh so konfigurieren, dass es danach noch einmal die Sender aktualisiert, für die ich das EPG über Sat benötige!


    Danke für den Hinweis, das werde ich ausprobieren!


    (und wenn trotzdem noch jemand eine Idee hat, warum der virtuelle Tuner nicht in der Tunerliste auftaucht, und wo ich schrauben könnte, damit er es doch tut, gerne her mit den Tipps :winking_face: )