Elektro Power Save 2021

  • Sven H hat im Dreambox-Board darauf hingewiesen, dass das unter den älteren Dreambox-Besitzern beliebte Plugin Elektro Power Save von Morty mit einer der kommenden Änderungen im OE2.5 und OE2.6 nicht mehr richtig funktionieren wird. Sven H hat einige kleine Anpassungen am Plugin vorgenommen und diese Änderung zwecks Test im Dreambox-Board veröffentlicht. Damit auch unsere User von seiner Arbeit Kenntnis erlangen, ohne in diversen Boads mitlesen zu müssen, habe ich nach Rücksprache mit Sven H den Text als Zitat hier eingefügt und die geänderte Datei als Anhang beigefügt.


    Die alte Datei auf der Dreambox hatte bei mir die Rechte 644. Die Neue wich nach dem Kopiervorgang davon ab. Ob dies Auswirkungen hat, kann ich nicht sagen. Ich zumindest habe die Rechte auf meiner Box wieder auf 644 gesetzt.


    Viel Spaß beim Testen :)

  • Danke !


    J.

    | 920 ULTRA HD | 7080 HD| 8000 HD | 2 x 7020 HD V2 | 2 x 800 HD SE V2 | 525 S2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB || 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy ;)


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials

  • So, der erste Tag ist rum.

    Wie befohlen eingeschlafen und wie befohlen aufgewacht.

    Ich werde für morgen noch einen Timer setzen der in die Schlafenszeit fällt und erwarte, dass die Box für die Aufnahme aufwacht und danach auch wieder schlafen geht, sofern genug Restzeit bis zum eigentlichen Aufwachzeitpunkt vorhanden ist.

  • Du kannst auch mal die Frage zum DeepStandby beim Schalten in den Idle austesten ;)


    Dazu einfach im Elektro-Setup für den aktuellen Tag die Sleep-Time so einstellen, dass sie zu diesem Zeitpunkt schlafen gehen sollte, wenn du die Box in den Idle schickst.


    Da sollte dann beim Schalten in den Idle die Frage zum DeepStandby kommen.

    (sofern die Option im Setup aktiviert ist - default ist die Option eingeschaltet)


    Die Frage kannst du mit Exit abbrechen, dann bleibt die Box an.

    Bei "Ja" geht die Box sofort in den DeepStandby.

    Bei "Nein" geht sie normal in den Idle. Eine neuerliche DeepStandby-Prüfung passiert dann erst nach dem Einschalten und neuen Schalten in den Idle.

  • Ich wollte mich nochmal kurz rückversichern, bevor ich die Box umstelle...


    Ich habe Verstanden, dass das Plugin folgendes Verhalten hat:


    Wenn zum Zeitpunkt des DeepSleep eine dieser Situationen vorliegen, wird nicht in den Deepsleep gewechselt: Box an, Aufnahme läuft oder Box streamt zur Partnerbox.


    Geht die Box in diesem Zyklus nicht mehr in den DeepSleep, oder wird in Zyklen geprüft, und dann bei Inaktivität in den DeepSleep gewechselt. Ich glaube Ersteres.


    Wenn innerhalb des DeepSleep eine Aufnahme startet, dann fährt die Box hoch, macht die Aufnahme, und wenn es noch lohnt, geht sie wieder schlafen, korrekt?


    Dazu noch eine Frage, wenn jetzt meine Partnerbox in der DeepSleep-Zeit auf die Box zugreifen will, kann ich manuell die Box mit WOL aufwecken? Gibt es dazu Plugins?


    Viele Grüße

    Skullmonkey

  • Der, meiner Meinung nach, beste Anwendungsfall dieses Plugins ist, wenn man die Box mehrere Tage nicht bedienen kann oder möchte (Urlaub oder sonstige Abwesenheiten). Wenn man die Box dann zu bestimmten Zeiten aufwachen lässt, dann das epgrefresh sein Update machen lässt und den autotimer nebst serienplugin durchlaufen lässt, verpasst man eigentlich keine Serien mehr.


    Gerade die kurzweiligen EPGs (mit Inhalt von drei Tagen oder gar weniger) werden so ebenfalls aufgefrischt und die Timer gesetzt, ohne das die Box tage- oder wochenlang durchlaufen muss.


    Darüberhinaus bleibt einem ein Memorybug oder sonstige schleichenden RAM-Speicherfresser (gab es mal bei der 8000er) verborgen, da die Box jeden Tag komplett ausgeschaltet und einmal täglich wieder eingeschaltet wird.

  • Teste ich nachher mal.

  • Ja, das mit der Zeit ist mir auch aufgefallen.

    Das war aber wohl schon immer so.


    Die Meldung kommt erst, wenn die SleepZeit kleiner als die aktuelle Zeit ist.

    Da ist dann also schon mal 1min drüber.

    Dann kommt immer noch die Sekunden-Zeit der Prüfung dazu, wann diese gemacht wird.

    (also die minütliche Prüfung findet zB um x:57sek statt, also 3sek vor der vollen Minute - das ist immer abhängig von der jeweiligen Startzeit der Box )

    Dann hast du in diesem Fall fast 2min Versatz ;)


    Ich könnte es ändern, dass die Prüfung immer zur vollen Minute erfolgt und dass die Zeiten identisch sind.

    Aber das wäre wieder 2 Anpassungen, wo ich nicht weiß, ob das anderswo Probleme macht.

    Und da das schon immer so war, hab ich das eben nicht angefasst ;)

  • Nein, ist noch nicht im git.

    Im OE2.5 wurde die Anpassung zum Idle durch DP nicht integriert, so dass da die Version aus dem git zumindest noch funktionieren sollte.


    Die hier angepasste Version vom Elektro kannst du da aber trotzdem nutzen.