[gelöst] Alle NAS-Freigaben weg

  • Hallo an Euch


    Nun ist es mal wieder soweit. Nach Jahren fehlerfreien Funktionierens sind heute

    meine kpl. Freigaben verschwunden, bzw. werden mir diese in der GUI nicht mehr angezeigt.

    Die NAS-Freigaben waren über media/nas eingebunden.



    Ich nutze die 7080HD


    Dummerweise habe ich bei den Rechten schon rumgespielt, da weiß ich jetzt

    leider nicht mehr, wie die genau sein müssen. Daher habe ich dies mal mit dabei geschrieben.


    Hier nun die Konfiguration:


    Unter Media habe ich einen Ordner : nas ( Rechte = 755 ).

    Unter etc habe ich die Datei : auto.nas ( Rechte = 600 )

    In der auto.nas stehen dann die ganzen Freigaben wie z.B. : Filme -fstype=nfs,rw,retry=0,timeo=2,retrans=1,soft,nolock,udp 192.168.100.150:/Filme

    Im Ordner auto.master.d ( Rechte = 755 ) gibt es die Datei nas.autofs ( Rechte = 600 ) mit dem Inhalt /media/nas /etc/auto.nas --ghost -- timeout=60


    Gehe ich über die GUI wird mir das Lesezeichen media/nas angezeigt, wähle ich dieses aus erscheint nur das Lesezeichen media/hdd/. Die Serverfreigaben fehlen.


    Auf dem Server ( nas ) habe ich keine Veränderungen vorgenommen. Da ist unter NFS Hostzugriff die IP der DM7080 eingetragen.

    Erlaubnis "nur lesen" und unter der Squash-Option ist "No_ROOT_SQUASH". Der Anonyme GID und UID steht beide Male auf "Guest". ( Alles ausgegraut )


    Auf der Dreambox habe ich den Root-Login in der GUI über die Option Passwort deaktiviert, da ich keine Nutzer eingerichtet habe und ich direkt mit dem Mac

    drauf zugreifen möchte.


    Kann mir da evtl. jemand weiterhelfen, wie ich die Freigaben wieder sichtbar bekomme?


    Vielen Dank an Euch im voraus

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • ich würde dir empfehlen ein neues Image zu installieren und dann deine Mounts per Networkbrowser einbinden, so wie man das aktuell macht.

    Alternativ kannst du auch Gemini Netscan verwenden und weiterhin per Automount verbinden.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • ...uuups


    Bin ich jetzt so veraltet?


    Oh Gott, somit alles von vorne aufsetzen?


    Na ich werde das mal versuchen. Bin ich denn mit den regelmäßigen Updates nicht aktuell?


    Welches Image würdest Du mir denn da empfehlen ? Kannst Du mir da evtl. einen Link senden?

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • ob dein Image so veraltet ist, kann ich dir nicht sagen, ich bin nur von deiner Mountvariante ausgegangen.

    Wir empfehlen hier das Original-Image von Dream plus GP 4.1 Plugins.

    Den Link zu den Dreambox-Images findest du weiter oben.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Hallo Jürgen


    Ich habe mal "Info" befragt.


    Da steht:


    Dreambox OS: 4.3.2r14-2020-12-02

    Image : Experimental 2018-04-27

    Frontprozessor Version : 1.2


    Runtergeladen habe ich mir folgendes Image :

    gemini4-unstable-OE25-image-dm7080-20190917104544.tar


    Wäre dies das richtige ?


    Zudem noch eine Frage, welche sich mir nach der Nutzung von Gemini Netscan

    stellt hat.


    Die Server wurden gefunden und als Mountpunkt wird dann immer


    /media/gp4share/... vorangestellt. Wenn ich jetzt versuche diesen Mountpunkt in Media

    zu finden wird dieser nicht angezeigt. Es sind nur meine alten vorhanden. Muss ich in Media

    den Ordner gp4share anlegen ? Wenn "JA" mit welchen Rechten und was müsste ich dann noch machen?


    Habe das mal versucht, Ordner ist mit 700'er Rechten erstellt worden. Habe aber die Mountpunkte da nicht hinbekommen.


    Bitte nicht lachen, aber wie gesagt, habe das mehrere Jahre nicht mehr gemacht.


    Noch ein kleiner Nachtrag


    Habe mal geschaut. In der auto.master.d gibt es die Datei gemini4.autofs welche als Inhalt folgendes enthält : /media/gp4share /etc/auto.gemini4 --ghost


    Die dazu gehörige auto.gemini4 in etc mit den Freigaben ist auch vorhanden.


    Sieht ja somit ganz gut aus, nur wie kann ich die nutzen ?

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

    Edited 2 times, last by DJDive ().

  • ich würde das aktuelle Unstable Dreamboximage vom 02.12.2020 verwenden und GP 4.1 installieren, wie es im Wiki steht. Wenn du das gp4share nicht haben möchtest, verwende den Networkmanager und mounte über fstab, dann werden deine Laufwerke direkt unter /media gemountet.


    Du kannst den ganzen Spass auch manuell in die Datei fstab eintragen (zu finden unter /etc)

    nehmen wir mal dein obigen Beispiel

    Code
    Filme -fstype=nfs,rw,retry=0,timeo=2,retrans=1,soft,nolock,udp 192.168.100.150:/Filme

    dieser würde in der fstab dann so aussehen

    Code
    192.168.100.150:/Filme /media/Filme nfs x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,timeo=2,retrans=1,async,nolock,noauto,nofail,soft,rw 0 0

    aber den Ornder "Filme" must du bevor du die Box neu startest manuell unter /media anlegen, sonst funktiobiert der Mount nicht.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Hallo Jürgen


    Ich klapp hier echt ab.


    An die fstab traue ich mich nicht ran. Zudem hätte ich nichts gegen den gp4share. Dieser wurde anscheinend

    auch sauber angelegt, aber es erscheinen keine Freigaben. Anbei mal ein paar Bildschirmfotos. Wenn ich ein

    Lesezeichen anklicke erhalte ich immer nur die anderen Lesezeichen. Ich wandere da im Kreis.


    Woran erkenne ich denn, das ich GP 4.1 installiert habe. Habe das Wiki befragt und ausgeführt, sieht aber alles aus

    wie vorher.

    auto.gemini4.pnggp4share.pngStart.png

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • es gibt kein GP 4 bzw GP 4.1 sondern nur GP 4/4.1-Plugins und wenn du Netscan installiert hast, ist dies ein GP 4.1-Plugin.


    Sind das auf Bild 1 deine Freigaben?

    Bei Netscan bin ich der falsche Ansprechpartner, das müsste jemand anderes beantworten.

    Wenn du die Mounts per fstab haben möchtest, kann ich dir die Einträge posten, du musst nur die Ordner dazu unter /media anlegen.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Hallo Jürgen


    Das oben sind meine Freigaben. Wenn Du mir bezüglich der fstab helfen würdest wär eich Dir sehr dankbar.

    Gemininetcast ist installiert.

    Als Order würde ich dann DVD / Bluray usw. als Ordner in Media anlegen. Welche Rechte muss der Ordner haben ?

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • Mount werden auch nur angezeigt, wenn auch vorhanden.

    Ist es nicht der fall, wird da nichts angezeigt. Movie-Center und Stream: Zwei zusätzliche ip?


    Was sagt dir das Netzwerksuche? (gemininetscan)


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • das war ein Vertipper, ich meinte Netscan, aberauch Dreamnetcast ist ein GP 4.1-Plugin.


    Die Ordner brauchen die Rechte 755.


    Code
    192.168.4.192:/DVD /media/DVD nfs x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,timeo=2,retrans=1,async,nolock,noauto,nofail,soft,rw 0 0
    192.168.4.192:/Bluray    /media/Bluray    nfs    x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,timeo=2,retrans=1,async,nolock,noauto,nofail,soft,rw    0    0
    192.168.4.194:/Media-Center    /media/Media-Center    nfs    x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,timeo=2,retrans=1,async,nolock,noauto,nofail,soft,rw    0    0
    192.168.4.196:/Streams    /media/Streams    nfs    x-systemd.automount,x-systemd.device-timeout=15,x-systemd.idle-timeout=60,retry=0,timeo=2,retrans=1,async,nolock,noauto,nofail,soft,rw    0    0

    so müsste es klappen, du musst die Box aber vollständig neu starten, nich tnur ein GUI-Neustart.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Hallo cepheus


    Was muss ich denn machen, damit der mount vorhanden ist?

    Die Server sind online und verfügbar.

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • Hast du auch die NFS Freigabe in deine drei verschiedene server angelegt?


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • Alle Server haben entsprechende NFS-Freigaben ( siehe oben - erster Beitrag)

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • Hallo Jürgen


    Vielen vielen Dank für Deine Hilfe.


    Habe die Ordner in Media mit 755 angelegt und die Textzeilen in der fstab hinzugefügt.


    Box kpl. neu gestartet. Jetzt arbeiten die Zahnräder ( seit 2-3 Minuten )


    Ich denke ich muss mich morgen wohl damit weiter beschäftigen.


    Euch beiden erst einmal nochmal vielen lieben Dank für Eure Unterstützung.

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • Hallo Jürgen

    Hallo Cepheus


    Sorry, das ich mich erst heute melde, aber arbeitstechnisch kam ziemlich viel dazwischen.


    Hier nun kurz der Status:


    Dank Eurer Hilfe läuft alles. Alle Freigaben wieder da, somit Problem gelöst.


    Euch beiden nochmal vielen lieben Dank und bleibt gesund.

    Grüße


    DjDive



    :rolleyes: Am Ende wird alles Gut, ist nicht alles Gut, ist es auch noch nicht zu Ende ! ;)

  • Kaiser Wilhelm

    Changed the title of the thread from “Alle NAS-Freigaben weg” to “[gelöst] Alle NAS-Freigaben weg”.